Gerenciar ferramentas externasManage external tools

Você pode chamar ferramentas externas de dentro do Visual Studio usando o menu Ferramentas.You can call external tools from inside Visual Studio by using the Tools menu. Algumas ferramentas padrão estão disponíveis no menu Ferramentas, e você pode personalizar o menu adicionando outros executáveis de sua preferência.A few default tools are available from the Tools menu, and you can customize the menu by adding other executables of your own.

Ferramentas disponíveis no menu FerramentasTools available on the Tools menu

O menu Ferramentas contém vários comandos internos, incluindo:The Tools menu contains several built-in commands, including:

Adicionar novas ferramentas ao menu FerramentasAdd new tools to the Tools menu

É possível adicionar uma ferramenta externa para aparecer no menu Ferramentas.You can add an external tool to appear on the Tools menu.

  1. Abra a caixa de diálogo Ferramentas externas escolhendo ferramentas > externas ferramentas.Open the External Tools dialog box by choosing Tools > External Tools.

  2. Clique em Adicionar e preencha as informações.Click Add, and then fill in the information. Por exemplo, a seguinte entrada faz com que o Windows Explorer Abra no diretório do arquivo que você abriu atualmente no Visual Studio:For example, the following entry causes Windows Explorer to open at the directory of the file you currently have open in Visual Studio:

    • Título: Open File LocationTitle: Open File Location

    • Comando: explorer.exeCommand: explorer.exe

    • Argumentos: /root, "$(ItemDir)"Arguments: /root, "$(ItemDir)"

    Caixa de diálogo Ferramentas Externas

Esta é uma lista completa de argumentos que podem ser usados ao definir uma ferramenta externa:The following is a full list of arguments that can be used when defining an external tool:

NomeName ArgumentoArgument DescriçãoDescription
Caminho de itemItem Path $(ItemPath)$(ItemPath) O nome de arquivo completo do arquivo atual (unidade + caminho + nome de arquivo).The complete file name of the current file (drive + path + file name).
Diretório do itemItem Directory $(ItemDir)$(ItemDir) O diretório do arquivo atual (unidade + caminho).The directory of the current file (drive + path).
Nome de arquivo de itemItem File Name $(ItemFilename)$(ItemFilename) O nome de arquivo do arquivo atual (nome de arquivo).The file name of the current file (file name).
Extensão de itemItem Extension $(ItemExt)$(ItemExt) A extensão de nome de arquivo do arquivo atual.The file name extension of the current file.
Linha atualCurrent Line $(CurLine)$(CurLine) A posição da linha atual do cursor na janela de código.The current line position of the cursor in the code window.
Coluna atualCurrent Column $(CurCol)$(CurCol) A posição da coluna atual do cursor na janela de código.The current column position of the cursor in the code window.
Texto atualCurrent Text $(CurText)$(CurText) O texto selecionado.The selected text.
Caminho de destinoTarget Path $(TargetPath)$(TargetPath) O nome de arquivo completo do item a ser criado (unidade + caminho + nome de arquivo).The complete file name of the item to be built (drive + path + file name).
Diretório de destinoTarget Directory $(TargetDir)$(TargetDir) O diretório do item a ser criado.The directory of the item to be built.
Nome de destinoTarget Name $(TargetName)$(TargetName) O nome de arquivo do item a ser criado.The file name of the item to be built.
Extensão de destinoTarget Extension $(TargetExt)$(TargetExt) A extensão de nome de arquivo do item a ser criada.The file name extension of the item to be built.
Diretório binárioBinary Directory $(BinDir)$(BinDir) O local final do binário que está sendo criado (definido como unidade + caminho).The final location of the binary that is being built (defined as drive + path).
Diretório do projetoProject Directory $(ProjectDir)$(ProjectDir) O diretório do projeto atual (unidade + caminho).The directory of the current project (drive + path).
Nome de arquivo do projetoProject File Name $(ProjectFileName)$(ProjectFileName) O nome de arquivo do projeto atual (unidade + caminho + nome de arquivo).The file name of the current project (drive + path + file name).
Diretório da soluçãoSolution Directory $(SolutionDir)$(SolutionDir) O diretório da solução atual (unidade + caminho).The directory of the current solution (drive + path).
Nome de arquivo da soluçãoSolution File Name $(SolutionFileName)$(SolutionFileName) O nome de arquivo da solução atual (unidade + caminho + nome de arquivo).The file name of the current solution (drive + path + file name).

Observação

A barra de status do IDE exibe a linha atual e as variáveis da coluna atual para indicar onde o ponto de inserção está localizado no Editor de código ativo.The IDE status bar displays the Current Line and Current Column variables to indicate where the insertion point is located in the active Code Editor. A variável de texto atual retorna o texto ou o código selecionado nesse local.The Current Text variable returns the text or code selected at that location.

Consulte tambémSee also