Soluções e projetos no Visual StudioSolutions and projects in Visual Studio

Este artigo descreve o conceito de um projeto e de uma solução no Visual Studio.This article describes the concept of a project and a solution in Visual Studio. Ele também aborda rapidamente a janela de ferramentas Gerenciador de Soluções e como criar um projeto.It also briefly covers how to create a new project and the Solution Explorer tool window.

Note

Este tópico aplica-se ao Visual Studio no Windows.This topic applies to Visual Studio on Windows. Para o Visual Studio para Mac, confira Projetos e soluções no Visual Studio para Mac.For Visual Studio for Mac, see Projects and solutions in Visual Studio for Mac.

ProjetosProjects

Ao criar um aplicativo, um site, um plug-in, etc. no Visual Studio, você inicia um projeto.When you create an app, website, plug-in, etc. in Visual Studio, you start with a project. Logicamente, um projeto contém todos os arquivos de código-fonte, ícones, imagens, arquivos de dados, etc. que são compilados em um executável, biblioteca ou site.In a logical sense, a project contains all the source code files, icons, images, data files, etc. that are compiled into an executable, library, or website. Um projeto também contém as configurações de compilador e outros arquivos de configuração que podem ser necessários para diversos serviços ou componentes com os quais seu programa se comunica.A project also contains compiler settings and other configuration files that might be needed by various services or components that your program communicates with.

Note

Você não precisa usar soluções ou projetos no Visual Studio para editar, compilar e depurar o código.You don't have to use solutions or projects in Visual Studio to edit, build and debug code. Você pode simplesmente abrir a pasta que contém os arquivos de origem no Visual Studio e começar a editá-los.You can simply open the folder that contains your source files in Visual Studio and start editing. Para obter mais informações, consulte Desenvolver código no Visual Studio sem projetos nem soluções.For more information, see Develop code in Visual Studio without projects or solutions.

Um projeto é definido em um arquivo XML com uma extensão, como .vbproj, .csproj ou .vcxproj.A project is defined in an XML file with an extension such as .vbproj, .csproj, or .vcxproj. Este arquivo contém uma hierarquia de pasta virtual e os caminhos para todos os itens no projeto.This file contains a virtual folder hierarchy, and paths to all the items in the project. Ele também contém as configurações de build.It also contains the build settings.

Tip

Para examinar o conteúdo de um arquivo de projeto no Visual Studio, primeiro descarregue o projeto selecionando o nome do projeto no Gerenciador de Soluções e escolhendo Descarregar Projeto no menu de contexto ou de clique com o botão direito do mouse.To look at the contents of a project file in Visual Studio, first unload the project by selecting the project name in Solution Explorer and choosing Unload Project from the context or right-click menu. Em seguida, abra o menu de contexto novamente e escolha Editar <projectname> .Then, open the context menu again and choose Edit <projectname>.

No Visual Studio, o arquivo de projeto é usado pelo Gerenciador de Soluções para exibir as configurações e o conteúdo do projeto.In Visual Studio, the project file is used by Solution Explorer to display the project contents and settings. Quando você compila seu projeto, o mecanismo do MSBuild consome o arquivo de projeto para criar o executável.When you compile your project, the MSBuild engine consumes the project file to create the executable. Você também pode personalizar os projetos para produzir outros tipos de saída.You can also customize projects to produce other kinds of output.

SoluçõesSolutions

Um projeto está contido dentro de uma solução.A project is contained within a solution. Apesar do nome, uma solução não é uma "resposta".Despite its name, a solution is not an "answer". Ela é apenas um contêiner de um ou mais projetos relacionados, juntamente com informações de build, configurações de janela do Visual Studio e arquivos diversos que não estão associados a nenhum projeto específico.It's simply a container for one or more related projects, along with build information, Visual Studio window settings, and any miscellaneous files that aren't associated with a particular project. Uma solução é descrita por um arquivo de texto (extensão .sln) com seu próprio formato exclusivo; não se destina à edição manual.A solution is described by a text file (extension .sln) with its own unique format; it's not intended to be edited by hand.

O Visual Studio usa dois tipos de arquivos ( .sln e .suo) para armazenar configurações de soluções:Visual Studio uses two file types (.sln and .suo) to store settings for solutions:

ExtensãoExtension NomeName DescriçãoDescription
.sln.sln Solução do Visual StudioVisual Studio Solution Organiza projetos, itens de projeto e itens de solução na solução.Organizes projects, project items, and solution items in the solution.
.suo.suo Opções do usuário da soluçãoSolution User Options Armazena configurações e personalizações no nível do usuário, como pontos de interrupção.Stores user-level settings and customizations, such as breakpoints.

Criar novos projetosCreate new projects

A maneira mais fácil de criar um novo projeto é começar de um modelo de projeto para um tipo específico de aplicativo ou site.The easiest way to create a new project is to start from a project template for a particular type of application or website. Um modelo de projeto consiste em um conjunto básico de arquivos de código, arquivos de configuração, ativos e configurações gerados previamente.A project template consists of a basic set of pre-generated code files, config files, assets, and settings. Esses modelos estão disponíveis na caixa de diálogo em que você cria um projeto (Arquivo > Novo > Projeto).These templates are available in the dialog box where you create a new project (File > New > Project). Para saber mais, confira Criar um novo projeto no Visual Studio e Criar soluções e projetos.For more information, see Create a new project in Visual Studio and Create solutions and projects.

Se você costuma personalizar seus projetos de uma determinada maneira, é possível criar um modelo de projeto personalizado que possa ser usado para criar novos projetos.If you often customize your projects in a certain way, You can create a custom project template that you can then use to create new projects from. Para obter mais informações, confira Criar modelos de projeto e de item.For more information, see Create project and item templates.

Quando você cria um novo projeto, ele é salvo por padrão em %USERPROFILE%\source\repos.When you create a new project, it is saved by default at %USERPROFILE%\source\repos. Você pode alterar esse local na configuração Locais do projeto em Ferramentas > Opções > Projetos e Soluções > Locais.You can change this location in the Projects location setting under Tools > Options > Projects and Solutions > Locations. Para obter mais informações, consulte a página Projetos e Soluções, caixa de diálogo Opções.For more information, see Projects and Solutions page, Options dialog box.

Gerenciador de SoluçõesSolution Explorer

Depois de criar um novo projeto, você pode usar o Gerenciador de Soluções para exibir e gerenciar o projeto, a solução e seus itens associados.After you create a new project, you can use Solution Explorer to view and manage the project and solution and their associated items. A ilustração a seguir mostra o Gerenciador de Soluções com uma solução C# que contém dois projetos:The following illustration shows Solution Explorer with a C# solution that contains two projects:

Gerenciador de Soluções

Muitos comandos de menu estão disponíveis no menu do botão direito em vários itens no Gerenciador de Soluções.Many menu commands are available from the right-click menu on various items in Solution Explorer. Esses comandos incluem criar um projeto, gerenciar pacotes do NuGet, adicionar uma referência, renomear um arquivo e executar testes, apenas para citar alguns.These commands include building a project, managing NuGet packages, adding a reference, renaming a file, and running tests, just to name a few. A barra de ferramentas na parte superior do Gerenciador de Soluções possui botões para alternar de uma exibição de solução para uma exibição de pasta, mostrar arquivos ocultos, recolher todos os nós e muito mais.The toolbar across the top of Solution Explorer has buttons to switch from a solution view to a folder view, show hidden files, collapse all nodes, and more.

Para projetos ASP.NET Core, você pode personalizar como os arquivos são aninhados no Gerenciador de Soluções.For ASP.NET Core projects, you can customize how files are nested in Solution Explorer. Para saber mais, confira Personalizar o aninhamento de arquivos no Gerenciador de Soluções.For more information, see Customize file nesting in Solution Explorer.

Consulte tambémSee also