Criando um novo projetoCreating a New Project

Como abrir a caixa de diálogo de criação do projetoOpening the Project Creation Dialog

Há várias maneiras de criar um projeto no Visual Studio para Mac.There are a few ways to create a new project in Visual Studio for Mac. Quando você abrir o Visual Studio para Mac pela primeira vez, a tela de boas-vindas será mostrada.When you first open Visual Studio for Mac, the welcome screen will be shown. Aqui, você pode escolher Novo, que o levará para a tela de criação do projeto.From here you can choose New which will take you to the project creation screen.

Tip

Além disso, na tela de boas-vindas, você também pode abrir e pesquisar projetos e soluções recentes.Additionally, from the welcome screen, you can also open, and search for, recent projects and solutions. Abra também os projetos recentes acessando a barra de menus e escolhendo Arquivo > Soluções RecentesYou can also open recent projects by going to the menu bar and choosing File > Recent Solutions

Tela de boas-vindas com criar um projeto

Se o Visual Studio para Mac já estiver aberto com uma solução carregada, crie uma solução acessando a barra de menus e escolhendo Arquivo > Nova Solução.If Visual Studio for Mac is already open with a solution loaded, you can create a new solution by going to the menu bar and choosing File > New Solution. A criação de uma solução dessa maneira fechará a solução que já está carregada.Creating a new solution this way will close the solution that is already loaded.

Como criar um projeto com base em um modeloCreating a New Project from a Template

A caixa de diálogo Novo Projeto, por padrão, mostrará os modelos usados recentemente classificados pelos usados mais recentemente.The New Project dialog, by default, will show your recently used templates sorted by most recently used.

Caso você não deseje usar um modelo recente, escolha um nas categorias à esquerda da caixa de diálogo.If you do not want to use a recent template, you can choose from the categories on the left of the dialog. Cada categoria contém vários modelos de projeto para sua escolha.Each category contains several project templates for you to choose from. Ao clicar em um tipo de projeto, você poderá ver uma descrição no lado direito da tela.Clicking on a project type allows you to see a description on the right side of the screen.

Tela do novo projeto

Como configurar o novo projetoConfiguring Your New Project

Depois que você escolher um modelo de projeto, as telas a seguir orientarão você em todas as etapas de configuração necessárias para configurar o projeto; isso pode variar por tipo de projeto.Once you have chosen a project template, the following screens will take you through any configuration steps required to set up the project; this can vary by project type.

Todos os projetos exigem um novo projeto, juntamente com um local para armazenar os arquivos.All projects require a new project, along with a location to store the files. Se o projeto fizer parte de uma nova solução, em vez de adicioná-lo a uma solução existente, um nome de solução também será necessário.If the project is part of a new solution, rather than adding it to an existing solution, a solution name will also be required.

Opcionalmente, neste estágio, você também pode configurar opções de controle do código-fonte do Git.Optionally, at this stage you can also configure Git source control options. A imagem a seguir é um exemplo da etapa de configuração final de um projeto .NET Core:The following image is an example of the final configuration step for a .NET Core project:

Como configurar um novo projeto

Como adicionar projetos adicionais a uma soluçãoAdding Additional Projects to a Solution

Adicione outros projetos a uma solução clicando com o botão direito do mouse no Painel de Soluções e escolhendo Adicionar > Adicionar Novo Projeto ou Adicionar > Adicionar Projeto Existente.You can add additional projects to a solution by right-clicking the solution in the Solution Pad and choosing either Add > Add New Project or Add > Add Existing Project.

A adição de um novo projeto orientará você pela criação do projeto, conforme mostrado em Como configurar o novo projeto.Adding a new project will take you through project creation, as shown in Configuring Your New Project.

A opção de adicionar um projeto existente permitirá que você procure um projeto existente no computador e adicione-o à solução.Choosing to add an existing project will allow you to browse for an existing project on your machine and add it to the solution.

Consulte tambémSee also