Abrir várias soluções ou instâncias do Visual Studio para MacOpen multiple solutions or instances of Visual Studio for Mac

Por padrão, todos os aplicativos de um Mac, incluindo o Visual Studio para Mac, são aplicativos de instância única.By default, all applications on a Mac, including Visual Studio for Mac, are single-instance apps. Isso significa que se o aplicativo que você deseja usar já estiver aberto (ilustrado por um ponto sob o ícone no encaixe), selecionar o ícone novamente abrirá a instância em execução, em vez de uma nova.This means that if the application you want to use is already open (illustrated by a dot under the icon in the dock), selecting the icon again opens the running instance, rather than a new one. Caso precise de instâncias adicionais do aplicativo, solicite ao sistema para abri-las para você, conforme descrito na próxima seção.If you require additional instances of the application, you can prompt the system to open it for you, as described in the next section.

Além disso, quando você abre uma solução, o comportamento padrão é abrir a solução em um novo workspace e fechar o workspace atual (se necessário).In addition, when you open a solution, the default behavior is to open the solution in a new workspace and close the current workspace (if necessary). Substitua esse comportamento padrão mantendo o workspace atual aberto, conforme descrito na seção Abrir uma segunda solução.You can override this default behavior by keeping the current workspace open, as described in the Open a second solution section.

Abrir uma segunda instância do Visual Studio para MacOpen a second instance of Visual Studio for Mac

Para abrir uma segunda instância do IDE (ambiente de desenvolvimento integrado), abra o aplicativo Terminal e insira a seguinte linha:To open a second instance of the integrated development environment (IDE), open the Terminal application and enter the following line:

open -n "/Applications/Visual Studio.app"

Abrir uma segunda solução dentro de uma instância únicaOpen a second solution inside a single instance

Para abrir uma segunda solução junto com a primeira solução, use as seguintes etapas:To open a second solution alongside your first solution, use the following steps:

  1. Com sua primeira solução já aberta, selecione Arquivo > Abrir.With your first solution already open, select File > Open.

  2. Navegue pelo sistema de arquivos para encontrar a solução existente.Browse the file system to find the existing solution.

  3. Selecione o arquivo .sln e depois Opções:Select the .sln file, and select Options:

    Captura de tela do Visual Studio para Mac, com o arquivo .sln e Opções realçados

  4. Desmarque a caixa Fechar área de trabalho atual:Clear the Close current workspace box:

    Captura de tela da caixa de diálogo Opções, com a caixa Fechar área de trabalho atual desmarcada

  5. Selecione Abrir para abrir a segunda solução no Painel de Soluções.Select Open to open the second solution in the Solution Pad.

Como alternativa, se você abriu a solução recentemente, use as seguintes etapas:Alternatively, if you've recently opened the solution, you can use the following steps:

  1. Vá para Arquivo > Soluções Recentes.Go to File > Recent Solutions.

    Captura de tela do menu Soluções Recentes

  2. Mantenha a tecla Ctrl pressionada e selecione a solução.Hold down the Ctrl key and select the solution. Essa combinação abre a segunda solução no Painel de Soluções.This combination opens the second solution in the Solution Pad.