Visual Studio Icon Notas de versão do Visual Studio 2017 para Mac versão 7.4Visual Studio 2017 for Mac version 7.4 Release Notes


Comunidade de Desenvolvedores | Requisitos de Sistema | Compatibilidade | Código Distribuível | Xamarin | Blogs | Manutenção |Developer Community | System Requirements | Compatibility | Distributable Code | Xamarin | Blogs | Servicing |


Observação

Se você estiver acessando esta página em uma versão de idioma que não seja o inglês e quiser ver o conteúdo mais atualizado, visite a página de Notas de Versão em inglês.If you are accessing this page from a non-English language version, and want to see the most up-to-date content, please visit this Release Notes page in English. Você pode alterar o idioma desta página clicando no ícone de globo no rodapé de página e selecionando o idioma desejado.You can change the language of this page by clicking the globe icon in the page footer and selecting your desired language.


Use o Visual Studio 2017 para Mac para criar aplicativos para dispositivos móveis, para a Web e a nuvem com o Xamarin e o .NET Core, bem como jogos com o Unity.Use Visual Studio 2017 for Mac to build apps for mobile, web, and the cloud with Xamarin and .NET Core, as well as games with Unity.

Baixar a versão atual do Visual Studio 2017 para MacDownload the Current Release of Visual Studio 2017 for Mac

Download Visual Studio 2017 for Mac

Para saber mais sobre o Visual Studio 2017 para Mac, consulte Mac System Requirements (Requisitos do sistema Mac) e Mac Platform Targeting and Compatibility (Direcionamento e compatibilidade da plataforma Mac).To learn more about Visual Studio 2017 for Mac, see Mac System Requirements and Mac Platform Targeting and Compatibility.

Para saber mais sobre outros downloads relacionados, consulte a página Downloads.To learn more about other related downloads, see the Downloads page.

ComentáriosFeedback

Adoraríamos ouvir sua opinião!We’d love to hear from you! Você pode relatar um problema usando a opção Relatar um Problema do IDE do Visual Studio para Mac e acompanhar seus comentários no portal da Comunidade de Desenvolvedores.You can report a problem via the Report a Problem option the Visual Studio for Mac IDE and track your feedback in the Developer Community portal. Para sugestões, fale conosco por meio do UserVoice.For suggestions, let us know through UserVoice.

Histórico de versõesRelease History


Release Notes Icon Visual Studio 2017 para Mac 7.4 (7.4.0.1033)Visual Studio 2017 for Mac 7.4 (7.4.0.1033)

lançado em 5 de março de 2018released March 5, 2018

Para a versão do Visual Studio para Mac 7.4, reservamos um tempo para focar na correção de alguns dos principais vazamentos de memória, problemas de desempenho e problemas de estabilidade que foram relatados.For the Visual Studio for Mac 7.4 release, we've taken time to focus on fixing some of the top memory leaks, performance problems, and stability issues that have been reported to us. Esta versão também oferece suporte para o desenvolvimento do Android Oreo 8.1 e várias melhorias de produtividade para desenvolvedores do Xamarin.This release also brings support for Android Oreo 8.1 development and several productivity enhancements for Xamarin developers.

Destaques da versãoRelease Highlights

  • Agora, o macOS High Sierra tem suporte oficialmente.macOS High Sierra is now officially supported.
  • Suporte para Xcode 9.3.Support for Xcode 9.3.
  • O C# 7.1 agora tem suporte (confira novidades no C# 7.1).C# 7.1 is now supported (see what's new in C# 7.1).
  • Suporte para Android 8.1 Oreo.Support for Android 8.1 Oreo.
  • Implantação sem fio e depuração para Xamarin.iOS.Wireless deployment and debugging for Xamarin.iOS.
  • Foram feitas importantes alterações de arquitetura no editor C#; como resultado, o desempenho e a confiabilidade do IntelliSense e a capacidade de resposta a digitação foram aperfeiçoados.Core architectural changes were made to the C# editor; both IntelliSense performance/reliability and typing responsiveness are improved as a result.

Problemas corrigidos nesta versãoIssues fixed in this release

Versão em DetalhesRelease in Detail

  • Adição de um menu Editar > Alternar para o Modo de Sugestão, para alternar entre o modo de sugestão do IntelliSense e o modo de conclusão.Added an Edit > Switch to Suggestion Mode menu, to toggle between IntelliSense suggestion mode and completion mode. No modo de sugestão, as sugestões de preenchimento automático do IntelliSense não substituirão o texto que você escreveu, a menos que você as escolha manualmente da lista de sugestões do IntelliSense.In suggestion mode, IntelliSense auto-complete suggestions will not override the text you've written unless you manually choose them from the IntelliSense suggestion list. Para voltar ao Modo de Conclusão, você pode escolher o menu Editar | Alternar para o Modo de Conclusão.To switch back to Completion Mode you can choose the Edit | Switch to Completion Mode menu. Um atalho de teclado padrão do Ctrl+Alt+Espaço é fornecido se você estiver usando esquemas de associação de teclas do Visual Studio (Misto) ou Visual Studio (Windows).A default keyboard shortcut of Ctrl+Alt+Space is provided if you're using Visual Studio (Mixed) or Visual Studio (Windows) key binding schemes.

  • Adição de um atalho Cmd+Shift+P que abrirá a caixa de pesquisa Navegar para, filtrada de modo que você possa pesquisar comandos disponíveis com base no seu contexto atual.Added a Cmd+Shift+P shortcut that will open the Navigate To search box, filtered so you can search for available commands based on your current context.

Debug source files option
(Figura 1) Filtragem de Comando(Figure 1) Command Filtering
  • Pesquisa de fonte do depurador.Debugger source lookup.

    • Adição de suporte para a guia Arquivos de Origem do Depurador nas opções de solução (Figura 2).Added support for the Debug Source Files tab in solution options (Figure 2). Para manter a interface do usuário limpa, esse menu é exibido somente depois que você adicionar a primeira pasta.To keep the UI clean, this menu appears only after you add the first folder.

      Debug source files option
      (Figura 2) Opção de arquivos de origem do depurador(Figure 2) Debug source files option
    • Se você tentar navegar para um registro de ativação ou entrar em um método e o depurador não conseguir encontrar arquivos de origem, um novo documento Fonte Não Encontrada, a (Figura 3) será mostrada.If you try to navigate to a stack frame or step into a method and the debugger doesn't find source files, a new Source Not Found document (Figure 3) is shown. Este documento ajuda a fornecer algumas opções para localizar arquivos de origem caso eles existam.This document helps to provide some options to locate source files if you have them. Isso é útil ao depurar assemblies que foram compilados no CI e o usuário tem acesso aos arquivos de origem e ao arquivo .pdb.This is useful when debugging assemblies that were compiled on CI and user has access to source files and .pdb file.

      New 'source not found' dialog
      (Figura 3) Nova caixa de diálogo "origem não encontrada"(Figure 3) New "source not found" dialog
  • Inspetor de arquivo para detectar arquivos adicionados ao projeto.File watcher to detect files added to the project.

    O Visual Studio para Mac detectará os arquivos adicionado ou removidos de um projeto .NET Core e atualizará a janela Solução com as alterações de forma dinâmica.Visual Studio for Mac will now detect files added to or removed from a .NET Core project and update the Solution window with the changes dynamically. Essa melhoria tratou o problema de descarregamento/recarregamento necessário após migrações de EF relatado na Comunidade de Desenvolvedores.This improvement addressed the unload/reload required after EF migrations issue reported in the Developer Community.

  • Usar o diretório .vs para .userprefsUse .vs directory for .userprefs

    • Para melhorar a compatibilidade com o Visual Studio no Windows, os arquivos de preferências do usuário gerados pelo Visual Studio para Mac não são mais armazenados no diretório da solução, mas são armazenados no .vs/SolutionName/xs/UserPrefs.xml.To improve compatibility with Visual Studio on Windows the user preferences file generated by Visual Studio for Mac are no longer stored in the solution directory but are now stored in .vs/SolutionName/xs/UserPrefs.xml.

XamarinXamarin

  • Não oferecemos mais suporte à função "Carregar no Xamarin Test Cloud" no Visual Studio para Mac (chamado clicando na árvore de teste de Unidade).We no longer support the “Upload to Xamarin Test Cloud” function in Visual Studio for Mac (invoked by right-clicking the Unit test tree). Posteriormente, os testes podem ser enviados pela CLI do Visual Studio App Center.Moving forwards tests can be submitted through the Visual Studio App Center CLI.

  • Removemos o suporte para componentes no IDE.We have removed the support for components in IDE. Caso abra um projeto que tenha componentes já referenciados, você receberá uma mensagem de erro.If you open a project that has components already referenced, you will be met with an error. Para corrigir este erro, edite o arquivo .csproj manualmente e remova todas as informações nas marcações de <XamarinComponentReference/>.The fix this error, you must edit the .csproj file manually and remove all information in the <XamarinComponentReference/> tags. Para saber mais, veja o Guia de migração de componentes.For more information see the Components migration guide.

iOSiOS

  • Adicionamos suporte para a implantação sem fio e depuração para dispositivos iOS ou AppleTV.We've added support for wireless deployment and debugging for iOS or AppleTV devices. Quando um dispositivo está conectado por meio de uma rede e pronto para ser usado para a implantação, ele agora é exibido na lista de dispositivos de destino, como se estivesse conectado por USB.When a device is connected via a network and ready to be used for deployment, it now shows up in the device target list, as if the device were connected through USB. (Figura 4):(Figure 4):

    Apple device connected over Wi-Fi selected in device list
    (Figura 4) O dispositivo da Apple conectado por uma rede é exibido na lista de dispositivos(Figure 4) Apple device connected over a network is displayed in device list

    Para saber mais sobre esse recurso, veja o guia Implantação sem fio.For more information on this feature, see the Wireless Deployment guide.

  • O Visual Studio para Mac agora pede para desbloquear o dispositivo de implantação antes de iniciar o aplicativo (Figura 5) e não interrompe a sessão de depuração:Visual Studio for Mac now asks to unlock the deployment device before launching the app (Figure 5) and does not interrupt the debugging session:

    Alert advising user to unlock iOS device
    (Figura 5) Alerta avisando ao usuário para desbloquear o dispositivo iOS(Figure 5) Alert advising user to unlock iOS device
  • O Visual Studio para Mac agora gera automaticamente associações C# para modelos CoreML quando eles são adicionados a um projeto, permitindo a utilização rápida e fácil de modelos CoreML.Visual Studio for Mac now auto-generates C# bindings for CoreML models when they are added to a project allowing for quick and easy usage of CoreML models.

  • Aprimoramentos de Provisionamento:Provisioning Improvements:

    • Esta versão apresenta um melhor fluxo de trabalho de instalação do fastlane.This release introduces a better fastlane installation workflow. Se o fastlane não estiver instalado, em vez de mostrar uma caixa de diálogo de erro solicitando que você leia a documentação de provisionamento e instale o fastlane, forneceremos uma maneira de fazer isso no IDE.If fastlane is not installed, instead of showing an error dialog asking you to read the provisioning documentation and install fastlane, we provide a way to do it within the IDE.
    • Dependendo da velocidade da Internet e dos parâmetros do computador, a instalação pode levar até dois minutos.Depending on the internet speed and computer parameters the installation can take up to two minutes. Por esse motivo, o fastlane será baixado em segundo plano para sua conveniência.For this reason, fastlane will be downloaded in the background for your convenience.
    • Fizemos vários aprimoramentos na interface do usuário para o widget de provisionamento automático no editor Info.plist.We made a number of UI improvements to the automatic provisioning widget in Info.plist editor. O novo widget traça uma distinção definida entre os modos de provisionamento manuais e automáticos e comunica o status de provisionamento para o usuário.The new widget draws a definite distinction between manual and automatic provisioning modes and communicates provisioning status to the user.

AndroidAndroid

O Android 8.1 Oreo é a versão mais recente do Android disponível no Google.Android 8.1 Oreo is the latest version of Android available from Google. O Android Oreo 8.1 oferece muitos novos recursos do interesse de desenvolvedores do Xamarin.Android como Android Go, API de Redes Neurais, atualizações de Estrutura de Preenchimento Automático, API do SharedMemory e muito mais.Android 8.1 Oreo offers many new features of interest to Xamarin.Android developers such as Android Go, Neural Networks API, Autofill Framework updates, SharedMemory API, and many more. Essas APIs estão disponíveis para aplicativos do Xamarin.Android quando você usa o Xamarin.Android 8.2 e posterior.These APIs are available to Xamarin.Android apps when you use Xamarin.Android 8.2 and later.

  • Adicionamos integração para o Gerenciador de Dispositivos Xamarin Android (prévia) para usuários que têm o SDK Tools 26 instalado.We've added integration for the Xamarin Android Device Manager (preview) for users with SDK Tools 26 installed. Para saber mais, consulte a documentação.For more information, refer to the documentation.

  • Agora você será avisado se o emulador do Android não está usando HAXM.You'll now be warned if the Android emulator is not using HAXM.

Designers VisuaisVisual Designers

Designer do iOSiOS Designer
  • Associações de Teclas do Modo de Restrições:Constraints Mode Key Bindings:

    As novas associações de teclas facilitam o trabalho com o novo modo de restrições (introduzido no 15.5).New key bindings make it easier to work with the new constraints mode (introduced in 15.5). Por exemplo:For example:

    • Alternar o modo de restrições: ⌘ EToggle constraints mode: ⌘ E
    • Habilitar o modo de restrições temporariamente: Pressione ⌃Temporarily enable constraints mode: Hold ⌃
    • No modo de restrições, atualize as restrições; outros quadros de atualização: ⇧ ⌘ RIn constraints mode, update constraints; else update frames: ⇧ ⌘ R
  • Agora, as variações de características podem ser habilitadas para tvOS:Trait Variations can now be enabled for tvOS :

    As variações de características agora podem ser habilitadas para XIBs e storyboards do tvOS, o que permite a variação de estilo claro ou escuro.Trait variations can now be enabled for tvOS storyboards and XIBs, which enables variation by light style or dark style.

  • Reduzir automático ao arrastar itens grandes da Caixa de Ferramentas:Automatic Zoom Out when dragging large items from the Toolbox:

    A superfície de design agora reduz automaticamente quando você arrasta um item grande da caixa de ferramentas.The design surface now automatically zooms out when you drag a large item from the toolbox. Isso facilita a colocação de itens grandes no storyboard ou XIB.This makes it easier to place large items on your XIB or storyboard.

  • Seletor e Indicador de Zoom:Zoom Indicator and Selector:

    Indica o percentual do nível de zoom e permite a seleção dos níveis de zoom de uma lista pop-up.Indicates current zoom level percentage and enables selecting zoom levels from a pop up list.

Designer AndroidAndroid Designer
  • A análise e o processamento de recursos do Android foram amplamente renovados nessa versão, resultando em um melhor desempenho e maior precisão no painel.Android resource parsing and processing has been vastly revamped in this release resulting in increased performance and accuracy across the board.
  • Adição do suporte a renderização do Android Oreo (API 26).Added Android Oreo (API 26) rendering support.
  • Recursos do Oreo como fontes personalizadas e ícones adaptativos agora têm suporte.Oreo features like custom fonts and adaptive icons are now supported.
  • Melhorias na velocidade de renderização.Rendering speed improvements.
  • Aprimoramento da experiência de conclusão do IntelliSense.Improved IntelliSense completion experience.

Xamarin.FormsXamarin.Forms

Corrigimos uma séria de bugs para melhorar a edição do XAML:We fixed a number of bugs to improve XAML editing:

  • [CORRIGIDO] Comportamento inconsistente no editor XML/XAML entre vs/vsmac ao pressionar "ENTER" para adicionar um novo atributo a um elemento.[FIXED] Inconsistent behavior in XML/XAML editor between vs/vsmac when hitting "ENTER" in to add a new attribute to an element.
  • [CORRIGIDO] Faltam muitos elementos de conclusão: ResourceDictionary, x:Double, x:Key etc.[FIXED] Many elements are missing from completion: ResourceDictionary, x:Double, x:Key etc.
  • [CORRIGIDO] Nenhum IntelliSense após digitar um ponto no nome.[FIXED] No IntelliSense after typing period in name.
  • [CORRIGIDO] Falta uma Plataforma do IntelliSense.[FIXED] One Platform is missing from IntelliSense.
  • [CORRIGIDO] A tecla Tab insere espaços, e a opção de recuo insere tabulações.[FIXED] Tab key inserts spaces, indenter inserts tabs.
  • [CORRIGIDO] O IntelliSense XAML lista propriedades de elementos armazenadas por comprimento do nome.[FIXED] XAML IntelliSense lists element properties sorted by length of name.

Xamarin Workbooks e InstallerXamarin Workbooks and Installer

Separamos completamente o Xamarin Inspector do Xamarin Workbooks.We have fully split Xamarin Inspector from Xamarin Workbooks. A extensão Inspector não requer mais a instalação do Workbooks para funcionar.The Inspector extension no longer requires a Workbooks installation to function.

Notas de versão de todos os produtos do XamarinAll Xamarin Product release notes


Release Notes Icon Visual Studio 2017 para Mac 7.4.1 (7.4.1.48)Visual Studio 2017 for Mac 7.4.1 (7.4.1.48)

lançado em 26 de março de 2018released March 26, 2018


Release Notes Icon Visual Studio 2017 para Mac 7.4.2 (7.4.2.12)Visual Studio 2017 for Mac 7.4.2 (7.4.2.12)

lançado em 3 de abril de 2018released April 3, 2018

Esta versão inclui suporte para Xcode 9.3 e aborda os seguintes problemas:This release includes support for Xcode 9.3 and addresses the following issues:


Release Notes Icon Visual Studio 2017 para Mac 7.4.3 (7.4.3.10)Visual Studio 2017 for Mac 7.4.3 (7.4.3.10)

lançado em 18 de abril de 2018released April 18, 2018

Esta versão corrige os problemas a seguir:This release addresses the following issues:


Problemas ConhecidosKnown Issues


Histórico de notas de versão do Visual Studio 2017 para MacVisual Studio 2017 for Mac Release Notes History

Notas de versão atuaisCurrent Release Notes

Notas de versão do Visual Studio 2017 para Mac versão 7.4Visual Studio 2017 for Mac version 7.4 Release Notes

Notas de versão do Visual Studio 2017 para Mac versão 7.3Visual Studio 2017 for Mac version 7.3 Release Notes

Notas de versão do Visual Studio 2017 para Mac versão 7.2Visual Studio 2017 for Mac version 7.2 Release Notes

Notas de versão do Visual Studio 2017 para Mac versão 7.1Visual Studio 2017 for Mac version 7.1 Release Notes

Notas de versão do Visual Studio 2017 para Mac versão 7.0Visual Studio 2017 for Mac version 7.0 Release Notes


Início da página
Top of Page