Visual Studio 2017 versão 15.3 - notas de versão de visualizaçãoVisual Studio 2017 version 15.3 - Preview Release Notes


Comunidade de desenvolvedores | Requisitos do sistema | Compatibilidade | Código distribuível | Termos de licença | Blogs | Problemas conhecidosDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Known Issues


Observação

Esta não é a versão mais recente do Visual Studio 2017.This is not the latest version of Visual Studio 2017. Para obter informações sobre a versão mais recente do Visual Studio 2017, visite a página atual de Notas de versão.To see information on the latest version of Visual Studio 2017, please visit the current Release Notes page.


Neste artigo, você encontrará informações sobre a versão prévia libera para o Visual Studio 2017 versão 15.3.In this article, you will find information regarding the Preview releases for Visual Studio 2017 version 15.3.

Observação

Esta versão não é "go-live" e não se destina para uso em computadores de produção ou para a criação de código de produção.This release is not "go-live" and not intended for use on production computers or for creating production code.

Para saber mais sobre outros downloads relacionados, consulte a página Downloads.To learn more about other related downloads, see the Downloads page.

ComentáriosFeedback

Adoraríamos ouvir sua opinião!We’d love to hear from you! Você pode relatar um problema por meio da opção Relatar um Problema no canto superior direito do instalador ou do próprio IDE do Visual Studio.You can report a problem via the Report a Problem option in the upper right hand corner of either the installer or the Visual Studio IDE itself. Você pode acompanhar seus comentários no portal Developer Community (Comunidade do Desenvolvedor).You can track your feedback in the Developer Community portal. Para sugestões, fale conosco por meio do UserVoice.For suggestions, let us know through UserVoice.

Problemas ConhecidosKnown Issues

Consulte a seção Problemas conhecidos.Please refer to the Known Issues section.


Data de lançamento: 18 de agosto de 2017 – Visual Studio 2017 versão 15.3.1 versão prévia 1Release Date: August 18, 2017 - Visual Studio 2017 version 15.3.1 Preview 1

Problemas corrigidos nesta versãoIssues Fixed in this Release

Estes são os problemas relatados pelo cliente abordados nesta versão:These are the customer-reported issues addressed in this version:


Data de lançamento: 11 de agosto de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 7.1Release Date: August 11, 2017 - Visual Studio 2017 version 15.3.0 Preview 7.1

Problemas corrigidos nesta versãoIssues Fixed in this Release

Estes são os problemas relatados pelo cliente abordados nesta versão:These are the customer-reported issues addressed in this version:


Data de lançamento: 1 de agosto de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 7Release Date: August 1, 2017 - Visual Studio 2017 version 15.3.0 Preview 7

Problemas corrigidos nesta versãoIssues Fixed in this Release

Estes são os problemas relatados pelo cliente abordados nesta versão:These are the customer-reported issues addressed in this version:


Data de lançamento: 26 de julho de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 6Release Date: July 26, 2017 - Visual Studio 2017 version 15.3.0 Preview 6

Problemas corrigidos nesta versãoIssues Fixed in this Release

Estes são os problemas relatados pelo cliente abordados nesta versão:These are the customer-reported issues addressed in this version:


Data de lançamento: 24 de julho de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 5Release Date: July 24, 2017 - Visual Studio 2017 version 15.3.0 Preview 5

Problemas corrigidos nesta versãoIssues Fixed in this Release

Estes são os problemas relatados pelo cliente abordados nesta versão:These are the customer-reported issues addressed in this version:


Data de lançamento: 12 de julho de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 4Release Date: July 12, 2017 - Visual Studio 2017 version 15.3.0 Preview 4

Resumo de atualizaçõesSummary of Updates

Principais problemas corrigidos nesta versãoTop Issues Fixed in this Release

A Comunidade de Desenvolvedores falou e nós escutamos.The Developer Community spoke and we listened. Esta lista fornece os problemas mais votados e que foram corrigidos nesta versão.This list provides the issues that received your highest votes and were fixed in this release.


O que há de novo nesta versãoWhat's New in this Release

Aprimoramentos ao IDE do Visual Studio Visual Studio IDE Improvements

  • Adicionamos o comando de menu de acessibilidade do teclado sob o menu "Ajuda".We added the Keyboard Accessibility menu command under the "Help" menu. Isso fornece a você um atalho para a documentação online sobre Dicas e Truques de Acessibilidade.This provides you with a shortcut to online documention about Accessibility Tips and Tricks.
  • O vswhere.exe arquivo executável não mostra mais instâncias de versão prévia por padrão.The vswhere.exe executable file no longer shows preview instances by default. Para pesquisar a versão prévia ou outras instâncias de pré-lançamento, você deve passar -prerelease na linha de comando.To search preview or other prerelease instances, you must pass -prerelease on the command line.
  • O sistema de diagnóstico agora informará por meio da barra de informações sobre as extensões que podem ter sido envolvidas em um encerramento inesperado do Visual Studio.The diagnostic system will now inform you via InfoBar about extensions that might have been involved in an unexpected termination of Visual Studio. A barra de informações (Figura 1) fornece informações sobre o encerramento e perguntará se você gostaria de desabilitar a extensão suspeita.The InfoBar (Figure 1) provides information about the termination and will ask if you would like to disable the suspected extension.
InfoBar
(Figura 1) Barra de informações(Figure 1) InfoBar

Serviços de Linguagem C++ C++ Language Services

  • Vários assistentes de código e de projeto foram reescritos no estilo de caixa de diálogo de assinatura.Several project and code wizards have been rewritten in the signature dialog style.
  • Adicionar Classe agora inicia o Assistente para Adicionar Classe diretamente.Add Class now launches the Add Class wizard directly. Todos os outros itens que estavam anteriormente aqui agora estão disponíveis em "Adicionar > Novo Item".All of the other items that were previously here are now available under "Add > New Item".
  • Projetos de Win32 agora estão sob a categoria Área de Trabalho do Windows na caixa de diálogo Novo Projeto.Win32 projects are now under the Windows Desktop category in the New Project dialog.
  • Os modelos de Console do Windows e Aplicativo de Área de Trabalho agora criam projetos sem exibir um assistente.The Windows Console and Desktop Application templates now create the projects without displaying a wizard. Agora há um novo Assistente de Área de Trabalho do Windows, sob a mesma categoria e que exibe as mesmas opções de antes.There's a new Windows Desktop Wizard now under the same category that displays the same options as before.
  • Suporte aprimorado de depuração em "Abrir pasta" para os executáveis compilados com GCC com base em compiladores como MinGW e Cygwin.Improved debugging support in "Open Folder" for executables built with GCC based compilers such as MinGW and Cygwin.
  • Adicionado suporte para definir variáveis de ambiente globais e específicas de configuração em "CppProperties.json" e "CMakeSettings.json".Added support to define global and configuration specific environment variables in "CppProperties.json" and "CMakeSettings.json". Essas variáveis de ambiente podem ser consumidas por configurações de depuração definidas em "launch.vs.json" e tarefas em "tasks.vs.json".These environment variables can be consumed by debug configurations defined in "launch.vs.json" and tasks in "tasks.vs.json".
  • Suporte aprimorado para o gerador Ninja do CMake, incluindo a capacidade de direcionar facilmente plataformas de 64 bits.Improved support for CMake's Ninja generator, including the ability to easily target 64-bit platforms.

Suporte à Linguagem C# 7.1C# 7.1 Language Support


Data de lançamento: 26 de junho de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 3Release Date: June 26, 2017 - Visual Studio 2017 version 15.3.0 Preview 3

Resumo de atualizaçõesSummary of Updates

Principais problemas corrigidos nesta versãoTop Issues Fixed in this Release

A Comunidade de Desenvolvedores falou e nós escutamos.The Developer Community spoke and we listened. Esta lista fornece os problemas mais votados e que foram corrigidos nesta versão.This list provides the issues that received your highest votes and were fixed in this release.


O que há de novo nesta versãoWhat's New in this Release

Aprimoramentos do .NET core e ASP.NET Core .NET Core and ASP.NET Core improvements

  • Interoperabilidade do .NET framework e .NET Standard/Core: os usuários podem agora mais perfeitamente instalarem ou fazer referência às bibliotecas .NET Core/.NET Standard de projetos do .NET Framework e vice-versa..NET Framework and .NET Standard/Core interop: Users can now more seamlessly install or refer to .NET Core/.NET Standard libraries from .NET Framework projects and vice versa. Não é preciso adicionar manualmente os pacotes do NuGet interoperabilidade – sistema faz isso para você automaticamente.No need to manually add interop NuGet packages – system does this for you automatically.
  • Compilação: Compilações incrementais para o .NET Core agora é ativado por padrão.Build: Incremental builds for .NET Core is now turned ON by default.
  • Do Live Unit Testing: Do Live Unit Testing agora funciona para projetos .NET Core que direcionam várias estruturas de destino.Live Unit Testing: Live Unit Testing now works for .NET Core projects that target multiple Target Frameworks.
  • ASP.NET Core: Além do IIS Express, podemos também dão suporte a F5 com o IIS para projetos do ASP.NET Core.ASP.NET Core : In addition to IIS Express, we now also support F5 with IIS for ASP.NET Core projects.
  • Suporte para .NET Core 2.0 e ASP.NET Core 2.0: essa versão prévia do Visual Studio, continua a oferecer suporte a criação e execução de aplicativos .NET Core 2.0 se o SDK 2.0 é instalado separadamente.Support for .NET Core 2.0 and ASP.NET Core 2.0: This preview release of Visual Studio, continues to support creating and running .NET Core 2.0 apps if the 2.0 SDK is installed separately. A demonstração pública mais recente do SDK do .NET Core 2.0 está disponível para você baixar.Latest public preview of .NET Core 2.0 SDK is available for you to download.
    • Se você quiser fazer experiências com compilações diárias de visualização do .NET Core, você pode instalar o build diário mais recente do SDK do .NET Core.If you would like to experiment with .NET Core Preview daily builds, you can install the latest daily build of the .NET Core SDK. Escolha o pacote apropriado da tabela instaladores e binários.Choose the appropriate package from the Installers and Binaries table. Essas compilações diárias funcionará com esta versão de visualização do Visual Studio.These daily builds will work with this preview release of Visual Studio.
  • Consulte o blog do .NET Core 2.0 para obter mais detalhes.See .NET Core 2.0 blog for more details.

Aprimoramentos do NuGet NuGet improvements

  • O NuGet agora exibe avisos e erros aprimorados ao instalar pacotes ou adicionar referências de projeto para projeto que não são compatíveis.NuGet now displays improved warnings and errors when installing packages or adding project-to-project references that are not compatible.
  • O NuGet agora permite que você suprima avisos específicos ou todos os avisos ou eleve-os a erros por meio de propriedades de Build.NuGet now allows you to suppress specific or all warnings or elevate them to errors via Build properties.

Melhorias do Visual Studio IDE Visual Studio IDE improvements

  • O Instalador do Visual Studio agora dá suporte a dimensionamento de DPI alto em níveis de menos de 150%.Visual Studio Installer now supports high-DPI scaling at levels less than 150%.

  • Em cenários de abrir pasta, você pode selecionar o depurador desejado por meio da interface do usuário dedicada.In open folder scenarios, you can select your desired debugger via dedicated UI.

  • Nós interrompemos o compartilhamento de algumas configurações, tais como o layout de janela de ferramentas, entre diferentes instalações lado a lado do Visual Studio 2017; isso foi feito alterando o local do arquivo “CurrentSettings.vssettings” em “%userprofile%\Documents\Visual Studio 2017\Settings” para uma pasta de instalação específica que se parece com “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx\Settings”.We’ve stopped sharing certain settings, like tool window layout, between different side by side installations of Visual Studio 2017 by changing location of “CurrentSettings.vssettings” file in “%userprofile%\Documents\Visual Studio 2017\Settings” to an installation specific folder that looks like “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx\Settings”.

    OBSERVAÇÃO: o local de configurações específicas de nova instalação é usado somente no caso de uma nova instalação.NOTE: The new installation specific settings location is used only in case of a fresh installation. Fazer uma atualização de uma instalação do Visual Studio 2017 existente resultará no uso do local compartilhado existente.Doing an upgrade of an existing Visual Studio 2017 installation to this update will result in using the existing shared location. Se atualmente você tiver instalações lado a lado do Visual Studio 2017 e decide atualizar e desejar fazer a usar o novo local do arquivo de configurações específicas de instalação do Visual Studio, consulte as seguintes etapas:If you currently have side by side installations of Visual Studio 2017 and decide to upgrade and wish to make Visual Studio use the new installation specific settings file location, see following steps:

    1. Após a atualização, use o assistente de configurações de Importação\Exportação para exportar todas as configurações existentes para um local fora da pasta “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx”.After the upgrade use the Import\Export settings wizard to export all your existing settings to some location outside of “%localappdata%\Microsoft\VisualStudio\15.0_xxxxxxxx” folder.
    2. Abra o prompt de comando do desenvolvedor da instalação do Visual Studio atualizada e execute devenv resetuserdata por meio dele.Open the developer command prompt of the upgraded Visual Studio installation and run devenv resetuserdata from it.
    3. Inicie o Visual Studio e importe as configurações salvas do arquivo de configurações exportado.Launch Visual Studio and import the saved settings from the exported settings file.

    Carga de Solução LeveLightweight Solution Load

  • Adicionado resultados da pesquisa de arquivo de pesquisa do Gerenciador de Soluções para projetos adiados, em vez de apenas para projetos carregados.Added file search results for Solution Explorer search for deferred projects, instead of just for loaded projects.

    • Existem alguns limites para isso:There are some limits to this:
      • A pesquisa não se estende para dentro do arquivo e não inclui resultados progressivos, ou seja, classes, métodos, etc.Search does not extend to within the file and does not include progressive results, i.e. classes, methods, etc.
      • Arquivos que pertencem a um projeto são mostrados como uma lista plana.Files belonging to a project are shown as a flat list. Quando arquivos pertencem a uma pasta, é mostrado o caminho relativo em vez de apenas o nome do arquivo.When files belong to a folder, the relative path is shown instead of just the file name.
      • Não há nenhum menu de contexto para os itens de arquivo na exibição de pesquisa.There are no context menus for the file items in the search view.
    • Quando você carrega um projeto, todas as pesquisas existentes serão atualizadas para adicionar os resultados de progressão.When you load a project, all existing searches will be refreshed to add progression results.
  • Ir para Tudo e Ir para Arquivos mostram conteúdos de itens externos no espaço de trabalho.GoTo All and GoTo Files now show content from external items in the workspace.

  • Corrigimos o build em Lote em projetos usando LSL.We fixed Batch build in projects using LSL.

    ConfiguraçãoSetup

  • A CLI é capaz de manipular --verify, --fix e --clean.CLI is able to handle --verify, --fix and --clean.

    • --verify verifica o layout e informa você sobre cargas ausentes ou inválidas.--verify verifies layout and informs you of missing and invalid payloads.
    • --fix verificará o layout e baixará novamente os pacotes que estão faltando ou são inválidos.--fix will verify the layout and re-download the packages that are either missing or invalid.
    • --clean excluirá pacotes obsoletos e permitirá que você corte o layout para um intervalo de versão específico.--clean will delete obsolete packages and allows you to trim layout to a specific version range.

Data de lançamento: 20 de junho de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 2.1Release Date: June 20, 2017 - Visual Studio 2017 version 15.3.0 Preview 2.1

Principais problemas corrigidos nesta versãoTop Issues Fixed in this Release


Data de lançamento: 8 de junho de 2017 – Visual Studio 2017 versão 15.3.0 versão prévia 2Release Date: June 8, 2017 - Visual Studio 2017 version 15.3.0 Preview 2

Resumo de atualizaçõesSummary of Updates

Principais problemas corrigidos nesta versãoTop Issues Fixed in this Release

A Comunidade de Desenvolvedores falou e nós escutamos.The Developer Community spoke and we listened. Esta lista fornece os problemas mais votados e que foram corrigidos nesta versão.This list provides the issues that received your highest votes and were fixed in this release.


O que há de novo nesta versãoWhat's New in this Release

.NET Framework 4.7 .NET Framework 4.7

15.3 versão prévia 2 do Visual Studio 2017 agora oferece as ferramentas de desenvolvimento do .NET Framework 4.7 para todas as plataformas compatíveis com o tempo de execução 4.7 incluído.Visual Studio 2017 15.3 Preview 2 now offers the .NET Framework 4.7 development tools to all supported platforms with the 4.7 runtime included. O .NET Framework 4.7 oferece diversos novos recursos e melhorias, bem como várias correções de confiabilidade, estabilidade, segurança e desempenho.The .NET Framework 4.7 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes. Você pode exibir mais detalhes sobre .NET 4.7 aqui:You can view more details about .NET 4.7 here:

Melhorias do Visual Studio IDE Visual Studio IDE improvements

Entrada-no/Connected ServicesSign-In/Connected Services

  • Adicionamos suporte condicional falha de acesso e autorização.We've added support conditional access and authorization failure.
    • Os usuários agora podem entrar no Visual Studio, mesmo se eles têm a autenticação multifator ativada somente para alguns recursos usados no fluxo de entrada do Visual studio.Users can now sign into Visual Studio even if they have Multifactor authentication turned on only for some resources used in the Visual studio sign in flow.
  • Conectado guia mostra os serviços que os serviços que já foram configurados.Connected Services tab shows which services have already been configured.
    • Agora você pode ver um indicador visual para o serviço conectado configurado na guia serviço conectado (Figura 2).You can now see visual indicator for configured connected service in Connected Service tab (Figure 2).
  • Adicionado suporte de interface do usuário para a adição de pilhas ADFS do azure, juntamente com nuvens governamentais.Added UI support for adding of ADFS azure stacks along with government clouds.
Connected Services with Configured badge
(Figura 2) Serviços conectados com notificação configurado(Figure 2) Connected Services with Configured badge
  • Resolver um bug em que contas antigas apareceriam no seletor de conta.Resolved a bug where old accounts would show up in the Account Picker.

Visual Studio IDEVisual Studio IDE

  • Entrada de Visual Studio 2017 no painel de controle -> programas desinstalar/alterar agora dá suporte a modificar.Visual Studio 2017 entry in Control Panel -> Uninstall/Change Programs now supports Modify.
    • Nas versões anteriores, você só poderá desinstalar no painel de controle.In previous versions, you could only uninstall from Control Panel.
  • Adicionamos um item "Obtenha ferramentas e recursos..." na parte superior do seu menu de ferramenta para torná-lo mais fácil adicionar mais componentes (Figura 3).We've added a "Get Tools and Features..." item to the top of your Tool menu to make it easier to add more components (Figure 3).
    • Isso iniciará o instalador na tela modificar para ajudá-lo a adicionar rapidamente as ferramentas e recursos que você precisa.This will launch the installer on the Modify screen to help you quickly add the tools and features you need.
Menu item to add more tools and features
(Figura 3) Item de menu para adicionar mais ferramentas e recursos(Figure 3) Menu item to add more tools and features
  • Resolveu um travamento que estava ocorrendo ao alternar entre as guias de arquivo.Solved a hang that was occurring when switching between file tabs.
  • Adicionamos uma nova tela de apresentação (Figura 4).We've added a new Splash Screen (Figure 4).
    • Além disso, essa tela será exibida se a versão é uma versão de visualização.As well, this screen will display if the version is a Preview version.
Splash Screen with Preview Badge
(Figura 4) Tela de abertura com selo de visualização(Figure 4) Splash Screen with Preview Badge
  • Corrigido um problema de atalho, fazendo com que os monitores para desconectar-se em laptops da Intel.Fixed a shortcut issue causing monitors to disconnect on Intel laptops.
    • Nas versões anteriores, o atalho padrão para enviar por push as confirmações não publicadas (Ctrl + Alt + F8) era o mesmo que o atalho para desconectar monitores em laptops da Intel.In previous versions, the default shortcut to push unpublished commits (Ctrl + Alt +F8) was the same as the shortcut to disconnect monitors on Intel laptops. Alteramos o atalho para Ctrl + E, Ctrl + C para corrigir esse problema.We've changed the shortcut to Ctrl + E, Ctrl + C to fix this.

Gerenciador de SoluçõesSolution Explorer

  • CamelCase habilitado correspondente para arquivos.Enabled camelCase matching for files.
  • Abrir pasta agora dá suporte a MinGW e Cygwin depuradores.Open folder now supports MinGW and Cygwin debuggers.
  • Agora como um empecilho ao arquivo indesejado move dentro do Gerenciador de soluções, um prompt pedirá confirmação sempre que os arquivos são movidos.As a deterrent to unwanted file moves inside the Solution Explorer, a prompt now asks for confirmation whenever files are moved. Os usuários podem desabilitar o prompt e habilitar novamente, vá para Ferramentas / opções...Users can disable the prompt and re-enable by going to Tools / Options… / Projetos e soluções (Figura 5)./ Projects and Solutions (Figure 5).
Warning when moving files in Solution Explorer
(Figura 5) Aviso ao mover arquivos no Gerenciador de soluções(Figure 5) Warning when moving files in Solution Explorer

EditorEditor

  • Os diferentes ícones para correções rápidas e refatorações na lâmpada.Different icons for quick fixes and refactorings in Lightbulb.

ConfiguraçãoSetup

  • O programa de instalação do Visual Studio melhorou a nossa estimativa de tamanho de instalação para ser mais precisa com base no que você tiver selecionado no momento e instalado anteriormente.Visual Studio’s Installer program has improved our install size estimation to be more accurate based on what you have currently selected and previously installed.
  • Atualizações do Visual Studio agora exibirá um novo formato de versão para torná-lo mais fácil de entender quais atualizações que você está recebendo.Visual Studio updates will now display a new version format to make it easier to understand what updates you are getting.
    • Essa versão serão exibidos no aplicativo instalador (Figura 6), Ajuda > sobre atualizações e caixa de diálogo notificações, por exemplo:This version will show in the installer application (Figure 6), Help > About dialog and updates notifications, for example:
About dialog with Version
(Figura 6) Sobre a caixa de diálogo com a versão(Figure 6) About dialog with Version
  • O --layout recurso agora inclui a capacidade de modificar ou layouts existentes de upgrade, verificar e corrigir layouts corrompidos e limpar os layouts de versões mais antigas não for mais necessários.The --layout feature now includes the ability to modify or upgrade existing layouts, verify and fix corrupted layouts, and clean layouts of older builds no longer needed. Além disso, durante a criação de layouts parciais um Response é criado com os padrões para instalar os componentes que foram incluídos no layout parcial e cargas de trabalho.Additionally, when creating partial layouts a response.json is created with defaults to install the workloads and components that were included in the partial layout.

Depuração e Diagnósticos Debugging and Diagnostics

Suporte do Depurador para os Servidores de Símbolos do Visual Studio Team ServicesDebugger Support for Visual Studio Team Services Symbol Servers

Agora você pode consultar e baixar símbolos (Figura 7) do Visual Studio Team Services símbolo Servers (atualmente em versão prévia privada).You can now query and download symbols (Figure 7) from Visual Studio Team Services Symbol Servers (currently in private preview). Você pode selecionar e adicionar caminhos de símbolo do Visual Studio Team Services ao seu ambiente do Visual Studio usando a página Ferramentas -> Opções -> Depurador -> Símbolos.You can select and add Visual Studio Team Services symbol paths to your Visual Studio environment using the Tools->Options->Debugger->Symbols page. Para configurar um servidor de símbolo do Visual Studio Team Services seguir estas instruções para inscrever-se a versão prévia privada.To set up a Visual Studio Team Services Symbol Server follow these instructions to sign up for the private preview.

Add VSTS Symbol Server
(Figura 7) Adicionar Servidor de Símbolos do VSTS(Figure 7) Add VSTS Symbol Server

Aponte e clique para Definir a Próxima InstruçãoPoint and Click to Set Next Statement

Agora, você pode manter pressionada a tecla Ctrl enquanto estiver parado em um ponto de interrupção durante a depuração.You can now hold down the Ctrl key while stopped at a breakpoint when debugging. O ícone Executar até o Clique (Realizar a execução até aqui) ao lado da linha de código foi alterado para a funcionalidade “Definir Próxima Instrução” (Figura 8).The Run to Click (Run execution to here) icon next to your line of code changes to “Set Next Statement” functionality (Figure 8). Clique para mover o ponteiro de instrução amarelo para essa linha e definir a próxima instrução para o depurador executar.Click on it to move the yellow instruction pointer to that line and set the next statement for the debugger to execute.

Click to Set Next Statement
(Figura 8) Clique para definir a próxima instrução(Figure 8) Click to Set Next Statement

O link de origem agora tem suporte em PDBs do Windows (além de PDBs portáteis).Source Link is now supported for Windows PDBs (in addition to Portable PDBs). Compiladores que dão suporte a ele podem colocar as informações necessárias no PDB do Windows e o depurador pode recuperar arquivos de origem com base nessas informações.Compilers that support it can put the necessary information in the Windows PDB and debugger can retrieve source files based on that information.

Aprimoramentos de Depuração de Abrir PastaOpen Folder Debugging Improvements

Agora você pode mais facilmente escolher sua experiência de depuração ao usar a pasta aberta.You can now more easily choose your debugging experience when using Open Folder. Com os novos modelos para a pasta aberta experiência, se você tiver o depurador core experiência instalada, agora você pode escolher o tipo de depurador que você deseja usar (gerenciado, nativo ou misto) na caixa de diálogo "Selecionar um depurador" acessado por meio de "depurar e iniciar Opção de menu de configurações"no Gerenciador de soluções.With the new templates for the Open Folder experience, if you have the core debugger experience installed you can now choose the type of debugger you want to use (Managed, Native, or Mixed) from the "Select a Debugger" dialog accessed through the "Debug and Launch Settings" menu option in Solution Explorer. Se você tiver uma experiência de MDD do C++ instalada (C++ Android, depuração do Linux, etc.), você agora verá opções de suporte para MinGW e Cygwin usando GDB para anexar e inicializar dentro da mesma opção de menu.If you have a C++ MDD experience installed (Android C++, Linux Debugging, etc.), you will now see options for MinGW and Cygwin support using GDB for attach and launch within the same menu option.

Atualizar Todos os Valores Aninhados nas Janelas de VariáveisRefresh All Nested Values in Variable Windows

Agora quando você clica no botão Atualizar para o nó pai de uma variável ou expressão nas janelas inspeção, Autos e locais, todas as variáveis e expressões visíveis que são filhos do nó também ser atualizadas e reavaliadas.Now when you click the refresh button for the parent node of a variable or expression in the Watch, Autos, and Locals windows, all visible variables and expressions that are children of that node will also be refreshed and re-evaluated. Você não precisa clicar no botão de atualização para cada um dos filhos.You no longer have to click on the refresh button for each of the children.


Data de lançamento: 11 de maio de 2017 – Visual Studio 2017 Preview versão 15.3 (26510.00 - versão prévia)Release Date: May 11, 2017 - Visual Studio 2017 Preview version 15.3 (26510.00 - Preview)

Principais problemas corrigidos nesta versãoTop Issues Fixed in this Release

  • Corrigido o problema em que o uso de projetos da UWP RS3 produzidos rabiscos nas marcações devido a recursos que estão faltando.Fixed issue where the use of RS3 UWP projects produced squiggles in the markups due to missing resources.
  • Problema de confiabilidade da interface do usuário do instalador fixado produzido quando um usuário clica no botão Iniciar Depois de clicar em Cancelar.Fixed installer UI reliability issue produced when a user clicks on the launch button after clicking on cancel.

Data de lançamento: 10 de maio de 2017 – Visual Studio 2017 Preview versão 15.3 (26507.0 - versão prévia)Release Date: May 10, 2017 - Visual Studio 2017 Preview version 15.3 (26507.0 - Preview)

Resumo das atualizações nesta versãoSummary of Updates in this Release

Principais problemas corrigidos nesta versãoTop Issues Fixed in this Release

A Comunidade de Desenvolvedores falou e nós escutamos.The Developer Community spoke and we listened. Esta lista fornece os problemas mais votados e que foram corrigidos nesta versão.This list provides the issues that received your highest votes and were fixed in this release.


O que há de novo nesta versãoWhat's New in this Release

.NET Core .NET Core

  • Adicionamos suporte a Live Unit Testing para projetos do .NET Core.We added live Unit Testing support for .NET Core projects.
  • Você pode agora criar aplicativos de console .NET Core e bibliotecas de classes do .NET Core e do .NET Standard usando Visual Basic.You can now create .NET Core console applications, and .NET Core and .NET Standard class libraries using Visual Basic.
  • O Visual Studio agora dá suporte à criação e execução de aplicativos .NET Core 2.0 se o SDK é instalado separadamente.Visual Studio now supports creating and running .NET Core 2.0 apps if the SDK is installed separately. Instalar os builds mais recentes do SDK do .NET Core 2.0.Install the latest builds of the .NET Core 2.0 SDK.

Consulte o blog do .NET Core 2.0 para obter mais detalhes.See .NET Core 2.0 blog for more details.

As ferramentas do ASP.NET Core ASP.NET Core tooling

Adicionamos suporte para colocar em contêineres aplicativos ASP.NET Core como imagens do Windows Nano.We added support for containerizing ASP.NET Core apps as Windows Nano images. Agora é possível selecionar Nano como a plataforma do contêiner.You can now select Nano as the container platform. Você pode fazer isso em Arquivo -> Novo Projeto para projetos do ASP.NET Core.You can do this under File->New Project for ASP.NET Core projects. Para seus projetos existentes, ele pode ser adicionado usando o menu de contexto do projeto.For your existing projects, it can be added using the Project Context Menu.


Adicionamos clusters de eventos relacionados aos resultados da consulta de pesquisa na ferramenta Pesquisa do Application Insights.We added clusters of related events to the search query results in the Application Insights Search tool. Esses clusters podem lhe ajudar a descobrir padrões surpreendentes no comportamento do seu aplicativo, tais como um grande volume de exceções provenientes de um único país, versão ou usuário.These clusters can help you discover surprising patterns in your application's behavior, like a large volume of exceptions coming from a single country, version, or user.


Depuração e Diagnósticos Debugging and Diagnostics

  • O API SetThreadDescription agora tem suporte durante a depuração usando Iniciar depuração (F5) ou anexar ao processo (Ctrl + Alt + P).The SetThreadDescription API is now supported while debugging using Start Debugging (F5) or Attach to Process (Ctrl+Alt+P). Os nomes de thread definidos por meio dessa API agora aparecerão na janela Threads e na lista suspensa Thread na barra de ferramentas Local de Depuração.The thread names that are set via this API will now show up in the Threads window and in the Thread dropdown in the Debug Location toolbar. Isso não tem suporte atualmente durante a depuração de despejo.This is not currently supported while dump debugging.
  • A Janela de Saída agora mostra a saída do console de um aplicativo em execução dentro de um Contêiner do Windows durante a depuração.The Output Window now shows you the console output of an application running inside a Windows Container while debugging.
  • Adicionamos novo suporte para depuração de aplicativos .NET Core que você executa dentro de contêineres do Windows baseados no Nano Server.We added new support for debugging .NET Core apps you run inside Windows Containers based on Nano Server.

Aprimoramentos ao IDE do Visual Studio Visual Studio IDE Improvements

Melhorias do IDEIDE improvements

  • Corrigimos o bug "janela oculta" que fazia com que o Visual Studio travasse antes de a janela principal ser exibida.We fixed the "hidden window" bug that made Visual Studio appear to hang before its main window appeared.
  • Aumentamos a área de destino que pode ser clicada para tornar mais fácil ignorar dicas de notificação.We increased the clickable target area to make it easier to dismiss notification tips.
  • Adicionamos suporte para globalização de arquivo fora de sua pasta de projeto.We added support for file globbing outside of your project folder.

Melhorias do IDE .NET.NET IDE Improvements

  • Adicionamos várias novas refatorações e correções rápidas, como "Resolver conflitos de mesclagem", "Adicionar verificações nulas", "Adicionar parâmetro" e muito mais.We added several new refactorings and quick fixes, like "Resolve merge conflicts", "Add null checks", "Add parameter", and many more. Visite nossa documentação para ver a lista completa.Visit our documentation to see the full list.
  • Sugerimos nomes de variáveis no IntelliSense para lhe ajudar a nomear suas variáveis rapidamente, por exemplo, Person person.We suggest variable names in IntelliSense to help you name your variables quickly, e.g., Person person.
  • Editar e Continuar agora dá suporte a recursos do C# 7.0 (exceto funções locais).Edit and Continue now supports C# 7.0 features (except local functions).

Melhorias para entrar e de identidadeSign in and identity improvements

  • Corrigimos o controle de seletor de conta de modo que "Reinserir credenciais" funciona com mais eficiência.We fixed the account picker control so "Re-enter credentials" works more reliably.
  • Em alguns casos, o seletor de conta desmarcava contas após a reinserção de credenciais.In some cases, the account picker would clear accounts upon re-entering credentials. Essa correção deve solucionar esse problema.This fix should resolve that issue.

Página inicialStart page

Aumentamos a área de destino na qual é possível clicar nos "alfinetes" de MRU da Home Page para facilitar a fixação de itens importantes para você na parte superior do MRU.We increased the clickable target area on Start Page MRU “pins” to make it easier to pin items you care about to the top of the MRU.

Carga de solução leveLightweight solution load

  • Aumentamos a velocidade de build e a estabilidade.We increased build speed and stability.
  • Reduzimos o número de projetos carregados.We reduced the number of loaded projects.
  • Fornecemos uma nova opção (Figura 9) para permitir que o Visual Studio decida o que é melhor para essa solução.We provided a new option (Figure 9) to let Visual Studio decide what’s best for this solution.
Lightweight Solution Load Options
(Figura 9) Opções de carregamento de solução leve(Figure 9) Lightweight Solution Load Options

Abrir pastaOpen folder

  • Melhoramos a estabilidade ao alternar entre a solução e a pasta.We improved stability for toggling between folder and solution.
  • Extensores de abrir a pasta podem adicionar o ícone de controle do código-fonte a suas pastas.Open folder extenders can add source control icon to your folders. Isso permite que você veja rapidamente o estado de controle do código-fonte de seus arquivos no Gerenciador de Soluções.This allows you to quickly see source control state of your files in Solution Explorer. Implementado atualmente pelo SVN.Currently implemented by SVN.

Ferramentas de entrega contínuaContinuous delivery tools

Os seguintes recursos da extensão de CD4VS para o Visual Studio foram melhorados:We moved these features from the CD4VS extension into Visual Studio:

  • Configure a entrega contínua para soluções que contêm projetos ASP.NET direcionados para um Serviço de Aplicativo do Azure.Configure continuous delivery for solutions containing ASP.NET projects targeting an Azure App Service.
  • Configure a entrega contínua para soluções que contêm projetos ASP.NET Core direcionados para um Serviço de Aplicativo do Azure.Configure continuous delivery for solutions containing ASP.NET Core projects targeting an Azure App Service.

Ferramentas de desenvolvimento de contêinerContainer development tools

Visualização do Visual Studio 2017 15.3 agora dá suporte a amplitude do desenvolvimento de contêiner em aplicativos do .NET Framework existentes com contêineres do Windows, ao .NET Core com suporte para Linux e Windows.Visual Studio 2017 15.3 preview now supports the breadth of container development across existing .NET Framework apps with Windows Containers, to .NET Core with Windows, and Linux Support. As adições recentes incluem suporte para seus aplicativos .NET Core em contêineres executando Nano server, bem como melhorias de depuração para aplicativos do .NET Framework em contêineres.Recent additions include support for your .NET Core applications in containers running Nano server, as well as debugging improvements for .NET Framework applications in containers.

Ferramentas do Service FabricService fabric tools

Esta versão fornece um novo modelo de projeto do ASP.NET Core com estado, suporte para ambos o SDK 2.5 e o 2.6 (e tempos de execução correspondentes) do Service Fabric, bem como várias correções de bug.This release provides a new stateful ASP.NET Core project template, support for both 2.5 and 2.6 SDK's (and corresponding runtimes) of Service Fabric, as well as several bug fixes.


Redgate Data Tools Redgate Data Tools

Redgate ReadyRoll Core:Redgate ReadyRoll Core:

Foi atualizado para a versão 1.13.23.3402 para adicionar:We updated to version 1.13.23.3402 to add:

  • Melhorias de ícone com suporte a alto DPI e melhor capacidade de resposta na barra de ferramentas.Icon improvements with high-DPI support and better responsiveness in the toolbar.
  • Aperfeiçoamentos na usabilidade para a Guia Configurações de Projeto.Usability Improvements to Project Settings Tab.
  • Aperfeiçoamentos na usabilidade para a exibição de Introdução, o Resumo de Implantação e a Janela de Logon.Usability Improvements to Getting Started view, Deployment Summary, and Login Window.
  • Adicionado um modo de exibição quando o banco de dados de destino não existe.Added a view for when the target database doesn’t exist.
  • Adicionada uma entrada ReadyRoll sob o menu Ferramentas.Added a ReadyRoll entry under the Tools menu.
  • Adicionado suporte para autenticação do SQL ao abrir o SSMS.Added support for SQL Authentication when opening SSMS.

Redgate SQL Prompt Core: É atualizado para a versão 7.5.1.1087 para melhorar o suporte à sintaxe do SQL Server 2016, bem como correção de problemas de qualificação de nome e com conectividade do Azure.Redgate SQL Prompt Core: We updated to version 7.5.1.1087 to improve syntax support for SQL Server 2016, as well as fixed issues around name qualification, and with Azure connectivity.

Redgate SQL Search: Foi atualizado para a versão 2.4.2.1321 para adicionar um ícone para suporte a alto DPI.Redgate SQL Search: We updated to version 2.4.2.1321 to add an icon for high-DPI support.


Ferramentas CMake CMake Tools

Ferramentas CMake para Visual Studio para fornecer suporte para a integração de CTest melhoradas e o gerador Ninja, incluindo suporte completo para compilar, depurar e editar com o IntelliSense.We enhanced CMake tools for Visual Studio to provide you with support for CTest integration and the Ninja generator, including full support to build, debug, and edit with IntelliSense.


Problemas conhecidos Known Issues

Aqui estão os problemas conhecidos e as soluções alternativas disponíveis específicas para essa visualização de versão.Here are the known issues and available workarounds specific to this Preview release. Para problemas conhecidos no Visual Studio 2017, que também afetará a esta versão, consulte conhecidos problemas do Visual Studio 2017.For known issues in Visual Studio 2017, which will also affect this release, see Visual Studio 2017 Known Issues.


Problemas do .NET Core .NET Core Issues

Para obter uma lista atual de problemas e soluções alternativas com o .NET Core e ASP.NET Core 2.0, consulte nossa página do GitHub.For a current list of issues and workarounds with .NET Core and ASP.NET Core 2.0 see our GitHub page.

Problemas de Ferramentas de Teste Testing Tools Issues

Cobertura de código de teste de unidade de C++ nativoNative C++ unit testing code coverage

  • Problema:Issue:

    A cobertura de código de teste de unidade de C++ nativo falhará com um erro indicando que nenhum módulo foi carregado.Native C++ unit testing code coverage fails with an error stating that no modules were loaded.

  • Solução alternativa:Workaround:

    Recompile seu código com informações de depuração geradas com a opção /DEBUG:FULL.Rebuild your code with debugging information generated with the /DEBUG:FULL option. A configuração pode ser encontrada em "propriedades do projeto | Propriedades de Configuração | Vinculador | Depuração".The setting can be found under "project properties | Configuration Properties | Linker | Debugging".

Cobertura de código de teste de unidade do .NET Core.NET Core unit testing code coverage

Criar opções de projeto do IntelliTestCreate IntelliTest project options

  • Problema:Issue:

    Quando a Carga da solução Lightweight está em vigor, a lista suspensa “Projeto de Teste” na caixa de diálogo Criar IntelliTest pode não listar todos os projetos de teste disponíveis.When Lightweight Solution Load is in effect, the 'Test Project' dropdown in the Create IntelliTest dialog may not list all available test projects.

  • Solução alternativa:Workaround:

    Projetos que já não estiverem carregados não serão mostrados.Projects that are not already loaded will not be shown. Carregue os projetos relevantes do Gerenciador de Soluções para garantir que eles sejam mostrados aqui.Load the relevant projects from the Solution Explorer to ensure that are shown here.

Problemas de depuração e diagnóstico Debugging and Diagnostics Issues

O Ferramentas Remotas para a Visualização do Visual Studio 2017 não estão disponíveisRemote Tools for Visual Studio 2017 Preview are not available

Ferramentas F# F# Tools

Há vários problemas, as ferramentas do F # e os projetos do .NET Core.There are multiple issues the F# tools and .NET Core projects. Esses problemas foram resolvidos principalmente, mas devido ao fato de que .NET Core e o Visual Studio não estão alinhados nas suas versões, essas correções não podem ser usadas, a menos que você instale a versão correta do SDK do .NET Core em seu computador.These issues have mostly been addressed, but due to the fact that .NET Core and Visual Studio do not align in their releases, these fixes cannot be used unless you install the correct version of the .NET Core SDK on your machine.

Em resumo, baixe e instale nesta versão da CLI do .NET Core.In short, download and install this release of the .NET Core CLI. Você deve instalá-lo, caso contrário, você irá se deparar com vários problemas que já foram resolvidos.You must install this, otherwise you will come across multiple issues which have already been addressed.

Os problemas a seguir estão sendo realizados no momento:The following issues are currently being worked on:

  • Problema:Issue:

    Não é possível criar um projeto por meio do sistema de menus do Visual Studio.Cannot create a project through Visual Studio's menu system.

  • Solução alternativa:Workaround:

    Crie projetos com a CLI do .NET.Create projects with the .NET CLI. Eles podem ser abertos no Visual Studio 2017.These can be opened in Visual Studio 2017.

  • Problema:Issue:

    Visual Studio não reconhece novos arquivos em sua ordem definida, as referências de outros projetos ou referências de NuGet ou Paket.Visual Studio does not recognize new files in their defined ordering, references from other projects, or references from NuGet or Paket. No entanto, compilar e executar o projeto funcionam.However, building and running the project works.

  • Solução alternativa:Workaround:

    Não há nenhuma solução alternativa no momento.There is no workaround at this time. Conforme mencionado, esses projetos ainda devem compilar e executar.As mentioned, these projects should still build and run.

Outros problemas Other Issues

  • Problema:Issue:

    Quando você abre uma pasta com um projeto do VC, pesquisa NavigateTo não retorna arquivos externos.When you open a folder with a VC project, NavigateTo search does not return external files.

  • Solução alternativa:Workaround:

    Abra a pasta com a Carga de Solução Leve ligada, feche a solução e reabra a pasta.Open the folder with Lightweight Solution Load on, close the solution, and reopen the folder.

Globs com barras (ou seja: "*/. cs") não têm suporte em projetos de CPS com base em (.NET Core e Cordova).Globs with forward slashes (ie: "*/.cs") are not supported in CPS based projects (.NET Core and Cordova).

  • Problema:Issue:

    Globs com barras não têm suporte em projetos de CPS e causarão um erro não fatal.Globs with forward slashes are not supported in CPS projects and will cause a non-fatal error.

  • Solução alternativa:Workaround:

    Não há nenhuma solução alternativa no momento.No workaround at this time.

Não é possível criar projetos de equipe ou atualizar modelos de processoCannot create team projects or update process templates

  • Problema:Issue:

    Os clientes não é possível criar novos projetos de equipe ou carregar ou editar modelos de processo do Visual Studio 2017 versão 15.3 versão prévia 1.Customers cannot create new team projects or upload or edit process templates from Visual Studio 2017, version 15.3 Preview 1. Criação do projeto de acesso via Web continua a funcionar.Project creation from web access continues to work.

  • Solução alternativa:Workaround:

    Isso será corrigido na próxima versão prévia.This will be fixed in the next preview. Por enquanto, se você precisar criar projetos de equipe ou carregar modelos de processo do Visual Studio, use o lançamento Visual Studio de 2017, versão 15.2 ou anterior.At this time, please use the released Visual Studio 2017, version 15.2 or earlier, if you need to create team projects or upload process templates from Visual Studio.

Erro ao abrir a pasta se C# e o Componente do Visual Basic não estão instaladosError when opening folder if C# and Visual Basic Component is not installed

  • Problema:Issue:

    Mensagem de erro "Exceção lançada pelo destino de uma invocação" ao abrir a pasta se o Componente do Visual Basic e do C# não está instalado.Error message "Exception thrown by the target of an invocation” when opening folder if C# and Visual Basic Component is not installed.

  • Solução alternativa:Workaround:

    Instalar o componente do C# e do Visual Basic.Install the C# and Visual Basic Component.

O cliente do MTM (Microsoft Test Manager) não pode se conectar ao Team Foundation Server ou ao Visual Studio Team ServicesMicrosoft Test Manager (MTM) client cannot connect to Team Foundation Server or Visual Studio Team Services

  • Problema:Issue:

    O cliente MTM não pode se conectar ao Team Foundation Server ou do Visual Studio Team Services, bloqueando a criação e execução de casos de teste pelos usuários.MTM client cannot connect to Team Foundation Server or Visual Studio Team Services, blocking users from creating and running tests cases.

  • Solução alternativaWorkaround

    Isso será corrigido na próxima versão prévia.This will be fixed in the next preview. Neste momento, use a seguinte solução alternativa:At this time, please use the following workaround:

Localize a pasta na qual o mtm.exe está instalado, pesquisando por mtm.exe no menu Iniciar e escolhendo 'Abrir local do arquivo' clicando com o botão direito do mouse no menu.Find the folder in which mtm.exe is installed by searching for mtm.exe in the start menu and choosing 'Open file location' in the right click menu. Edite o arquivo 'mtm.exe.config' presente na mesma pasta para adicionar a seção a seguir na seção configuração -> tempo de execução:Edit the 'mtm.exe.config' file present in the same folder to add the following section in configuration -> runtime section:

  <dependentAssembly>
    <assemblyIdentity name="Microsoft.VisualStudio.Threading" publicKeyToken="b03f5f7f11d50a3a" culture="neutral"/>
    <bindingRedirect oldVersion="10.0.0.0-15.0.0.0" newVersion="15.3.0.0"/>
  </dependentAssembly>

Falha ao criar um projeto de DSL com FileNotFoundExceptionBuilding a DSL project fails with FileNotFoundException

  • Problema:Issue:

    Falha ao criar um projeto de DSL recém-criado com FileNotFoundException.Building a newly created DSL project fails with FileNotFoundException.

  • Solução alternativa:Workaround:

    Adicione o snippet a seguir ao elemento assemblyBinding em MSBuild.exe.config (em \MSBuild\15.0\Bin):Add the following snippet to assemblyBinding element in MSBuild.exe.config (in \MSBuild\15.0\Bin):

    <dependentAssembly>
      <assemblyIdentity name="Microsoft.VisualStudio.Zip.9.0" culture="neutral" publicKeyToken="b03f5f7f11d50a3a" />
      <codeBase version="9.0.0.0" href="..\..\..\Common7\IDE\PrivateAssemblies\Microsoft.VisualStudio.Zip.9.0.dll" />
    </dependentAssembly>

Histórico de Notas de Versão do Visual Studio 2017Visual Studio 2017 Release Notes History

Para saber mais sobre as versões anteriores do Visual Studio 2017, confira a página Histórico de Notas de Versão do Visual Studio 2017.For more information relating to past versions of Visual Studio 2017, see the Visual Studio 2017 Release Notes History page.


Início da página
Top of Page