Visual Studio Icon Notas sobre a versão do Visual Studio 2019 para Mac versão 8.0Visual Studio 2019 for Mac version 8.0 Release Notes



Comunidade de desenvolvedores | Requisitos do sistema | Compatibilidade | Código distribuível | Documentação | Blogs | ManutençãoDeveloper Community | System Requirements | Compatibility | Distributable Code | Documentation | Blogs | Servicing


BaixarDownload

Clique no botão para baixar a versão mais recente do Visual Studio 2019 para Mac.Click the button to download the latest version of Visual Studio 2019 for Mac. Para obter informações sobre os requisitos do sistema, confira os guias Requisitos de sistema Mac e Direcionamento e compatibilidade da plataforma Mac.For information on the system requirements see the see Mac System Requirements and Mac Platform Targeting and Compatibility guides.

Para encontrar instruções sobre a instalação e a atualização do Visual Studio 2019 para Mac, consulte o guia Instalar o Visual Studio para Mac.For instructions on installing and updating Visual Studio 2019 for Mac, see the Install Visual Studio for Mac guide.

Download VS for Mac

Para saber mais sobre outros downloads relacionados, consulte a página Downloads.To learn more about other related downloads, see the Downloads page.

Importante

Não há suporte para o Visual Studio de 2019 para Mac (versão 8 e superior) no Mac OS X 10.11 (El Capitan) ou anterior.Visual Studio 2019 for Mac (version 8 and higher) is not supported on Mac OS X 10.11 (El Capitan) or lower. Se você tiver o Visual Studio 2017 para Mac (versão 7), não verá uma atualização para o Visual Studio 2019 para Mac.If you have Visual Studio 2017 for Mac (version 7), you will not be shown an update to Visual Studio 2019 for Mac. A instalação também será bloqueada.Installation will also be blocked. Para resolver esse problema, atualize para o macOS 10.12 (Sierra) ou posteriorTo resolve this issue, update to macOS 10.12 (Sierra) or higher


Novidades no Visual Studio 2019 para MacWhat's New in Visual Studio 2019 for Mac

Versões do Visual Studio 2019 para Mac versão 8.0Visual Studio 2019 for Mac version 8.0 Releases

Blog do Visual Studio 2019 para MacVisual Studio 2019 for Mac Blog

O Blog do Visual Studio 2019 para Mac é a fonte oficial de insights do produto da equipe de engenharia do Visual Studio.The Visual Studio 2019 for Mac Blog is the official source of product insight from the Visual Studio Engineering Team. É possível encontrar informações detalhadas sobre as versões do Visual Studio 2019 Mac nas seguintes postagens:You can find in-depth information about the Visual Studio 2019 for Mac releases in the following posts:

Destaques da versãoRelease Highlights

  • Esta versão contém uma versão prévia do editor de texto da próxima geração para o Visual Studio para Mac.This release contains a preview of the next generation text editor for Visual Studio for Mac.
  • Apresentamos uma nova experiência de introdução.We've introduced a new getting started experience.
  • Adicionamos o suporte para a fácil execução de várias instâncias do IDE.We've added support for easily running multiple instances of the IDE.
  • Adicionamos uma nova maneira de definir vários projetos de inicialização. Com ela, fica mais fácil criar uma solução de configuração de execução que iniciará vários projetos durante a depuração.We've added a new way to set multiple startup projects, making it easier to create a solution Run Configuration that will launch multiple projects when debugging.
  • O Visual Studio para Mac agora detecta atualizações disponíveis dos modelos do Azure Functions e apresenta uma caixa de diálogo para atualizá-las.Visual Studio for Mac can now detect that updates to Azure Functions templates are available, and will provide you with a dialog to update them.
  • Melhoramos a experiência de depuração para projetos do Unity compartilhando o depurador usado pelas Ferramentas do Visual Studio para Unity no Windows.We've improved the debugging experience for Unity projects by sharing the debugger used by Visual Studio Tools for Unity on Windows.
  • Adicionamos suporte para autenticação da Conta Microsoft com Git e Azure DevOps/Team Foundation Server.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server.
  • Passamos de três opções de canais: Alfa, Beta, Estável para apenas Versão prévia e Estável.We've moved from having three channels: Alpha, Beta, Stable to just Preview and Stable. Você pode acessar as atualizações no item de menu Visual Studio > Verificar se há atualizações…You can access updates from the Visual Studio > Check for Updates… .menu item.

Visual Studio 2019 para Mac versão 8.0 (8.0.9.5)Visual Studio 2019 for Mac version 8.0 (8.0.9.5)

lançada em 30 de maio de 2019released May 30, 2019

Corrigimos os seguintes problemas nesta versão:We fixed the following issues in this release:

Visual Studio 2019 para Mac versão 8.0 (8.0.8.2)Visual Studio 2019 for Mac version 8.0 (8.0.8.2)

lançada em 23 de maio de 2019released May 23, 2019

Esta versão corrige um problema em que o passo a passo durante a depuração com o Unity não funciona.This release fixes an issue where stepping during debugging with Unity does not work.

Visual Studio 2019 para Mac versão 8.0 (8.0.7.3)Visual Studio 2019 for Mac version 8.0 (8.0.7.3)

lançada em 21 de maio de 2019released May 21, 2019

Esta versão atualiza o modelo do Shell do Xamarin.Forms para trabalhar com a versão mais recente do Shell.This release updates the Xamarin.Forms Shell template to work with the latest version of Shell.

Visual Studio 2019 para Mac versão 8.0 (8.0.6.4)Visual Studio 2019 for Mac version 8.0 (8.0.6.4)

lançada em 14 de maio de 2019released May 14, 2019

Esta versão corrige um problema que pode levar a uma falha durante a renderização de pontos de interrupção no editor.This release addresses an issue that can lead to a crash when rendering breakpoints in the editor.

Visual Studio 2019 para Mac versão 8.0 (8.0.5.9)Visual Studio 2019 for Mac version 8.0 (8.0.5.9)

lançado em 29 de abril de 2019released April 29, 2019

Corrigimos os seguintes problemas nesta versão:We fixed the following issues in this release:

Visual Studio 2019 para Mac versão 8.0 (8.0.4.0)Visual Studio 2019 for Mac version 8.0 (8.0.4.0)

lançado em 18 de abril de 2019released April 18, 2019

Corrigimos os seguintes problemas nesta versão:We fixed the following issues in this release:

Visual Studio 2019 para Mac versão 8.0 (8.0.3.14)Visual Studio 2019 for Mac version 8.0 (8.0.3.14)

lançado em 15 de abril de 2019released April 15, 2019

Corrigimos os seguintes problemas nesta versão:We fixed the following issues in this release:

Visual Studio 2019 para Mac versão 8.0 (8.0.2.23)Visual Studio 2019 for Mac version 8.0 (8.0.2.23)

lançado em 9 de abril de 2019released April 9, 2019

Esta versão adiciona suporte para Xcode 10.2.This release adds support for Xcode 10.2.

Corrigimos os seguintes problemas nesta versão:We fixed the following issues in this release:

Visual Studio 2019 para Mac versão 8.0 (8.0.1.1)Visual Studio 2019 for Mac version 8.0 (8.0.1.1)

lançado em 4 de abril de 2019released April 4, 2019

  • Corrigimos um problema em que a IDE falhava se a Janela Iniciar fosse fechada enquanto um projeto estava sendo criado.We fixed an issue where the IDE would crash if the Start Window was closed while a project was being created.

Visual Studio 2019 para Mac versão 8.0 (8.0.0.3001)Visual Studio 2019 for Mac version 8.0 (8.0.0.3001)

lançada em 2 de abril de 2019released April 2, 2019

Instalar oInstall

  • Demos uma nova aparência ao Instalador do Visual Studio para Mac com ícones atualizados, telas iniciais e telas de carrossel com conteúdo útil para todos os desenvolvedores.We've given the Visual Studio for Mac Installer a fresh look with updated icons, splash screens, and carousel screens with useful content for all developers.
  • Adicionamos suporte para uma versão mínima do macOS necessário para o Visual Studio para Mac (10.12).We added support for a minimum version of macOS required for Visual Studio for Mac (10.12). Se você não estiver no macOS 10.12 ou mais recente, o instalador agora solicitará que você atualize sua versão do macOS.If you're not on macOS 10.12 of newer the installer now prompts you to upgrade your version of macOS.
  • Alteramos os padrões do nosso instalador para uma instalação menor e mais inteligente.We changed our installer defaults to a smaller and smarter install. Em vez de selecionar tudo por padrão, selecionamos o IDE e o .NET Core para todos os usuários e apenas o iOS ou o Android se qualquer versão do Xcode ou do SDK do Android é detectada em seu computador.Instead of selecting everything by default, we select the IDE and .NET Core for all users, and only select iOS or Android if any version of Xcode or Android SDK is detected on your machine.
  • Se você está desenvolvendo aplicativos Xamarin.iOS ou Xamarin.Mac, agora pedimos para que você atualize para a versão recomendada do Xcode, caso ela ainda não tenha sido instalada.If you are developing Xamarin.iOS or Xamarin.Mac apps, we now prompt you to update to the recommended version of Xcode, if you don't already have it installed.
  • Removemos o NDK do download do SDK do Android.We removed the NDK from the Android SDK download.
  • Fizemos muitas melhorias na caixa de diálogo de permissões do Android, incluindo melhorar a interface do usuário e permitir que o usuário desmarque Xamarin.Android.We made many improvements to the Android permissions dialog, including improving the UI and allowing the user to uncheck Xamarin.Android.

Janela de inícioStart Window

Com essa versão, apresentamos uma nova maneira de interagir com seus projetos e de conduzi-lo para onde você precisa ir no IDE.With this release, we've introduced a brand new way of interacting with your projects and getting you to where you need to go in the IDE.

Se você for um novo usuário do Visual Studio para Mac, quando abrir o IDE pela primeira vez, será solicitado que você faça logon.If you're a new Visual Studio for Mac user, you'll be prompted to log in when you first open the IDE. Ao fazer logon, você pode ativar sua conta Professional ou Enterprise ou se conectar ao Azure.By logging in you can activate your Professional or Enterprise account or connect to Azure. Se não estiver pronto para entrar, você poderá pressionar o botão Ignorar e entrar por meio do item de menu Visual Studio > Entrar.If you're not ready to sign in, you can press the Skip button and sign in through the Visual Studio > Sign In menu item.

Sign-in Dialog
Nova caixa de diálogo EntrarNew Sign in dialog

Em seguida, você será saudado com a nova janela de início.You'll then be greeted with the new start window. Essa janela tem três seções principais, permitindo que você crie ou abra projetos novos e existentes:This window has three main sections, allowing you to create or open new and existing projects:

New Start Window
Nova janela de inícioNew Start window
  • Projetos recentes: aqui você pode encontrar uma lista dos seus 25 projetos mais recentes.Recent Projects: Here you can find a list of your 25 most recent projects. Você pode, opcionalmente, "fixar" seus projetos mais frequentemente usados, se você prefere mantê-los na parte superior da lista.You can optionally "pin" your most frequently used project, if you'd prefer to keep them at the top of the list. A caixa de pesquisa pode ser usada para filtrar entre todos os projetos recentes na lista.The search box can be used to filter through all recent projects in the list.
  • Abrir: você pode abrir qualquer arquivo .csproj, .fsproj, .sln ou outros compatíveis do diretório local usando esse botão.Open: You can open any .csproj, .fsproj, .sln or any other supported file from your local directory using this button.
  • Novo: você pode selecionar vários modelos já preenchidos para ajudá-lo a começar um novo projeto.New: You can select from the many pre-populated templates to help you get started with a new project. A caixa de diálogo Novo projeto conduzirá você por todas as configurações necessárias para ajudá-lo a começar a trabalhar.The new project dialog will take you through all the necessary configurations to help you get up and running.

Novo editor de códigosNew Code Editor

O Visual Studio para Mac 2019 contém uma versão prévia do editor de texto da próxima geração para o Visual Studio para Mac!Visual Studio for Mac 2019 contains a preview of the next generation text editor for Visual Studio for Mac! Este novo editor de texto compartilha os mesmos principais componentes com o Windows Visual Studio com uma interface do usuário totalmente nova e nativa.This new text editor shares the same core components with Visual Studio Windows, with an entirely new, native user interface.

New Editor
Novos recursos do editor no Visual Studio para MacNew editor features in Visual Studio for Mac

Neste momento, o novo editor dá suporte apenas a arquivos C#.At this time, the new editor supports C# files only. O suporte a linguagens adicionais será adicionado em versões futuras.Additional language support will be added in future releases.

O novo editor do Visual Studio para Mac oferece os seguintes recursos:The new Visual Studio for Mac editor brings the following features:

  • Interface do usuário macOS (baseada em Cocoa) nativa (dicas de ferramenta, superfície do editor, adornos de margem, renderização de texto, IntelliSense)Native macOS (Cocoa-based) user interface (tooltips, editor surface, margin adornments, text rendering, IntelliSense)
  • Suporte para entradas de texto nativasSupport for native text inputs
  • Suporte à linguagem RTL/BiDiRTL/BiDi language support
  • Núcleo comum da Plataforma do Visual StudioCommon Visual Studio Platform core
  • Roslyn 3Roslyn 3
  • Suporte a vários cursoresMulti-caret support
  • Quebra automática de linhaWord Wrap
  • Atualizar a interface do usuário IntelliSenseUpdate IntelliSense UI
  • Melhoria do Localizar/SubstituirImproved Find/Replace

Agora as exceções usam a interface do usuário Cocoa para exibir mensagens de exceção, incluindo notificação de exceção e detalhes:Exceptions now use the Cocoa UI to display exception messages, including exception notification and details:

New Exceptions in Visual Studio for Mac
Novas exceções no Visual Studio para MacNew exceptions in Visual Studio for Mac

A navegação do menu de contexto está habilitada.Context Menu Navigation is enabled. Agora é possível usar comandos de navegação baseados em menu de contexto como “Ir para declaração” e “Ir para implementação”.You can now use context menu based navigation commands like "Go to Declaration" and "Go To Implementation". Também habilitamos “Remover e classificar usos”.We have also enabled "Remove and Sort Usings".

Como habilitar ou desabilitar o editorHow to enable or disable the editor

Como o novo editor é uma versão prévia do recurso dentro do Visual Studio para Mac 2019, é necessário aceitar para usar o recurso.As the new editor is a preview feature within Visual Studio for Mac 2019, you have to opt-in to use the feature. Acesse a seção Visual Studio > Preferências… > Editor de Texto > Geral e marque a caixa de seleção Abrir arquivos C# no Novo Editor.Go to the Visual Studio > Preferences… > Text Editor > General section and check the Open C# files in the New Editor checkbox. Quando esta opção estiver marcada, arquivos C# abertos recentemente usarão o novo editor.Once this option is checked, any newly opened C# files will be using the new editor. Você saberá que o novo editor está habilitado quando o botão “Versão prévia do novo editor” for exibido na parte inferior direita da janela de edição.You will know the new editor is enabled when the "New Editor Preview" button appears in the bottom-right of the editing window.

Para desabilitar o novo editor, clique no botão Versão prévia do novo editor na parte inferior direita do painel do editor e selecione Desabilitar a versão prévia do novo editor ou navegue até a seção Visual Studio > Preferências… > Editor de texto > Geral e desmarque a caixa de seleção Abrir arquivos C# no novo editor.To disable the new editor, either click the New Editor Preview button in the bottom right of the editor pane and select Disable the New Editor Preview or navigate to the Visual Studio > Preferences… > Text Editor > General section and un-check the Open C# files in the New Editor checkbox.

Como relatar um problema com o editorHow to Report a Problem with the editor

Para relatar um problema no novo editor, clique no botão “Versão prévia do novo editor” na parte inferior direita do painel do editor e selecione “Relatar um problema”.To report a problem in the new editor, either click the "New Editor Preview" button in the bottom right of the editor pane and select "Report a Problem". Também é possível ir diretamente para Comunidade de Desenvolvedores.You can also go directly to Developer Community.

Suporte para várias instânciasSupport for multiple instances

Agora o Visual Studio para Mac dá suporte à abertura de várias instâncias do IDE na plataforma.Visual Studio for Mac now supports opening multiple instances of the IDE from the dock. O Visual Studio para Mac sempre teve suporte para abrir várias soluções em uma janela, mas nós ouvimos muitas solicitações para dar suporte a várias janelas do IDE.Visual Studio for Mac has always had support for opening multiple solutions in one window but we’ve heard a lot of requests to support multiple windows for the IDE. Para abrir uma nova instância, clique com o botão direito do mouse no ícone na plataforma e selecione Nova Instância:To open a new instance, right-click on the icon in the dock and select New Instance:

Opening a new instance graphic
Abrindo uma nova instância do Visual Studio para MacOpening a new instance of Visual Studio for Mac

Definir Projetos de InicializaçãoSet Startup projects

Um novo comando, Definir projetos de inicialização, está disponível para facilitar a criação de uma solução de configuração de execução que iniciará vários projetos durante a depuração.A new command, Set Startup Projects, is available to make it easier to create a solution Run Configuration that will launch multiple projects when debugging. Para obter informações sobre como definir vários projetos de inicialização, consulte a documentação.For information on setting multiple startup projects, see the documentation.

Set startup projects dialog
Caixa de diálogo Definir projetos de inicializaçãoSet Startup Projects dialog

Aprimoramentos de depuração para UnityDebugging improvements for Unity

Nesta versão, substituímos o depurador que é usado para projetos do Unity pelo depurador das Ferramentas do Visual Studio para Unity no Windows.In this release we've replaced the debugger that's used for Unity projects with the debugger from Visual Studio Tools for Unity on Windows. Essa alteração tem uma compatibilidade melhor com versões mais antigas do Unity, aprimoramentos para a depuração de código C# não seguro e fornece melhor confiabilidade.This change has better compatibility with older versions of Unity, improvements for debugging unsafe C# code, and provides better reliability.

Melhorias do XamarinXamarin Improvements

Os desenvolvedores do Xamarin devem encontrar muitos aprimoramentos nesta versão.Xamarin developers should find a ton of improvements in this release. Os novos destaques incluem:New highlights include:

Xamarin.AndroidXamarin.Android

Sabemos que os desenvolvedores executam o ciclo de compilação-implantação-depuração incontáveis vezes por dia e estamos trabalhando constantemente para reduzir ainda mais o loop de desenvolvimento interno.We know that developers run through the build-deploy-debug cycle countless times a day, and we're consistently working towards shortening the inner development loop even more. Nesta versão, criamos uma grande vantagem ao otimizar compilações e implantações incrementais.In this release, we've made huge gains by optimizing incremental builds and deployments.

Usando o aplicativo SmartHotel360 para teste, os tempos de compilação incremental foram reduzidos em até 29% e os tempos de implantação estão até duas vezes mais rápidos.Using the SmartHotel360 app for testing, incremental build times have been trimmed by up to 29%, and deployment times are up to twice as fast. Um relatório completo da metodologia e criação de perfil de desempenho de compilação está disponível na wiki do Xamarin.Android, mas aqui está uma rápida visão geral:A full report of build performance profiling and methodology is available on the Xamarin.Android wiki, but here’s a quick overview:

EtapaStep Visual Studio 2017Visual Studio 2017 Visual Studio 2019Visual Studio 2019 DeltaDelta
Primeira compilaçãoFirst build 01:04.2001:04.20 00:50.1300:50.13 -21,95%-21.95%
Compilação incremental (alteração XAML)Incremental Build (XAML Change) 00:10.6200:10.62 00:07.4700:07.47 -29,66%-29.66%
Implantar (alteração XAML)Deploy (XAML Change) 00:09.0300:09.03 00:04.4400:04.44 -50,83%-50.83%

Nossa missão de aumentar continuamente a confiabilidade de compilação permanece e as atualizações de recursos do Android foram otimizadas.Our mission to continually increase build reliability continues and one area we've made optimizations to is Android resource updates. Ao minimizar cenários em que as atualizações de recurso ocorreriam no momento da compilação, deve haver uma redução significativa dos problemas de compilação decorrentes de conflitos nessa área.By minimizing scenarios where resource updates would occur at build time, there should be a significant reduction of build issues stemming from conflicts in this area.

Caminhando em direção à paridade com o Android no Visual Studio na experiência do Windows, o processo de implantação foi simplificado ainda mais e o emulador do Android agora será iniciado juntamente com uma compilação.In a step towards parity with the Android in Visual Studio on Windows experience, the deployment process has been further streamlined and the Android emulator will now launch when starting a build.

Xamarin.FormsXamarin.Forms

O novo modelo para projetos do Shell do Xamarin Forms agora está disponível. Para uma experiência mais uniforme entre IDEs, esta versão também inclui novos modelos de arquivo disponíveis anteriormente apenas no Visual Studio no Windows.The brand-new template for Xamarin Forms Shell projects is now available, and for a more uniform experience across IDEs, this release also includes new file templates previously available only in Visual Studio on Windows. Você pode usar os novos arquivos XAML de hoje, navegando até Arquivo > Novo arquivo... > Formulários no menu do Visual Studio 2019 para Mac.You can use the new XAML files today by navigating to File > New File… > Forms in the Visual Studio 2019 for Mac menu. Os novos itens de arquivo são:The new file items are:

  • Formulários ListViewPage XAMLForms ListViewPage XAML
  • Formulários MasterDetailPage XAMLForms MasterDetailPage XAML
  • Formulários TabbedPage XAMLForms TabbedPage XAML
  • Formulários ViewCell XAMLForms ViewCell XAML

E para ajudar a melhorar a produtividade, o Intellisense nos arquivos Xamarin.Forms XAML para suporte ao FontFamily agora está disponível:And to help make productivity a touch better, Intellisense in Xamarin.Forms XAML files for FontFamily support is now available:

New Xamarin.Forms XAML files
Novos arquivos XAML do Xamarin.FormsNew Xamarin.Forms XAML files

Android DesignerAndroid Designer

Agora temos suporte para Android Pie (9.0)!We now have support for Android Pie (9.0)! Além disso, fizemos aprimoramentos para aumentar o tempo de inicialização do Android Designer e melhoramos o suporte aos widgets de rolagem.Additionally, we made enhancements to increase Android Designer start up time and improved scrolling widget support.

Esta versão também traz suporte para adicionar namespaces XML "padrão" a documentos quando um atributo correspondente é definido, bem como suporte para sequências de escape como '@', '?' e sequências de escape Unicode.This release also ships support for adding “standard” XML namespaces to documents when a corresponding attribute is set, as well as support for escape sequences like '@', '?' and Unicode escape sequences.

iOS DesigneriOS Designer

Adicionamos suporte para PDF como formato de imagem e melhoramos o suporte a espaços e precisão de cores.We’ve added support for PDF as an image format, and improved support for color spaces and color precision. Além disso, agora você pode selecionar cores nomeadas de catálogos de ativos como o valor das propriedades de cores.Additionally, you can now select named colors from asset catalogs as the value for color properties.

Agora temos suporte para controles personalizados que precisam carregar estruturas ou bibliotecas dinâmicas nativas (observe que não há suporte para bibliotecas estáticas).We now have support for custom controls that need to load native dynamic libraries or frameworks (note that static libraries are not supported). Além disso, as propriedades personalizadas do tipo CGSize agora aparecerão no painel de propriedade para controles personalizadosAdditionally, custom properties of type CGSize will now appear in the property panel for custom controls

Aprimoramentos do Azure FunctionsAzure Functions improvements

Atualizamos o Azure Functions Runtime e os modelos (CLI) do Azure Functions nessa versão.We have updated Azure Functions runtime and templates (CLI) in this release. Além disso, o Visual Studio para Mac oferecerá a capacidade de atualizar seus modelos de função se novos modelos estiverem disponíveis ao criar um projeto do Functions.In addition, Visual Studio for Mac will offer you the ability to update your function templates if new templates are available when creating a new Functions project. Para atualizar modelos do Azure Functions, selecione o botão Atualizar ao lado do texto "Há modelos atualizados disponíveis":To update Azure Functions templates, select the update button next to the text "Updated templates are available":

Update Azure Fucntions templates
Atualizar CLI e modelos do Azure FunctionsUpdate Azure Functions templates and CLI

O Visual Studio para Mac também tem suporte para a CLI do Azure Functions instalada via HomeBrew e escolhe a instância com a versão mais alta descoberta.Visual Studio for Mac also supports Azure Functions CLI installed via HomeBrew and will choose the instance with the highest discovered version.

Problemas corrigidosIssues Fixed

Os problemas a seguir também foram corrigidos nesta versão.The following issues have also been fixed in this release.

Editor de CódigosCode Editor

ProjetosProjects

IDEIDE

  • Corrigimos um problema em que a cor do texto errada é usada em uma linha sem foco, mas selecionada na janela de saída do build estruturado.We fixed an issue where the wrong text color is used in an unfocused but selected row in the structured build output window.
  • Corrigimos um problema em que a criação de uma nova pasta no Gerenciador de Soluções não permite que você nomeie a pasta ao mesmo tempo.We fixed an issue where creating a new folder in the Solution Explorer does not let you name the folder at the same time.
  • Iniciar depuração após Iniciar sem depuração resulta em uma exceção para projetos do ASP.NET.Start Debugging after Start without Debugging results in an exception for ASP.Net projects.
  • O comando Executar item no Gerenciador de Soluções foi renomeado para Executar projeto.The Run Item command on the Solution Explorer has been renamed to Run Project.
  • Agora o Visual Studio para Mac usará HttpClient e a API de rede nativa do Mac ao realizar solicitações Web para quase todas as suas solicitações.Visual Studio for Mac will now use HttpClient and the native Mac networking API when making web requests for nearly all its requests. Algumas áreas ainda não foram atualizadas para usar HttpClient e a API de rede do Mac disponível por meio do NSUrlSession do Xamarin.Mac.Some areas have not yet been updated to use HttpClient and the Mac networking API available through Xamarin.Mac's NSUrlSession. A API de rede do Mac fornece seu próprio suporte interno para proxies.The Mac's networking API provides its own built in support for proxies. O Visual Studio para Mac também pode ser configurado para usar a API de rede do Mono como alternativa.Visual Studio for Mac can also be configured to use Mono's networking API as an alternative. Ainda não há suporte para algumas áreas como a caixa de diálogo de entrada e elas continuarão usando a API de rede do Mono.Some areas are not yet supported such as the sign in dialog, and will continue to use Mono's networking API.
  • Corrigimos um problema em que as políticas de Formatação de Código não estavam sendo vistas na interface do usuário.We fixed an issue where not seeing Code Formatting policies in the UI.
  • Corrigimos um problema em que o VisualStudio para Mac não podia alterar os projetos de C# -> F# ou vice-versa.We fixed an issue where VisualStudio for Mac cannot change projects from C# -> F# or vice versa.
  • Corrigimos um problema em que não era possível excluir entradas do anel da área de transferência da caixa de ferramentas para arquivos XAML.We fixed an issue where it was not possible to delete entries from Toolbox Clipboard Ring for XAML files.
  • Corrigimos um problema em que quando o usuário focava fora/dentro do Visual Studio, o elemento padrão focado na interface do usuário era alterado.We fixed an issue where focusing out/into Visual Studio changes the default focused element on the UI.
  • Corrigimos um problema em que o histórico de navegação removia arquivos do histórico.We fixed an issue where navigation history removes files from history.
  • Atualizamos itens no menu de ajuda.We updated items in the help menu.
  • Corrigimos um problema em que não era possível definir o foco no modo de edição da coluna 2 com duas soluções abertas.We fixed an issue where you cannot set focus in 2 column edit mode with 2 solutions open.
  • Atualizamos o título da janela da caixa de diálogo “Sobre” para ficar mais legível.We updated the "About" dialog window title to be more human readable.
  • Corrigimos um problema em que algumas janelas eram exibidas posicionadas incorretamente.We fixed an issue where some windows appear positioned incorrectly.
  • Corrigimos um problema em que Adicionar a janela de progresso modal Arquivos obscurecia o modal copiar/mover.We fixed an issue where Adding Files modal progress window obscures copy/move modal.

.NET Core.NET Core

ASP.NET CoreASP.NET Core

  • Corrigimos um problema em que os modelos que vinham com um back-end de API não tinham uma configuração de execução que iniciava os dois projetos.We fixed an issue where templates that come with an API backend did not have a run configuration that launches both projects.
  • Corrigimos um problema em que Navegar -> Implementando membros no projeto ASP.NET Core não funcionava.We fixed an issue where Navigate -> Implementing Members in ASP.NET Core project doesn't work.
  • Corrigimos um problema em que Converter formato da solução não fazia nada para uma solução com um aplicativo Web ASP.NET Core.We fixed an issue where Convert Solution Format doesn't do anything for a solution with an ASP.NET Core web app.

NuGetNuGet

Ferramentas da WebWeb Tools

  • Corrigimos um problema em que os arquivos .ts não estavam funcionando no VSMac.We fixed an issue where .ts files are not working in VSMac.
  • Corrigimos um problema em que o Visual Studio para Mac 2019 não podia abrir projetos Docker.We fixed an issue where Visual Studio for Mac 2019 cannot open Docker projects.
  • Corrigimos um problema em que a dica de ferramenta Informações Rápidas do JavaScript estava sendo exibida fora da janela do editor.We fixed an issue where JavaScript quick info tooltip is showing up outside the editor window.
  • Corrigimos um problema em que o Visual Studio para Mac falhava ao copiar e colar em launchSettings.json.We fixed an issue where Visual Studio for Mac crashes on copy & paste in launchSettings.json.

XamarinXamarin

  • Removemos o Live Player do Visual Studio para Mac.We have removed the Live Player from Visual Studio for Mac.
  • Corrigimos um problema em que a Ajuda -> Notas sobre a Versão estava vinculada ao lugar errado.We fixed an issue where the Help -> Release Notes linked to the wrong place.

DesignersDesigners

Android DesignerAndroid Designer

Xamarin.FormsXamarin.Forms

Xamarin.iOSXamarin.iOS

Xamarin.AndroidXamarin.Android

  • Removemos o suporte para a listagem e exibição de emuladores do Player do Xamarin Android.We have removed support for listing and showing Xamarin Android Player emulators.
  • Corrigimos um problema em que novos aplicativos Android têm letras maiúsculas no nome do pacote.We fixed an issue where new Android apps have uppercase letters in the package name.
  • Corrigimos um problema em que o uso de maiúsculas de strings.xml estava inconsistente para novos projetos.We fixed an issue where the casing of strings.xml was inconsistent for new projects.
  • Corrigimos um problema em que a abertura da caixa de diálogo Relatar um Problema também exibe a caixa de diálogo "Instalar o JDK".We fixed an issue where opening the Report A Problem dialog also displays "Install JDK" dialog.
  • Corrigimos um problema em que novos projetos não tinham a API mínima e de destino definida corretamente.We fixed an issue where new projects do not have the min and target API set correctly.
  • Corrigimos um problema em que o modelo “WebView” do Android não tinha uma opção “Desenvolvimento moderno” na caixa de diálogo de criação do projeto.We fixed an issue where the Android ‘WebView App’ template does not have a ‘Modern Development’ option in project creation dialog.
  • Corrigimos um problema em que a inicialização do Android Emulator no Visual Studio para Mac era extremamente lenta.We fixed an issue where the Android Emulator Launch in Visual Studio for Mac is extremely slow.
  • Corrigimos um problema em que a execução do aplicativo Android não começava com “HAXM” no Visual Studio para Mac 2019.We fixed an issue where running the Android app does not start with "HAXM" on Visual Studio for Mac 2019.
  • Agora iniciamos o Android Emulator ao começar a compilar o projeto.We now start the Android emulator when starting to build the project.
  • Os usuários agora podem escolher entre AAPT e o AAPT2 nas configurações do projeto Xamarin.Android.Users can now choose between AAPT and AAPT2 in Xamarin.Android project settings.
  • Corrigimos um problema em que a implantação no dispositivo travava em 100%.We fixed an issue where deploying to device hangs at 100%.
  • Corrigimos um problema em que não era possível cancelar o início de um emulador do Android e forçar a saída do Visual Studio para Mac, se a imagem estivesse quebrada.We fixed an issue where it was not possible to cancel starting an Android emulator, and having to force quit Visual Studio for Mac if the image was broken.
  • Corrigimos um problema em que, se houvesse vários arquivos .csproj do Android para um projeto (usando manifestos diferentes do Android com nomes de pacotes distintos), produziria um arquivamento incorreto ou inválido e haveria falha na publicação.We fixed an issue where, if there were multiple Android .csproj files for a project (using different Android Manifests with differing package names), would produce incorrect or invalid archive and would fail to publish.
  • Corrigimos um problema em que a notificação do JDK era mostrada na página de boas-vindas, mesmo para projetos que não são do Android.We fixed an issue where the JDK notification was shown on the welcome page, even for non-Android projects.
  • Corrigimos um problema em que a atualização de recurso do Android podia ocorrer ao mesmo tempo que um build, podendo causar problemas de build.We fixed an issue where the Android resource update could occur at the same time as a build which could then cause build issues.

Xamarin.MacXamarin.Mac

  • Corrigimos um problema em que não é possível alterar por completo a versão da estrutura de destino para Xamarin.Mac ao abrir novamente as opções do projeto.We fixed an issue where it is not possible to change the target framework version for Xamarin.Mac full on re-opening project options.
  • Corrigimos um problema em que modelos .xib parecem precisar de customObjectInstantitationMethod="direct" adicionado.We fixed an issue where .xib templates seem to need customObjectInstantitationMethod="direct" added.
  • Corrigimos um problema em que o macOS 10.13 não era mostrado como um destino de implantação.We fixed an issue where macOS 10.13 doesn't show up as a deployment target.
  • Corrigimos um problema em que a plataforma padrão dos projetos do macOS era x86, mas deveria ser AnyCPU.We fixed an issue where the default platform of macOS projects is x86, but should be AnyCPU.

Ferramentas de testeTest Tools

AcessibilidadeAccessibility

  • Corrigimos um número de problemas de acessibilidade nesta versão, incluindo vários problemas de VoiceOver no depurador e na criação de certificados de desenvolvedor do iOS e problemas de teclado no Gerenciador de SDK do Android.We fixed a number of accessibility issues in this release, including several VoiceOver issues in the Debugger and in creating iOS developer certificates, and Keyboard issues in the Android SDK Manager.

Controle do código-FonteSource Control

Adicionamos suporte para a autenticação de Conta Microsoft com o Git e o Azure DevOps/Team Foundation Server, que anteriormente solicitava credenciais continuamente sem se conectar com êxito.We have added support for Microsoft Account authentication with Git and Azure DevOps/Team Foundation Server, which previously would continually prompt for credentials without successfully connecting.

GitGit

DepuradorDebugger

Ferramentas do AzureAzure Tools

  • Agora, o Azure Functions é composto por duas palavras na caixa de diálogo Novo Projeto.Azure functions is now two words in the New Project Dialog.

Criador de PerfilProfiler

  • Corrigimos um problema em que uma NullReferenceException é gerada após a exclusão de preferências VSMac.We fixed an issue where a NullReferenceException is thrown after deleting VSMac preferences.

InstallerInstaller

  • Corrigimos um problema em que as Permissões do Android estavam fazendo o aplicativo travar.We fixed an issue where the Android Permissions were causing the application to hang.
  • Aprimoramos o relatório de erros para componentes individuais e não mostraremos a página de erro imediatamente.We improved the error reporting for individual components and will not show the error page right away.
  • Corrigimos o bug onde os links simbólicos eram desfeitos quando uma versão mais antiga do Visual Studio para Mac era copiada para backup.We fixed bug where symlinks were breaking when an older Visual Studio for Mac version was copied for backup.
  • Corrigimos um bug em que ícones sem retina/de baixa resolução eram exibidos em todos os lugares.We fixed a bug where non-retina/low-res icons are being displayed everywhere.

AtualizadorUpdater

  • Corrigimos um problema em que a verificação de atualizações poderia resultar em vários prompts para entrar.We fixed an issue where checking for updates can result in multiple prompts to sign in.
  • Corrigimos um problema em que atualizar sem reiniciar poderia causar erros estranhos do MSBuild.We fixed an issue where updating without restarting can cause strange MSBuild errors.

OutrosOther


Comentários e sugestõesFeedback and Suggestions

Adoraríamos ouvir sua opinião!We would love to hear from you! Você pode relatar um problema por meio da opção Relatar um Problema no IDE do Visual Studio para Mac.You can report a problem through the Report a Problem option in Visual Studio for Mac IDE. Você pode acompanhar seus comentários, incluindo sugestões, no portal Developer Community (Comunidade de Desenvolvedores).You can track your feedback, including suggestions, in the Developer Community portal.


Problemas conhecidosKnown Issues

Veja a seguir uma lista de todos os problemas conhecidos do Visual Studio 2019 para Mac versão 8.0:The following is a list of all existing known issues in Visual Studio 2019 for Mac version 8.0:


Histórico de notas de versão do Visual Studio para MacVisual Studio for Mac Release Notes History

Você pode exibir as notas sobre a versão das versões anteriores do Visual Studio 2017 para Mac na página Histórico de notas sobre a versão.You can view prior versions of Visual Studio 2017 for Mac release notes on the Release notes history page.


Início da página
Top of Page