Visual Studio Icon Notas sobre a versão do Visual Studio 2019 para MacVisual Studio 2019 for Mac Release Notes


|Comunidade de desenvolvedores | Requisitos do sistema | Compatibilidade | Código distribuível | Documentação | Blogs | Manutenção ||Developer Community | System Requirements | Compatibility | Distributable Code | Documentation | Blogs | Servicing |


Clique no botão para baixar a versão mais recente do Visual Studio 2019 para Mac.Click the button to download the latest version of Visual Studio 2019 for Mac. Para obter informações sobre os requisitos do sistema, confira os guias Requisitos de sistema Mac e Direcionamento e compatibilidade da plataforma Mac.For information on the system requirements see the see Mac System Requirements and Mac Platform Targeting and Compatibility guides.

Para encontrar instruções sobre a instalação e a atualização do Visual Studio 2019 para Mac, consulte o guia Instalar o Visual Studio para Mac.For instructions on installing and updating Visual Studio 2019 for Mac, see the Install Visual Studio for Mac guide.

Para saber mais sobre outros downloads relacionados, consulte a página Downloads.To learn more about other related downloads, see the Downloads page.


Novidades no Visual Studio 2019 para MacWhat's New in Visual Studio 2019 for Mac

Versões do Visual Studio 2019 para MacVisual Studio 2019 for Mac Releases

Postagens no Blog do Visual Studio 2019 para MacVisual Studio 2019 for Mac Blog Posts

O Blog do Visual Studio é a fonte oficial de insights do produto da equipe de engenharia do Visual Studio.The Visual Studio Blog is the official source of product insight from the Visual Studio Engineering Team. É possível encontrar informações detalhadas sobre as versões do Visual Studio 2019 Mac nas seguintes postagens:You can find in-depth information about the Visual Studio 2019 for Mac releases in the following posts:


Destaques da versãoRelease Highlights

Problemas ConhecidosKnown Issues

Consulte a seção Problemas conhecidos.Refer to the Known Issues section.


Release Notes Icon Visual Studio 2019 para Mac versão 8.3.4 (8.3.4.7) Visual Studio 2019 for Mac version 8.3.4 (8.3.4.7)

lançado em 14 de outubro de 2019released October 14, 2019

Esta versão corrige problemas que estavam fazendo o Visual Studio para Mac falhar no Catalina.This release fixes issues that were causing Visual Studio for Mac to crash on Catalina. Se houver falhas, alterne para o canal de Versão Prévia.If you are experiencing crashing, please switch to the Preview channel.

Release Notes Icon Visual Studio 2019 para Mac versão 8.3.3 (8.3.3.8) Visual Studio 2019 for Mac version 8.3.3 (8.3.3.8)

lançado em 10 de outubro de 2019released October 10, 2019

Esta versão adiciona suporte ao Xcode 11.1.This release adds support for Xcode 11.1.

Esta versão de serviço também corrige os seguintes problemas:This service release also fixes the following issues:

  • Removemos o comando [Carregador de Aplicativo], pois o Xcode removeu este aplicativo.We removed the [Application Loader] command as Xcode has removed this application. Use as etapas deste guia para carregá-lo na App Store Connect.Use the steps in this guide to upload it to App Store Connect.
  • Várias falhas relatadas por meio de telemetria.Various crashes reported through telemetry.
  • O criador de perfil não é iniciado.The profiler does not start.

Release Notes Icon Visual Studio 2019 para Mac versão 8.3.2 (8.3.2.32) Visual Studio 2019 for Mac version 8.3.2 (8.3.2.32)

lançado em 7 de outubro de 2019released October 7, 2019

Esta versão de serviço corrige os seguintes problemas:This service release fixes the following issues:

  • A substituição de expressão regular está ausente no novo editor.Regular Expression Replace is missing from new editor.
  • Uma falha ao usar Navegar Para com determinados valores.A crash when using Navigate To with certain values.
  • Não é possível inserir um ponto de interrupção durante a execução no dispositivo iOS ao usar a Recarga Dinâmica.Unable to insert a breakpoint when running on iOS device when using Hot Reload.
  • Erro ao tentar abrir uma solução com global.json que faz referência a uma versão prévia do .Net Core que não está instalada.Error when trying to open a solution with a global.json that references a preview of .Net Core that is not installed.
  • Não é possível efetuar pull no seletor de emoji do novo editor.Unable to pull up the emoji selector from the new editor.

Release Notes Icon Visual Studio 2019 para Mac versão 8.3.1 (8.3.1.18) Visual Studio 2019 for Mac version 8.3.1 (8.3.1.18)

lançado em 30 de setembro de 2019released September 30, 2019

Esta versão de serviço corrige os seguintes problemas:This service release fixes the following issues:

  • VSMac exibe a janela "Erro ao buscar direitos" durante a inicialização.VSMac displays the error "Error fetching rights" window on launch.
  • Os editores da Web não dão suporte a arquivos com extensão jsx/tsx.Web Editors don't support files with jsx/tsx file extension.
  • Um estouro de pilha durante a análise de arquivos F# faz com que o IDE falhe.A stack overflow while parsing F# files causes IDE to crash.
  • As funções não podem ser publicadas no Azure (dotnet fechado inesperadamente).Azure functions cannot be published to Azure (dotnet closed unexpectedly).
  • Ao renomear a página .cshtml, o arquivo .cshtml.cs desaparece.When renaming page .cshtml the .cshtml.cs file disappears.
  • A movimentação de mais de dois arquivos aninhados não funciona.Moving more than 2 nested files does not work.
  • Todo o shell do IDE pisca em branco ao comutar de/para uma guia .xaml (mesmo entre arquivos .xaml).Entire IDE shell flashes blank when switching to/from a .xaml tab (even between .xaml files).

Release Notes Icon Visual Studio 2019 para Mac versão 8.3 (8.3.0.1805) Visual Studio 2019 for Mac version 8.3 (8.3.0.1805)

lançado em 23 de setembro de 2019released September 23, 2019

Novos recursosNew Features

Editores da WebWeb Editors

Nesta versão, adicionamos suporte para arquivos da Web para o novo editor de código nativo, que foi introduzido no Visual Studio 2019 para Mac 8.1In this release, we have added support for web files to the new native code editor, which was introduced in Visual Studio 2019 for Mac 8.1

JavaScript IntelliSense no novo editorJavaScript IntelliSense in the new editor

Agora o Visual Studio para Mac usará o novo editor de código nativo para os seguintes tipos de arquivo:Visual Studio for Mac will now use the new native code editor for the following file types:

  • .JS.JS
  • .TS.TS
  • .HTML.HTML
  • .CSS.CSS
  • .CSHTML.CSHTML
  • .JSON.JSON
  • .LESS.LESS
  • .SCSS.SCSS

Os novos editores da Web são ativados pela mesma interface de editor nativo dos editores de C# e XAML e pelo serviço de linguagem compartilhado do Visual Studio.The new web editors are powered by the same native editor interface as the C# and XAML editors and are powered by the shared Visual Studio language service. Com os novos editores, você pode esperar:With the new editors, you can expect:

  • Melhor desempenho do IntelliSenseImproved IntelliSense performance
  • Filtragem de tipo do IntelliSenseIntelliSense type filtering
  • Edição com vários cursoresMulti-caret editing
  • Suporte a texto da direita para a esquerda e bidirecionalRTL (right-to-left) and BiDi (Bidirectional) text support
  • Suporte a entrada nativoNative input support
  • Melhor desempenho de digitaçãoImproved typing performance
  • Melhor renderização de textoImproved text rendering
  • Quebra automática de linhaWord wrap
  • Melhor formataçãoImproved formatting
  • Melhor classificaçãoImproved classification

Também abordamos vários bugs implementando os novos editores, incluindo bugs relacionados ao desempenho e ao suporte a arquivos.We've also addressed numerous bugs by implementing the new editors, including bugs related to performance and file support.

Multi-TargetingMulti-Targeting

Nesta versão, adicionamos suporte aprimorado para projetos que têm estruturas de vários destinos.In this release we have added improved support for projects that have multi-target frameworks. Alguns dos recursos e benefícios são detalhados abaixo:Some of the features and benefits are detailed below:

  • Ao editar um arquivo em um projeto de várias estruturas de destino, a estrutura de destino pode ser selecionada para orientar o IntelliSense no editor:When editing a file in a multi-target framework project, the target framework can be selected to guide the intellisense in the editor:

    Experiência do editor de projeto de várias estruturas de destino no Visual Studio para MacMulti-target framework project editor experience in Visual Studio for Mac
  • O editor mostrará informações no IntelliSense e dicas de ferramentas sobre APIs que não estão disponíveis para uma estrutura de destino específica.The editor will show information in IntelliSense and tooltips about APIs that are not available for a particular target framework.

  • Também adicionamos suporte para depuração em uma estrutura específica:We have also added support for debugging against a specific framework:

    Depuração de um projeto de várias estrutura de destino no Visual Studio para MacDebugging a multi-target framework project in Visual Studio for Mac

.NET Core.NET Core

Esta versão adiciona a capacidade de selecionar o navegador que é usado quando você executa ou depura seu aplicativo Web ASP.NET Core.This release adds the ability to select the browser that is used when you run, or debug, your ASP.NET Core web application.

Selecionar o navegadorSelect browser

Publicar o suporte para o console do .NET Core e projetos de Biblioteca do .NET StandardPublish support for .NET Core Console and .NET Standard Library Projects

Em uma versão anterior, adicionamos a capacidade de publicar um projeto do ASP.NET Core em uma pasta.In a previous release we added the ability to publish an ASP.NET Core project to a folder. Nesta versão, introduzimos o suporte para publicar projetos do Console do .NET Core e da Biblioteca do .NET Standard.In this release we have introduced support to publish .NET Core Console and .NET Standard Library Projects. Para obter mais informações sobre como usar esse recurso, confira a documentação sobre a pasta de publicação.For more information on how to use this feature, see the Publish Folder documentation.

Suporte para launchSettings.jsonSupport for launchSettings.json

Ao desenvolver aplicativos ASP.NET Core, você pode configurar o modo como o aplicativo é iniciado para fins de desenvolvimento usando o arquivo launchSettings.json.When developing ASP.NET Core applications, you can configure how the application is launched for development purposes using the launchSettings.json file. Para obter mais informações sobre esse arquivo, confira a documentação sobre os ambientes .NET Core.For more info on this file, see the .NET Core Environments documentation. No arquivo launchSettings.json, você pode configurar a URL que o aplicativo deve escutar, bem como variáveis de ambiente que são aplicadas na execução ou na depuração.In the launchSettings file, you can configure the URL for the app to listen on as well as environment variables that are applied on run or debug. Com essa atualização, facilitamos a colaboração em projetos com outras pessoas que talvez não estejam usando o Visual Studio para Mac.With this update, we have made it easier for you to collaborate on projects with others that may not be using Visual Studio for Mac. O Visual Studio, o Visual Studio Code e a CLI (interface de linha de comando) do dotnet dão suporte a esse arquivo.Visual Studio, Visual Studio Code and the dotnet CLI (Command Line Interface) all support this file.

Suporte a aninhamento de arquivosFile Nesting support

Nesta versão, estamos adicionando o aninhamento de arquivos automático para projetos ASP.NET Core.In this release we are adding automatic file nesting for ASP.NET Core projects. As regras de aninhamento de arquivos automático aplicadas são as mesmas que você encontra no Visual Studio.The auto file nesting rules applied are the same as what you find in Visual Studio. Com o aninhamento de arquivos habilitado, você pode se concentrar melhor nos arquivos que você editar com mais frequência.With file nesting enabled, you can focus better on the files that you edit most frequently. Os arquivos gerados e os arquivos editados com menos frequência serão aninhados sob outros arquivos relacionados.Generated files, and less frequently edited files will be nested under other related files.

  • Para obter informações sobre todos os bugs do .NET corrigidos nesta versão, vá para a seção Correções de bugs.For information on all .NET bugs fixed in this release, jump to the bug fixes section.

Dica

Para obter mais informações sobre tudo o que há de novo no .NET Core, confira as notas sobre a versão do .NET Core.For more information on everything new with .NET Core, see the .NET Core release notes.

UnityUnity

Nós aprofundamos a compreensão que o Visual Studio para Mac tem para projetos do Unity adicionando novas especificações de diagnóstico ao Unity.We've deepened the understanding that Visual Studio for Mac has for Unity projects by adding new diagnostics specific to Unity. Também tornamos o IDE mais inteligente, suprimindo diagnósticos C# gerais que não se aplicam a projetos do Unity.We've also made the IDE smarter by suppressing general C# diagnostics that don't apply to Unity projects. Por exemplo, o IDE não mostrará uma correção rápida para alterar uma variável de inspetor para readonly – que impediria que você modificasse a variável no Editor do Unity.For example, the IDE won't show a quick-fix to change an inspector variable to readonly - which would prevent you from modifying the variable in the Unity Editor.

Adicionaremos mais desses diagnósticos específicos do Unity conforme aprendermos melhores práticas com os desenvolvedores.We'll add more of these Unity-specific diagnostics as we learn best practices from developers. Informe-nos se há algo que você gostaria de ver e como isso ajudaria.Let us know if there is something you'd like to see and how it would help!

Novos diagnósticos com correções rápidasNew diagnostics with quick-fixes

  • UNT0001: as mensagens do Unity serão chamadas pelo tempo de execução mesmo se estiverem vazias. Não as declare para evitar o processamento de desnecessário pelo tempo de execução do Unity.UNT0001: Unity messages are called by the runtime even if they are empty, do not declare them to avoid uncesseray processing by the Unity runtime.
  • UNT0002: a comparação de marcas usando a igualdade de cadeia de caracteres é mais lenta do que o método CompareTag interno.UNT0002: Tag comparison using string equality is slower than the built-in CompareTag method.
  • UNT0003: O uso da forma genérica de GetComponent é preferencial para a segurança de tipos.UNT0003: Usage of the generic form of GetComponent is preferred for type safety.
  • UNT0004: A mensagem de atualização é dependente da taxa de quadros e deve usar Time.deltaTime em vez de Time.fixedDeltaTime.UNT0004: Update message is frame-rate dependent, and should use Time.deltaTime instead of Time.fixedDeltaTime.
  • UNT0005: a mensagem FixedUpdate é independente da taxa de quadros e deve usar Time.fixedDeltaTime em vez de Time.deltaTime.UNT0005: FixedUpdate message is frame-rate independent, and should use Time.fixedDeltaTime instead of Time.deltaTime.
  • UNT0006: Uma assinatura de método incorreta foi detectada para esta mensagem do Unity.UNT0006: An incorrect method signature was detected for this Unity message.
  • UNT0007: o Unity substitui o operador de comparação nula para objetos do Unity que é incompatível com a união nula.UNT0007: Unity overrides the null comparison operator for Unity objects which is incompatible with null coalescing.
  • UNT0008: o Unity substitui o operador de comparação nula para objetos do Unity que é incompatível com a propagação nula.UNT0008: Unity overrides the null comparison operator for Unity objects which is incompatible with null propagation.
  • UNT0009: Ao aplicar o atributo InitializeOnLoad a uma classe, você precisa fornecer um construtor estático.UNT0009: When applying the InitializeOnLoad attribute to a class, you need to provide a static constructor. O atributo InitializeOnLoad verifica se ele será chamado quando o editor for iniciado.InitializeOnLoad attribute ensures that it will be called as the editor launches.
  • UNT0010: MonoBehaviours só deve ser criado usando AddComponent().UNT0010: MonoBehaviours should only be created using AddComponent(). O MonoBehaviour é um componente e precisa ser anexado a um GameObject.MonoBehaviour is a component, and needs to be attached to a GameObject.
  • UNT0011: ScriptableObject só deve ser criado usando CreateInstance().UNT0011: ScriptableObject should only be created using CreateInstance(). ScriptableObject precisa ser criado pelo mecanismo do Unity para manipular métodos de mensagem do Unity.ScriptableObject needs to be created by the Unity engine to handle Unity message methods.

Novos supressores de diagnósticoNew diagnostic suppressors

  • USP0001 para IDE0029: os objetos do Unity não devem usar união nulaUSP0001 for IDE0029: Unity objects should not use null coalescing
  • USP0002 para IDE0031: os objetos do Unity não devem usar propagação nulaUSP0002 for IDE0031: Unity objects should not use null propagation
  • USP0003 para IDE0051: as mensagens do Unity são invocadas pelo tempo de execução do UnityUSP0003 for IDE0051: Unity messages are invoked by the Unity runtime
  • USP0004 para IDE0044: os campos com um atributo SerializeField não devem se tornar somente leituraUSP0004 for IDE0044: Fields with a SerializeField attribute should not be made readonly

Também fizemos as seguintes melhorias para os desenvolvedores do Unity que usam o Visual Studio para Mac:We also made the following improvements for Unity developers using Visual Studio for Mac:

  • Aperfeiçoadas as informações exibidas na caixa de diálogo Anexar à Instância, incluindo a ID do processoImproved the information displayed in the attach to instance dialog, including process ID
  • Suporte adicionado para o editor hexadecimal ao inspecionar matrizes de bytes e cadeias de caracteresAdded support for the hex editor when inspecting byte arrays and strings
  • Suporte adicionado para acesso de membro de ponteiro no depurador, ou seja, p->foo->barAdded support for pointer member access in the debugger, i.e. p->foo->bar
  • Suporte adicionado para conversões implícitas em inicializadores de matriz, ou seja, novo byte[] {1,2,3,4}Added support for implicit conversions in array initializers, i.e. new byte[] {1,2,3,4}

XamarinXamarin

Xamarin.FormsXamarin.Forms

Recarregamento Frequente de XAML para Xamarin.FormsXAML Hot Reload for Xamarin.Forms

Agora você pode usar a versão prévia pública da Recarga Dinâmica de XAML do Xamarin.Forms no Visual Studio para Mac.You can now use the public preview of XAML Hot Reload for Xamarin.Forms in Visual Studio for Mac! O Recarregamento Frequente de XAML permite que você itere rapidamente em suas interfaces de usuários depurando seu aplicativo para um emulador, simulador ou dispositivo físico, alterando XAML e pressionando Salvar para ver essas alterações refletidas imediatamente no aplicativo em execução.XAML Hot Reload enables you to rapidly iterate on your UIs by debugging your app to an emulator, simulator, or physical device, changing your XAML, and hitting save to see those changes immediately reflected on the running app.

Para habilitar a Recarga Dinâmica de XAML, marque a caixa de seleção Habilitar Recarga Dinâmica do Xamarin em Visual Studio > Preferências > Projetos > Recarga Dinâmica do Xamarin.To enable XAML Hot Reload check the Enable Xamarin Hot Reload checkbox at Visual Studio > Preferences > Projects > Xamarin Hot Reload.

Para obter mais informações, confira a documentação da Recarga Dinâmica de XAML.For more info, see the XAML Hot Reload documentation.

Recarregamento Frequente de XAML integrado no Visual Studio para MacXAML Hot Reload built into Visual Studio for Mac

Design de Material do Visual no Pré-visualizador XAMLVisual Material Design in the XAML Previewer

O design de material usando o Visual Xamarin.Forms agora é uma versão prévia para iOS e Android no Pré-visualizador XAML do Xamarin.Forms.Material design using Xamarin.Forms Visual now previews for both iOS and Android in the Xamarin.Forms XAML Previewer. Para obter mais informações sobre o Pré-visualizador de XAML, confira a documentação do Pré-visualizador do XAML.For more information on the XAML Previewer, see the XAML Previewer documentation.

Dica

Para obter mais informações sobre tudo o que há de novo no Xamarin.Forms, confira as notas sobre a versão do Xamarin.Forms.For more information on everything new with Xamarin.Forms, see the Xamarin.Forms release notes.

Xamarin.AndroidXamarin.Android

Adição de suporte do Android 10 para o XamarinAdded Android 10 support for Xamarin

Agora você pode usar as APIs do Android 10 no Xamarin.Android.You can now use Android 10 APIs within Xamarin.Android. Comece com o Android 10 configurando Compilar usando a versão do Android: (Estrutura de Destino) para Android 10.0 (Q) na guia Build > General das páginas de propriedades do projeto do Visual Studio para Mac.You can get started with the Android 10 by setting Compile using Android version: (Target Framework) to Android 10.0 (Q) under the Build > General tab of the Visual Studio for Mac project property pages. Os novos recursos do Android 10 incluem:Features new to Android 10 include:

  • Suporte a um Tema Escuro para garantir uma experiência consistente para os usuários que habilitam o tema escuro em todo o sistema.Support a Dark Theme to ensure a consistent experience for users who enable system-wide dark theme.
  • Suporte à Navegação por Gestos no aplicativo indo de ponta a ponta e garantindo que os gestos personalizados sejam complementares aos gestos de navegação do sistema.Support Gesture Navigation in your app by going edge-to-edge and making sure your custom gestures are complementary to the system navigation gestures.
  • Otimizar para dobráveis: Forneça experiências diretas e de ponta a ponta nos inovadores dispositivos dobráveis atuais.Optimize for foldables: Deliver seamless, edge-to-edge experiences on today’s innovative foldable devices.
  • Notificações mais interativas habilitando respostas e ações sugeridas dentro das notificações para interagir com seus usuários.More interactive notifications by enabling suggested replies and actions in your notifications to engage with your users.
  • APIs de Rede Melhores para solicitações e conectividade de rede Wi-Fi.Better Networking APIs for Wi-Fi network requests and connectivity.
Defina Compilar usando a versão do Android: (Estrutura de Destino) para Android 10.0 (Q).Set the Compile using Android version: (Target Framework) to Android 10.0 (Q).

Para saber mais sobre o Android 10, confira nossa documentação.To learn more about Android 10, see our documentation.

Experiência aprimorada do modo divisão do Android DesignerImproved Android designer split-view experience

Fizemos inúmeras melhorias na experiência de exibição dividida ao editar layouts do Android:We have made a number of improvements to the split-view experience when editing Android layouts:

  • Sincronização do cursor: os itens serão selecionados automaticamente ao mover o cursor no editor de código-fonte.Caret synchronization: items will automatically be selected when moving the caret in the source editor.
  • Os elementos da caixa de ferramentas agora podem ser arrastados e soltos no Design Surface e no editor de código-fonte.Toolbox elements can now be drag & dropped to both the design surface and the source editor.
  • Agora há suporte para o comando "Alternar Comentário".The "Toggle Comment" command is now supported.

Dica

Para obter mais informações sobre tudo o que há de novo no Xamarin.Android, confira as notas sobre a versão do Xamarin.Android.For more information on everything new with Xamarin.Android, see the Xamarin.Android release notes.

Xamarin.iOSXamarin.iOS

Suporte para o Xcode 11 e o iOS 13Xcode 11 and iOS 13 Support

Esta versão adiciona suporte ao Xcode 11 para compilar e depurar aplicativos para o iOS 13, o tvOS 13 e o watchOS 6.This release adds support for Xcode 11 to build and debug apps for iOS 13, tvOS 13, and watchOS 6. Confira nossa Introdução ao iOS 13 para obter mais detalhes sobre os novos recursos disponíveis.See our Introduction to iOS 13 for more details on the new features available.

Carregar para o App Store ConnectUpload to App Store Connect

Você pode carregar para o App Store Connect usando o assistente de publicação no Visual Studio para Mac, agora que a ferramenta Carregador de Aplicativos não está mais incluída com o Xcode.You can upload to App Store Connect using the publishing wizard in Visual Studio for Mac now that the Application Loader tool is no longer included with Xcode. Nossa página de documentação Publicar aplicativos Xamarin.iOS na App Store detalha esse novo fluxo de trabalho.Our Publishing Xamarin.iOS apps to the App Store documentation page details this new workflow.

Editor de RestriçõesConstraints Editor

O Xamarin Designer para iOS está apresentando uma nova maneira de trabalhar com restrições.The Xamarin Designer for iOS is introducing a new way to work with constraints. Quando você seleciona uma exibição restrita, reticências agora aparecem na barra de ferramentas ao lado do seletor de Modo de Fixação de Restrições.When you select a constrainable view, an ellipsis will now appear in the toolbar next to the Constraints Pinning Mode selector. Clique nas reticências para exibir um popover para as restrições de edição no modo de exibição selecionado:Click the ellipsis to display a popover for editing constraints on the selected view:

Seletor de Modo de Fixação de RestriçõesConstraints Pining Mode selector

Dica

Para obter mais informações sobre tudo o que há de novo no Xamarin.iOS, confira as notas sobre a versão do Xamarin.iOS.For more information on everything new with Xamarin.iOS, see the Xamarin.iOS release notes.

Nova caixa de diálogo Gerenciar pacotes do NuGetNew Manage NuGet packages dialog

Agora os pacotes NuGet podem ser instalados, atualizados ou desinstalados para vários projetos em uma única etapa com a caixa de diálogo Gerenciar Pacotes NuGet:NuGet packages can now be installed, updated, or uninstalled for multiple projects in one step with the Manage NuGet Packages dialog:

Gerenciar pacotes NuGet para a solução no Visual Studio para MacManaging NuGet packages for the solution in Visual Studio for Mac

A caixa de diálogo antiga Adicionar Pacotes foi substituída por uma nova caixa de diálogo Gerenciar Pacotes NuGet que tem quatro guias, proporcionando a você mais controle sobre o NuGets:The old Add Packages dialog has been replaced with a new Manage NuGet Packages dialog that has four tabs, giving you more control over NuGets:

  • Procurar – mostra os pacotes disponíveis na origem do pacote selecionado.Browse - shows packages available from the selected package source.
  • Instalado – mostra os pacotes instalados na solução ou o projeto, se estiver gerenciando pacotes para um único projeto.Installed - shows packages installed in the solution, or project if managing packages for a single project.
  • Atualizações – mostra as atualizações de pacote disponíveis para a solução ou o projeto, se estiver gerenciando pacotes para um único projeto.Updates - shows package updates available for the solution, or project if managing packages for a single project.
  • Consolidar – mostra pacotes que têm versões diferentes em toda a solução.Consolidate - shows packages that have different versions across the solution.

Para abrir a caixa de diálogo Gerenciar pacotes NuGet para a solução, faça o seguinte:To open the Manage NuGet Packages dialog for the solution, do the following:

  1. Verifique se a solução está selecionada na janela Solução.Make sure the solution is selected in the Solution window.
  2. Clique com o botão direito do mouse na solução e selecione Gerenciar Pacotes NuGet ou selecione Gerenciar Pacotes NuGet no menu Projeto.Right click the solution and select Manage NuGet Packages OR select Manage NuGet Packages from the Project menu.

As guias podem ser usadas das seguintes maneiras:The tabs can be used in the following ways:

Instalar/DesinstalarInstall / Uninstall

Para instalar um pacote em vários projetos, faça o seguinte:To install a package into multiple projects, do the following:

  1. Selecione o pacote na guia Procurar.Select the package in the Browse tab.
  2. Clique no botão Adicionar Pacote.Click the Add Package button.
  3. Verifique os projetos na caixa de diálogo Selecionar Projetos e clique em OK, conforme ilustrado abaixo:Check the projects in the Select Projects dialog and click OK, as illustrated below:
Caixa de diálogo Selecionar Projetos no Visual Studio para MacSelect Projects dialog in Visual Studio for Mac

Para desinstalar um pacote de vários projetos:To uninstall a package from multiple projects:

  1. Selecione a guia Instalado.Select the Installed tab.
  2. Selecione o pacote que você deseja desinstalar.Select the package you want to uninstall.
  3. Clique no botão Desinstalar Pacote.Click the Uninstall Package button.
  4. Verifique os projetos dos quais você deseja que o pacote seja desinstalado e clique em OK.Check the projects you want the package to be uninstalled from and click OK.

AtualizaçõesUpdates

Para atualizar um pacote em vários projetos:To update a package in multiple projects:

  1. Selecione o pacote na guia Atualizações.Select the package in the Updates tab.
  2. Clique no botão Pacote de Atualização.Click the Update Package button.
  3. Verifique os projetos na caixa de diálogo Selecionar Projetos e clique em OK.Check the projects in the Select Projects dialog and click OK.

ConsolidarConsolidate

Para consolidar o pacote em vários projetos:To consolidate package in multiple projects:

  1. Selecione a guia Consolidar.Select the Consolidate tab.

  2. Selecione o pacote que você deseja consolidar.Select the package you want to consolidate.

  3. Marque ou desmarque projetos na lista projetos.Check or uncheck projects in the projects list. Por padrão, os projetos que contêm o pacote NuGet selecionado serão verificados.By default projects that contain the selected NuGet package will be checked.

  4. Selecione a versão do pacote para a qual consolidar.Select the package version to consolidate to. Por padrão, a versão mais recente do pacote será selecionada.By default the latest package version will be selected.

  5. Clique no botão Consolidar:Click the Consolidate button:

    Caixa de diálogo Gerenciar Pacotes NuGet consolida a guia no Visual Studio para MacManage NuGet Packages dialog consolidate tab in Visual Studio for Mac

Para gerenciar pacotes NuGet para um único projeto:To manage NuGet packages for a single project:

  1. Selecione o projeto no painel Solução.Select the project in the Solution pad.
  2. Clique com o botão direito do mouse no projeto, selecione Gerenciar Pacotes do NuGet e siga as etapas necessárias acima.Right click the project and select Manage NuGet Packages, and follow the steps you need above. Observe que a guia Consolidar não será exibida, mas as guias Procurar, Instalado e Atualizações estarão disponíveisNote that the Consolidate tab will not be displayed but the Browse, Installed, and Updates tabs will be available

Documentos fixadosPinned Documents

Nesta versão, introduzimos a capacidade de fixar guias de documentos, permitindo que você fixe suas guias de arquivos favoritas para mantê-las sempre abertas e visíveis:In this release we have introduced the ability to pin document tabs allowing you to pin your favorite file-tabs to keep them always open and visible:

Guias FixadasPinned Tabs

Para fixar uma guia, use o ícone de Marcador, o menu de contexto do documento ou o comando Fixar/Desafixar Guia (⌥ ⌘ P).To pin a tab, use the Pin icon, document context menu, or the Pin/Unpin Tab command (⌥⌘P). Você também pode reorganizar as guias fixadas arrastando-as no workspace.You can also rearrange pinned tabs by dragging in the workspace.

Tela de boas-vindas – atalhos de teclado favoritosWelcome Screen – Favorite Keyboard Shortcuts

Se você for um novo usuário do Visual Studio para Mac, deverá selecionar seu esquema de atalho de teclado favorito como parte da primeira experiência de execução, conforme ilustrado abaixo.If you're a new Visual Studio for Mac user, you will be asked to select your favorite Keyboard Shortcut Scheme as part of the first run experience, as illustrated below. É claro que você também pode selecionar um esquema ou criar seu próprio do zero mais tarde em Visual Studio > Preferências.Of course, you can also select a scheme or build your own from scratch later under Visual Studio > Preferences.

Tela de Boas-Vindas – Atalhos de TecladoWelcome Screen – Keyboard Shortcuts

Agora o Visual Studio para Mac dá suporte ao Source Link.Visual Studio for Mac now supports Source Link. Isso permite que você depure no código-fonte de pacotes NuGet que enviam .PDBs com links para arquivos de origem.This allows you to debug into source code from NuGet packages that ship .PDBs with links to source files. O Visual Studio para Mac detectará que os arquivos de origem estão disponíveis e oferecerá o download do arquivo de origem, permitindo que você intervenha no código do pacote.Visual Studio for Mac will detect that source files are available and offer to download the source file allowing you to step through package code. O Source Link também funciona com o código do Mono BCL, permitindo que você também intervenha no código do .NET Framework.Source Link also works with Mono BCL code allowing you to step into .NET Framework code as well.

Opção Intervir em Código ExternoStep into External Code option
Aviso do Source LinkSource Link prompt

Informações de atualização do Novo PacoteNew Package update information

As informações de atualização do pacote agora são exibidas para projetos de estilo do SDK no painel de Solução.Package update information is now displayed for SDK style projects in the Solution pad.

A maneira como as informações são exibidas para projetos não SDK e em estilo SDK foi deixada consistente.The way the information is displayed for SDK style and non-SDK projects has been made consistent. Um ícone de atualização agora é exibido com uma dica de ferramenta mostrando a versão atualizada do pacote NuGet.An update icon is now displayed with a tooltip showing the updated NuGet package version. A versão instalada agora é exibida ao lado da ID do pacote NuGet para todos os tipos de projetos:The installed version is now displayed next to the NuGet package id for all projects types:

Atualizações do pacote NuGet na janela de Solução no Visual Studio para MacNuGet package updates in the Solution window in Visual Studio for Mac

InstallerInstaller

As seguintes melhorias foram feitas no instalador:The following improvements were made in the installer:

  • Adicionamos uma verificação adicional para tornar o download de pacotes muito mais rápido.We added some some additional verification to make downloading packages much faster.
  • Se o download falhar ou for interrompido por algum motivo, o instalador o retomará do ponto de falha em vez do início.If download fails or gets interrupted for some reason, the installer will resume from the failure point rather than from the start. Se, por qualquer motivo, o arquivo de cache for corrompido, o produto será baixado novamente.If for any reason cache file gets corrupted, product will be re-downloaded again.
  • O instalador agora exibe um progresso muito mais preciso de cada pacote.The Installer now displays much more accurate progress for each package.
  • Também adicionamos melhorias adicionais de interface do usuário durante a instalação.We also added additional UI improvements during installation. Agora mostramos com precisão quantos pacotes você precisa instalar e quantos faltam.We now accurately show how many packages you have to install and how many are left.
  • Sempre tentaremos instalar as versões lançadas recomendadas do Xamarin, do .NET Core e do Mono.We'll always try to install the recommended released versions of Xamarin, .NET Core and Mono. Às vezes, isso significa fazer downgrade das versões para entrar em um estado compatível.Sometimes this will mean downgrading your versions to get you into a supported state.
  • Corrigimos problemas com a autorização.We fixed issues with authorization. A solicitação de senha deve ser mostrada apenas uma vez a cada 5 minutos durante a instalação.The password prompt should only shown once per every 5 minutes during installation.
  • Agora ocultaremos o botão ‘localização’ se não houver nenhuma ação a ser feita.We now hide the ‘location’ button if there is no actions to do.

Correções de bugBug Fixes

InstalaçãoInstallation

Corrigimos os seguintes principais problemas no instalador:We fixed the following top issues in the Installer:

  • Correções de bug do Catalina.Bug fixes for Catalina.
  • Correção do bug de incremento de percentual resultante da configuração do separador de números quando usada com idiomas localizadosFixed percentage increment bug resulted by number separator configuration when used with localized languages
  • Correção para exibir o tamanho correto quando VSFMac é o único item a ser instalado.Fix to display correct size when VSFMac is the only item to install.

Web e AzureWeb and Azure

Corrigimos os seguintes principais problemas do suporte e das ferramentas do .NET Core e do ASP.NET Core:We fixed the following top issues with .NET Core and ASP.NET Core support and tooling:

  • O SDK do .NET Core 3.0.100 ainda aparecia no atualizador após a instalação das atualizações..NET Core SDK 3.0.100 still appears in the updater after installing updates.
  • É sugerido um comando incorreto para o certificado de desenvolvimento de confiança.Incorrect command is suggested for trusting development certificate.
  • O modelo de tipo de arquivo JavaScript não está em Adicionar > Novo Arquivo > Web.JavaScript File Type template is not under Add > New File > Web.
  • O Visual Studio para Mac salva o novo arquivo JSON como uma marca de ordem de byte UTF-8.Visual Studio for Mac saves new JSON file as UTF-8 BOM.
  • Ao remover um arquivo que tem um filho, um arquivo não é removido.When removing a file that has a child, one file is not removed.
  • A URL do aplicativo Web é revertida para 5001 após a reinicialização do IDE.The Web app URL reverts back to 5001 after the IDE is restarted.
  • As variáveis de ambiente não são selecionadas quando um usuário escolhe "Iniciar sem Depuração".Environment variables are not getting picked up when a user chooses to "Start without Debugging".
  • O menu de contexto "Incluir no Projeto" é exibido quando não deveria ser."Include in Project" context menu appears when it shouldn't.

Corrigimos os seguintes principais problemas do Azure:We fixed the following top issues with with Azure:

Shell e FerramentasShell and Tools

Corrigimos os seguintes principais problemas do IDE:We fixed the following top issues with the IDE:

Edição do código-fonteSource Code Editing

Corrigimos os seguintes principais problemas da edição de código-fonte:We fixed the following top issues with editing source code:

Controle de versãoVersion Control

Corrigimos os seguintes principais problemas do Controle de Versão:We fixed the following top issues with Version Control:

  • O IDE trava no controle de versão ao abrir um Storyboard no Xcode Interface Builder.The IDE hangs in version control when opening a Storyboard in Xcode Interface Builder.
  • O Visual Studio 2019 para Mac congelava ao alternar o branch.Visual Studio 2019 for Mac freezes when switching branch.
  • A renomeação de arquivos no controle de versão do Git fazia o IntelliSense desaparecer.Renaming files under Git version control make IntelliSense disappear.
  • As guias do controle de versão não eram exibidas ao abrir soluções com arquivos C# abertos anteriormente.Version control tabs do not appear when opening solutions with previously open C# files.
  • O lote de aplicativo contém arquivos que não deveria ao usar o Git.The App bundle contains files it shouldn't when using Git.
  • O IDE falha ao fazer a publicação no GitHub.The IDE crashes when publishing to GitHub.
  • Remover um git stash que tem conflitos fornece um aviso inválido e nenhum outro log.Popping a git stash that has conflicts gives invalid warning and no further logs.
  • Clonar projeto com submódulos é interrompido com o erro “Falha na operação de controle de versão”.Cloning project with sub-modules stops with error 'Version control operation filed'.
  • O Visual Studio falha/sai ao tentar fazer commit do Git.Visual Studio crashes/exists when attempting to commit to Git.
  • A guia "Alterações" não é atualizada.The "Changes" tab is not refreshed.
  • Os comandos Diff/View estão corrompidos no Painel de Soluções.Diff/View commands are broken in Solution Pad.
  • O comando "Criar patch" está corrompido."Create Patch" command is broken.
  • Carregamento de revisão muito lento na exibição Diff/Comparação.Very slow revision loading in Diff/Comparison view.
  • O VS para Mac congela no git revert.VS for Mac freezes on git revert.
  • As exibições do documento de controle de versão estão ausentes no novo editor.Version control document views are missing with the new editor.
  • Fazer check-out de um repositório com um nome de usuário e uma senha não preservava o nome de usuário.Checking out a repository with a username and password would not preserve the username.
  • Não é possível usar o Subversion em SVN + SSH sem uma porta.It is not possible to use Subversion over svn+ssh without a port.
  • A alternância de branches não respeita as alterações da estrutura de destino.Switching branches doesn't respect target framework changes.
  • SIGABRT ao tentar efetuar fetch de um branch do Git do Azure DevOps.SIGABRT when attempting to fetch a branch from Azure DevOps Git.

Ferramentas de testeTesting Tools

Corrigimos o seguinte problema dos testes:We fixed the following issue with testing:

  • Não é possível executar testes únicos definidos em MonoDevelop.VersionControl.Git.Test a partir do IDE porque há falha ao carregar o assembly LibGit2Sharp.It is not possible to execute single tests defined in MonoDevelop.VersionControl.Git.Test from the IDE, because it fails to load the LibGit2Sharp assembly.

Sistema de projetoProject System

Corrigimos os seguintes problemas com Projetos:We fixed the following issues with Projects:

NuGetNuGet

Corrigimos o seguinte problema do NuGet:We fixed the following issue with NuGet:


Problemas Conhecidos Known Issues

  • A Recarga Dinâmica de XAML do Xamarin.Forms não é funcional em dispositivos iOS e exibe uma barra de informações após alguns minutos solicitando que você relate um problema.XAML Hot Reload for Xamarin.Forms is not functional on iOS devices, and displays an Info Bar after a couple minutes asking you to report an issue. Isso será corrigido em uma versão futura.This will be fixed in an upcoming release.
  • A opção Código Compartilhado está ausente ao criar um aplicativo multiplataforma Xamarin.Shared Code option is missing when creating a Xamarin Multi-platform app.

Importante

O Visual Studio 2019 para Mac pode ser instalado no macOS Catalina Beta, mas pode não funcionar como esperado com um sistema operacional em versão prévia.Visual Studio 2019 for Mac can be installed on macOS Catalina Beta, but may not work as expected with a preview OS. Use Relatar um Problema para nos informar problemas que você descobrir durante o uso do Visual Studio para Mac e Catalina.Please use Report a Problem to inform us of any issues you discover while using Visual Studio for Mac and Catalina.


ComentáriosFeedback

Adoraríamos ouvir sua opinião!We would love to hear from you! Você pode relatar um problema por meio da opção Relatar um Problema no IDE do Visual Studio para Mac.You can report a problem through the Report a Problem option in Visual Studio for Mac IDE. Você pode acompanhar seus comentários, incluindo sugestões, no portal Developer Community (Comunidade de Desenvolvedores).You can track your feedback, including suggestions, in the Developer Community portal.


Início da página
Top of Page