2. Como inicializar o seu projeto e implantar o primeiro aplicativo2. Initializing your project and deploying your first application

Neste tutorial, você aprenderá a criar um projeto do Unity, configurá-lo para o desenvolvimento do MRTK (Kit de Ferramentas de Realidade Misturada) e importar o MRTK.In this tutorial, you'll learn how to create a new Unity project, configure it for Mixed Reality Toolkit (MRTK) development, and import MRTK. Você também aprenderá mais sobre como configurar, compilar e implantar uma cena básica do Unity do Visual Studio para o HoloLens 2.You'll also walk through configuring, building, and deploying a basic Unity scene from Visual Studio to your HoloLens 2. Depois de implantá-la no HoloLens 2, você verá uma malha de mapeamento espacial que abrange as superfícies percebidas pelo HoloLens.Once you have deployed it to your HoloLens 2, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. Além disso, você verá indicadores em suas mãos e dedos para o acompanhamento de mão e um contador da taxa de quadros para monitorar o desempenho do aplicativo.Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance.

ObjetivosObjectives

  • Saiba como configurar o Unity para o desenvolvimento no HoloLens.Learn how to configure Unity for HoloLens development.
  • Saiba como criar e implantar seu aplicativo no HoloLens.Learn how to build and deploy your app to HoloLens.
  • Experimente a malha de mapeamento espacial, as malhas de mão e o contador da taxa de quadros no dispositivo HoloLens 2.Experience the spatial mapping mesh, hand meshes, and framerate counter on your HoloLens 2 device.

Como criar o projeto do UnityCreating the Unity project

  1. Inicie o Hub do Unity, selecione a guia Projetos e clique na seta para baixo ao lado do botão Novo:Launch Unity Hub, select the Projects tab, and then click the down arrow next to the New button:

Hub do Unity com a seta para baixo do botão "Novo" realçada

  1. No menu suspenso, selecione a versão do Unity especificada nos Pré-requisitos:In the dropdown menu, select the Unity version specified in the Prerequisites:

Selecionar a versão do Unity

Dica

Se a versão específica do Unity não estiver disponível no Hub do Unity, você poderá iniciar a instalação em Arquivos de Download do Unity.If the particular Unity version is not available in Unity Hub, you can initiate the installation from Unity's Download Archive.

  1. Na janela Criar um projeto, faça o seguinte:In the Create a new project window, do the following:

    • Verifique se Modelos está definido como 3D.Ensure Templates is set to 3D.
    • Na caixa Nome do Projeto, insira um nome adequado para seu projeto (por exemplo, "Tutoriais do MRTK").In the Project Name box, enter a suitable name for your project (for example, "MRTK Tutorials").
    • Clique no botão de três pontos ao lado de Localização e procure a pasta em que deseja salvar o projeto.Click the three-dot button next to Location, and then navigate to the folder where you want to save your project.

Cuidado

Ao trabalhar no Windows, há um limite de MAX_PATH de 255 caracteres.When working on Windows, there is a MAX_PATH limit of 255 characters. Por conta disso, você deve salvar o projeto do Unity próximo à raiz da unidade.Because of this, you should save the Unity project close to the root of the drive.

* <span data-ttu-id="a5576-125">Selecione o botão **Criar**.</span><span class="sxs-lookup"><span data-stu-id="a5576-125">Click the **Create** button.</span></span> <span data-ttu-id="a5576-126">Isso cria e inicia o projeto do Unity.</span><span class="sxs-lookup"><span data-stu-id="a5576-126">This creates and launches your new Unity project.</span></span>

Hub do Unity com a janela "Criar um projeto" preenchida

A barra de status mantém você atualizado sobre seu progresso.The status bar keeps you updated on your progress.

A barra de progresso do Unity mantém você atualizado sobre o status de "criar projeto"

Como alternar a plataforma de buildSwitching the build platform

  1. Na barra de menus, selecione Arquivo > Configurações de Build...On the menu bar, select File > Build Settings...

Caminho do menu Configurações de Build... do Unity

  1. Na janela Configurações de Build, selecione Plataforma Universal do Windows e clique no botão Mudar Plataforma:In the Build Settings window, select Universal Windows Platform and then click the Switch Platform button:

Janela Configurações de Build do Unity com o UWP selecionado para alternar a plataforma da opção Autônomo

  1. Aguarde até que o Unity termine de mudar a plataforma e feche a janela Configurações de Build.Wait for Unity to finish switching the platform, and then close the Build Settings window.

Como importar os Recursos Essenciais do TextMeshProImporting the TextMeshPro Essential Resources

Os Recursos Essenciais do TextMeshPro são exigidos pelos elementos da interface do usuário do MRTK.The TextMeshPro Essential Resources are required by MRTK's UI elements. Se não estiver planejando usar os elementos de interface do usuário do MRTK no seu projeto, ignore esta etapa.If you are not planning to use MRTK's UI elements in your project, you can skip this step.

  1. Na barra de menus, selecione Janela > TextMeshPro > Importar Recursos Essenciais do TMP.On the menu bar, select Window > TextMeshPro > Import TMP Essential Resources.

Caminho do menu Importar Recursos Essenciais do TMP do Unity

  1. Na janela Importar Pacote do Unity, clique no botão Todos para garantir que todos os ativos sejam selecionados e clique no botão Importar para importar os ativos:In the Import Unity Package window, click the All button to ensure that all the assets are selected, and then click the Import button to import the assets:

Janela Importar Recursos Essenciais do TMP do Unity

Como importar o Kit de Ferramentas de Realidade MisturadaImporting the Mixed Reality Toolkit

  1. Baixe o pacote personalizado do Unity:Download the Unity custom package:

    Microsoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackageMicrosoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackage

  2. Na barra de menus, selecione Ativos > Importar Pacote > Pacote Personalizado... .On the menu bar, select Assets > Import Package > Custom Package....

  3. Na caixa de diálogo Importar pacote... , procure a localização do pacote recém-baixado, selecione-o e clique no botão Abrir.In the Import package... dialog, navigate to the location of the package you just downloaded, then select it, and then click the Open button.

  4. Na janela Importar Pacote do Unity, clique no botão Todos para garantir que todos os ativos sejam selecionados e clique no botão Importar para importar os ativos.In the Import Unity Package window, click the All button to ensure that all the assets are selected, and then click the Import button to import the assets.

Como selecionar as configurações de projeto e do MRTKSelecting MRTK and project settings

Depois que o Unity terminar de importar o pacote da seção anterior, a janela Configurador de Projeto do MRTK será exibida.After Unity has finished importing the package from the previous section, the MRTK Project Configurator window should appear. Caso contrário, você pode abri-la manualmente acessando Kit de Ferramentas de Realidade Misturada > Utilitários > Configurar Projeto do Unity:If it doesn't, you can manually open it by going to Mixed Reality Toolkit > Utilities > Configure Unity Project:

Caminho do menu Configurar Projeto do Unity no Unity

  1. Na janela Configurador de Projeto do MRTK, expanda a seção Modificar Configurações, se necessário, e verifique se todas as opções estão selecionadas.In the MRTK Project Configurator window, expand the Modify Configurations section, if necessary, and then ensure that all options are selected.

Janela Configurador de Projeto do MRTK no Unity com a opção Modificar Configurações exibida

  1. Para aplicar as configurações, clique no botão Aplicar.To apply the settings, click the Apply button.

Botão Aplicar no MRTK

Observação

Você está usando o XR herdado interno do Unity em vez do novo Sistema de Plug-ins do XR, porque o novo sistema não é totalmente compatível com as versões recomendadas do Unity e do MRTK para esta série de tutoriais.You are using Unity's built-in legacy XR instead of the new XR Plugin System because the new system is not fully compatible with the recommended Unity and MRTK versions for this tutorial series. Se você receber algum aviso sobre o XR interno ser preterido, ignore-o.If you see any warnings about built-in XR being deprecated, you can ignore them.

Dica

A aplicação das Configurações Padrão do MRTK é opcional, mas altamente recomendável, pois ela ajudará a definir algumas das configurações recomendadas do Unity:Applying the MRTK Default Settings is optional but strongly recommended as it will help configure some recommended Unity settings:

  • Habilitar o XR herdado: habilita a VR para o projeto.Enable legacy XR: Enables VR for the project.
  • Definir o caminho de renderização com uma Instância de Passagem Única: aprimora o desempenho gráfico executando o pipeline de renderização dos dois olhos na mesma chamada de desenho.Set Single Pass Instanced rendering path: Improves graphics performance by executing the render pipeline for both eyes in the same draw call. Para saber mais sobre este tópico, veja a seção Renderização com uma Instância de Passagem Única da documentação Desempenho do MRTK.To learn more about this topic, you can refer to the Single-Pass Instanced rendering section of MRTK's Performance documentation.
  • Definir camada padrão de Reconhecimento Espacial: cria uma camada do Unity chamada Reconhecimento Espacial e configura o MRTK para usá-la na malha de reconhecimento espacial.Set default Spatial Awareness layer: Creates a Unity Layer named Spatial Awareness and configures MRTK to use this layer for the spatial awareness mesh. Para saber mais sobre as Camadas do Unity, veja a documentação Como personalizar seu workspace do Unity.To learn more about Unity Layers, you can refer to Unity's Customizing Your Workspace documentation.
  1. Na barra de menus, selecione Editar > Configurações de Projeto... .On the menu bar, select Edit > Project Settings... .

  2. Na janela Configurações de Projeto, selecione Player, clique na lista suspensa Configurações de XR e escolha a caixa ao lado de Realidade Virtual Compatível:In the Project Settings window, select Player, then click the XR Settings dropdown, and then select the box next to Virtual Reality Supported:

Configurações de XR no Unity com a opção Realidade Virtual Compatível exibida

Isso importa o SDK do Windows Mixed Reality:This imports the Windows Mixed Reality SDK:

Configurações de XR no Unity com a opção SDKs de Realidade Virtual exibida

Depois que o Unity terminar de importar o SDK do Windows Mixed Reality, a janela Configurador de Projeto do MRTK será exibida novamente.After Unity has finished importing the Windows Mixed Reality SDK, the MRTK Project Configurator window should appear again. Caso contrário, selecione Kit de Ferramentas de Realidade Misturada > Utilitários > Configurar Projeto do Unity para abri-lo.If it doesn't, select Mixed Reality Toolkit > Utilities > Configure Unity Project to open it.

  1. Na janela Configurador de Projeto do MRTK, clique na lista suspensa Espacializador de áudio e selecione Espacializador MS HRTF.In the MRTK Project Configurator window, click the Audio spatializer dropdown, and then select MS HRTF Spatializer.

Configurações de projeto com as opções Espacializador de áudio exibidas

  1. Clique no botão Aplicar.Click the Apply button. Isso fechará a janela Configurador de Projeto do MRTK.This closes the MRTK Project Configurator window.

    Dica

    A definição da propriedade Espacializador de áudio é opcional, mas pode aprimorar a experiência de áudio no seu projeto.Setting the Audio spatializer property is optional but may improve the audio experience in your project. Se você a definir como Espacializador MS HRTF, esse plug-in do espacializador será usado quando a propriedade AudioSource.spatialize do Unity estiver habilitada.If you set it to MS HRTF Spatializer, this spatializer plugin will be used when Unity's AudioSource.spatialize property is enabled. Para saber mais sobre este tópico, veja os Tutoriais sobre áudio espacial.To learn more about this topic, you can refer to the Spatial audio tutorials.

  2. Na janela Configurações de Projeto, clique na lista suspensa Formato de Profundidade e selecione Profundidade de 16 bits:In the Project Settings window, click the Depth Format dropdown, and then select 16-bit depth:

    Configurações de XR do Unity com profundidade de 16 bits selecionada.

    Dica

    A redução do formato de profundidade para 16 bits é opcional, mas pode ajudar a aprimorar o desempenho gráfico no projeto.Reducing the Depth Format to 16-bit is optional but may help improve graphics performance in your project. Para saber mais sobre este tópico, veja a seção Compartilhamento de buffer de profundidade (HoloLens) da documentação Desempenho do MRTK.To learn more about this topic, you can refer to the Depth buffer sharing (HoloLens) section of MRTK's Performance documentation.

  3. Clique na lista suspensa Configurações de Publicação e, na caixa Nome do pacote, insira um nome adequado (por exemplo, "MRTK-Tutoriais-Getting-Started").Click the Publishing Settings drop-down, and then in the Package name box, enter a suitable name (for example, "MRTK-Tutorials-Getting-Started").

    Configurações de Publicação do Unity com o Nome do pacote configurado.

    Nome do Pacote e Nome do ProdutoPackage Name and Product Name

    • O 'Nome do pacote' é o identificador exclusivo do aplicativo.The 'Package name' is the unique identifier for the app. Você deve criar esse identificador antes de implantar o aplicativo para evitar a substituição de aplicativos instalados anteriormente.You should create this identifier before deploying the app to avoid overwriting previously installed apps.
    • O 'Nome do Produto' é o nome exibido no menu Iniciar do HoloLens.The 'Product Name' is the name displayed in the HoloLens Start menu. Para facilitar a localização do aplicativo durante o desenvolvimento, adicione um sublinhado na frente do nome para que ele seja classificado para o topo.To make the app easier to locate during development, you can add an underscore in front of the name to sort it to the top.

    Configurações de Projeto do Unity com o Nome de produto configurado.

  4. Feche a janela Configurações de Projeto.Close the Project Settings window.

Como criar e configurar a cenaCreating and configuring the scene

  1. Na barra de menus, selecione Arquivo > Nova Cena.On the menu bar, select File > New Scene.

  2. Para adicionar o MRTK à cena, na barra de menus, selecione Kit de Ferramentas de Realidade Misturada > Adicionar à Cena e Configurar... .To add the MRTK to the scene, on the menu bar, select Mixed Reality Toolkit > Add to Scene and Configure....

    Caminho do menu Adicionar à Cena e Configurar... do Unity.

  3. Na janela Hierarquia, verifique se MixedRealityToolkit está selecionado.In the Hierarchy window, ensure that MixedRealityToolkit is selected.

    Verificar se MixedRealityTookit está selecionado.

  4. Na seção MixedRealityToolkit da janela Inspetor, confirme se o perfil de configuração está definido como DefaultMixedRealityToolkitConfigurationProfile:In the Inspector window's MixedRealityToolkit section, verify that the configuration profile is set to DefaultMixedRealityToolkitConfigurationProfile:

    Componente MixedRealityToolkit do Unity com DefaultMixedRealityTookitConfigurationProfile selecionado.

    Importante

    Normalmente, você usará o DefaultHoloLens2ConfigurationProfile ao desenvolver para o HoloLens.Typically, you will use the DefaultHoloLens2ConfigurationProfile when developing for HoloLens. No entanto, para este tutorial, você usará o DefaultMixedRealityToolkitConfigurationProfile.However, for this tutorial, you will use the DefaultMixedRealityToolkitConfigurationProfile. No próximo tutorial, Como configurar os perfis do MRTK, você o trocará pelo DefaultHoloLens2ConfigurationProfile.In the next tutorial, Configuring the MRTK profiles, you will change to the DefaultHoloLens2ConfigurationProfile.

  5. Na barra de menus, selecione Arquivo > Salvar como...On the menu bar, select File > Save As...

  6. Na caixa de diálogo Salvar Cena, procure a pasta Cenas do projeto.In the Save Scene dialog, navigate to your project's Scenes folder. Na caixa Nome do arquivo, dê um nome adequado à sua cena (por exemplo, "_GettingStarted_") e clique no botão Salvar.In the File name box, give your scene a suitable name (for example, "_GettingStarted_"), and then click the Save button.

    Janela do prompt Salvar para salvar a cena do Unity.

Build e implantação no HoloLens 2Building and deploying to your HoloLens 2

Antes do build no seu dispositivo, confirme o seguinte:Before building to your device, confirm the following:

  • Seu dispositivo está no Modo de Desenvolvedor.Your device is in Developer Mode.
  • Ele está emparelhado com o computador de desenvolvimento.Your device is paired with your development computer. Caso contrário, você verá a seguinte caixa de diálogo no Visual Studio durante o processo de build:If it's not, you will see the following dialog box in Visual Studio during the build process:

Como inserir o PIN para emparelhamento de dispositivos

Para saber mais sobre essas duas etapas, confira Como usar o Visual Studio para implantação e depuração.To learn more about both of these steps, see Using Visual Studio to deploy and debug.

  1. Na barra de menus, selecione Arquivo > Configurações de Build... .On the menu bar, select File > Build Settings....
  2. Na janela Configurações de Build, clique no botão Adicionar Cenas Abertas para adicionar a cena atual à lista de Cenas no Build.In the Build Settings window, click the Add Open Scenes button to add your current scene to the Scenes In Build list.

Adicionar a cena atual à lista "Cenas no Build"

  1. Clique no botão Compilar.Click the Build button.

    Clique no botão Compilar.

  2. Na caixa de diálogo Compilar Plataforma Universal do Windows, escolha uma localização adequada para armazenar o build (por exemplo, o ideal é criar uma pasta "Builds" na pasta "Tutoriais do MRTK").In the Build Universal Windows Platform dialog, choose a suitable location to store your build (for example, you may want to create a "Builds" folder in your "MRTK Tutorials" folder). Crie uma pasta e dê a ela um nome adequado (por exemplo, "GettingStarted"). Selecione a pasta e clique no botão Selecionar Pasta para iniciar o processo de build.Create a new folder and give it a suitable name (for example, "GettingStarted"), then select the folder, and then click the Select Folder button to start the build process.

    Janela Build do Unity com a pasta de build exibida.

    Uma barra de status será exibida e manterá você atualizado sobre o progresso do build.A status bar appears and keeps you updated on your build progress.

    Processo de build do Unity em andamento.

    Dica

    Você também pode implantar no Emulador do HoloLens ou criar um Pacote do Aplicativo para sideload.You can also deploy to the HoloLens Emulator or create an App Package for sideloading.

  3. Quando o processo de build for concluído, no Explorador de Arquivos, procure a localização em que você armazenou o build e clique duas vezes no arquivo de solução para abri-lo no Visual Studio:When the build process has completed, in File Explorer, navigate to the location where you stored the build, and then double-click the solution file to open it in Visual Studio:

    Windows Explorer com o arquivo de solução do Visual Studio recém-criado selecionado.

    Observação

    Se o Visual Studio solicitar a instalação de novos componentes, reserve um momento para assegurar-se de que você tenha todos os componentes de pré-requisitos na documentação Instalar as Ferramentas .If Visual Studio asks you to install new components, take a moment to check that you have all the prerequisite components in the Install the Tools documentation.

  4. Configure o Visual Studio para o HoloLens selecionando a configuração Mestre ou Versão, a arquitetura ARM64 e Dispositivo como o destino.Configure Visual Studio for HoloLens by selecting the Master or Release configuration, the ARM64 architecture, and Device as the target.

    Dica

    Se você estiver implantando no HoloLens (1ª geração), selecione a arquitetura x86.If you're deploying to HoloLens (1st generation), select the x86 architecture.

    Visual Studio configurado para implantação no HoloLens 2.

    Observação

    Para o HoloLens, você normalmente criará para a arquitetura ARM.For HoloLens, you will typically build for the ARM architecture. No entanto, há um problema conhecido no Unity 2019.3 que causa erros ao selecionar o ARM como a arquitetura de build no Visual Studio.However, there is a known issue in Unity 2019.3 that causes errors when selecting ARM as the build architecture in Visual Studio. A solução alternativa recomendada é criar para o ARM64.The recommended workaround is to build for ARM64. Se essa não for uma opção, acesse Editar > Configurações de Projeto > Player > Outras Configurações e desabilite Trabalhos Gráficos.If that is not an option, go to Edit > Project Settings > Player > Other Settings and disable Graphics Jobs.

    Observação

    Se o Dispositivo não for exibido como uma opção de destino, talvez seja necessário alterar o projeto de inicialização para a solução do Visual Studio do projeto IL2CPP para o projeto UWP.If you don't see Device as a target option, you may need to change the startup project for the Visual Studio solution from the IL2CPP project to the UWP project. Para fazer isso, no Gerenciador de Soluções, clique com o botão direito do mouse em NomeDoProjeto (Universal do Windows) e selecione Definir como Projeto de Inicialização.To do this, in the Solution Explorer, right-click on YourProjectName (Universal Windows), and then select Set as StartUp Project.

  5. Conecte o HoloLens ao computador e siga um destes procedimentos:Connect your HoloLens to your computer, and then do one of the following:

  • Para compilar o aplicativo, implante-o no HoloLens e inicie-o automaticamente sem o depurador do Visual Studio anexado. Na barra de menus, selecione Depurar > Iniciar Sem Depuração.To build the app, deploy it to your HoloLens, and start it automatically without the Visual Studio debugger attached, on the menu bar, select Debug > Start Without Debugging.

    Caminho do menu Iniciar Sem Depuração do Visual Studio.

  • Para compilar e implantar o aplicativo no HoloLens, mas não o iniciar automaticamente, na barra de menus, selecione Build > Implantar Solução.To build and deploy the app to your HoloLens but not have it start automatically, on the menu bar, select Build > Deploy Solution.

    Observação

    Observe o criador de perfil de Diagnóstico no aplicativo, você pode ativar ou desativar a sua visibilidade usando o comando de fala Alternar Diagnóstico.You may notice the Diagnostics profiler in the app, which you can toggle on or off by using the speech command Toggle Diagnostics. É recomendável que você mantenha o criador de perfil visível na maior parte do tempo durante o desenvolvimento para entender quando as alterações no aplicativo podem afetar o desempenho.It's recommended that you keep the profiler visible most of the time during development to understand when changes to the app may impact performance. Por exemplo, os aplicativos do HoloLens devem ser executados continuamente em 60 FPS.For example, HoloLens apps should continuously run at 60 FPS.

ParabénsCongratulations

Você acabou de implantar o seu primeiro aplicativo do HoloLens.You've now deployed your first HoloLens app. Enquanto caminha, você deverá ver uma malha de mapeamento espacial cobrindo todas as superfícies detectadas pelo HoloLens.As you walk around, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. Além disso, você verá indicadores em suas mãos e dedos para o acompanhamento de mão e um contador da taxa de quadros para monitorar o desempenho do aplicativo.Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance. Esses recursos são apenas alguns dos componentes fundamentais incluídos no MRTK.These features are just a few foundational pieces included with MRTK. Nos próximos tutoriais, você adicionará o conteúdo à sua cena para explorar as funcionalidades do HoloLens e do MRTK.In the upcoming tutorials, you'll add content to your scene to explore the capabilities of HoloLens and the MRTK.