2. Como criar um aplicativo de Comunicação Remota Holográfica para PC2. Creating a Holographic Remoting PC application

Neste tutorial, você aprenderá a criar um aplicativo para PC de Comunicação Remota Holográfica e a conectar-se ao HoloLens 2 a qualquer momento, fornecendo um modo de visualizar o conteúdo em 3D na realidade misturada.In this tutorial, you will learn how to create a PC app for Holographic Remoting and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality.

ObjetivosObjectives

  • Configurar o Unity para Comunicação Remota HolográficaConfigure Unity for Holographic Remoting
  • Saber como criar e implantar o aplicativo com o Visual StudioLearn how to build and deploy the application with Visual Studio
  • Desenvolver o aplicativo de Comunicação Remota Holográfica e conectar-se ao HoloLensDeveloping Holographic Remoting application and connecting to HoloLens

Configurar a sua cena para a Comunicação Remota HolográficaConfiguring your scene for Holographic Remoting

Nesta seção, você vai configurar o projeto para transmitir a sua experiência de Realidade Misturada do seu PC para o dispositivo de HoloLens 2 em tempo real em uma conexão Wi-Fi.In this section, you will configure your project to stream your Mixed Reality experience to your HoloLens 2 device from your PC in real-time over a Wi-Fi connection.

Na janela Projeto, navegue até a pasta Ativos > MRTK.Tutorials.PCHolograhicRemoting > Pré-fabricados e clique e arraste o pré-fabricado HolographicRemoting para a sua cena.In the Project window, navigate to the Assets > MRTK.Tutorials.PCHolograhicRemoting > Prefabs folder, and click and drag HolographicRemoting prefab into your scene.

Unity com o pré-fabricado HolographicRemoting recém-adicionado ainda selecionado

Criar o aplicativo para PCBuild your application to PC

O seu aplicativo de Comunicação Remota Holográfica agora está pronto para ser criado no PC.Your Holographic Remoting app is now ready to build on your PC. Siga as etapas abaixo e faça estas alterações para criar esse aplicativo no seu PC.Follow the below steps and make these changes to build this application on to your PC.

1. Definir as configurações do player1. Set the player settings

No menu do Unity, selecione Editar > Configurações do Projeto para abrir a janela Configurações do Player.In the Unity menu, select Edit > Project Settings to open the Player Settings window.

Na janela Configurações do Projeto, expanda as Configurações de Publicação, role para baixo até a seção Funcionalidades e selecione a caixa de seleção de funcionalidades mostrada abaixo, além das funcionalidades existentes.In the Project Settings window, expand the Publishing Settings, scroll down to the Capabilities section and select the below-shown capability checkbox in addition to the existing capabilities.

  • Servidor Cliente da InternetInternet Clint server
  • Servidor Cliente de Redes PrivadasPrivate Network Client Server

Na seção Configurações de XR, marque a caixa de seleção Comunicação Remota Holográfica do WSA com Suporte e habilite a Comunicação Remota Holográfica.In the XR Settings section, select the WSA Holographic Remoting Supported checkbox and enable the Holographic Remoting.

Janela Configurações de XR do Unity com a caixa Comunicação Remota Holográfica do WSA com Suporte habilitada

2. Criar o Projeto do Unity2. Build the Unity Project

No menu do Unity, selecione Arquivo > Configurações de Build para abrir a janela Configurações de Build.In the Unity menu, select File > Build Settings to open the Build Settings window.

Na janela Configurações de Build, clique no botão *Adicionar Cenas Abertas _ para adicionar a cena atual às Cenas.In the Build Settings window, click the *Add Open Scenes _ button to add your current scene to the Scenes. Na lista Build, clique no botão Build para abrir a janela Compilar Plataforma Universal do Windows:In the Build list, then click the Build button to open the Build Universal Windows Platform window:

Janela Configurações de Build do Unity com a cena adicionada

Na janela Criar Plataforma Universal do Windows, escolha uma localização adequada para armazenar o seu build, por exemplo, Documents\MixedRealityLearning.In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, Documents\MixedRealityLearning. Crie uma pasta e dê a ela um nome adequado, por exemplo, PCHolographicRemoting.Create a new folder and give it a suitable name, for example, PCHolographicRemoting. Em seguida, clique no botão Selecionar Pasta para iniciar o processo de build:Then click the Select Folder button to start the build process:

Janela Configurações de Build do Unity com a janela de prompt Selecionar Pasta

Aguarde até que o Unity conclua o processo de build.Wait for Unity to finish the build process.

Processo de build do Unity em andamento

3. Compilar e implantar o aplicativo3. Build and deploy the application

Quando o processo de build for concluído, o Unity solicitará que o Explorador de Arquivos do Windows abra o local em que você armazenou o build.When the build process is completed, Unity will prompt Windows File Explorer to open the location you stored the build. Navegue dentro da pasta e clique duas vezes no arquivo .sln para abri-lo no Visual Studio:Navigate inside the folder, and double-click the .sln file to open it in Visual Studio:

Windows Explorer com a solução do Visual Studio recém-criada selecionada

Observação

Se o Visual Studio solicitar a instalação de novos componentes, reserve um momento para assegurar que todos os componentes necessários estejam instalados conforme especificado na documentação Instalar as Ferramentas.If Visual Studio asks you to install new components, take a moment to ensure that all prerequisite components are installed as specified in the Install the Tools documentation.

Configure o Visual Studio para PC selecionando a configuração da Versão, a arquitetura x64 e o Computador Local como um destino:Configure Visual Studio for PC by selecting the Release configuration, the x64 architecture, and Local Machine as target:

Visual Studio configurado para Computador Local

Clique no botão Computador Local.Click the button that says Local Machine. Ele começa a criar e implantar o aplicativo no seu PC.It starts to build and deploy the application on to your PC. O aplicativo será instalado no seu PC por padrão.The application will be installed in your PC by default.

Como testar o aplicativo remoto de Comunicação Remota HolográficaTesting Holographic Remoting remote application

Para conectar o seu aplicativo para PC ao seu HoloLens 2, siga o processo abaixo:To connect your PC application to your HoloLens 2, follow the below process:

1. Instale o aplicativo de Player de Comunicação Remota no dispositivo HoloLens 21. Install the Remoting Player application on HoloLens 2 device

No HoloLens 2, acesse a Loja de aplicativos e pesquise "Player de Comunicação Remota"._ On your HoloLens 2, visit the Store app and search for "Remoting Player."

  • Selecione o aplicativo Player de Comunicação Remota.Select the Remoting Player app.
  • Toque em Instalar para baixar e instalar o aplicativo.Tap Install to download and install the app.

2. Conectar o aplicativo de Comunicação Remota Holográfica para PC ao Player de Comunicação Remota2. Connect the Holographic remoting PC app to the Remoting Player

  • Inicie o Player de Comunicação Remota no seu HoloLens.Start the Remoting Player on your HoloLens.
  • Anote o endereço IP do HoloLens.Take note of the HoloLens IP address. Ele será exibido como um holograma pelo Player de Comunicação Remota assim que for iniciado.It will be displayed as a hologram by the Remoting Player as soon as it launches.
  • Abra um aplicativo de Comunicação Remota Holográfica para PC no seu PC.Open the Holographic Remoting PC application on your PC.
  • Depois que o aplicativo for iniciado, insira o endereço IP e clique no botão Conectar para se conectar.Once the application is launched, enter the IP address and click on the Connect button to connect.

ParabénsCongratulations

Neste tutorial, você aprendeu como criar um aplicativo remoto para PC de Comunicação Remota Holográfica e a conectar-se ao HoloLens 2 a qualquer momento, fornecendo um modo de visualizar o conteúdo em 3D na realidade misturada.In this tutorial, you learned how to create a Holographic Remoting remote app and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality. Depois que o HoloLens estiver conectado ao aplicativo de Comunicação Remota Holográfica para PC, você deverá ver a transmissão da experiência de realidade misturada no seu dispositivo de HoloLens 2.Once the HoloLens connected to the Holographic Remoting PC application, you should see the mixed reality experience streaming into your HoloLens 2 device.