Solução de problemas de comunicação remota do HolographicHolographic Remoting troubleshooting

Importante

Estas diretrizes são específicas para a comunicação remota do Holographic no HoloLens 2.This guidance is specific to Holographic Remoting on HoloLens 2.

Bibliotecas atenuadas do Spectre não encontradas.Spectre mitigated libraries not found.

Os aplicativos de exemplo de comunicação remota Holographic têm/Qspectre (mitigação de Spectre) habilitada na configuração de versão.Holographic Remoting sample apps have Spectre mitigation (/Qspectre) enabled in Release configuration.

Se você receber um erro de vinculador fatal que declara que ' vccorlib. lib ' não pode ser aberto, certifique-se de que sua carga de trabalho do Visual Studio inclui as bibliotecas atenuadas do Spectre.If you get a fatal linker error which states that 'vccorlib.lib' cannot be opened, make sure that your Visual Studio Workload includes the Spectre mitigated libraries. Consulte https://aka.ms/Ofhn4c para obter mais informações.See https://aka.ms/Ofhn4c for more information.

FalaSpeech

O player de comunicação remota do Holographic dá suporte a uma sobreposição de diagnóstico que pode ser habilitada dizendo Enable Diagnostics e desabilitada dizendo Disable Diagnostics .The Holographic Remoting Player supports a diagnostics overlay which can be enabled by saying Enable Diagnostics and disabled by saying Disable Diagnostics. Se você tiver problemas com esses comandos de voz, também poderá iniciar o player de comunicação remota do Holographic por meio de um navegador da Web usando ms-holographic-remoting:?stats como uma URL.If you have trouble with these voice commands you can also launch the Holographic Remoting player via a web browser using ms-holographic-remoting:?stats as an URL.

Codec de vídeo H265 não disponívelH265 video codec not available

Você precisa instalar as extensões de vídeo do HEVC ao usar o codec de vídeo do H265 em seu aplicativo remoto.You need to install the HEVC Video Extensions when using H265 video codec in your remote app. Se você encontrar problemas em que o codec está instalado, mas não pode ser usado, consulte o guia de solução de problemas .If you run into issues where the codec is installed but can't be used, check out troubleshooting guide.

LimitaçõesLimitations

Atualmente, não há suporte para as seguintes APIs ao usar a comunicação remota do Holographic para o HoloLens 2 e gerará um ERROR_NOT_SUPPORTED erro, salvo indicação em contrário:The following APIs are currently not supported when using Holographic Remoting for HoloLens 2 and will raises an ERROR_NOT_SUPPORTED error unless otherwise stated:

Windows.Graphics.HolographicWindows.Graphics.Holographic

Windows.Perception.SpatialWindows.Perception.Spatial

Windows.UI.Input.SpatialWindows.UI.Input.Spatial

Windows.Perception.Spatial.PreviewWindows.Perception.Spatial.Preview

Consulte TambémSee Also