2. Como inicializar o seu projeto e implantar o primeiro aplicativo2. Initializing your project and deploying your first application

Visão geralOverview

Neste tutorial, você aprenderá a criar um projeto do Unity, configurá-lo para o desenvolvimento do MRTK (Kit de Ferramentas de Realidade Misturada) e importar o MRTK.In this tutorial, you'll learn how to create a new Unity project, configure it for Mixed Reality Toolkit (MRTK) development, and import MRTK. Você também aprenderá sobre a configuração, a criação e a implantação da cena de amostra do Unity básica do Visual Studio para o seu próprio HoloLens 2 ou emulador.You'll also walk through configuring, building, and deploying the basic Unity sample scene from Visual Studio to your HoloLens 2 or emulator.

ObjetivosObjectives

  • Saiba como configurar o Unity para o desenvolvimento no HoloLensLearn how to configure Unity for HoloLens development
  • Saiba como criar e implantar o seu aplicativo no HoloLensLearn how to build and deploy your app to HoloLens
  • Experimente a malha de mapeamento espacial, as malhas de mão e o contador da taxa de quadrosExperience the spatial mapping mesh, hand meshes, and the framerate counter

Como criar o projeto do UnityCreating the Unity project

Inicie o Hub do Unity, selecione a guia Projetos e clique na seta para baixo ao lado do botão Novo:Launch Unity Hub, select the Projects tab, and click the down arrow next to the New button:

mr-learning-base

Na lista suspensa, selecione a versão do Unity especificada em Pré-requisitos:In the dropdown, select the Unity version specified in the Prerequisites:

mr-learning-base

Dica

Se a versão específica do Unity não estiver disponível no Hub do Unity, você poderá iniciar a instalação em Arquivos de Download do Unity.If the particular Unity version is not available in Unity Hub, you can initiate the installation from Unity's Download Archive.

Na janela Criar um novo projeto:In the Create a new project window:

  • Verifique se Modelos está definido como 3DEnsure Templates is set to 3D
  • Insira um Nome de Projeto adequado, por exemplo, Tutoriais do MRTKEnter a suitable Project Name, for example, MRTK Tutorials
  • Escolha um Local adequado para armazenar seu projeto, por exemplo, D:\MixedRealityLearningChoose a suitable Location to store your project, for example, D:\MixedRealityLearning
  • Clique no botão Criar para criar e iniciar o novo projeto do UnityClick the Create button to create and launch your new Unity project

mr-learning-base

Cuidado

Ao trabalhar no Windows, há um limite de MAX_PATH de 255 caracteres.When working on Windows, there is a MAX_PATH limit of 255 characters. Consequentemente, você deve salvar o projeto do Unity próximo à raiz da unidade.Consequently, you should save the Unity project close to the root of the drive.

Aguarde até que o Unity crie o projeto:Wait for Unity to create the project:

mr-learning-base

Como alternar a plataforma de buildSwitching the build platform

No menu do Unity, selecione Arquivo > Configurações de Build... para abrir a janela Configurações de Build:In the Unity menu, select File > Build Settings... to open the Build Settings window:

mr-learning-base

Na janela Configurações de Build, selecione Plataforma Universal do Windows e clique no botão Mudar Plataforma:In the Build Settings window, select Universal Windows Platform and click the Switch Platform button:

mr-learning-base

Aguarde até que o Unity termine de mudar a plataforma:Wait for Unity to finish switching the platform:

mr-learning-base

Quando o Unity terminar de mudar a plataforma, clique no ícone vermelho x para fechar a janela Configurações de Build:When Unity has finished switching the platform, click the red x icon to close the Build Settings window:

mr-learning-base

Como importar os Recursos Essenciais do TextMeshProImporting the TextMeshPro Essential Resources

No menu do Unity, selecione Janela > TextMeshPro > Importar Recursos Essenciais do TMP para abrir a janela Importar Pacote do Unity:In the Unity menu, select Window > TextMeshPro > Import TMP Essential Resources to open the Import Unity Package window:

mr-learning-base

Na janela Importar Pacote do Unity, clique no botão Todos para garantir que todos os ativos sejam selecionados e clique no botão Importar para importar os ativos:In the Import Unity Package window, click the All button to ensure all the assets are selected, then click the Import button to import the assets:

mr-learning-base

Dica

Os Recursos Essenciais do TextMeshPro são exigidos pelos elementos da interface do usuário do MRTK.The TextMeshPro Essential Resources are required by MRTK's UI elements. Você poderá ignorar esta etapa se não estiver planejando usar os elementos da interface do usuário do MRTK no seu projeto.You can skip this step if you are not planning to use MRTK's UI elements in your project.

Como importar o Kit de Ferramentas de Realidade MisturadaImporting the Mixed Reality Toolkit

Baixe o pacote personalizado do Unity:Download the Unity custom package:

No menu do Unity, selecione Ativos > Importar Pacote > Pacote Personalizado... para abrir a janela Importar pacote...:In the Unity menu, select Assets > Import Package > Custom Package... to open the Import package... window:

mr-learning-base

Na janela Importar pacote..., selecione o Microsoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackage que você baixou e clique no botão Abrir:In the Import package... window, select the Microsoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackage you downloaded and click the Open button:

mr-learning-base

Na janela Importar Pacote do Unity, clique no botão Todos para garantir que todos os ativos sejam selecionados e clique no botão Importar para importar os ativos:In the Import Unity Package window, click the All button to ensure all the assets are selected, then click the Import button to import the assets:

mr-learning-base

Como configurar o projeto do UnityConfiguring the Unity project

1. Aplicar as configurações do Configurador de Projeto do MRTK1. Apply the MRTK Project Configurator settings

Depois que o Unity terminar de importar o pacote da seção anterior, a janela Configurador de Projeto do MRTK deverá aparecer.After Unity has finished importing the package from the previous section, the MRTK Project Configurator window should appear. Se ela não aparecer, abra a janela do Configurador acessando o menu do Unity e selecionando Kit de Ferramentas de Realidade Misturada > Utilitários > Configurar o Projeto do Unity:If it doesn't, open the Configurator window by going to the Unity menu and selecting Mixed Reality Toolkit > Utilities > Configure Unity Project:

mr-learning-base

Na janela Configurador de Projeto do MRTK, expanda a seção Modificar Configurações, verifique se todas as opções estão marcadas e clique no botão Aplicar para aplicar as configurações:In the MRTK Project Configurator window, expand the Modify Configurations section, ensure all options are checked, and click the Apply button to apply the settings:

mr-learning-base

2. Definir configurações adicionais do projeto2. Configure additional project settings

No menu do Unity, selecione Editar > Configurações de Projeto... para abrir a janela Configurações de Projeto:In the Unity menu, select Edit > Project Settings... to open the Project Settings window:

mr-learning-base

Na janela Configurações do Projeto, selecione Player > Configurações de XR, clique no ícone + e selecione Windows Mixed Reality para adicionar o SDK do Windows Mixed Reality:In the Project Settings window, select Player > XR Settings, click the + icon, and select Windows Mixed Reality to add the Windows Mixed Reality SDK:

mr-learning-base

Depois que o Unity terminar de importar o SDK do Windows Mixed Reality, a janela Configurador de Projeto do MRTK deverá aparecer novamente.After Unity has finished importing the Windows Mixed Reality SDK, the MRTK Project Configurator window should appear again. Se ela não aparecer, use o menu do Unity para abri-la.If it doesn't, use the Unity menu to open it.

Na janela Configurador de Projeto do MRTK, use a lista suspensa Espacializador de áudio para selecionar o Espacializador MS HRTF e clique no botão Aplicar para aplicar a configuração:In the MRTK Project Configurator window, use the Audio spatializer dropdown to select the MS HRTF Spatializer, then click the Apply button to apply the setting:

mr-learning-base

Na janela Configurações do Projeto, selecione Player > Configurações de XR e, em seguida, use a lista suspensa Formato de Profundidade para selecionar a Profundidade de 16 bits:In the Project Settings window, select Player > XR Settings, then use the Depth Format dropdown to select 16-bit depth:

mr-learning-base

Na janela Configurações do Projeto, selecione Player > Configurações de Publicação e, em seguida, no campo Nome do pacote, insira um nome adequado, por exemplo, MRTKTutorials-GettingStarted:In the Project Settings window, select Player > Publishing Settings, then in the Package name field, enter a suitable name, for example, MRTKTutorials-GettingStarted:

mr-learning-base

Observação

O 'Nome do pacote' é o identificador exclusivo do aplicativo.The 'Package name' is the unique identifier for the app. Você deve alterar esse identificador antes de implantar o aplicativo para evitar a substituição de aplicativos instalados anteriormente.You should change this identifier before deploying the app to avoid overwriting previously installed apps.

Dica

O 'Nome do Produto' é o nome exibido no menu Iniciar do HoloLens.The 'Product Name' is the name displayed in the HoloLens Start menu. Para facilitar a localização do aplicativo durante o desenvolvimento, adicione um sublinhado na frente do nome para que ele seja classificado para o topo.To make the app easier to locate during development, add an underscore in front of the name to sort it to the top.

Como criar e configurar a cenaCreating and configuring the scene

No menu do Unity, selecione Arquivo > Nova Cena para criar uma cena:In the Unity menu, select File > New Scene to create a new scene:

mr-learning-base

No menu do Unity, selecione Kit de Ferramentas de Realidade Misturada > Adicionar à Cena e Configurar... para adicionar o MRTK à cena atual:In the Unity menu, select Mixed Reality Toolkit > Add to Scene and Configure... to add the MRTK to your current scene:

mr-learning-base

Com o objeto MixedRealityToolkit selecionado na janela Hierarquia, na janela Inspetor, verifique se o perfil de configuração MixedRealityToolkit está definido como DefaultMixedRealityToolkitConfigurationProfile:With the MixedRealityToolkit object still selected in the Hierarchy window, in the Inspector window, verify that the MixedRealityToolkit configuration profile is set to DefaultMixedRealityToolkitConfigurationProfile:

mr-learning-base

Importante

Normalmente, você usará o DefaultHoloLens2ConfigurationProfile ao desenvolver para o HoloLens.Typically, you will use the DefaultHoloLens2ConfigurationProfile when developing for HoloLens. No entanto, neste tutorial, você usará o DefaultMixedRealityToolkitConfigurationProfile. Depois, no próximo tutorial, Como configurar os perfis do MRTK, altere para o DefaultHoloLens2ConfigurationProfile.However, for this tutorial, you will use the DefaultMixedRealityToolkitConfigurationProfile, then in the next tutorial, Configuring the MRTK profiles, you will change to the DefaultHoloLens2ConfigurationProfile.

No menu do Unity, selecione Arquivo > Salvar Como... para abrir a janela Salvar Cena:In the Unity menu, select File > Save As... to open the Save Scene window:

mr-learning-base

Na janela Salvar cena, navegue até a pasta Cenas do seu projeto, dê um nome adequado à sua cena (por exemplo, Introdução) e clique no botão Salvar para salvar a cena:In the Save Scene window, navigate to your project's Scenes folder, give your scene a suitable name, for example, GettingStarted, and click the Save button to save the scene:

mr-learning-base

Como criar o aplicativo para o seu HoloLens 2Building your application to your HoloLens 2

1. Compilar o projeto do Unity1. Build the Unity project

No menu do Unity, selecione Arquivo > Configurações de Build... para abrir a janela Configurações de Build.In the Unity menu, select File > Build Settings... to open the Build Settings window.

Na janela Configurações de Build, clique no botão Adicionar Cenas Abertas para adicionar sua cena atual à lista Cenas no Build e clique no botão Build para abrir a janela Compilar Plataforma Universal do Windows:In the Build Settings window, click the Add Open Scenes button to add your current scene to the Scenes In Build list, then click the Build button to open the Build Universal Windows Platform window:

mr-learning-base

Na janela Compilar Plataforma Universal do Windows, escolha um local adequado para armazenar seu build, por exemplo, D:\MixedRealityLearning\Builds, crie uma nova pasta e dê a ela um nome adequado, por exemplo, GettingStarted e, em seguida, clique no botão Selecionar Pasta para iniciar o processo de build:In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, D:\MixedRealityLearning\Builds, create a new folder and give it a suitable name, for example, GettingStarted, and then click the Select Folder button to start the build process:

mr-learning-base

Aguarde até que o Unity conclua o processo de build:Wait for Unity to finish the build process:

mr-learning-base

2. Compilar e implantar o aplicativo2. Build and deploy the application

Quando o processo de build for concluído, o Unity solicitará que o Explorador de Arquivos do Windows abra a localização em que você armazenou o build.When the build process has completed, Unity will prompt Windows File Explorer to open the location you stored the build. Navegue dentro da pasta e clique duas vezes no arquivo da solução para abri-lo no Visual Studio:Navigate inside the folder, and double-click the solution file to open it in Visual Studio:

mr-learning-base

Observação

Se o Visual Studio solicitar a instalação de novos componentes, reserve um momento para assegurar-se de que você tenha todos os componentes de pré-requisitos na documentação Instalar as Ferramentas .If Visual Studio asks you to install new components, take a moment to check that you have all the prerequisite components in the Install the Tools documentation.

Configure o Visual Studio para o HoloLens selecionando a configuração Mestre ou Versão, a arquitetura ARM64 e o Dispositivo como destino:Configure Visual Studio for HoloLens by selecting the Master or Release configuration, the ARM64 architecture, and Device as target:

mr-learning-base

Dica

Se você estiver implantando no HoloLens (1ª geração), selecione a arquitetura x86.If you're deploying to HoloLens (1st generation), select the x86 architecture.

Observação

Para o HoloLens, você normalmente criará para a arquitetura ARM.For HoloLens, you will typically build for the ARM architecture. No entanto, há um problema conhecido no Unity 2019.3 que causa erros ao selecionar o ARM como a arquitetura de build no Visual Studio.However, there is a known issue in Unity 2019.3 that causes errors when selecting ARM as the build architecture in Visual Studio. A solução alternativa recomendada é criar para o ARM64.The recommended workaround is to build for ARM64. Se essa não for uma opção, acesse Editar > Configurações de Projeto > Player > Outras Configurações e desabilite Trabalhos Gráficos.If that is not an option, go to Edit > Project Settings > Player > Other Settings and disable Graphics Jobs.

Observação

Se o Dispositivo não for exibido como uma opção de destino, talvez seja necessário alterar o projeto de inicialização para a solução do Visual Studio do projeto IL2CPP para o projeto UWP.If you don't see Device as a target option, you may need to change the startup project for the Visual Studio solution from the IL2CPP project to the UWP project. Para fazer isso, no Gerenciador de Soluções, clique com o botão direito do mouse no NomeDoSeuProjeto (Universal do Windows) e selecione Definir como Projeto de Inicialização.To do this, in the Solution Explorer, right-click on YourProjectName (Universal Windows) and select Set as StartUp Project.

Conecte o seu HoloLens ao seu computador e, em seguida, selecione Depurar > Iniciar sem Depuração para criar e implantar no seu dispositivo:Connect your HoloLens to your computer, then select Debug > Start Without Debugging to build and deploy to your device:

mr-learning-base

Importante

Antes de compilar no dispositivo, ele precisa estar no Modo de Desenvolvedor e emparelhado com o computador de desenvolvimento.Before building to your device, the device must be in Developer Mode and paired with your development computer. Essas duas etapas podem ser concluídas seguindo estas instruções.Both of these steps can be completed by following these instructions.

Dica

Você também pode implantar no Emulador do HoloLens ou criar um Pacote do Aplicativo para sideload.You can also deploy to the HoloLens Emulator or create an App Package for sideloading.

O uso de Iniciar sem Depuração inicia automaticamente o aplicativo no seu dispositivo sem o depurador do Visual Studio anexado.Using Start Without Debugging automatically starts the app on your device without the Visual Studio debugger attached.

Selecione Criar > Implantar Solução para implantar no seu dispositivo sem iniciar o aplicativo automaticamente.Select Build > Deploy Solution to deploy to your device without having the app start automatically.

Observação

Observe o criador de perfil de Diagnóstico no aplicativo, você pode ativar ou desativar a sua visibilidade usando o comando de fala Alternar Diagnóstico.You may notice the Diagnostics profiler in the app, which you can toggle on or off by using the speech command Toggle Diagnostics. É recomendável que você mantenha o criador de perfil visível na maior parte do tempo durante o desenvolvimento para entender quando as alterações no aplicativo podem afetar o desempenho.It's recommended that you keep the profiler visible most of the time during development to understand when changes to the app may impact performance. Por exemplo, os aplicativos do HoloLens devem ser executados continuamente em 60 FPS.For example, HoloLens apps should continuously run at 60 FPS.

ParabénsCongratulations

Você acabou de implantar o seu primeiro aplicativo do HoloLens.You've now deployed your first HoloLens app. Enquanto caminha, você deverá ver uma malha de mapeamento espacial cobrindo todas as superfícies detectadas pelo HoloLens.As you walk around, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. Além disso, você verá indicadores em suas mãos e dedos para o acompanhamento de mão e um contador da taxa de quadros para monitorar o desempenho do aplicativo.Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance. Esses recursos são apenas alguns dos componentes fundamentais incluídos no MRTK.These features are just a few foundational pieces included with MRTK. Nos próximos tutoriais, você adicionará o conteúdo à sua cena para explorar as funcionalidades do HoloLens e do MRTK.In the upcoming tutorials, you'll add content to your scene to explore the capabilities of HoloLens and the MRTK.

Próximo tutorial: 3. Como configurar os perfis do MRTKNext Tutorial: 3. Configuring the MRTK profiles