Bibliotecas necessárias

Uma lista de arquivos .lib necessários para compilar vários aplicativos TAPI 3, a partir de 22/1/01:

  • Advapi32.lib
  • Amstrmid.lib (GUIDs ActiveMovie)
  • Kernel32.lib
  • Mdhcpid.lib (GUIDs multicast)
  • Ole32.lib (COM)
  • Oleaut32.lib (Automação COM)
  • Rendid.lib (GUIDs de encontro)
  • Rpcndr.lib
  • Rpcns4.lib
  • Rpcrt4.lib
  • Sdpblbid.lib (GUIDs do Protocolo de Descritor de Sessão (SDP)
  • Strmiids.lib
  • User32.lib
  • Uuid.lib
  • Wldap32.lib
  • Ws2_32.lib

Se você estiver usando Microsoft Visual Studio, talvez seja necessário atualizar sua versão. Em particular, Link.exe deve ter uma data de 19/03/98 ou posterior.

As definições do compilador devem incluir _WIN32_WINNT definido como pelo menos 0x500 e _WIN32_DCOM.