Configure BFD sobre ExpressRouteConfigure BFD over ExpressRoute

O ExpressRoute suporta a Deteção bidirecional de encaminhamento (BFD) tanto sobre o espreício privado como para a Microsoft.ExpressRoute supports Bidirectional Forwarding Detection (BFD) both over private and Microsoft peering. Quando ativa o BFD em vez do ExpressRoute, pode acelerar a deteção de falhas de ligação entre os dispositivos microsoft Enterprise edge (MSEE) e os routers que o seu circuito ExpressRoute fica configurado (CE/PE).When you enable BFD over ExpressRoute, you can speed up the link failure detection between Microsoft Enterprise edge (MSEE) devices and the routers that your ExpressRoute circuit gets configured (CE/PE). Pode configurar o ExpressRoute sobre os seus dispositivos de encaminhamento de arestas ou os seus dispositivos de encaminhamento Partner Edge (se for com o serviço de ligação da Camada 3 gerido).You can configure ExpressRoute over your edge routing devices or your Partner Edge routing devices (if you went with managed Layer 3 connection service). Este documento acompanha-o através da necessidade de BFD, e como ativar o BFD em vez do ExpressRoute.This document walks you through the need for BFD, and how to enable BFD over ExpressRoute.

Necessidade de BFDNeed for BFD

O seguinte diagrama mostra o benefício de permitir o BFD sobre o circuito ExpressRoute: 1The following diagram shows the benefit of enabling BFD over ExpressRoute circuit: 1

Pode ativar o circuito ExpressRoute através das ligações da Camada 2 ou das ligações geridas da Camada 3.You can enable ExpressRoute circuit either by Layer 2 connections or managed Layer 3 connections. Em ambos os casos, se houver mais de um dispositivo Layer-2 na rota de ligação ExpressRoute, a responsabilidade de detetar quaisquer falhas de ligação no caminho reside na sessão de BGP sobressaída.In both cases, if there are more than one Layer-2 devices in the ExpressRoute connection path, the responsibility of detecting any link failures in the path lies with the overlying BGP session.

Nos dispositivos MSEE, o BGP mantém-se vivo e o tempo de espera são tipicamente configurados como 60 e 180 segundos, respectivamente.On the MSEE devices, BGP keep-alive and hold-time are typically configured as 60 and 180 seconds respectively. Por esta razão, quando uma falha de ligação acontece, pode levar até três minutos para detetar qualquer falha de ligação e mudar o tráfego para a ligação alternativa.For that reason when a link failure happens it can take up to three minutes to detect any link failure and switch traffic to alternate connection.

Pode controlar os temporizadores BGP configurando um BGP inferior mantendo-se vivo e tempo de espera no seu dispositivo de observação de borda.You can control the BGP timers by configuring a lower BGP keep-alive and hold-time on your edge peering device. Se os temporizadores BGP não forem os mesmos entre os dois dispositivos de observação, a sessão de BGP estabelecerá utilizando o valor de tempo mais baixo.If the BGP timers aren't the same between the two peering devices, the BGP session will establish using the lower time value. A continuação do BGP pode ser definida até três segundos e o tempo de espera até 10 segundos.The BGP keep-alive can be set as low as three seconds, and the hold-time as low as 10 seconds. No entanto, a definição de um temporizador BGP muito agressivo não é recomendada porque o protocolo é intensivo em processos.However, setting a very aggressive BGP timer is not recommended because the protocol is process intensive.

Neste cenário, o BFD pode ajudar.In this scenario, BFD can help. O BFD fornece uma deteção de falha de ligação de baixa sobrecarga num intervalo de tempo de subsegundo.BFD provides low-overhead link failure detection in a subsecond time interval.

Habilitação BFDEnabling BFD

O BFD é configurado por padrão em todas as interfaces de observação privadas ExpressRoute recentemente criadas nos MSEEs.BFD is configured by default under all the newly created ExpressRoute private peering interfaces on the MSEEs. Como tal, para ativar o BFD, basta configurar o BFD nos seus dispositivos primários e secundários.As such, to enable BFD, you only need to configure BFD on both your primary and secondary devices. Configurar o BFD é um processo em duas etapas.Configuring BFD is two-step process. Configura o BFD na interface e, em seguida, ligue-o à sessão de BGP.You configure the BFD on the interface and then link it to the BGP session.

Uma configuração CE/PE (utilizando Cisco IOS XE) é mostrada abaixo.An example CE/PE (using Cisco IOS XE) configuration is shown below.

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Nota

Para permitir o BFD sob um espreitamento privado já existente; é necessário reiniciar o espreitamento.To enable BFD under an already existing private peering; you need to reset the peering. Ver reset ExpressRouteSee Reset ExpressRoute peerings

Negociação do Temporizador BFDBFD Timer Negotiation

Entre os pares do BFD, o mais lento dos dois pares determina a taxa de transmissão.Between BFD peers, the slower of the two peers determine the transmission rate. Os intervalos de transmissão/receção MSEEs BFD são definidos em 300 milissegundos.MSEEs BFD transmission/receive intervals are set to 300 milliseconds. Em certos cenários, o intervalo pode ser definido com um valor mais elevado de 750 milissegundos.In certain scenarios, the interval may be set at a higher value of 750 milliseconds. Ao configurar um valor mais elevado, pode forçar estes intervalos a serem mais longos, mas não é possível torná-los mais curtos.By configuring a higher value, you can force these intervals to be longer but it's not possible to make them shorter.

Nota

Se tiver circuitos ExpressRoute Geo redundantes configurados ou utilizar a conectividade IPSec VPN local como cópia de segurança.If you have configured Geo-redundant ExpressRoute circuits or use Site-to-Site IPSec VPN connectivity as backup. Permitir o BFD ajudaria a falhar mais rapidamente após uma falha de conectividade ExpressRoute.Enabling BFD would help failover quicker following an ExpressRoute connectivity failure.

Passos SeguintesNext Steps

Para mais informações ou ajuda, confira os seguintes links:For more information or help, check out the following links: