Installing the AIPService PowerShell module (Instalar o módulo AIPService no PowerShell)Installing the AIPService PowerShell module

Aplica-se a: proteção de informações do Azure, Office 365Applies to: Azure Information Protection, Office 365

Use as informações a seguir para ajudá-lo a instalar o módulo do Windows PowerShell para o serviço de proteção da proteção de informações do Azure.Use the following information to help you install the Windows PowerShell module for the protection service from Azure Information Protection. O nome desse módulo é AIPService e substitui a versão anterior que foi denominada AADRM.The name of this module is AIPService, and it replaces the previous version that was named AADRM.

Você pode usar este módulo do PowerShell para administrar o serviço de proteção (Azure Rights Management) na linha de comando usando qualquer computador Windows que tenha uma conexão com a Internet e que atenda aos pré-requisitos listados na próxima seção.You can use this PowerShell module to administer the protection service (Azure Rights Management) from the command line by using any Windows computer that has an internet connection and that meets the prerequisites listed in the next section. O Windows PowerShell para proteção de informações do Azure dá suporte a scripts para automação ou pode ser necessário para cenários de configuração avançada.Windows PowerShell for Azure Information Protection supports scripting for automation or might be necessary for advanced configuration scenarios. Para obter mais informações sobre as tarefas e configurações de administração às quais o módulo dá suporte, consulte administrando a proteção da proteção de informações do Azure usando o PowerShell.For more information about the administration tasks and configurations that the module supports, see Administering protection from Azure Information Protection by using PowerShell.

Pré-requisitosPrerequisites

Esta tabela lista os pré-requisitos para instalar e usar o módulo AIPService do PowerShell para o serviço de proteção da proteção de informações do Azure.This table lists the prerequisites to install and use the AIPService PowerShell module for the protection service from Azure Information Protection.

RequisitoRequirement Mais informaçõesMore information
Versão mínima do Windows PowerShell: 3,0Minimum version of Windows PowerShell: 3.0 Você pode confirmar a versão do Windows PowerShell que está executando digitando $PSVersionTable em uma sessão do PowerShell.You can confirm the version of Windows PowerShell that you are running by typing $PSVersionTable in a PowerShell session.

Se precisar de instalar uma versão mais recente do Windows PowerShell, veja Atualizar o Windows PowerShell existente.If you need to install a later version of Windows PowerShell, see Upgrading existing Windows PowerShell.
Versão mínima do Microsoft .NET Framework: 4.5Minimum version of the Microsoft .NET Framework: 4.5

Observação: essa versão do Microsoft .NET Framework está incluída nos sistemas operacionais posteriores, portanto, você precisará instalá-lo manualmente somente se o sistema operacional do cliente for menor do que o Windows 8,0 ou o sistema operacional do servidor for menor do que o Windows Server 2012.Note: This version of the Microsoft .NET Framework is included with the later operating systems, so you should need to manually install it only if your client operating system is less than Windows 8.0 or your server operating system is less than Windows Server 2012.
Se a versão mínima do Microsoft .NET Framework não estiver já instalada, pode transferir o Microsoft .NET Framework 4.5.If the minimum version of the Microsoft .NET Framework is not already installed, you can download Microsoft .NET Framework 4.5.

Essa versão mínima do Microsoft .NET Framework é necessária para algumas das classes que o módulo AIPService usa.This minimum version of the Microsoft .NET Framework is required for some of the classes that the AIPService module uses.

Se você tiver o módulo AADRM instaladoIf you have the AADRM module installed

O módulo AIPService substitui o módulo mais antigo, AADRM.The AIPService module replaces the older module, AADRM. Se você tiver o módulo mais antigo instalado, desinstale-o e, em seguida, instale o módulo AIPService.If you have the older module installed, uninstall it and then install the AIPService module.

O módulo mais recente tem aliases para os nomes de cmdlet no módulo mais antigo, para que todos os scripts existentes continuem a funcionar.The newer module has aliases to the cmdlet names in the older module so that any existing scripts will continue to work. No entanto, planeje atualizar essas referências antes de o módulo antigo ficar sem suporte.However, plan to update these references before the old module falls out of support. O suporte para o módulo AADRM será encerrado em 15 de julho de 2020.Support for the AADRM module will end July 15, 2020.

Se você instalou o módulo AADRM do Galeria do PowerShell, para desinstalá-lo, inicie uma sessão do PowerShell com a opção Executar como administrador e digite:If you installed the AADRM module from the PowerShell Gallery, to uninstall it, start a PowerShell session with the Run as Administrator option, and type:

Uninstall-Module -Name AADRM

Se você instalou o módulo AADRM com a ferramenta de administração de Rights Management do Azure, use programas e recursos para desinstalar o Windows Azure ad Rights Management Administration.If you installed the AADRM module with the Azure Rights Management Administration Tool, use Programs and Features to uninstall Windows Azure AD Rights Management Administration.

Como instalar o módulo AIPServiceHow to install the AIPService module

O módulo AIPService está na Galeria do PowerShell e não está disponível no centro de download da Microsoft.The AIPService module is on the PowerShell Gallery and is not available from the Microsoft Download Center.

Se você for novo no Galeria do PowerShell, consulte introdução ao Galeria do PowerShell.If you're new to the PowerShell Gallery, see Get Started with the PowerShell Gallery. Siga as instruções para os requisitos da galeria, que incluem a instalação do módulo PowerShellGet e o provedor do NuGet.Follow the instructions for the gallery requirements, which include installing the PowerShellGet module and the NuGet provider.

Para ver detalhes sobre o módulo AIPService no Galeria do PowerShell, visite a página AIPService.To see details about the AIPService module on the PowerShell Gallery, visit the AIPService page.

Para instalar o módulo AIPService, inicie uma sessão do PowerShell com a opção Executar como administrador e digite:To install the AIPService module, start a PowerShell session with the Run as Administrator option, and type:

Install-Module -Name AIPService

Se você for avisado sobre a instalação de um repositório não confiável, poderá pressionar Y para confirmar.If you are warned about installing from an untrusted repository, you can press Y to confirm. Ou então, pressione N e configure o Galeria do PowerShell como um repositório confiável usando o comando Set-PSRepository -Name PSGallery -InstallationPolicy Trusted e execute novamente o comando para instalar o módulo AIPService.Or, press N and configure the PowerShell Gallery as a trusted repository by using the command Set-PSRepository -Name PSGallery -InstallationPolicy Trusted and then rerun the command to install the AIPService module.

Se você tiver uma versão anterior do módulo AIPService instalada da galeria, atualize-a para o mais recente digitando:If you have a previous version of the AIPService module installed from the Gallery, update it to the latest by typing:

Update-Module -Name AIPService

Próximos passosNext steps

Em uma sessão do Windows PowerShell, confirme a versão do módulo instalado.In a Windows PowerShell session, confirm the version of the installed module. Esta verificação é particularmente importante se tiver atualizado de uma versão mais antiga:This check is particularly important if you upgraded from an older version:

(Get-Module AIPService –ListAvailable).Version

Observação: se esse comando falhar, primeiro execute Import-Module AIPService.Note: If this command fails, first run Import-Module AIPService.

Para ver os cmdlets disponíveis, escreva o seguinte:To see which cmdlets are available, type the following:

Get-Command -Module AIPService

Utilize o comando Get-Help <cmdlet_name> para ver a Ajuda de um cmdlet específico e utilize o parâmetro -online para ver a ajuda mais recente no site de documentação da Microsoft.Use the Get-Help <cmdlet_name> command to see the Help for a specific cmdlet, and use the -online parameter to see the latest help on the Microsoft documentation site. Por exemplo:For example:

Get-Help Connect-AipService -online

Para obter mais informações:For more information:

Antes de executar qualquer comando que configure o serviço de proteção, você deve se conectar ao serviço usando o cmdlet Connect-AipService .Before you can run any commands that configure the protection service, you must connect to the service by using the Connect-AipService cmdlet.

Quando você terminar de executar seus comandos de configuração, como uma prática recomendada, desconecte-se do serviço usando o cmdlet Disconnect-AipService .When you have finished running your configuration commands, as a best practice, disconnect from the service by using the Disconnect-AipService cmdlet. Se não desligar, a ligação é automaticamente desligada após um período de inatividade.If you do not disconnect, the connection is automatically disconnected after a period of inactivity. Devido ao comportamento de desativação automático, pode ter de voltar a ligar ocasionalmente numa sessão do PowerShell.Because of the automatic disconnection behavior, you might find that you need to occasionally reconnect in a PowerShell session.

Nota

Se o serviço de proteção ainda não estiver ativado, você poderá fazer isso depois de se conectar ao serviço, usando o cmdlet Enable-AipService .If the protection service is not yet activated, you can do this after you have connected to the service, by using the Enable-AipService cmdlet.