Instalar o .NET Framework no Windows 10 e no Windows Server 2016 e posterior

O .NET Framework é necessário para executar muitos aplicativos no Windows. As instruções neste artigo devem ajudá-lo a instalar as versões do .NET Framework que você precisa. O .NET Framework 4.8 é a versão mais recente disponível.

Você pode ter chegado nesta página depois de tentar executar um aplicativo e ver uma caixa de diálogo em seu computador semelhante à seguinte:

This application could not be started

.NET Framework 4.8

.NET Framework 4.8 está incluído com:

O .NET Framework 4.8 pode ser usado para executar aplicativos criados para as versões 4.0 a 4.7.2 do .NET Framework.

Instale o .NET Framework 4.8 na:

  • Atualização de outubro de 2018 para Windows 10 (Versão 1809)
  • Atualização de abril de 2018 para o Windows 10 (versão 1803)
  • Windows 10 Fall Creators Update (versão 1709)
  • No Windows 10 Creators Update (versão 1703)
  • Na Atualização de Aniversário do Windows 10 (versão 1607)
  • Windows Server 2019
  • Windows Server, versão 1809
  • Windows Server, versão 1803
  • Windows Server 2016

O .NET Framework 4.8 não é compatível com:

  • Windows 10 1507
  • Com o Windows 10 1511

Se estiver usando o Windows 10 1507 ou 1511 e quiser instalar o .NET Framework 4.8, primeiro, você precisará atualizar para uma versão posterior do Windows 10.

.NET Framework 4.6.2

O .NET Framework 4.6.2 é a versão mais recente do .NET Framework compatível com o Windows 10 1507 e o 1511.

O .NET Framework 4.6.2 é compatível com aplicativos compilados para as versões 4.0 até 4.6.2 do .NET Framework.

.NET Framework 3.5

Siga as instruções para instalar o .NET Framework 3.5 no Windows 10.

O .NET Framework 3.5 é compatível com aplicativos compilados para as versões 1.0 até 3.5 do .NET Framework.

Informações adicionais

As versões 4.x do .NET Framework são atualizações in-loco de versões anteriores. Isso significa o seguinte:

  • Você pode ter somente uma versão do .NET Framework 4. x instalada em seu computador.

  • Você não poderá instalar uma versão anterior do .NET Framework em seu computador se uma versão mais recente já tiver sido instalada.

  • As versões 4.x do .NET Framework podem ser usadas para executar aplicativos compilados para o .NET Framework 4.0 por meio dessa versão. Por exemplo, .NET Framework 4.7 pode ser usado para executar aplicativos compilados para as versões 4.0 até 4.7 do .NET Framework. A versão mais recente (.NET Framework 4.8) pode ser usada para executar aplicativos compilados para todas as versões do .NET Framework da 4.0 em diante.

Para obter uma lista de todas as versões do .NET Framework disponíveis para download, consulte a página Downloads do .NET.

Ajuda

Se não for possível instalar a versão correta do .NET Framework, entre em contato com a Microsoft para obter ajuda.

Confira também