"A candidatura não pode ser iniciada. Contacte o fornecedor de aplicações" quando executar a configuração do Ambiente de Trabalho office 365

Nota

O Office 365 ProPlus está a ser renomeado para Aplicações do Microsoft 365 para empresas. Para obter mais informações sobre essa alteração, leia este post no blog.

Problema

Quando tenta executar uma aplicação ClickOnce do Microsoft Office 365, como a Configuração do Ambiente de Trabalho do Office 365 ou a Ferramenta de Preparação para o Ambiente de Trabalho office 365, recebe a seguinte mensagem de erro:

A candidatura não pode ser iniciada. Contacte o vendedor de aplicações.

Uma imagem de ecrã da caixa de diálogo de aplicação não pode iniciar, mostrando a mensagem de erro

Ao clicar em Detalhes, recebe uma mensagem de erro detalhada que se assemelha ao seguinte:

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of https://<NameOfDomain>/ClickOnceConnector/Office365DesktopSetup.application resulted in exception. Following failure messages were detected:
+ Unable to install this application because an application with the same identity is already installed. To install this application, either modify the manifest version for this application or uninstall the preexisting application.

Causa

Este problema ocorre se a aplicação foi cached na cache de aplicação ClickOnce. A aplicação deve ser removida da cache antes de poder executá-la com sucesso.

Solução

Para limpar a cache de aplicação ClickOnce, siga estes passos:

  1. Clique em Iniciar, clique em Executar, digite cmd e, em seguida, clique em OK.
  2. Digite o seguinte comando e, em seguida, pressione Enter: rundll32 dfshim CleanOnlineAppCache

Para verificar se o problema está resolvido, siga estes passos:

Mais informações

Para obter mais informações, consulte clickOnce Unmanaged API Reference.

Ainda necessita de ajuda? Vá ao https://go.microsoft.com/fwlink/?linkid=2003907 site.