Corrigir problemas de autenticação em aplicações do Office ao tentar ligar-se a um serviço Microsoft 365

Sintomas

A autenticação falha automaticamente em algumas aplicações do Microsoft Office e o Outlook pode entrar no estado "Precisa de Palavra-passe" sem qualquer interação. Além disso, quando efetua uma chamada à API do Gestor de Conta Web para FindAllAccountsAsync, poderá ver o código de erro "-2147024809" nos registos de Microsoft Entra ou nos registos do Cliente do Office.

Importante

Este problema ocorre apenas em computadores que executam o Windows 10, versão 1703 ou posterior e a versão 1807 ou posterior do Microsoft 365.

Causa

O problema de autenticação ocorre devido a informações do pacote em falta sobre a Biblioteca de Autenticação do Active Directory (ADAL) ou o Live ID.

Resolução

Sugestão

Para diagnosticar e corrigir automaticamente vários problemas comuns de início de sessão do Office, pode transferir e executar Suporte da Microsoft e o Assistente de Recuperação.

Para corrigir este problema, utilize o PowerShell para reinstalar os pacotes para Microsoft Entra plug-in WAM (para contas organizacionais ou profissionais) e Live ID (para contas pessoais, como @outlook.com, @hotmail.come assim sucessivamente). Para tal, siga estes passos:

  1. Clique com o botão direito do rato no ícone do Windows na barra de tarefas e, em seguida, selecione Windows PowerShell (Administração).

  2. Se for solicitado por uma janela de Controlo de Conta de Utilizador (UAC), selecione Sim para iniciar o PowerShell.

  3. Se o problema tiver a ver com uma conta profissional, terá de corrigir o Microsoft Entra pacote de plug-in WAM. Execute o seguinte comando na consola de comando:

    if (-not (Get-AppxPackage Microsoft.AAD.BrokerPlugin)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.AAD.BrokerPlugin
    
  4. Se o seu problema é uma conta pessoal, tem de corrigir o pacote do Live ID. Execute o seguinte comando na consola de comando:

    if (-not (Get-AppxPackage Microsoft.Windows.CloudExperienceHost)) { Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown } Get-AppxPackage Microsoft.Windows.CloudExperienceHost
    

Depois de executar os comandos e, se estes concluíram sem erros, poderá ver um indicador de progresso rápido ou um resultado de estado que contém informações sobre a instalação do pacote.