"Um utilizador com este nome já existe. Use um nome diferente. erro no portal do Office 365

Nota

O Office 365 ProPlus está a ser renomeado para Aplicações do Microsoft 365 para empresas. Para obter mais informações sobre essa alteração, leia este post no blog.

Problema

No Microsoft Office 365, recebe uma mensagem de erro que é como a seguinte no portal Microsoft Office 365:

Um utilizador com este nome já existe. Use um nome diferente.

Causa

Este problema pode ocorrer se o nome de utilizador já estiver utilizado ou se já existir um endereço de e-mail existente baseado no nome de utilizador.

A tentativa de licenciamento falhará se o processo de provisionamento determinar que outro objeto já tem um nome de utilizador ou um endereço de e-mail que corresponda ao nome de utilizador que está a ser criado.

Por predefinição, quando os utilizadores são adicionados ou atribuídos uma licença Exchange Online, os utilizadores recebem um endereço SMTP primário que se baseia no seu nome de utilizador. E, os utilizadores são fornecidos com um endereço de e-mail baseado no Domínio de Encaminhamento Direto (MODRD) da Microsoft Online, como, por exemplo, contoso.onmicrosoft.com. Além disso, quando um nome de utilizador é alterado, o endereço SMTP primário também pode ser alterado. No entanto, os endereços alternativos não são atualizados ou removidos.

Aqui estão alguns cenários de exemplo.

Cenário 1

É adicionado um utilizador que tem um nome de utilizador de john@contoso.com , o MODRD para a organização é contoso.onmicrosoft.com, e o utilizador é atribuído a uma Licença Exchange Online. Neste cenário, são fornecidos os seguintes endereços de e-mail:

  • O utilizador é fornecido com um endereço SMTP primário que é john@contoso.com .
  • O utilizador é fornecido com um endereço de e-mail alternativo que é john@contoso.onmicrosoft.com .

Cenário 2

É adicionado um utilizador que tem um nome de utilizador de john@contoso.onmicrosoft.com , o MODRD para a organização é contoso.onmicrosoft.com, e o utilizador é atribuído a uma Licença Exchange Online. Neste cenário, é fornecido o seguinte endereço de e-mail:

  • O utilizador é fornecido com um endereço SMTP primário que é john@contoso.onmicrosoft.com .

Cenário 3

Um nome de utilizador é alterado de john@contoso.com johnsmith@contoso.com . Neste cenário, ocorrem os seguintes acontecimentos:

  • O endereço SMTP primário, john@contoso.com pode ser alterado para johnsmith@contoso.com .
  • O endereço de e-mail john@contoso.com alternativo, não é alterado. Portanto, ocorrem problemas se tentar adicionar john@contoso.com mais tarde.
  • Não é criado nenhum endereço de e-mail johnsmith@contoso.onmicrosoft.com alternativo.

Solução

Para resolver este problema, faça uma ou mais das seguintes seguintes questões:

  • Quando adicionar um utilizador, utilize um nome de utilizador diferente.
  • Quando adicionar um utilizador, encontre e altere o nome de utilizador existente para que possa utilizar o nome de utilizador com o qual está a passar pelo problema.
  • Quando adicionar ou atribuir um utilizador a uma licença Exchange Online, encontre e altere os endereços de e-mail existentes que são baseados no nome de utilizador que está a tentar utilizar.

Para verificar se já existe um endereço de e-mail, siga estes passos:

  1. Ligue ao Exchange Online através do PowerShell remoto. Para obter mais informações sobre como fazê-lo, aceda ao seguinte website da Microsoft:

    Conecte-se a trocar online usando o Remote PowerShell

  2. Executar o seguinte cmdlet:

    get-mailbox| where {$_.EmailAddresses -match "user name"} | ft Name, RecipientType, EmailAddresses
    

    Nota

    "Nome de utilizador" é o nome de utilizador com o qual está a experimentar o problema.

  3. Com base nos resultados que recebe depois de executar o cmdlet, atualizar ou eliminar o endereço de e-mail existente.

Ainda necessita de ajuda? Vá para Comunidade Microsoft