Resolver erros de pesquisa na Deteção de Dados Eletrónicos (Standard)

Se encontrar um problema ou erro relacionado com pesquisas no Deteção de Dados Eletrónicos do Microsoft Purview (Standard), repita a operação para excluir problemas transitórios. Para problemas que persistem, selecione a descrição aplicável na lista seguinte:

Se nenhuma destas resoluções se aplicar ao problema de pesquisa, contacte Suporte da Microsoft. Consoante o problema, recolha a saída com o cmdlet Get-ComplianceSearch ou Get-ComplianceSearchAction do PowerShell antes de criar um pedido de suporte. Para obter informações sobre outras informações de diagnóstico que Suporte da Microsoft possam precisar, veja Recolher informações de diagnóstico de Deteção de Dados Eletrónicos.

Para problemas de retenção da Deteção de Dados Eletrónicos, veja Resolver erros de retenção na Deteção de Dados Eletrónicos (Standard).

Problema de pesquisa: diferença entre os resultados de pesquisa estimados e transferidos

Sintomas

Quando vê as estatísticas dos resultados da pesquisa no carimbo de data/>hora Resumo <da Exportação.csv ficheiro na pasta de resultados da pesquisa de Deteção de Dados Eletrónicos transferida, repara que as estatísticas de resultados de pesquisa estimadas e transferidas diferem. As estatísticas de resultados de pesquisa estimadas também são apresentadas no painel de detalhes da pesquisa no Portal de Conformidade do Microsoft Purview e na ferramenta de exportação de Deteção de Dados Eletrónicos.

Causa

Uma estimativa dos resultados da pesquisa é apenas isso: é uma estimativa e não uma contagem real de itens que cumprem os critérios da consulta de pesquisa. Para obter mais informações sobre o motivo pelo qual os resultados de pesquisa estimados e transferidos podem ser diferentes, veja Diferenças entre os resultados de pesquisa de Deteção de Dados Eletrónicos estimados e reais.

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Erro de pesquisa: "A localização é ambígua"

Sintomas

Quando executa uma pesquisa de Deteção de Dados Eletrónicos, a pesquisa falha e devolve a seguinte mensagem de erro:

A pesquisa de conformidade contém as seguintes localizações inválidas: <identificador> de caixa de correio. O identificador> da caixa de correio de localização <é ambíguo.

Causa

As localizações especificadas na mensagem de erro são inválidas. O identificador da caixa de correio para cada localização inválida é utilizado por objetos duplicados ou em conflito no Proteção do Exchange Online (EOP).

Resolução

Para cada localização inválida, siga estes passos:

  1. Ligue-se ao PowerShell de Conformidade & de Segurança.

  2. Localize os objetos duplicados ou em conflito que utilizam um identificador de caixa de correio. Para tal, execute o seguinte comando Get-Recipient :

    Get-Recipient -Identity "<mailbox identifier from error message>"
    
  3. Remova o objeto duplicado ou em conflito.

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Erro de pesquisa: "Destinatário não encontrado"

Sintomas

A pesquisa de Deteção de Dados Eletrónicos falha e devolve a mensagem de erro "Destinatário não encontrado".

Causa

O sistema não consegue encontrar um dos destinatários na pesquisa de Deteção de Dados Eletrónicos devido a atrasos de sincronização no Proteção do Exchange Online (EOP).

Resolução

  1. Ligue-se ao PowerShell de Conformidade & de Segurança.

  2. Verifique se os destinatários na consulta de pesquisa estão sincronizados na EOP com o cmdlet Get-Recipient . Execute o seguinte comando:

    Get-Recipient -Identity "<user identifier>" | FL
    
  3. Se o comando não devolver um objeto de utilizador para um destinatário, aguarde 30 minutos para que a sincronização seja concluída e, em seguida, volte a verificar.

  4. Depois de verificar se o destinatário foi sincronizado na EOP, repita a pesquisa.

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Erro de pesquisa: CS007

Sintomas

A pesquisa de Deteção de Dados Eletrónicos falha e devolve um código de CS007 erro.

Causa

Qualquer um dos seguintes problemas pode causar este erro:

  • Um problema transitório

  • Uma consulta de pesquisa que devolve demasiados resultados para o sistema processar. Por exemplo, uma consulta que utiliza vários carateres universais pode devolver um conjunto de resultados grande.

Resolução

Repita a pesquisa. Se a pesquisa continuar a falhar, divida a pesquisa em pesquisas mais pequenas. Por exemplo, utilize intervalos de datas ou limite o número de localizações de pesquisa para devolver conjuntos de resultados mais pequenos.

Erro de pesquisa: "Ocorreu um erro interno do servidor (500)"

Sintomas

A pesquisa de Deteção de Dados Eletrónicos falha e devolve a mensagem de erro "Ocorreu um erro interno do servidor (500)".

Causa

Os problemas que podem causar este erro incluem:

  • Uma consulta de pesquisa que devolve demasiados resultados para o sistema processar. Por exemplo, uma consulta que utiliza vários carateres universais pode devolver um conjunto de resultados grande.

  • Outros erros de pesquisa. Para verificar esses erros, execute o seguinte comando para obter informações sobre a pesquisa e, em seguida, procure mensagens de erro na saída:

    Get-ComplianceSearch -Identity <search name> | FL ResultDetails
    

Resolução

Repita a pesquisa. Se a pesquisa continuar a falhar, divida a pesquisa em pesquisas mais pequenas. Por exemplo, utilize intervalos de datas ou limite o número de localizações de pesquisa para devolver conjuntos de resultados mais pequenos.

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Erro de pesquisa ou exportação: "Número máximo de tarefas para a sua organização em execução"

Sintomas

Quando tenta procurar ou exportar os resultados da pesquisa de Deteção de Dados Eletrónicos, a operação falha e recebe a seguinte mensagem de erro:

Não é possível iniciar o pedido porque o número máximo de tarefas para a sua organização está atualmente em execução.

Causa

A sua organização atingiu o limite máximo de 50 tarefas simultâneas. Uma vez que normalmente as tarefas de exportação demoram mais tempo a concluir do que as tarefas de pesquisa, é mais provável que as tarefas de exportação preencham a quota.

Resolução

Utilize o procedimento seguinte para ver que tarefas de exportação estão atualmente em execução:

Nota

Para utilizar o procedimento seguinte, tem de ser membro do grupo de funções Gestor de Deteção de Dados Eletrónicos e ser um administrador de Deteção de Dados Eletrónicos nesse grupo. Para obter mais informações sobre como ver ou atribuir Administradores de Deteção de Dados Eletrónicos na sua organização, consulte Atribuir permissões de Deteção de Dados Eletrónicos, Get-eDiscoveryCaseAdmin e Add-eDiscoveryCaseAdmin.

  1. Ligue-se ao PowerShell de Conformidade & de Segurança.

  2. Execute o seguinte script:

    $date = Get-Date
    $exports = @(Get-ComplianceSearchAction -Export -ResultSize Unlimited)
    $cases = Get-ComplianceCase | ?{$_.status -like "Active"}
    $i = 1
    foreach ($case in $cases) {
      $exports += Get-ComplianceSearchAction -Export -Case $case.Name
      Write-Host "Processing case $($i) of $($cases.Count)"
      $i++
    }
    $inProgressExports = $exports | ?{$_.Results -eq $null -or (!$_.Results.Contains("Export status: Completed") -and !$_.Results.Contains("Export status: none"))}
    $inProgressExportsSince = $inProgressExports | ?{$_.JobStartTime -ge $date.AddDays(-7)} | Sort-Object JobStartTime -Descending
    Write-Host "In-progress export jobs:"
    $inProgressExports | Format-Table Name,JobStartTime,JobEndTime,Status | More
    Write-Host "In-progress export jobs started in the last 7 days:"
    $inProgressExportsSince | Format-Table Name,JobStartTime,JobEndTime,Status | More
    

Para resolver o erro, utilize o seguinte procedimento:

  1. Reduza o número de tarefas em execução. Utilize uma ou ambas as seguintes abordagens:

    • Aguarde até que uma ou mais tarefas em execução sejam concluídas.

    • Remova uma ou mais tarefas em execução que já não necessite com o cmdlet Remove-ComplianceSearchAction do PowerShell.

  2. Repita a operação de pesquisa ou exportação.

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Problema de exportação: a exportação parece estar parada

Sintomas

Tenta exportar os resultados da pesquisa de Deteção de Dados Eletrónicos, mas a exportação não é concluída e parece estar parada.

Causa

Os problemas transitórios podem atrasar o processo de exportação.

Resolução

Reinicie a exportação.

Nota

Não pode reiniciar uma exportação dos resultados da pesquisa que foram gerados mais de sete dias antes. Em vez disso, volte a executar a pesquisa e, em seguida, inicie a exportação.

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Erro de exportação: "O item foi movido ou eliminado" ou "Não é possível obter o item devido ao tempo limite"

Sintomas

Depois de transferir os resultados da pesquisa de Deteção de Dados Eletrónicos, verá os seguintes erros no ficheiro Exportar Avisos e Errors.csv na pasta de exportação transferida:

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: A exportação falhou com o tipo de erro: "FailedToExportItem". Mensagem: O item foi movido ou eliminado.

  • FailedToExportItem_Microsoft.Exchange.EDiscovery.Export.ExportException: A exportação falhou com o tipo de erro: "FailedToExportItem". Mensagem: Não é possível obter o item devido ao tempo limite excedido após várias tentativas.

Causa

Estas mensagens de erro "FailedToExportItem" indicam que o sistema não exportou todos os itens de resultados da pesquisa. Os itens não suportados são cópias de segurança temporárias que o sistema criou durante o arquivo da caixa de correio. Embora a Deteção de Dados Eletrónicos possa procurar itens de cópia de segurança temporários, estes itens não são exportáveis.

Resolução

Aguarde que o sistema obtenha e exporte os itens da caixa de correio original que estão associados às cópias de segurança temporárias.

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Erro de exportação: "O pedido falhou com o código de estado 500" ou "Erro interno do servidor 500"

Sintomas

Quando tenta exportar ou transferir os resultados da pesquisa de Deteção de Dados Eletrónicos, recebe uma das seguintes mensagens de erro:

  • O pedido falhou com o código de estado 500

  • Erro de servidor interno 500

Causa

O problema pode ocorrer por qualquer um dos seguintes motivos.

Causa 1

Não tem a função Exportar. A função Exportar é automaticamente atribuída aos membros do grupo de funções Gestor de Deteção de Dados Eletrónicos. A função Exportar não é atribuída automaticamente aos membros do grupo de funções Gestão da Organização.

Causa 2

O erro ocorre quando tenta transferir os resultados de pesquisa exportados se não for o administrador que exportou os resultados da pesquisa.

Causa 3

Os filtros de permissões da sua conta de utilizador restringem as caixas de correio, as localizações de armazenamento ou o conteúdo que pode procurar e exportar.

Causa 4

A quantidade de dados exportáveis para a sua pesquisa excede 2 TB. A quantidade máxima de dados exportáveis para uma única pesquisa é de 2 TB. Para determinar o tamanho dos dados exportáveis, execute o seguinte comando:

Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics

Resolução

Escolha a resolução que corresponde à causa aplicável.

Resolução 1

Se for membro do grupo de funções Gestão da Organização, adicione-se ao grupo de funções Gestor de Deteção de Dados Eletrónicos. Pode fazê-lo na página Permissões no Portal de Conformidade do Microsoft Purview ou através do cmdlet Add-eDiscoveryCaseAdmin do PowerShell.

Resolução 2

Peça ao administrador que criou a exportação para concluir a transferência. Para localizar esse administrador, execute o seguinte comando:

Get-ComplianceSearchAction -Export -Case <case name> | FL Name,CreatedBy

Resolução 3

Para as caixas de correio e localizações de armazenamento que pretende procurar e exportar, verifique se os filtros de permissões impedem essas ações. Se necessário, peça a um administrador para configurar filtros de permissões.

Resolução 4

Reduza o tamanho da transferência ao dividir a pesquisa em pesquisas mais pequenas. Por exemplo, utilize intervalos de datas ou limite o número de localizações de pesquisa para devolver conjuntos de resultados mais pequenos.

Para verificar se as funções de Pesquisa, Exportação ou Pré-visualização estão atribuídas à conta de administrador designada, execute o seguinte teste no centro de administração do Microsoft 365. Tem de ter permissões de administrador Global ou de Conformidade para utilizar os seguintes passos.

Nota

Este diagnóstico não está disponível para os ambientes GCC High ou DoD ou para o Microsoft 365 operado pela 21Vianet.

  1. Na centro de administração do Microsoft 365, selecione o botão de verificação Executar Testes: RBAC de Deteção de Dados Eletrónicos para preencher o teste associado:

  2. Na secção Executar diagnóstico, introduza o UPN ou o endereço de e-mail do utilizador que está a tentar executar a tarefa Procurar, Exportar ou Pré-visualizar.

  3. Selecione Executar Testes.

  4. Se o utilizador não tiver as funções de Deteção de Dados Eletrónicos necessárias atribuídas, atribua-as para que o utilizador possa executar a tarefa pretendida.

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Erro de exportação: "O ficheiro não foi exportado porque não existe" ou "Ficheiro não encontrado"

Sintomas

Depois de transferir os resultados da pesquisa de Deteção de Dados Eletrónicos, verá uma das seguintes mensagens de erro na pasta Exportar Avisos e Errors.csv, Ignorado Items.csvou trace.log ficheiros na pasta de exportação transferida:

  • Este ficheiro já não foi exportado porque já não existe. O ficheiro foi incluído na contagem de resultados estimados da pesquisa porque ainda está listado no índice. O ficheiro será eventualmente removido do índice e não causará um erro no futuro.

  • FailedToExportItem_Failed para transferir conteúdo. Informações de diagnóstico adicionais: Microsoft.Office.Compliance.EDiscovery.ExportWorker.Exceptions.ContentDownloadTemporaryFailure: Falha ao transferir a partir do ID> do documento de conteúdo <do tipo Documento. ID de Correlação: <ID de> correlação. ServerErrorCode: -2147024894 ---> Microsoft.SharePoint.Client.ServerException: Ficheiro Não Encontrado. em Microsoft.SharePoint.Client.ClientRequest.ProcessResponseStream(Stream responseStream) em Microsoft.SharePoint.Client.ClientRequest.ProcessResponse() --- Fim do rastreio da pilha de exceções interna ---

Causa

Poderá ver esta mensagem de erro se a pesquisa de Deteção de Dados Eletrónicos incluir localizações Microsoft Office SharePoint Online ou Microsoft OneDrive para Empresas. A Deteção de Dados Eletrónicos baseia-se no índice do SharePoint Online para identificar ficheiros em ambas as localizações. O erro ocorre se um utilizador mudar o nome, mover ou eliminar um ficheiro nos resultados da pesquisa após a conclusão da pesquisa, mas antes de o sistema atualizar o índice do SharePoint Online. Pode verificar se o nome de um ficheiro foi mudado, movido ou eliminado ao procurar o ficheiro na localização do SharePoint Online ou OneDrive para Empresas aplicável.

Resolução

Para resolver o problema, reindexe a localização do SharePoint Online ou OneDrive para Empresas através de um dos procedimentos fornecidos em Pedido manual de pesquisa e reindexação de um site, biblioteca ou lista. Se quiser que os resultados da pesquisa incluam os ficheiros mudados ou movidos, execute novamente a pesquisa de Deteção de Dados Eletrónicos.

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Problema de transferência da exportação: transferência lenta dos resultados da pesquisa exportada

Sintomas

Quando transfere os resultados da pesquisa de Deteção de Dados Eletrónicos, a transferência demora mais tempo do que o esperado.

Causa

Os problemas que podem causar uma transferência lenta incluem:

  • Uma grande quantidade de dados de exportação. Para determinar o tamanho da transferência, execute o seguinte comando:

    Get-ComplianceSearch -Identity <search name> | FL Size,SuccessResults,SearchStatistics
    
  • Uma carga superior ao habitual nos servidores da caixa de correio.

  • Outros erros de transferência. Para verificar a existência desses erros:

    • Execute o seguinte comando para obter informações sobre uma exportação em curso. Procure mensagens de erro na saída do comando.

      Get-ComplianceSearchAction | FL Results
      
    • Procure mensagens de erro no ficheiro trace.log na pasta de exportação transferida.

Resolução

Para reduzir o tamanho da transferência, divida a pesquisa em pesquisas mais pequenas. Por exemplo, utilize intervalos de datas ou limite o número de localizações de pesquisa para devolver conjuntos de resultados mais pequenos.

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Problema de transferência da exportação: a ferramenta de exportação de Deteção de Dados Eletrónicos não transfere ficheiros

Sintomas

Executa a ferramenta de exportação de Deteção de Dados Eletrónicos para transferir os resultados da pesquisa de Deteção de Dados Eletrónicos. No entanto, após a conclusão da operação, o campo Total Estimado na janela da ferramenta mostra que não foram transferidos ficheiros.

Causa

O problema pode ocorrer por qualquer um dos seguintes motivos:

  • O software antivírus no computador de destino bloqueia a transferência.

  • Selecione uma unidade de transferência que não seja uma unidade local.

  • Selecione uma pasta de destino que seja:

    • A pasta de transferência de outra exportação de Deteção de Dados Eletrónicos.

    • A pasta principal da pasta de transferência de outra exportação de Deteção de Dados Eletrónicos. Uma vez que a ferramenta de exportação guarda ficheiros de metadados na pasta principal, os ficheiros de metadados para transferências diferentes podem entrar em conflito entre si.

Resolução

Experimente cada um dos seguintes métodos pela ordem indicada até que o problema seja resolvido:

  1. Coloque o scanner antivírus em pausa no computador de destino e, em seguida, repita a transferência.

  2. Transfira para uma unidade local. Se necessário, transfira para um computador cliente diferente.

  3. Selecione uma pasta de destino que não entre em conflito com nenhuma exportação simultânea de Deteção de Dados Eletrónicos.

  4. Desative a exportação para uma pasta comprimida e desative a eliminação de duplicados de conteúdos do Exchange. Se este passo resolver o problema, é provável que o software antivírus esteja a bloquear a transferência ou que tenha tentado transferir para uma unidade remota.

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Erro de transferência da exportação: "O resultado da pesquisa não foi transferido porque é uma pasta"

Sintomas

Depois de transferir os resultados da pesquisa de Deteção de Dados Eletrónicos, verá a seguinte mensagem de erro no ficheiro Items.csvIgnorado na pasta de exportação transferida:

Este resultado de pesquisa não foi transferido porque é uma pasta ou outro artefacto que não pode ser transferido por si só, quaisquer itens dentro da pasta ou biblioteca serão transferidos.

Causa

Poderá ver esta mensagem de erro se a pesquisa incluir Microsoft Office SharePoint Online ou Microsoft OneDrive para Empresas localizações. O ficheiro Items.csvIgnorado lista todas as pastas e outros itens ignorados nos resultados da pesquisa. Normalmente, a mensagem de erro é apresentada junto aos caminhos das pastas porque não são itens transferíveis.

Resolução

Não é necessária nenhuma resolução. Pode ignorar com segurança a mensagem de erro.

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Erro ao exportar transferência: "Não é possível aceder ao ficheiro 'ExportData.db'"

Sintomas

Executa a ferramenta de exportação de Deteção de Dados Eletrónicos para transferir os resultados da pesquisa de Deteção de Dados Eletrónicos, mas a transferência fica bloqueada ou produz ficheiros de byte zero. Verá a seguinte mensagem de erro no ficheiro trace.log na pasta de exportação transferida:

Ocorre um erro tolerável e tentará novamente: o processo não consegue aceder ao ficheiro "ExportData.db" porque está a ser utilizado por outro processo.

Causa

O problema pode ocorrer se:

  • O software antivírus no computador de destino bloqueia a transferência.

  • Selecione uma unidade de transferência que não seja uma unidade local.

  • Selecione uma pasta de destino que seja:

    • A pasta de transferência de outra exportação de Deteção de Dados Eletrónicos.

    • A pasta principal da pasta de transferência de outra exportação de Deteção de Dados Eletrónicos. Uma vez que a ferramenta de exportação guarda ficheiros de metadados na pasta principal, os ficheiros de metadados para transferências diferentes podem entrar em conflito.

Resolução

Experimente cada um dos seguintes métodos pela ordem indicada até que o erro seja resolvido:

  1. Coloque o scanner antivírus em pausa no computador de destino e, em seguida, repita a transferência.

  2. Transfira para uma unidade local. Se necessário, transfira para um computador cliente diferente.

  3. Selecione uma pasta de destino que não entre em conflito com nenhuma exportação simultânea de Deteção de Dados Eletrónicos.

  4. Desative a exportação para uma pasta comprimida e desative a eliminação de duplicados de conteúdos do Exchange. Se este passo resolver o problema, é provável que o software antivírus esteja a bloquear a transferência ou que tenha tentado transferir para uma unidade remota.

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