"Não podemos iniciar esta app..." erro de instalação de um add-in do Office

Nota

O Office 365 ProPlus está a ser renomeado para Aplicações do Microsoft 365 para empresas. Para obter mais informações sobre essa alteração, leia este post no blog.

Sintomas

Quando tenta instalar um Add-in de Office a partir da Loja de Escritórios, recebe o seguinte erro:

Não podemos iniciar esta aplicação porque não está configurada corretamente. Este erro é mostrado na imagem seguinte.

caixa de diálogo de mensagem de erro

Causa

Este problema ocorre devido a informações incorretas no registo do Windows.

Resolução

Aviso

Podem ocorrer problemas graves se modificar o registo incorretamente utilizando o Editor de Registo ou utilizando outro método. Estes problemas podem exigir que reinstale o sistema operativo. A Microsoft não pode garantir que estes problemas possam ser resolvidos. Modifique o registo por sua conta e risco.

Para resolver este problema, siga estes passos.

  1. Saia de qualquer programa de escritório aberto.

  2. Inicie o Editor de Registo. Para isso, prima a tecla Windows+R para abrir a janela Executar, digite o regedit na caixa Aberta e, em seguida, prima OK.

  3. No Editor de Registo, localize e clique na seguinte subchave:

    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\WEF\Providers

    Nota

    Substitua x.0 pela sua versão de Office (16.0 = Office 365, Office 2019, Office 2016, e 15.0 = Office 2013).

  4. Selecione a primeira subchave em \Providers (por exemplo,\KpwDSnL9jumf9ZJTx_XF_Q===).

  5. Examine o valor dos dados para o valor UniqueID. Procura qualquer um dos seguintes valores:

    • guia_ADAL

    • Anónimo

    Nota

    O _ADAL orientador é um conjunto aleatório de números e letras (por exemplo, 3a975b5d-ad3e-4e3d-84b0-a7e6776ba6a6).

  6. Se o valor de dados do UniqueID for guid_ADAL ou Anónimo, elimine a subchave-mãe do UniqueID.

    Por exemplo, se uniqueID = 3a975b5d-ad3e-4e3d-84b0-a7e6776ba6a6_ADAL sob a subchave \KpwDSnL9jumf9ZJTx_XF_Q=== então eliminaria a subchave \KpwDSnL9jumf9ZJTx_XF_Q====

  7. Repita os passos 4-6 para cada subchave sob a tecla \Fornecedores.

  8. Saia do Editor de Registo.

  9. No Windows Explorer, elimine a pasta \Wef no seguinte caminho:

    C:\users\username\AppData\Local\Microsoft\Office\x.0\Wef

    Nota

    o nome de utilizador é o seu nome de utilizador e x.0 é a sua versão Office.

    Se não conseguir localizar manualmente a pasta acima, prima a tecla Windows+R para abrir a janela Executar, digite o comando abaixo para a sua versão do Office na caixa Aberta e, em seguida, prima OK:

    • Escritório 365, Escritório 2019 e Escritório 2016

      %localappdata%\microsoft\office\16.0\WEF

    • Escritório 2013

      %localappdata%\microsoft\office\15.0\WEF