"Desculpe, mas estamos tendo problemas em contratá-lo" erro ao assinar no Escritório 365

Nota

O Office 365 ProPlus está a ser renomeado para Aplicações do Microsoft 365 para empresas. Para obter mais informações sobre essa alteração, leia este post no blog.

Sintomas

Quando tenta entrar no portal do Office 365, recebe a seguinte mensagem de erro:

Lamentamos, mas estamos a ter problemas com o seu início de sessão.

Além disso, também pode ver a seguinte mensagem de erro:

AADSTS7000112: A aplicação '0000002-0000-0ff1-ce000-000000000000000000000'(Office 365 Exchange Online) está desativada.

Causa

Esta questão ocorre se o Diretor de Serviço para a aplicação Exchange Online for desativado para o arrendatário.

Resolução

Antes de seguir estes passos, certifique-se de que os seguintes pré-requisitos são cumpridos:

  • Instale o Módulo de Diretório Ativo Azure para o Windows PowerShell. Para mais informações, aceda ao Connect to Office 365 PowerShell.
  • Os passos são realizados por um administrador global do Office 365.

Para resolver esta questão, siga estes passos:

  1. Verifique o estado atual do titular de serviço para a aplicação Exchange Online. Para isso, executar o seguinte cmdlet:

    (Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000).accountenabled
    
  2. Ativar o Principal de Serviço para Troca Online executando o seguinte cmdlet:

    Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000 | Set-MsolServicePrincipal -AccountEnabled $true