Erro "Pedimos desculpa, mas estamos a ter problemas ao iniciar sessão" ao iniciar sessão no Microsoft 365

Sintomas

Ao tentar iniciar sessão no portal Microsoft 365, recebe a seguinte mensagem de erro:

Lamentamos, mas estamos a ter problemas com o seu início de sessão.

Além disso, também poderá ver a seguinte mensagem de erro:

AADSTS7000112: a aplicação "00000002-0000-0ff1-ce00-000000000000"(Office 365 Exchange Online) está desativada.

Causa

Este problema ocorre se o Principal de Serviço do Exchange Online aplicação estiver desativado para o inquilino.

Resolução

Antes de seguir estes passos, certifique-se de que são cumpridos os seguintes pré-requisitos:

  • Instale o módulo do Azure Active Directory para Windows PowerShell. Para obter mais informações, aceda a Ligar ao Microsoft 365 PowerShell.
  • Os passos são realizados por um administrador global do Microsoft 365.

Para resolver este problema, siga estes passos:

  1. Verifique o estado atual do Principal de Serviço da aplicação Exchange Online. Para tal, execute o seguinte cmdlet:

    (Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000).accountenabled
    
  2. Ative o Principal de Serviço para Exchange Online ao executar o seguinte cmdlet:

    Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000 | Set-MsolServicePrincipal -AccountEnabled $true
    

Nota

Azure AD e os módulos do PowerShell do MSOnline são preteridos a partir de 30 de março de 2024. Para saber mais, leia a atualização de preterição. Após esta data, o suporte para estes módulos está limitado à assistência de migração para o SDK do PowerShell do Microsoft Graph e correções de segurança. Os módulos preteridos continuarão a funcionar até 30 de março de 2025.

Recomendamos que migre para o Microsoft Graph PowerShell para interagir com Microsoft Entra ID (anteriormente Azure AD). Para perguntas de migração comuns, veja as FAQ sobre Migração. Nota: As versões 1.0.x do MSOnline podem sofrer interrupções após 30 de junho de 2024.