Não pode ativar ou iniciar sessão depois de atualizar para o Office 2016 para a versão 15.33 do Mac

Nota

O Office 365 ProPlus está a ser renomeado para Aplicações do Microsoft 365 para empresas. Para obter mais informações sobre essa alteração, leia este post no blog.

Sintomas

Quando tenta ativar ou iniciar sessão em qualquer uma das aplicações do Microsoft Office 2016 depois de instalar a atualização versão 15.33, recebe um ecrã de autenticação em branco.   Além disso, pode ver qualquer um dos seguintes sintomas.

Sintoma 1

As seguintes questões ocorrem no registo do Serviço De Registo Supérficado Unificado (ULS): 

  • O servidor redirecionou para um URL não https.
  • Erros ocorrem na autenticação da Biblioteca de Autenticação ativa do Diretório Azure (ADAL).

Para localizar o registo ULS, abra o Finder e navegue para o seguinte caminho:

~/Library/Containers/com.microsoft.<Application>/Data/Library/Caches/Microsoft/uls/com.microsoft.<Application>/logs 

Nota < A aplicação> representa o nome da aplicação que está a resolver.

Sintoma 2

Note que num traço HTTP, a resposta do servidor inclui vários cabeçalhos www-authenticato, tais como os seguintes:

WWW-Authenticate: Negotiate

WWW-Authenticate: NTLM 

Causa

Os sintomas ocorrem pelas seguintes razões correspondentes: 

Causa para o sintoma 1

A partir do Office 2016 para a versão 15.33 do Mac, o tráfego de pontofinal não garantido está bloqueado nos fluxos de autenticação.

Causa para o sintoma 2

A partir do Office 2016 para a versão 15.33 do Mac, o método de autenticação já não seleciona a autenticação NTLM quando vários cabeçalhos www-authenticato estão presentes na resposta. O problema ocorre quando o método de autenticação selecionado não é bem sucedido. 

Resolução

Resolução para o sintoma 1

Configure todos os pontos finais de autenticação para utilizar o protocolo Secure Sockets Layer (SSL).

Resolução para o sintoma 2

Instale a atualização de setembro de 2017 para o Office 2016 para a versão 15.38do Mac .

Mais Informações

Mais informações para o sintoma 1

A resolução aplica-se quando utiliza os Serviços da Federação de Diretórios Ativos da Microsoft ou as soluções da federação não Microsoft.