Não pode ativar ou iniciar sessão depois de atualizar para Office 2016 para Mac versão 15.33

Sintomas

Quando tenta ativar ou iniciar sessão em qualquer uma das aplicações do Microsoft Office 2016 após instalar a atualização da versão 15.33, recebe um ecrã de autenticação em branco.

Além disso, poderá ver qualquer um dos seguintes sintomas.

Sintoma 1

Os seguintes problemas ocorrem no registo uls (Unified Logging Service):

  • O servidor redirecionou para um URL não https.
  • Ocorrem erros na autenticação da Biblioteca de Autenticação do Azure Active Directory (ADAL).

Para localizar o registo ULS, abra o Finder e navegue para o seguinte caminho:

~/Library/Containers/com.microsoft.<Aplicação>/Dados/Biblioteca/Caches/Microsoft/uls/com.microsoft.<Aplicação>/registos

Nota<A aplicação> representa o nome da aplicação que está a resolver.

Sintoma 2

Repare que, num rastreio HTTP, a resposta do servidor inclui vários cabeçalhos de WWW-Authenticate, tais como:

WWW-Authenticate: Negociar

WWW-Authenticate: NTLM

Causa

Os sintomas ocorrem pelos seguintes motivos correspondentes:

Causa para o sintoma 1

A partir do Office 2016 para Mac versão 15.33, o tráfego de ponto final não seguro é bloqueado nos fluxos de autenticação.

Causa para o sintoma 2

A partir do Office 2016 para Mac versão 15.33, o método de autenticação já não seleciona a autenticação NTLM quando estão presentes vários cabeçalhos de WWW-Authenticate na resposta. O problema ocorre quando o método de autenticação selecionado não tem êxito.

Resolução

Resolução do sintoma 1

Configure todos os pontos finais de autenticação para utilizar o protocolo SSL (Secure Sockets Layer).

Resolução para o sintoma 2

Instale a atualização de setembro de 2017 para Office 2016 para Mac versão 15.38.

Mais Informações

Mais informações sobre o sintoma 1

A resolução aplica-se quando utiliza o Microsoft Serviços de Federação do Active Directory (AD FS) ou soluções de federação não Microsoft.