Tutorial: Consumir modelos do Azure Machine Learning no Power BI

Este tutorial explica como pode criar um relatório do Power BI com base num modelo de machine learning. No final deste tutorial, será capaz de:

  • Classificar modelos de machine learning (implementados com o Azure Machine Learning) no Power BI.
  • Ligar a um modelo do Azure Machine Learning no Editor do Power Query.
  • Criar um relatório com uma visualização baseada nesse modelo.
  • Publicar o relatório no serviço Power BI.
  • Configurar uma atualização agendada para o relatório.

Pré-requisitos

Antes de iniciar este tutorial, tem de:

Criar o modelo de dados

Abra o Power BI Desktop e selecione Obter Dados. Na caixa de diálogo Obter Dados, procure Web. Selecione a origem Web > Ligar.

Captura de ecrã a mostrar dados da Web.

Na caixa de diálogo Da Web, copie e cole o seguinte URL na caixa:

https://www4.stat.ncsu.edu/~boos/var.select/diabetes.tab.txt

Captura de ecrã a mostrar o URL da Web.

Selecione OK.

No conteúdo da Web de acesso, selecione Anonymous > Ligação.

Screenshot mostrando acesso anónimo para conteúdo web.

Selecione Transformar dados para abrir a janela Editor do Power Query.

No friso Base do Editor do Power Query, selecione o botão Azure Machine Learning.

Captura de ecrã a mostrar o Editor do Power Query.

Depois de iniciar sessão na conta do Azure com o início de sessão único, verá uma lista dos serviços disponíveis. Selecione o serviço my-sklearn-service que criou no tutorial Preparar e implementar um modelo de machine learning.

O Power Query povoa as colunas automaticamente. Deve lembrar-se de que no nosso esquema do serviço, tínhamos um decorador Python que especificava as entradas. Selecione OK.

Captura de ecrã a mostrar os Modelos do Azure Machine Learning.

A seleção de OK chama o serviço Azure Machine Learning. Aciona um aviso sobre a privacidade dos dados e do ponto final.

Captura de ecrã a mostrar um aviso de privacidade.

Selecione Continuar. No ecrã seguinte, selecione Ignorar as verificações de Níveis de Privacidade neste ficheiro > Guardar.

Após a classificação dos dados, o Power Query cria uma coluna adicional denominada zureML.my-diabetes-model.

Captura de ecrã a mostrar a coluna classificada adicionada.

Os dados são devolvidos pelo serviço na forma de uma lista.

Nota

Se tiver implementado um modelo de estruturador, verá um registo.

Para obter as previsões, selecione a seta de duas cabeças no cabeçalho da coluna AzureML.my-diabetes-diabetes > Expandir para Novas Linhas.

Screenshot mostrando ícone de coluna expandir.

Após a expansão, verá as predições na coluna AzureML.my-diabetes-model.

Captura de ecrã a mostrar a expansão.

Siga os passos seguintes para concluir a limpeza do modelo de dados.

  1. Mude o nome da coluna AzureML.my-diabetes-model para previsto.
  2. Mude o nome da coluna Y para real.
  3. Altere o tipo da coluna real: selecione a coluna e, no friso Transformar, selecione Tipo de Dados > Número Decimal.
  4. Altere o tipo da coluna previsto: selecione essa coluna e, no friso Transformar, selecione Tipo de Dados > Número Decimal.
  5. No friso Base, selecione Fechar e Aplicar.

Criar um relatório com visualizações

Pode agora criar algumas visualizações para mostrar os dados.

  1. No painel Visualizações, selecione um Gráfico de linhas.
  2. Com o elemento visual do gráfico de linhas selecionado:
  3. Arraste o campo IDADE para o Eixo.
  4. Arraste o campo real para Valores.
  5. Arraste o campo previsto para Valores.

Redimensione o gráfico de linhas para preencher a página. O relatório tem agora um único gráfico de linhas com duas linhas, uma para os valores previstos e outra para os valores reais, distribuídos por idade.

Captura de ecrã a mostrar a visualização do relatório.

Publicar o relatório

Pode adicionar mais visualizações, se desejar. Por questões de brevidade, vamos publicar o relatório neste tutorial.

  1. Guarde o relatório.

  2. Selecione Ficheiro > Publicar > Publicar no Power BI.

  3. Inicie sessão no serviço Power BI.

  4. Selecione A Minha Área de Trabalho.

  5. Quando o relatório for publicado com êxito, selecione a ligação Abrir <O_MEU_FICHEIRO_PBIX.pbix> no Power BI. O relatório é aberto no Power BI no browser escolhido.

    Captura de ecrã a mostrar a publicação realizada com êxito.

Permitir a atualização dos conjuntos de dados

Num cenário em que a origem de dados é atualizada com os novos dados a classificar, tem de atualizar as credenciais para que os dados possam ser classificados.

Em A Minha Área de Trabalho do serviço Power BI, na barra de cabeçalho preta, selecione Mais opções (...) > Definições > Definições.

Captura de ecrã a mostrar as definições.

Selecione Conjuntos de dados, expanda Credenciais da origem de dados e selecione Editar Credenciais.

Captura de ecrã a mostrar a atualização das credenciais.

Siga as instruções para azureMLFunctions e Web. Selecione um nível de privacidade. Pode agora definir a Atualização agendada dos dados. Selecione uma Frequência de atualização e o Fuso horário. Também pode selecionar um endereço de e-mail para o qual o Power BI possa enviar as notificações de falha das atualizações.

Captura de ecrã a mostrar o conjunto de dados e a atualização da classificação.

Selecione Aplicar.

Nota

Quando os dados são atualizados, também são enviados para o ponto final do Azure Machine Learning para classificação.

Limpar os recursos

Importante

Pode utilizar os recursos que criou como pré-requisitos para outros tutoriais do Azure Machine Learning e artigos de procedimentos.

Se não planear utilizar os recursos que criou, elimine-os para não incorrer em custos.

  1. No portal do Azure, selecione Grupos de recursos na extremidade esquerda.

  2. Na lista, selecione o grupo de recursos que criou.

  3. Selecione Eliminar grupo de recursos.

    Captura de ecrã a mostrar as seleções para eliminar um grupo de recursos no portal do Azure.

  4. Introduza o nome do grupo de recursos. Em seguida, selecione Eliminar.

  5. Em A Minha Área de Trabalho no serviço Power BI, elimine o relatório e o conjunto de dados relacionado. Não precisa de eliminar o Power BI Desktop nem o relatório no computador. O Power BI Desktop é gratuito.

Passos seguintes

Nesta série de tutoriais, aprendeu a configurar um agendamento no Power BI para que os novos dados possam ser classificados pelo ponto final de classificação no Azure Machine Learning.