Descrição geral de consulta no Power BI DesktopQuery overview in Power BI Desktop

Com o Power BI Desktop, pode ligar-se ao mundo dos dados, criar relatórios apelativos e fundamentais e partilhar os seus trabalhos com outras pessoas, que poderão basear-se no seu trabalho e expandir os seus esforços de business intelligence.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

O Power BI Desktop tem três vistas:Power BI Desktop has three views:

  • Vista de Relatório, onde pode utilizar consultas criadas por si para criar visualizações atraentes, dispostas como pretender, e com múltiplas páginas, que pode partilhar com outras pessoasReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Vista de Dados: veja os dados no seu relatório em formato de modelo de dados, onde pode adicionar medidas, criar novas colunas e gerir relaçõesData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Vista de Relações: obtenha uma representação gráfica das relações que foram estabelecidas no seu modelo de dados e gira ou modifique as mesmas conforme necessário.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Estas vistas são acedidos através da seleção de um dos três ícones no lado esquerdo do Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. Na imagem seguinte, a vista de Relatório está selecionada, indicada pela faixa amarela ao lado do ícone.In the following image, Report view is selected, indicated by the yellow band beside the icon.

O Power BI Desktop também vem com o Editor de Consultas, onde se pode ligar a uma ou várias origens de dados, formatar e transformar os dados em função das suas necessidades e, em seguida, carregar esse modelo para o Power BI Desktop.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Este documento fornece uma descrição geral de como trabalhar com os dados no Editor de Consultas.This document provides an overview of the work with data in the Query Editor. É claro que há mais para aprender e, posto isto, no final deste documento, encontrará ligações para diretrizes detalhadas sobre os tipos de dados suportados, ligação a dados, formatação de dados, criação de relações e como começar.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Mas primeiro, vamos conhecer melhor o Editor de Consultas.But first, let’s see get acquainted with Query Editor.

Editor de ConsultasThe Query Editor

Para ir para o Editor de Consultas, selecione Editar Consultas no separador Base do Power BI Desktop.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Sem ligações de dados, o Editor de Consultas é apresentado como um painel em branco, pronto para receber dados.With no data connections, Query Editor appears as a blank pane, ready for data.

Após uma consulta ser carregada, a vista do Editor de Consultas torna-se mais interessante.Once a query is loaded, Query Editor view becomes more interesting. Se nos ligarmos à seguinte origem de dados, o Editor de Consultas carrega informações sobre os dados, que pode depois começar a formatar.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

https://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Eis o aspeto do Editor de Consultas após uma ligação de dados ser estabelecida:Here’s how Query Editor appears once a data connection is established:

  1. Na faixa de opções, muitos botões estão agora ativos para interagir com os dados na consultaIn the ribbon, many buttons are now active to interact with the data in the query

  2. No painel esquerdo, as consultas são listadas e ficam disponíveis para seleção, visualização e formataçãoIn the left pane, queries are listed and available for selection, viewing, and shaping

  3. No painel central, os dados da consulta selecionada são apresentados e estão disponíveis para formataçãoIn the center pane, data from the selected query is displayed and available for shaping

  4. A janela Definições de Consulta é apresentada, listando as propriedades e passos aplicados da consultaThe Query Settings window appears, listing the query’s properties and applied steps

Examinemos cada uma destas quatro áreas – a faixa de opções, o painel de consultas, a vista de dados e o painel de Configurações de Consulta – nas secções seguintes.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Friso de consultaThe query ribbon

O friso no Editor de Consultas consiste em quadro separadores: Base, Transformar, Adicionar Coluna e Vista.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

O separador Base contém as tarefas de consulta comuns, incluindo o primeiro passo de qualquer consulta, ou seja, Obter Dados.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. A seguinte imagem mostra o friso Base.The following image shows the Home ribbon.

Para se ligar aos dados e dar início ao processo de criação da consulta, selecione o botão Obter Dados.To connect to data and begin the query building process, select the Get Data button. É apresentado um menu, fornecendo as origens de dados mais comuns.A menu appears, providing the most common data sources.

Para obter mais informações sobre as origens de dados disponíveis, consulte Origens de Dados.For more information about available data sources, see Data Sources. Para obter informações sobre como se ligar a dados, incluindo exemplos e passos, consulte Ligar-se a Dados.For information about connecting to data, including examples and steps, see Connect to Data.

O separador Transformar fornece acesso a tarefas comuns de transformação de dados, como adicionar ou remover colunas, alterar os tipos de dados, dividir colunas e outras tarefas baseadas em dados.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. A seguinte imagem mostra o separador Transformar.The following image shows the Transform tab.

Para obter mais informações sobre como transformar dados, incluindo exemplos, consulte Combinar e Formatar Dados.For more information about transforming data, including examples, see Combine and Shape Data.

O separador Adicionar Coluna fornece tarefas adicionais associadas à adição de uma coluna, formatação de dados da coluna e adição de colunas personalizadas.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. A seguinte imagem mostra o separador Adicionar Coluna.The following image shows the Add Column tab.

O separador Ver no friso é utilizado para mostrar ou ocultar determinados painéis ou janelas.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Também é utilizado para apresentar o Editor Avançado.It’s also used to display the Advanced Editor. A seguinte imagem mostra o separador Ver.The following image shows the View tab.

É útil saber que muitas das tarefas disponíveis na faixa de opções também estão disponíveis clicando com o botão direito do rato numa coluna ou noutros dados, no painel central.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Painel à esquerdaThe left pane

O painel esquerdo apresenta o número de consultas ativas, bem como o nome da consulta.The left pane displays the number of active queries, as well as the name of the query. Quando seleciona uma consulta no painel à esquerda, os dados são apresentados no painel central, no qual pode formatar e transformar os dados para atender às suas necessidades.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. A imagem seguinte mostra o painel esquerdo com várias consultas.The following image shows the left pane with multiple queries.

Painel central (dados)The center (data) pane

No painel central ou no painel Dados, são apresentados os dados da consulta selecionada.In the center pane, or Data pane, data from the selected query is displayed. É aqui que muito do trabalho da vista de Consulta é realizado.This is where much of the work of the Query view is accomplished.

Na imagem a seguir, a ligação de dados da Web estabelecida anteriormente é mostrada, a coluna Pontuação geral está selecionada e seu cabeçalho foi clicado com o botão direito do rato para mostrar os itens de menu disponíveis.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Tenha em atenção que muitos destes itens de menu de clique com o botão direito do rato são os mesmos botões nos separadores da faixa de opções.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Quando seleciona um item de menu de clique com o botão direito do rato (ou um botão da faixa de opções), a Consulta aplica o passo aos dados e guarda-a como parte da própria consulta.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Os passos são registados no painel Definições de Consulta por ordem sequencial, conforme descrito na próxima secção.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Painel Definições de ConsultaThe query settings pane

O painel Definições de Consulta é onde são apresentados todos os passos associados a uma consulta.The Query Settings pane is where all steps associated with a query are displayed. Por exemplo, na imagem a seguir, a secção Passos Aplicados do painel Definições de Consulta reflete o facto de que acabámos de alterar o tipo da coluna Pontuação geral.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Conforme os passos de formatação adicionais são aplicados à consulta, são capturados na secção Passos Aplicados.As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

É importante saber que os dados subjacentes não são alterados; em vez disso, o Editor de Consultas ajusta e formata a sua vista dos dados, sendo que qualquer interação com os dados subjacentes ocorre com base na vista moldada e modificada do Editor de Consultas para esses dados.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

No painel Definições de Consulta, pode mudar o nome de passos, eliminar passos ou reordenar os passos conforme julgue mais adequado.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Para o fazer, clique com o botão direito do rato no passo na secção Passos Aplicados e selecione uma opção no menu apresentado.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Todos os passos de consultas são efetuados pela ordem apresentada no painel Passos Aplicados.All query steps are carried out in the order they appear in the Applied Steps pane.

Editor AvançadoThe Advanced Editor

Se pretender ver o código que a Consulta está a criar em cada passo ou criar o seu próprio código de formatação, pode utilizar o Editor Avançado.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Para abrir o editor avançado, selecione Ver no friso e, em seguida, selecione Editor Avançado.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. É apresentada uma janela a mostrar o código da consulta.A window appears, showing the existing query code.

Pode editar diretamente o código na janela Editor Avançado.You can directly edit the code in the Advanced Editor window. Para fechar a janela, selecione o botão Concluído ou Cancelar.To close the window, select the Done or Cancel button.

Guardar o seu trabalhoSaving your work

Quando a consulta está onde pretende, é possível fazer com que o Editor de Consulta aplique as alterações ao modelo de dados no Power BI Desktop e feche o Editor de Consulta.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. Para o fazer, selecione Fechar e Aplicar no menu Ficheiro do Editor de Consultas.To do that, select Close & Apply from Query Editor's File menu.

Conforme registado progresso, o Power BI Desktop fornece um diálogo para apresentar o estado.As progress is made, Power BI Desktop provides a dialog to display its status.

Uma vez que a consulta esteja onde pretende, ou se apenas desejar certificar-se de que o trabalho está guardado, o Power BI Desktop pode guardar o trabalho na forma de um ficheiro .pbix.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Para guardar o seu trabalho, selecione Ficheiro > Guardar (ou Ficheiro > Guardar Como), conforme mostrado na imagem seguinte.To save your work, select File > Save (or File > Save As), as shown in the following image.

Passos seguintesNext steps

Existem inúmeras coisas que pode fazer com o Power BI Desktop.There are all sorts of things you can do with Power BI Desktop. Para obter mais informações sobre as suas capacidades, veja os seguintes recursos:For more information on its capabilities, check out the following resources: