Atualizar o Microsoft Quantum Development kit (QDK)Update the Microsoft Quantum Development Kit (QDK)

Saiba como atualizar o Microsoft Quantum Development kit (QDK) para a versão mais recente.Learn how to update the Microsoft Quantum Development Kit (QDK) to the latest version.

Este artigo pressupõe que já tem o QDK instalado.This article assumes that you already have the QDK installed. Se estiver a instalar pela primeira vez, veja o guia de instalação.If you are installing for the first time, then please refer to the installation guide.

Recomendamos utilizar a última versão do QDK.We recommend keeping up to date with the latest QDK release. Para atualizar para a versão mais recente do QDK, siga este guia de atualização.Follow this update guide to upgrade to the most recent QDK version. O processo consiste em duas partes:The process consists of two parts:

  1. Atualizar os ficheiros e projetos Q# já existentes para alinhar o código com eventuais sintaxes atualizadas.Updating your existing Q# files and projects to align your code with any updated syntax.
  2. Atualizar o QDK propriamente dito para o ambiente de desenvolvimento que escolheu.Updating the QDK itself for your chosen development environment.

Atualizar os Projetos Q#Updating Q# Projects

Independentemente de utilizar C# ou Python para alojar operações Q#, siga estas instruções para atualizar os seus projetos Q#.Regardless of whether you are using C# or Python to host Q# operations, follow these instructions to update your Q# projects.

  1. Primeiro, verifique se tem a última versão do SDK de .NET Core 3.1.First, check that you have the latest version of the .NET Core SDK 3.1. Execute o seguinte comando na linha de comandos:Run the following command in the command prompt:

    dotnet --version
    

    Veja se a saída é 3.1.100 ou superior.Verify the output is 3.1.100 or higher. Se não for, instale a versão mais recente e verifique novamente.If not, install the latest version and check again. Depois, consoante a sua configuração (Visual Studio, Visual Studio Code ou diretamente na linha de comandos), siga as instruções abaixo.Then follow the instructions below depending on your setup (Visual Studio, Visual Studio Code, or directly from the command prompt).

Atualizar projetos Q# no Visual StudioUpdate Q# projects in Visual Studio

  1. Atualize para a versão mais recente do Visual Studio 2019; veja as instruções aqui.Update to the latest version of Visual Studio 2019, see here for instructions.

  2. Abra a sua solução no Visual Studio.Open your solution in Visual Studio.

  3. No menu, selecione Build (Compilar) -> Clean Solution (Limpar Solução).From the menu, select Build -> Clean Solution.

  4. Em cada ficheiro .csproj, atualize o framework de destino para netcoreapp3.1 (ou netstandard2.1, se for um projeto de biblioteca).In each of your .csproj files, update the target framework to netcoreapp3.1 (or netstandard2.1 if it is a library project). Ou seja, edite as linhas do formulário:That is, edit lines of the form:

    <TargetFramework>netcoreapp3.1</TargetFramework>
    

    Pode obter mais detalhes sobre como especificar os frameworks de destino aqui.You can find more details on specifying target frameworks here.

  5. Em cada ficheiro .csproj, defina o SDK com Microsoft.Quantum.Sdk, conforme indicado na linha abaixo.In each of the .csproj files, set the SDK to Microsoft.Quantum.Sdk, as indicated in the line below. Tenha em conta que o número da versão deve ser o último disponível. Para saber qual é, reveja as notas de versão.Please notice that the version number should be the latest available, and you can determine it by reviewing the release notes.

    <Project Sdk="Microsoft.Quantum.Sdk/0.12.20072031">
    
  6. Guarde e feche todos os ficheiros da solução.Save and close all files in your solution.

  7. Selecione Tools (Ferramentas) -> Command Line (Linha de Comandos) -> Developer Command Prompt (Linha de Comandos de Programador).Select Tools -> Command Line -> Developer Command Prompt. Em alternativa, pode utilizar a consola do gestor de pacotes no Visual Studio.Alternatively, you can use the package management console in Visual Studio.

  8. Em cada projeto na solução, execute o comando seguinte para remover este pacote:For each project in the solution, run the following command to remove this package:

    dotnet remove [project_name].csproj package Microsoft.Quantum.Development.Kit
    

    Se os seus projetos utilizarem quaisquer outros pacotes do Microsoft.Quantum ou do Microsoft.Azure.Quantum packages (por exemplo, Microsoft.Quantum.Numerics), execute o comando add para os mesmos, de modo a atualizar a versão utilizada.If your projects use any other Microsoft.Quantum or Microsoft.Azure.Quantum packages (e.g. Microsoft.Quantum.Numerics), run the add command for these to update the version used.

    dotnet add [project_name].csproj package [package_name]
    
  9. Escolha a linha de comandos e selecione Build (Compilar) -> Build Solution (Compilar Solução) (não selecione Rebuild Solution [Recompilar Solução]).Close the command prompt and select Build -> Build Solution (do not select Rebuild Solution).

Agora, pode avançar para a atualização da extensão QDK do Visual Studio.You can now skip ahead to update your Visual Studio QDK extension.

Atualizar projetos Q# no Visual Studio CodeUpdate Q# projects in Visual Studio Code

  1. No Visual Studio Code, abra a pasta que contém o projeto a atualizar.In Visual Studio Code, open the folder containing the project to update.
  2. Selecione Terminal (Terminal) -> New Terminal (Novo Terminal).Select Terminal -> New Terminal.
  3. Siga as instruções de atualização com a linha de comandos (diretamente abaixo).Follow the instructions for updating using the command prompt (directly below).

Atualizar projetos Q# com a linha de comandosUpdate Q# projects using the command prompt

  1. Navegue para a pasta que contém o ficheiro de projeto principal.Navigate to the folder containing your main project file.

  2. Execute o seguinte comando:Run the following command:

    dotnet clean [project_name].csproj
    
  3. Determine a versão atual do QDK.Determine the current version of the QDK. Para isso, reveja as notas de versão.To find it, you can review the release notes. A versão estará num formato semelhante a 0.12.20072031.The version will be in a format similar to 0.12.20072031.

  4. Em cada ficheiro .csproj, percorra os passos abaixo:In each of your .csproj files, go through the following steps:

    • Atualize o framework de destino para netcoreapp3.1 (ou netstandard2.1, se for um projeto de biblioteca).Update the target framework to netcoreapp3.1 (or netstandard2.1 if it is a library project). Ou seja, edite as linhas do formulário:That is, edit lines of the form:

      <TargetFramework>netcoreapp3.1</TargetFramework>
      

      Pode obter mais detalhes sobre como especificar os frameworks de destino aqui.You can find more details on specifying target frameworks here.

    • Substitua a referência ao SDK na definição do projeto.Replace the reference to the SDK in the project definition. Confirme que o número da versão corresponde ao valor determinado no passo 3.Make sure that the version number corresponds to the value determined in step 3.

      <Project Sdk="Microsoft.Quantum.Sdk/0.12.20072031">
      
    • Se presente, remova a referência ao pacote Microsoft.Quantum.Development.Kit, que será especificada na seguinte entrada:Remove the reference to package Microsoft.Quantum.Development.Kit if present, which will be specified in the following entry:

      <PackageReference Include="Microsoft.Quantum.Development.Kit" Version="0.10.1910.3107" />
      
    • Atualize a versão de todos os pacotes do Microsoft Quantum para a mais recente do QDK (determinada no passo 3).Update the version of the all the Microsoft Quantum packages to the most recently released version of the QDK (determined in step 3). Esses pacotes seguem os padrões de nomenclatura abaixo:Those packages are named with the following patterns:

      Microsoft.Quantum.*
      Microsoft.Azure.Quantum.*
      

      As referências aos pacotes têm o formato seguinte:References to packages have the following format:

      <PackageReference Include="Microsoft.Quantum.Compiler" Version="0.12.20072031" />
      
    • Guarde o ficheiro atualizado.Save the updated file.

    • Restaure as dependências do projeto da seguinte forma:Restore the dependencies of the project, by doing the following:

      dotnet restore [project_name].csproj
      
  5. Navegue para a pasta que contém o projeto principal e execute:Navigate back to the folder containing your main project and run:

    dotnet build [project_name].csproj
    

Com os projetos Q# já atualizados, siga as instruções abaixo para atualizar o próprio QDK.With your Q# projects now updated, follow the instructions below to update the QDK itself.

Atualizar o QDKUpdating the QDK

O processo de atualização do QDK varia de acordo com a linguagem e o ambiente de desenvolvimento.The process to update the QDK varies depending on your development language and environment. Selecione o seu ambiente de desenvolvimento abaixo:Select your development environment below.

Atualize o pacote qsharp do PythonUpdate the qsharp Python package

O procedimento de atualização depende se instalou originalmente com o conda ou o .NET CLI e o pip.The update procedure depends on whether you originally installed using conda or using the .NET CLI and pip.

  1. Ative o ambiente conda onde instalou o pacote qsharp e, em seguida, execute este comando para atualizá-lo:Activate the conda environment where you installed the qsharp package, and then run this command to update it:

    conda update -c quantum-engineering qsharp
    
  2. Execute o seguinte comando a partir da localização dos ficheiros .qs:Run the following command from the location of your .qs files:

    python -c "import qsharp; qsharp.reload()"
    

Agora, pode utilizar o pacote qsharp do Python para executar os seus programas quânticos já existentes.You can now use the updated qsharp Python package to run your existing quantum programs.

Atualize o kernel do IQ# JupyterUpdate the IQ# Jupyter kernel

O procedimento de atualização depende se instalou originalmente com o conda ou o .NET CLI e o pip.The update procedure depends on whether you originally installed using conda or using the .NET CLI and pip.

  1. Ative o ambiente conda onde instalou o pacote qsharp e, em seguida, execute este comando para atualizá-lo:Activate the conda environment where you installed the qsharp package, and then run this command to update it:

    conda update -c quantum-engineering qsharp
    
  2. Execute o seguinte comando a partir de uma célula em cada Q# Jupyter Notebook existente:Run the following command from a cell in each of your existing Q# Jupyter Notebooks:

    %workspace reload
    

Agora, pode utilizar o kernel do IQ# atualizado para executar cada Q# Jupyter Notebook existente.You can now use the updated IQ# kernel to run your existing Q# Jupyter Notebooks.

Atualizar a extensão QDK do Visual StudioUpdate Visual Studio QDK extension

  1. Atualizar a extensão Q# do Visual StudioUpdate the Q# Visual Studio extension

    Nota

    Os modelos de projetos são atualizados com a extensãoThe project templates are updated with the extension. e só se aplicam a projetos recém-criados.The updated templates apply to newly created projects only. O código dos projetos já existentes não é atualizado quando a extensão é atualizada.The code for your existing projects is not updated when the extension is updated.

Atualizar a extensão QDK do VS CodeUpdate VS Code QDK extension

  1. Atualize a extensão Quantum do VS CodeUpdate the Quantum VS Code extension

    • Reinicie o VS CodeRestart VS Code
    • Navegue para o separador Extensions (Extensões)Navigate to the Extensions tab
    • Selecione a extensão Microsoft Quantum Development Kit for Visual Studio CodeSelect the Microsoft Quantum Development Kit for Visual Studio Code extension
    • Recarregue a extensãoReload the extension

C# com a ferramenta de linha de comandos dotnetC#, using the dotnet command-line tool

  1. Atualize os modelos de projetos quânticos para .NETUpdate the Quantum project templates for .NET

    Na linha de comandos:From the command prompt:

    dotnet new -i Microsoft.Quantum.ProjectTemplates
    

    Em alternativa, se quiser utilizar os modelos da linha de comandos e já tiver a extensão QDK do VS Code instalada, pode atualizar os modelos de projeto a partir da própria extensão:Alternatively, if you intend to use the command-line templates, and already have the VS Code QDK extension installed, you can update the project templates from the extension itself:

    • Atualizar a extensão QDKUpdate the QDK extension
    • No VS Code, vá para Ver -> Paleta de ComandosIn VS Code, go to View -> Command Palette
    • Selecione Q#: Instalar modelos de projeto da linha de comandosSelect Q#: Install command line project templates
    • Ao fim de alguns segundos, deverá receber um pop-up com a mensagem "project templates installed successfully" ("modelos de projetos instalados com êxito")After a few seconds you should get a popup confirming "project templates installed successfully"