Os clientes do Configuration Manager reinstalam a cada cinco horas e podem causar uma atualização inadvertida do cliente

Este artigo aborda um problema no cliente do Gerenciador de Configurações do System Center 2012 e no cliente do Gerenciador de Configurações do 2012 R2 do System Center 2012 R2 que pode causar uma atualização inadvertida do cliente em uma filial atual do Configuration Manager ou em um ambiente de ramificação de manutenção de longo prazo (LTSB).

Versão original do produto:   Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager
Número KB original:   4018655

Resumo

A instalação do cliente do Configuration Manager (CCMSetup) falha inicialmente e faz com que uma tarefa de nova tentativa do cliente seja registrada Windows Agendador de Tarefas. Depois que a instalação do cliente for bem-sucedida, a tarefa de repetir não será excluída conforme o esperado. Portanto, os clientes continuam a reinstalar a cada cinco horas.

Nessa situação, se você atualizar a infraestrutura do Configuration Manager para a filial atual do Configuration Manager ou LTSB e se você não atualizar os clientes do Configuration Manager, a tarefa de nova tentativa agendada continuará forçando uma reinstalação do cliente a cada cinco horas.

Na próxima vez que o CCMSetup for executado, os clientes encontrarão um ponto de gerenciamento ou ponto de distribuição atualizado e reinstalam o software cliente. Isso atualiza os clientes para o Configuration Manager.

Essas atualizações contínuas ocorrem fora do processo de atualização normal configurado pelo administrador. Isso inclui o recurso de pilotagem do cliente.

Sintomas

Em um ambiente do Microsoft System Center 2012 ou System Center 2012 R2, você notará os seguintes sintomas:

  • Os clientes reinstalam-se com êxito a cada cinco horas. Essa atividade é registrada em ccmsetup.log e Windows de eventos.
  • Quando você exibir a pasta \Microsoft\Microsoft\ConfigurationManager no Agendador de Tarefas, você encontrará uma tarefa chamada Configuration Manager Client Retry Task.

Motivo

Esse problema ocorre porque o CCMSetup cria a tarefa de nova tentativa do cliente na pasta errada no cliente. Isso impede que CCMSetup aloce e remova a tarefa.

A tarefa agendada é criada na pasta \Microsoft\Microsoft\Configuration Manager em vez da pasta \Microsoft\Configuration Manager.

Solução alternativa 1

Remova manualmente a Tarefa de Nova Tentativa de Cliente do Gerenciador de Configurações da pasta \Microsoft\Microsoft\Configuration Manager usando o Agendador de Tarefas.

Solução alternativa 2

Implante um script para remover a Tarefa de Nova Tentativa do Gerenciador de Configurações da pasta \Microsoft\Microsoft\Configuration Manager.

Exemplo Windows PowerShell comandos a adicionar ao seu script:

get-scheduledtask -taskname "Configuration Manager Client Retry Task"  
unregister-scheduledtask -taskname "Configuration Manager Client Retry Task" -confirm:$false

Mais informações

No Configuration Manager atual branch versão 1602 e versões posteriores, e no LTSB versão 1606, Ccmsetup remove corretamente a tarefa agendada depois que os clientes são atualizados.