Поделиться через


Проблемы проверки подлинности в Azure HDInsight

В этой статье описаны действия по устранению неполадок и возможные способы решения проблем при взаимодействии с кластерами Azure HDInsight.

В защищенных кластерах, поддерживаемых Azure Data Lake (1-го поколения или 2-го поколения), при входе пользователей домена в службы кластеров через шлюз HDI (например, вход на портал Apache Ambari), шлюз HDI сначала пытается получить маркер OAuth из Microsoft Entra, а затем получить билет Kerberos из доменных служб Microsoft Entra. На одном из этих этапов может произойти сбой проверки подлинности. Эта статья предназначена для устранения некоторых из этих проблем.

При сбое проверки подлинности появится запрос на получение учетных данных. Если отменить это диалоговое окно, выводится сообщение об ошибке. Ниже приведены некоторые распространенные сообщения об ошибках:

invalid_grant or unauthorized_client, 50126

Проблема

Не удается выполнить вход для федеративных пользователей с кодом ошибки 50126 (для пользователей облака вход выполнен успешно). Сообщение об ошибке выглядит следующим образом:

Reason: Bad Request, Detailed Response: {"error":"invalid_grant","error_description":"AADSTS70002: Error validating credentials. AADSTS50126: Invalid username or password\r\nTrace ID: 09cc9b95-4354-46b7-91f1-efd92665ae00\r\n Correlation ID: 4209bedf-f195-4486-b486-95a15b70fbe4\r\nTimestamp: 2019-01-28 17:49:58Z","error_codes":[70002,50126], "timestamp":"2019-01-28 17:49:58Z","trace_id":"09cc9b95-4354-46b7-91f1-efd92665ae00","correlation_id":"4209bedf-f195-4486-b486-95a15b70fbe4"}

Причина

Код ошибки Microsoft Entra 50126 означает AllowCloudPasswordValidation , что политика не задана клиентом.

Разрешение

Глобальный Администратор istrator клиента Microsoft Entra должен включить идентификатор Microsoft Entra для использования хэшей паролей для поддерживаемых пользователей ADFS. Примените AllowCloudPasswordValidationPolicy, как показано в статье Использование корпоративного пакета безопасности в HDInsight.


invalid_grant or unauthorized_client, 50034

Проблема

Не удается войти в систему с кодом ошибки 50034. Сообщение об ошибке выглядит следующим образом:

{"error":"invalid_grant","error_description":"AADSTS50034: The user account Microsoft.AzureAD.Telemetry.Diagnostics.PII doesn't exist in the 0c349e3f-1ac3-4610-8599-9db831cbaf62 directory. To sign into this application, the account must be added to the directory.\r\nTrace ID: bbb819b2-4c6f-4745-854d-0b72006d6800\r\nCorrelation ID: b009c737-ee52-43b2-83fd-706061a72b41\r\nTimestamp: 2019-04-29 15:52:16Z", "error_codes":[50034],"timestamp":"2019-04-29 15:52:16Z","trace_id":"bbb819b2-4c6f-4745-854d-0b72006d6800", "correlation_id":"b009c737-ee52-43b2-83fd-706061a72b41"}

Причина

Неправильное имя пользователя (не существует). Пользователь не использует то же имя пользователя, которое используется в портал Azure.

Разрешение

Используйте то же имя пользователя, которое работает на этом портале.


invalid_grant or unauthorized_client, 50053

Проблема

Учетная запись пользователя заблокирована, код ошибки 50053. Сообщение об ошибке выглядит следующим образом:

{"error":"unauthorized_client","error_description":"AADSTS50053: You've tried to sign in too many times with an incorrect user ID or password.\r\nTrace ID: 844ac5d8-8160-4dee-90ce-6d8c9443d400\r\nCorrelation ID: 23fe8867-0e8f-4e56-8764-0cdc7c61c325\r\nTimestamp: 2019-06-06 09:47:23Z","error_codes":[50053],"timestamp":"2019-06-06 09:47:23Z","trace_id":"844ac5d8-8160-4dee-90ce-6d8c9443d400","correlation_id":"23fe8867-0e8f-4e56-8764-0cdc7c61c325"}

Причина

Слишком много попыток входа с неверным паролем.

Разрешение

Подождите около 30 минут, остановите все приложения, которые могут пытаться пройти проверку подлинности.


invalid_grant or unauthorized_client, 50053 (#2)

Проблема

Срок действия пароля истек, код ошибки 50053. Сообщение об ошибке выглядит следующим образом:

{"error":"user_password_expired","error_description":"AADSTS50055: Password is expired.\r\nTrace ID: 241a7a47-e59f-42d8-9263-fbb7c1d51e00\r\nCorrelation ID: c7fe4a42-67e4-4acd-9fb6-f4fb6db76d6a\r\nTimestamp: 2019-06-06 17:29:37Z","error_codes":[50055],"timestamp":"2019-06-06 17:29:37Z","trace_id":"241a7a47-e59f-42d8-9263-fbb7c1d51e00","correlation_id":"c7fe4a42-67e4-4acd-9fb6-f4fb6db76d6a","suberror":"user_password_expired","password_change_url":"https://portal.microsoftonline.com/ChangePassword.aspx"}

Причина

Истек срок действия пароля.

Разрешение

Измените пароль на портале Azure (в вашей локальной системе), а затем подождите 30 минут, пока завершится синхронизация.


interaction_required

Проблема

Получение сообщения об ошибке interaction_required.

Причина

Политика условного доступа или MFA применяется к пользователю. Так как интерактивная проверка подлинности пока не поддерживается, пользователю или кластеру необходимо исключить из MFA или условного доступа. Если вы решили исключить кластер (политика исключения на основе IP-адреса), убедитесь, что AD ServiceEndpoints включен для этой виртуальной сети.

Разрешение

Используйте политику условного доступа и исключите кластеры HDInsight из MFA, как показано в разделе "Настройка кластера HDInsight с корпоративным пакетом безопасности" с помощью доменных служб Microsoft Entra.


Вход запрещен

Проблема

Вход запрещен.

Причина

Для этого этапа проверка подлинности OAuth не является проблемой, но проверка подлинности Kerberos выполняется. Если этот кластер поддерживается ADLS, вход OAuth был успешным до попытки аутентификации Kerberos. В кластерах WASB вход OAuth не выполняется. Может быть много причин сбоя Kerberos, таких как хэши паролей, не синхронизированы, учетная запись пользователя заблокирована в доменных службах Microsoft Entra и т. д. Хэши паролей синхронизируются только тогда, когда пользователь меняет пароль. При создании экземпляра доменных служб Microsoft Entra начнется синхронизация паролей, которые изменяются после создания. Он не может ретроактивно синхронизировать пароли, которые были установлены до его создания.

Разрешение

Если вы считаете, что пароли могут не синхронизироваться, попробуйте изменить пароль и подождите несколько минут для синхронизации.

Попробуйте выполнить SSH-подключение к домену, чтобы попытаться выполнить проверку подлинности (kinit), используя те же учетные данные пользователя, с компьютера, присоединенного к домену. Подключитесь по SSH к головному/граничному узлу с локальным пользователем, а затем запустите kinit.


Сбой kinit

Проблема

Сбой kinit.

Причина

Возможны разные варианты.

Разрешение

Для успешного выполнения kinit необходимо знать свой sAMAccountName (это короткое имя учетной записи без области). sAMAccountName обычно является префиксом учетной записи (например, bob в bob@contoso.com). Для некоторых пользователей все могло быть иначе. Вам нужна возможность просматривать и искать каталог, чтобы узнать свой sAMAccountName.

Способы поиска sAMAccountName:

  • Если вы можете войти в Ambari с помощью локального администратора Ambari, посмотрите список пользователей.

  • Если у вас есть компьютер с Windows, присоединенный к домену, вы можете использовать стандартные инструменты Windows AD для просмотра. Для этого требуется наличие рабочей учетной записи в домене.

  • Из головного узла вы можете использовать команды SAMBA для поиска. Для этого требуется наличия действующего сеанса Kerberos (успешный kinit). поиск объявлений в сети "(userPrincipalName=bob*)"

    В результатах поиска/просмотра должен отображаться атрибут sAMAccountName. Кроме того, вы можете посмотреть на другие атрибуты, такие как pwdLastSet, badPasswordTime, userPrincipalName и т. д., чтобы убедиться, что эти свойства соответствуют вашим ожиданиям.


Сбой kinit с ошибкой предварительной проверки подлинности

Проблема

Kinit завершается сбоем с ошибкой Preauthentication.

Причина

Неверное имя пользователя или пароль.

Разрешение

Проверьте свое имя пользователя и пароль. Кроме того, проверка для других свойств, описанных. Чтобы включить подробную отладку, запустите export KRB5_TRACE=/tmp/krb.log из сеанса, прежде чем пробовать kinit.


Команда Job/HDFS не работает из-за TokenNotFoundException

Проблема

Команда Job/HDFS не работает из-за TokenNotFoundException.

Причина

Требуемый маркер доступа OAuth не найден для успешного выполнения задания или команды. Драйвер ADLS /ABFS пытается получить маркер доступа OAuth из службы учетных данных перед выполнением запросов на хранение. Этот маркер регистрируется, когда вы входите на портал Ambari под тем же пользователем.

Разрешение

Убедитесь, что вы успешно выполнили вход на портал Ambari один раз, используя имя пользователя, идентификатор которого используется для выполнения задания.


Ошибка при получении маркера доступа

Проблема

Пользователь получает сообщение об ошибке Error fetching access token.

Причина

Эта ошибка возникает периодически, когда пользователи пытаются получить доступ к Azure Data Lake Storage 2-го поколения с помощью списков контроля доступа и срок действия маркера Kerberos истек.

Разрешение

  • Для Azure Data Lake Storage 1-го поколения очистите кэш браузера и снова войдите в Ambari.

  • Для Azure Data Lake Storage 2-го поколения запустите /usr/lib/hdinsight-common/scripts/RegisterKerbTicketAndOAuth.sh <upn> для пользователя, под которым пользователь пытается войти в систему


Следующие шаги

Если вы не видите своего варианта проблемы или вам не удается ее устранить, дополнительные сведения можно получить, посетив один из следующих каналов.

  • Получите ответы специалистов Azure на сайте поддержки сообщества пользователей Azure.

  • Подпишитесь на @AzureSupport — официальный канал Microsoft Azure для улучшения качества взаимодействия с клиентами. Вступайте в сообщество Azure для получения нужных ресурсов: ответов, поддержки и советов экспертов.

  • Если вам нужна дополнительная помощь, отправьте запрос в службу поддержки на портале Azure. Выберите Поддержка в строке меню или откройте центр Справка и поддержка. Дополнительные сведения см. в статье Создание запроса на поддержку Azure. Доступ к управлению подписками и поддержкой выставления счетов уже включен в вашу подписку Microsoft Azure, а техническая поддержка предоставляется в рамках одного из планов Службы поддержки Azure.