Создание и отладка надстроек Office в Visual StudioCreate and debug Office Add-ins in Visual Studio

В этой статье описано создание надстройки Office для Excel, Word, PowerPoint или Outlook и отладка надстройки в настольном клиенте Office для Windows с помощью Visual Studio 2019.This article describes how to use Visual Studio 2019 to create an Office Add-in for Excel, Word, PowerPoint, or Outlook and debug the add-in in the Office desktop client on Windows. Если вы используете другую версию Visual Studio, используемые действия могут немного отличаться.If you're using another version of Visual Studio, the procedures might vary slightly.

Примечание

Visual Studio не поддерживает создание надстроек Office для OneNote или проекта, но вы можете использовать Yeoman генератор для надстроек Office для создания данных типов надстроек.Visual Studio does not support creating Office Add-ins for OneNote or Project, but you can use the Yeoman generator for Office Add-ins to create these types of add-ins.

Предварительные требованияPrerequisites

Создание проекта надстройки в Visual StudioCreate the add-in project in Visual Studio

Начните с выполнения этих трех шагов, а затем выполните действия, описанные в следующем разделе, которые соответствуют типу надстройки, который вы создаете.Start by completing these three steps, and then complete the steps in the following section that corresponds to the type of add-in you're creating.

  1. Откройте Visual Studio и в строке меню выберите Создать проект.Open Visual Studio and from the Visual Studio menu bar, choose Create a new project.

  2. Используя поле поиска, введите Надстройки и выберите тип проекта надстройки, который нужно создать.Using the search box, enter Add-ins, then choose the type of add-in project you want to create.

  3. Укажите имя проекта и нажмите кнопку ОК.Name the project, and then choose OK.

Надстройка Word Web или надстройка Outlook Web Word Web Add-in or Outlook Web Add-in

Если вы выбрали вариант создания надстройки Word Web или надстройки Outlook Web, Visual Studio создает решение, а два его проекта отображаются в обозревателе решений.If you've chosen to create a Word Web Add-in or an Outlook Web Add-in, Visual Studio creates a solution and its two projects appear in Solution Explorer. После этого вы можете просматривать решение Visual Studio.Next, you can explore the Visual Studio solution.

Веб-надстройка PowerPointPowerPoint Web Add-in

Если вы выбрали вариант создания веб-надстройки PowerPoint, будет отображено диалоговое окноСоздание надстройки Office.If you've chosen to create a PowerPoint Web Add-in, the Create Office Add-in dialog appears.

  • Чтобы создать надстройку области задач, выберите Добавить новые функциональные возможности для PowerPoint и нажмите кнопку Готово, чтобы создать решение Visual Studio.To create a task pane add-in, select Add new functionalities to PowerPoint and then choose the Finish button to create the Visual Studio solution.

  • Чтобы создать надстройку контента, выберите Вставить контент в слайды PowerPoint и нажмите кнопку Готово, чтобы создать решение Visual Studio.To create a content add-in, select Insert content into PowerPoint slides and then choose the Finish button to create the Visual Studio solution.

После этого вы можете просматривать решение Visual Studio.Next, you can explore the Visual Studio solution.

Веб-надстройка ExcelExcel Web Add-in

Если вы выбрали вариант создания Веб-надстройки Excel, будет отображено диалоговое окноСоздание надстройки Office.If you've chosen to create an Excel Web Add-in, the Create Office Add-in dialog appears.

  • Чтобы создать надстройку области задач, выберите Добавить новые функциональные возможности для Excel и нажмите кнопку Готово, чтобы создать решение Visual Studio.To create a task pane add-in, select Add new functionalities to Excel and then choose the Finish button to create the Visual Studio solution.

  • Чтобы создать надстройку контента, выберите Вставить контент в лист Excel и нажмите кнопку Далее, выберите одну из следующих опций и нажмите кнопку Готово, чтобы создать решение Visual Studio.To create a content add-in, select Insert content into Excel spreadsheets, choose the Next button, select one of the following options, and then choose the Finish button to create the Visual Studio solution:

    • Основные надстройки - для создания проекта надстройки контента с минимальным начальным знанием кодаBasic Add-in - to create a content add-in project with minimal starter code

    • Надстройка визуализации документа — для создания проекта надстройки контента с начальным кодом для визуализации и привязки к даннымDocument Visualization Add-in - to create a content add-in project with starter code to visualize and bind to data

Обзор решения Visual StudioExplore the Visual Studio solution

После завершения работы мастера Visual Studio создает решение, которое содержит два проекта.When you've completed the wizard, Visual Studio creates a solution that contains two projects.

ПроектProject ОписаниеDescription
Проект надстройкиAdd-in project Содержит только XML-файл манифеста, который содержит все параметры, описывающие надстройку. Эти параметры помогают ведущему приложению Office определять, когда и где должна активироваться надстройка. Visual Studio создает содержимое этого файла за вас, чтобы вы могли сразу запустить проект и начать использовать надстройку. Вы можете изменить эти параметры в любой момент, изменив XML-файл.Contains only an XML manifest file, which contains all the settings that describe your add-in. These settings help the Office host determine when your add-in should be activated and where the add-in should appear. Visual Studio generates the contents of this file for you so that you can run the project and use your add-in immediately. You change these settings any time by modifying the XML file.
Проект веб-приложенияWeb application project Содержит страницы контента надстройки, включающие все файлы и ссылки на файлы, необходимые для разработки страниц HTML и JavaScript с поддержкой Office. При разработке надстройки Visual Studio размещает веб-приложение на локальном сервере IIS. Для публикации надстройки этот проект веб-приложения нужно развернуть на веб-сервере.Contains the content pages of your add-in, including all the files and file references that you need to develop Office-aware HTML and JavaScript pages. While you develop your add-in, Visual Studio hosts the web application on your local IIS server. When you're ready to publish the add-in, you'll need to deploy this web application project to a web server.

Изменение параметров надстроекModify your add-in settings

Чтобы изменить параметры надстройки, отредактируйте XML-файл манифеста для проекта.To modify the settings of your add-in, edit the XML manifest file in the add-in project. В Обозревателе решений разверните узел проекта надстройки, откройте папку, содержащую XML-манифест, и выберите XML-манифест.In Solution Explorer, expand the add-in project node, expand the folder that contains the XML manifest, and choose the XML manifest. Вы можете навести указатель мыши на любой элемент в файле, чтобы увидеть подсказку с описанием назначения этого элемента.You can point to any element in the file to view a tooltip that describes the purpose of the element. Дополнительные сведения о файле манифеста см. в статье XML-манифест надстроек Office.For more information about the manifest file, see Office Add-ins XML manifest.

Разработка содержимого надстройкиDevelop the contents of your add-in

Проект надстройки позволяет изменить ее параметры, а веб-приложение предоставляет содержимое, которое отображается в надстройке.While the add-in project lets you modify the settings that describe your add-in, the web application provides the content that appears in the add-in.

Проект веб-приложения содержит HTML-файл по умолчанию, файл JavaScript и CSS-файл, которые можно использовать, чтобы приступить к работе.The web application project contains a default HTML file, JavaScript file, and CSS file that you can use to get started. Некоторые из этих файлов содержат ссылки на другие библиотеки JavaScript, включая API JavaScript для Office.Some of these files contain references to other JavaScript libraries including the JavaScript API for Office. Вы можете разработать собственную надстройку, выполнив обновление этих файлов и/или добавления дополнительных файлов HTML и JavaScript.You can develop your add-in by updating these files and/or adding more HTML and JavaScript files. В таблицу ниже описаны файлы по умолчанию, которые содержит проект веб-приложения при создании решений Visual Studio.The following table describes the default files that the web application project contains when the Visual Studio solution is created.

Имя файлаFile name ОписаниеDescription
Home.htmlHome.html
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.htmlMessageRead.html
(Outlook)(Outlook)
HTML-страница надстройки по умолчанию.The default HTML page of the add-in. Эта страница отображается как первая страница в надстройке, когда она активируется в документе, сообщении электронной почты или элементе встречи.This page appears as the first page inside of the add-in when it is activated in a document, email message, or appointment item. Этот файл содержит все ссылки на файл, которые необходимы для начала работы.This file contains all of the file references that you need to get started. Вы можете начать разработку вашей надстройки, добавив HTML-код к этому файлу.You can start developing your add-in by adding your HTML code to this file.
Home.jsHome.js
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.jsMessageRead.js
(Outlook)(Outlook)
Файл JavaScript, связанный со страницей Home.html (Excel, PowerPoint, Word) или страницейMessageRead.html (Outlook).The JavaScript file associated with the Home.html page (Excel, PowerPoint, Word) or the MessageRead.html page (Outlook). Этот файл должен содержать любой код, который определяет поведение страницы Home.html (Excel, PowerPoint, Word) или страницыMessageRead.html (Outlook).This file should contain any code that is specific to the behavior of the Home.html page (Excel, PowerPoint, Word) or the MessageRead.html page (Outlook). Данный файл содержит определенный пример кода, который можно использовать для начала работы.This file contains some example code to get you started.
Home.cssHome.css
(Excel, PowerPoint, Word)(Excel, PowerPoint, Word)

MessageRead.cssMessageRead.css
(Outlook)(Outlook)
Определяет стили по умолчанию, применяемые к надстройке.Defines the default styles to apply to your add-in. Мы рекомендуем использовать структуру и стили Office UI Fabric.We recommend using the Office UI Fabric for design and styles. Дополнительные сведения см. в статье Office UI Fabric в надстройках Office.For more information see Office UI Fabric in Office Add-ins.

Примечание

Вам необязательно использовать эти файлы.You don't have to use these files. Вы можете добавить другие файлы в проект и использовать их вместо первоначальных файлов.Feel free to add other files to the project and use those instead. Если вы хотите, чтобы другой HTML-файл отображался в качестве начальной странице для надстройки, откройте редактор манифеста и задайте свойство SourceLocation для имени файла.If you want another HTML file to appear as the initial page of the add-in, open the manifest editor, and then set the SourceLocation property to the name of the file.

Отладка вашей надстройкиDebug your add-in

Вы можете использовать Visual Studio для отладки надстройки в настольном клиенте Office для Windows, как описано в следующих разделах:You can use Visual Studio to debug your add-in in the Office desktop client on Windows, as described in the following sections:

Примечание

Visual Studio нельзя использовать для отладки надстроек в Office в Интернете или Office для Mac.You cannot use Visual Studio to debug add-ins in Office on the web or Mac. Сведения по выполнению отладки на данных платформах см. в статье Отладка надстроек Office в Office в Интернете или Отладка надстроек Office для iPad и компьютеров MacFor information about debugging on these platforms, see Debug Office Add-ins in Office on the web or Debug Office Add-ins on iPad and Mac

Просмотр параметров сборки и отладкиReview the build and debug properties

Перед началом отладки просмотрите свойства каждого проекта и убедитесь, что Visual Studio откроет нужное хост-приложение, а другие параметры сборки и отладки заданы правильно.Before you start debugging, review the properties of each project to confirm that Visual Studio will open the desired host application and that other build and debug properties are set appropriately.

Свойства проекта надстройкиAdd-in project properties

Откройте окноСвойства в проекте надстройки для просмотра свойств проекта:Open the Properties window for the add-in project to review project properties:

  1. В Обозревателе решений выберите проект надстройки, (не проект веб-приложения).In Solution Explorer, choose the add-in project (not the web application project).

  2. В панели меню выберите пункт Вид > Окно свойств.From the menu bar, choose View > Properties Window.

В следующей таблице описываются свойства проекта надстройки.The following table describes the properties of the add-in project.

СвойствоProperty ОписаниеDescription
Действие при запускеStart Action Определяет режим отладки для вашей надстройки.Specifies the debug mode for your add-in. В настоящее время только режимклассического клиента Office поддерживается для проектов надстройки Office.Currently only Office Desktop Client mode is supported for Office Add-in projects.
Начальный документStart Document
(только для надстроек Excel, PowerPoint и Word)(Excel, PowerPoint, and Word add-ins only)
Указывает, какой документ следует открыть при запуске проекта.Specifies what document to open when you start the project.
Веб-проектWeb Project Определяет имя веб-проекта, связанного с надстройкой.Specifies the name of the web project associated with the add-in.
Адрес электронной почтыEmail Address
(только для надстроек Outlook)(Outlook add-ins only)
Указывает адрес электронной почты учетной записи пользователя на сервере Exchange Server или Exchange Online, который вы хотите использовать для проверки надстройки Outlook.Specifies the email address of the user account in Exchange Server or Exchange Online that you want to use to test your Outlook add-in.
EWS UrlEWS Url
(только для надстроек Outlook)(Outlook add-ins only)
URL-адрес веб-службы Exchange (пример: https://www.contoso.com/ews/exchange.aspx).Exchange Web service URL (For example: https://www.contoso.com/ews/exchange.aspx).
URL-адрес OWAOWA Url
(только для надстроек Outlook)(Outlook add-ins only)
URL-адрес Outlook в Интернете (например, https://www.contoso.com/owa).Outlook on the web URL (For example: https://www.contoso.com/owa).
Использование многофакторной проверки подлинностиUse multi-factor auth
(только для надстроек Outlook)(Outlook add-ins only)
Логическое значение, которое определяет, следует ли использовать многофакторную проверку подлинности.Boolean value that indicates whether multi-factor authentication should be used.
Имя пользователяUser Name
(только для надстроек Outlook)(Outlook add-ins only)
Определяет имя учетной записи на сервере Exchange Server или Exchange Online, которое вы хотите использовать для проверки вашей надстройки Outlook.Specifies the name of the user account in Exchange Server or Exchange Online that you want to use to test your Outlook add-in.
**Файл проекта **Project File Задает имя файла, в котором указаны сборка, конфигурация и другие сведения о проекте.Specifies the name of the file containing build, configuration, and other information about the project.
Папка проектаProject Folder Расположение файла проекта.The location of the project file.

Примечание

Для надстройки Outlook вы можете задать значения для одной или нескольких используемых только для*надстроек Outlook свойств * в окне Свойства, но делать это необязательно.For an Outlook add-in, you may choose to specify values for one or more of the Outlook add-in only properties in the Properties window, but doing so is not required.

Свойства проекта веб-приложенияWeb application project properties

Откройте окноСвойства в проекте веб-приложения для просмотра свойств проекта:Open the Properties window for the web application project to review project properties:

  1. В Обозревателе решений выберите проект веб-приложения.In Solution Explorer, choose the web application project.

  2. В панели меню выберите пункт Вид > Окно свойств.From the menu bar, choose View > Properties Window.

В таблице ниже описаны свойства проекта веб-приложения, которые наиболее подходят для проектов надстройки Office.The following table describes the properties of the web application project that are most relevant to Office Add-in projects.

СвойствоProperty ОписаниеDescription
SSL включенSSL Enabled Указывает, включен ли SSL на сайте.Specifies whether SSL is enabled on the site. Это свойство должно иметь значение True для проектов надстройки Office.This property should be set to True for Office Add-in projects.
URL-АДРЕС SSLSSL URL Задает защищенный HTTPS URL-адрес сайта.Specifies the secure HTTPS URL for the site. Только для чтения.Read-only.
URLURL Задает HTTP URL-адрес сайта.Specifies the HTTP URL for the site. Только для чтения.Read-only.
**Файл проекта **Project File Задает имя файла, в котором указаны сборка, конфигурация и другие сведения о проекте.Specifies the name of the file containing build, configuration, and other information about the project.
Папка проектаProject Folder Указывает расположение файла проекта.Specifies the location of the project file. Только для чтения.Read-only. Файл манифеста, который генерирует Visual Studio во время выполнения, записывается в папку bin\Debug\OfficeAppManifests в этом расположении.The manifest file that Visual Studio generates at runtime is written to the bin\Debug\OfficeAppManifests folder in this location.

Использование существующего документа для отладки надстройкиUse an existing document to debug the add-in

Если у вас есть документ, содержащий тестовые данные, которые вы хотите использовать при отладке надстройки Excel, PowerPoint или Word, Visual Studio можно настроить на открытия документа при запуске проекта.If you have a document that contains test data you want to use while debugging your Excel, PowerPoint, or Word add-in, Visual Studio can be configured to open that document when you start the project. Чтобы указать существующий документ для использования при отладке надстройки, выполните указанные ниже действия.To specify an existing document to use while debugging the add-in, complete the following steps.

  1. В Обозревателе решений выберите проект надстройки (не проект веб-приложения).In Solution Explorer, choose the add-in project (not the web application project).

  2. В строке меню выберите Проект > добавить существующий элемент.From the menu bar, choose Project > Add Existing Item.

  3. В диалоговом окне Добавление существующего элемента найдите и выберите документ, который вы хотите добавить.In the Add Existing Item dialog box, locate and select the document that you want to add.

  4. Нажмите кнопку Добавить, чтобы добавить документ в проект.Choose the Add button to add the document to your project.

  5. В Обозревателе решений выберите проект надстройки (не проект веб-приложения).In Solution Explorer, choose the add-in project (not the web application project).

  6. В панели меню выберите Вид > Окно свойств.From the menu bar, choose View > Properties Window.

  7. В окнеСвойства выберите список Стартовый документ, а затем выберите документ, который вы добавили в проект.In the Properties window, choose the Start Document list, and then select the document that you added to the project. Проект теперь настроен на запуск надстройки в данном документе.The project is now configured to start the add-in in that document.

Запуск проектаStart the project

Для запуска проекта выберите Отладка > Начать отладку в строке меню.Start the project by choosing Debug > Start Debugging from the menu bar. Visual Studio будет автоматически собирать решение и запускать Office для размещения вашей надстройки.Visual Studio will automatically build the solution and start Office to host your add-in.

Примечание

При запуске проекта надстройки Outlook вам будет предложено ввести учетные данные для входа.When you start an Outlook add-in project, you'll be prompted for login credentials. Если вам постоянно приходится входить в систему или появляется сообщение об ошибке авторизации, Basic Auth может быть отключен для учетных записей в вашем клиенте Office 365.If you're asked to log in repeatedly or if you receive an error that you are unauthorized, then Basic Auth may be disabled for accounts on your Office 365 tenant. В этом случае попробуйте использовать учетную запись Майкрософт.In this case, try using a Microsoft account instead. Кроме того, может потребоваться задать в диалоговом окне свойств проекта веб-надстройки Outlook для свойства "Использовать многофакторную проверку подлинности" значение "True".You may also need to set the property "Use multi-factor auth" to True in the Outlook Web Add-in project properties dialog.

Когда Visual Studio выполняет сборку проекта, происходит выполнение следующих действий:When Visual Studio builds the project it performs the following tasks:

  1. Создает копию XML-файл манифеста и добавляет ее в каталоге _ProjectName_\bin\Debug\OfficeAppManifests.Creates a copy of the XML manifest file and adds it to _ProjectName_\bin\Debug\OfficeAppManifests directory. Хост-приложение использует эту копию, когда вы запускаете Visual Studio и выполняете отладку надстройки.The host application consumes this copy when you start Visual Studio and debug the add-in.

  2. Создает набор записей реестра на компьютере, который позволяет отображать надстройку в хост-приложении.Creates a set of registry entries on your computer that enable the add-in to appear in the host application.

  3. Выполняет сборку проекта веб-приложения, а затем развертывает его на локальном веб-сервере IIS (https://localhost).Builds the web application project, and then deploys it to the local IIS web server (https://localhost).

  4. Если это первый проект надстройки, который вы развернули на локальный веб-сервер IIS, вам может быть предложено установить самозаверяющий сертификат в хранилище доверенных корневых сертификатов текущего пользователя.If this is the first add-in project that you have deployed to local IIS web server, you may be prompted to install a Self-Signed Certificate to the current user's Trusted Root Certificate store. Это необходимо для того, чтобы приложение IIS Express отображало содержимое вашей надстройки правильно.This is required for IIS Express to display the content of your add-in correctly.

Примечание

Последняя версия Office может использовать более новый веб-элемент управления для отображения содержимого надстройки при запуске в Windows 10.The latest version of Office may use a newer web control to display the add-in contents when running on Windows 10. В таком случае, Visual Studio может предложить добавить исключение замыкания локальной сети на себя.If this is the case, Visual Studio may prompt you to add a local network loopback exemption. Это требуется для того, чтобы веб-элемент управления в хост-приложении Office мог получить доступ к веб-сайту, развернутому на локальном веб-сервере IIS.This is required for the web control, in the Office host application, to be able to access the website deployed to the local IIS web server. Эту настройку также можно изменить в любое время в Visual Studio в разделе Инструменты > Параметры > Средства Office (веб) > Отладка веб-настройки.You can also change this setting anytime in Visual Studio under Tools > Options > Office Tools (Web) > Web Add-In Debugging.

Затем Visual Studio выполняет следующее:Next, Visual Studio does the following:

  1. Изменяет элемент SourceLocation XML-файла манифеста, выполняя замену маркера ~remoteAppUrl с полностью отвечающим требованиям адресом начальной страницы (например, https://localhost:44302/Home.html).Modifies the SourceLocation element of the XML manifest file by replacing the ~remoteAppUrl token with the fully qualified address of the start page (for example, https://localhost:44302/Home.html).

  2. Запускает проект веб-приложения в IIS Express.Starts the web application project in IIS Express.

  3. Открывает хост-приложение.Opens the host application.

Visual Studio не отображает ошибки проверки в окне ВЫХОДНЫЕ ДАННЫЕ при сборке проекта.Visual Studio doesn't show validation errors in the OUTPUT window when you build the project. Visual Studio генерирует ошибки и предупреждения в окне СПИСОК ОШИБОК при их появлении.Visual Studio reports errors and warnings in the ERRORLIST window as they occur. Visual Studio также генерирует отчеты об ошибках проверки, отображая волнистые линии (называется волнистой линией) различных цветов в редакторе кода и текста.Visual Studio also reports validation errors by showing wavy underlines (known as squiggles) of different colors in the code and text editor. Эти отметки уведомляют о проблемах, которые Visual Studio обнаружил в вашем коде.These marks notify you of problems that Visual Studio detected in your code. Дополнительные сведения о том, как включить или отключить проверку см. в статье Параметры, текстовый редактор, JavaScript, IntelliSense.For more information about how to enable or disable validation, see Options, Text Editor, JavaScript, IntelliSense.

Чтобы просмотреть правила проверки XML-файла манифеста проекта, ознакомьтесь с разделом XML-манифест надстройки для Office.To review the validation rules of the XML manifest file in your project, see Office Add-ins XML manifest.

Отладка кода для надстройки Excel, PowerPoint или WordDebug the code for an Excel, PowerPoint, or Word add-in

Если ваша надстройка не отображается в документе, который отображается хост-приложением (Excel, PowerPoint или Word) после запуска проекта, вручную запустите надстройку в хост-приложением.If your add-in isn't visible within the document that's displayed in the host application (Excel, PowerPoint, or Word) after you've started the project, manually launch the add-in in the host application. Например, запустите вашу надстройку области задач, нажав кнопку Показать область задач на ленте вкладки Домой. После того как ваша надстройка будет отображена в Excel, PowerPoint или Word, вы можете выполнить отладку вашего кода, выполнив следующее:For example, launch your task pane add-in by choosing the Show Taskpane button in the ribbon of the Home tab. After your add-in is displayed in Excel, PowerPoint, or Word, you can debug your code by doing the following:

  1. В Excel, PowerPoint или Word, выберите вкладку Вставка, а затем нажмите стрелку вниз, находящуюся справа от панелиМои надстройки.In Excel, PowerPoint, or Word, choose the Insert tab and then choose the down-arrow located to the right of My Add-ins.

    Лента "Вставка" в Excel для Windows с выделенной стрелкой "Мои надстройки"

  2. В списке доступных надстроек найдите раздел Надстройки разработчика и выберите вашу надстройку, чтобы зарегистрировать ее.In the list of available add-ins, find the Developer Add-ins section and select the your add-in to register it.

  3. В среде Visual Studio задайте точки останова в вашем коде.In Visual Studio, set breakpoints in your code.

  4. В Excel, PowerPoint или Word выполняется взаимодействие с надстройкой.In Excel, PowerPoint, or Word, interact with your add-in.

  5. Так как точки останова отмечены в среде Visual Studio, просмотрите код поэтапно при необходимости.As breakpoints are hit in Visual Studio, step through the code as needed.

Вы можете изменить свой код и оценить результаты этих изменений для вашей надстройки, без необходимости закрытия хост-приложения и перезапуска проекта.You can change your code and review the effects of those changes in your add-in without having to close the host application and restart the project. После сохранения изменений вашего кода просто перезагрузите надстройку в хост-приложении.After you save changes to your code, simply reload the add-in in the host application. Например, выполните перезагрузку области задач надстройки, нажав правый верхний угол области задач, чтобы активировать меню персонализации и выбрав Перезагрузка.For example, reload a task pane add-in by choosing the top-right corner of the task pane to activate the personality menu and then choose Reload.

Отладка кода для надстройки OutlookDebug the code for an Outlook add-in

После того как вы запустили проект, Visual Studio открывает Outlook, чтобы разместить вашу надстройку, откройте сообщение электронной почты или элемент встречи.After you've started the project and Visual Studio launches Outlook to host your add-in, open an email message or appointment item.

Outlook активирует надстройка для этого элемента, если соблюдаются критерии активации. В верхней части окна инспектора или области чтения появляется строка надстройка, и надстройка Outlook отображается в строке надстройка в виде кнопки. Если в вашей надстройке есть команда, на ленте появится кнопка (либо на вкладке по умолчанию, либо на пользовательской вкладке), а надстройка не будет отображаться в области надстройка.Outlook activates the add-in for the item as long as the activation criteria are met. The add-in bar appears at the top of the Inspector window or Reading Pane, and your Outlook add-in appears as a button in the add-in bar. If your add-in has an add-in command, a button will appear in the ribbon, either in the default tab or a specified custom tab, and the add-in will not appear in the add-in bar.

Чтобы просмотреть надстройку Outlook, нажмите кнопку для вашей надстройки Outlook.To view your Outlook add-in, choose the button for your Outlook add-in. После отображения вашей надстройки в Outlook, вы можете выполнить отладку кода с помощью описанных ниже действий:After your add-in is displayed in Outlook, you can debug your code by doing the following:

  1. В среде Visual Studio задайте точки останова в вашем коде.In Visual Studio, set breakpoints in your code.

  2. В Outlook откройте надстройку.In Outlook, interact with your add-in.

  3. Так как точки останова отмечены в среде Visual Studio, просмотрите код поэтапно при необходимости.As breakpoints are hit in Visual Studio, step through the code as needed.

Вы можете изменить свой код и оценить результаты этих изменений для вашей надстройки, без необходимости закрытия Outlook и перезапуска проекта.You can change your code and review the effects of those changes in your add-in without having to close Outlook and restart the project. После сохранения изменений вашего кода просто откройте контекстное меню для надстройки (в Outlook) и выберите кнопку Перезагрузка.After you save changes to your code, simply open the shortcut menu for the add-in (in Outlook), and then choose Reload.

Дальнейшие действияNext steps

Если надстройка работает корректно, см. статью Развертывание и публикация вашей надстройки Office, чтобы ознакомиться со способами распространения вашей надстройки среди пользователей.After your add-in is working as desired, see Deploy and publish your Office Add-in to learn about the ways you can distribute the add-in to users.