Как восстановить поврежденные документы Word

Примечание

Office 365 ProPlus переименован в Майкрософт 365 корпоративные приложения. Для получения дополнительной информации об этом изменении прочитайте этот блог.

Аннотация

В статье описываются способы выявления поврежденных документов в программе Word 2007 и ее более поздних версиях. Кроме того, в статье содержатся рекомендации по восстановлению текста и данных, содержащихся в выявленных поврежденных документах.

Данная статья рассчитана на начинающих пользователей компьютера и пользователей со средним уровнем подготовки. Для удобства выполнения описанных действий рекомендуется начать с распечатки этой статьи.

Обновление Microsoft Office и Windows

Многие проблемы с программным обеспечением могут быть решены путем обновления программ Microsoft Office и Windows.

Часто задаваемые вопросы по центру обновления Windows

Установка обновлений Office

Обновление Office с обновлением Майкрософт

Поврежденный документ или проблема с программным обеспечением?

Документ Word может быть поврежден по нескольким причинам, которые помешают вам открыть его. Такое поведение может быть вызвано повреждением документа или шаблона, на котором основан документ. Ниже перечислены некоторые типы такого поведения:

  • Многократное перенумерование существующих страниц документа
  • Многократное восстановление разрывов страниц в документе
  • Неправильная структура и форматирование документа.
  • Вывод на экран нечитаемых знаков.
  • Вывод сообщений об ошибках во время обработки.
  • Зависание компьютера при открытии файла.
  • Любое другое нестандартное поведение, которое не соответствует обычной работе программы.

В некоторых случаях повреждение документа не является причиной подобного поведения. Важно определить, поврежден ли документ или проблема связана с программным обеспечением. Для устранения этих факторов выполните следующие действия.

  1. Убедитесь, что подобное поведение не наблюдается при работе с другими документами. Попробуйте открыть другие документы Word, чтобы увидеть, возникает ли та же проблема. Если они открываются правильно, то проблема может быть с документом Word.
  2. Убедитесь, что подобное поведение не наблюдается при использовании других программ Microsoft Office. Если это так, то проблема может быть с другим приложением или операционной системой.

Если при выполнении какого-либо из этих действий будет выявлено, что проблема заключается не в документе, необходимо устранить проблему с Word, набором Office или установленной на компьютере операционной системе.

Действия при невозможности открытия поврежденного документа

Попробуйте способы в указанном порядке. Если один не работает, попробуйте следующий.

Шаг 1. Настройка Word

  1. Запустите Word.
  2. На вкладке Вид в группе Представления выберите Черновик.
  3. Выберите меню «Файл», затем щелкните Настройки и Дополнительно.
  4. В разделе Отобразить содержимое документа отметьте пункты Использовать шрифт черновика в режимах отображения «Черновик» и «Разметка» и Показывать замещающие рамки рисунков.
  5. Прокрутите вниз до раздела Общее, снимите флажок с Автоматически обновлять связи при открытии, нажмите OK и закройте Word.

Шаг 2. Откройте поврежденный документ

  1. Запустите Word.
  2. Выберите меню «Файл», затем Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Если документ открыть невозможно, закройте его, затем снова откройте с помощью способа 6 и восстановите документ. В противном случае перейдите к способу 2.

Способ 2: Вставьте документ как файл в новый документ.

Шаг 1. Создание нового документа

  1. Выберите меню «Файл», затем Создать.

  2. Выберите Новый документ, затем Создать.

    Примечание

    Может потребоваться повторно применить форматирование к последнему разделу нового документа.

Шаг 2. Вставьте поврежденный документ в новый документ

  1. На вкладке Вставка нажмите Вставка объекта, затем выберите Текст из файла.

  2. В диалоговом окне Вставка файла найдите и выберите поврежденный документ. Затем выберите Вставить.

    Примечание

    Может потребоваться повторно применить форматирование к последнему разделу нового документа.

Шаг 1. Создание нового документа

  1. В Word откройте меню Файл, затем выберите Создать.
  2. Выберите Новый документ, затем Создать.
  3. В новом документе введите «Это проверка».
  4. Выберите меню «Файл», затем Сохранить.
  5. Введите «Ссылка спасения», затем Сохранить.
  1. Выберите текст, введенный на шаге 1-3.
  2. На вкладке Главная в группе Буфер обмена щелкните Копировать.
  3. Выберите меню «Файл», затем Создать.
  4. Выберите Новый документ, затем Создать.
  5. На вкладке Главная в группе Буфер обмена щелкните стрелку рядом с кнопкой Вставить, затем выберите Специальная вставка.
  6. Щелкните Вставить связь, затем Форматированный текст (RTF).
  7. Нажмите OK.
  1. Щелкните связанный текст правой кнопкой мыши, выберите команду Объект связанного документа, затем Связи.

  2. В диалоговом окне Связи выберите имя файла связанного документа и нажмите Изменить источник.

  3. В диалоговом окне Изменить источник выберите документ, который не удается открыть, и нажмите Открыть.

  4. Нажмите OK, чтобы закрыть диалоговое окно Связи.

    Примечание

    В новом документе должны появиться сведения из поврежденного документа, если в нем находились данные или текст, которые можно было восстановить.

  5. Щелкните связанный текст правой кнопкой мыши, выберите Объект связанного документа, затем Связи.

  6. В диалоговом окне Связи нажмите кнопку Разорвать связь.

  7. Нажмите кнопку Да в следующем сообщении: «Разорвать указанные связи?»

Способ 4: Использовать конвертер «Восстановление текста из любого файла»

Примечание

У конвертера "Восстановление текста из любого файла" есть свои ограничения. Например, он не сохраняет форматирование документа. Кроме того, теряются все нетекстовые данные (рисунки, поля, графические объекты и прочие элементы). Поэтому верхние и нижние колонтитулы, сноски и текст полей сохраняются в виде обычного текста.

  1. В Word откройте меню «Файл», затем Открыть.
  2. В поле Тип файлов выберите Восстановление текста из любого файла(.).
  3. Выберите документ, текст которого необходимо восстановить.
  4. Выберите Открыть.

После восстановления документа с помощью конвертера «Восстановление текста из любого файла» некоторые двоичные данные не преобразовались. В основном это текст начала и конца документа. Необходимо удалить эти двоичные данные перед сохранения файла в качестве документа Word.

Примечание

В пользовательском интерфейсе Word 2007 отсутствует кнопка «Файл». Вместо нее используйте кнопку Office и затем выполняйте необходимые указания.

Действия по устранению проблем, если поврежденный документ можно открыть

Способ 1. Скопируйте все содержимое, за исключением последнего знака абзаца, в новый документ.

Шаг 1. Создайте новый документ

  1. В Word откройте меню Файл на ленте и выберите пункт Создать.
  2. Выберите Новый документ, затем Создать.

Шаг 2. Откройте поврежденный документ

  1. Выберите меню «Файл» на ленте и выберите пункт Открыть.
  2. Щелкните поврежденный документ, затем выберите Открыть.

Шаг 3. Скопируйте содержимое документа и вставьте его в новый документ

Примечание

Если документ содержит разрывы разделов, копируйте только текст между разрывами. Разрывы разделов не следует копировать, так как они могут повредить новый документ. При копировании и вставке между документами необходимо изменить вид документа на черновой режим, чтобы избежать переноса разрывов разделов. Для перехода в черновой режим на вкладке Вид в группе Представления документа щелкните Черновик.

  1. В поврежденном документе нажмите сочетание клавиш CTRL+END, затем нажмите сочетание клавиш CTRL+SHIFT+HOME.
  2. На вкладке Главная в группе Буфер обмена щелкните Копировать.
  3. На вкладке Вид в группе Окно щелкните Переключение окон.
  4. Щелкните новый документ, созданный в шаге 1.
  5. На вкладке Главная в группе Буфер обмена щелкните Вставить.

Если неисправность сохраняется, перейдите к способу 8.

Способ 2: Замените используемый документом шаблон

Шаг 1. Определите используемый документом шаблон

  1. Откройте поврежденный документ в приложении Word.
  2. Выберите меню «Файл» на ленте и выберите пункт Параметры.
  3. Выберите пункт Надстройки.
  4. В окне Управление щелкните Шаблоны в области Просмотр и управление надстройками Office.
  5. Выберите Выполнить.

В окне Шаблон документа появится список шаблонов документа. Если отображенные шаблоны помечены как Обычный, перейдите к шагу 2. В противном случае перейдите к выполнению действия 3.

Шаг 2. Переименуйте общий шаблон (Normal.dotm)

  1. Закройте приложение Word.
  2. Нажмите Пуск.
  3. В своей операционной системе найдите normal.dotm. Этот шаблон обычно находится здесь: %userprofile%\appdata\roaming\microsoft\templates
  4. Щелкните правой кнопкой файл Normal.dotm и выберите Переименовать.
  5. Введите «Oldword.old» и нажмите клавишу ВВОД.
  6. Закройте проводник.
  7. Запустите приложение Word и откройте документ.

Шаг 3. Измените шаблон документа

  1. Откройте поврежденный документ в приложении Word.
  2. Выберите меню «Файл» на ленте и выберите пункт Параметры.
  3. Выберите пункт Надстройки.
  4. В окне Управление выберите Шаблоны и нажмите кнопку Перейти.
  5. Выберите Прикрепить.
  6. В папке Шаблоны выберите Normal.dotm, а затем нажмите Открыть.
  7. Нажмите кнопку OK, чтобы закрыть окно Шаблоны и надстройки.
  8. Закройте приложение Word.

Шаг 4. Проверьте изменение шаблонов.

  1. Запустите Word.
  2. Выберите меню «Файл» на ленте и выберите пункт Параметры.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Если неисправность сохраняется, перейдите к способу 3.

Способ 3: Запустите программу Word с параметрами по умолчанию.

Для запуска Word с параметрами по умолчанию вы можете использовать параметр командной строки /a. При использовании параметра /a Word не загружает никакие надстройки. Кроме того, Word не использует имеющийся шаблон Normal.dotm. Перезапустите Word с помощью параметра /a.

Вариант 1. Запуск Word с параметром /a

  1. Закройте приложение Word.

  2. Нажмите Пуск и выберите пункт «Выполнить». В диалоговом окне «Выполнить» введите:

    winword.exe /a

Этап 2. Открытие документа

  1. В Word откройте меню «Файл» на ленте и выберите пункт Открыть.
  2. Щелкните поврежденный документ, затем выберите Открыть.

Если неисправность сохраняется, перейдите к способу 4.

Способ 4: Изменение драйверов принтера.

Шаг 1. Попробуйте заменить драйвер принтера

  1. Найдите в вашей операционной системе меню «Устройства и принтеры».
  2. Нажмите Установка принтера.
  3. В диалоговом окне Установка принтера щелкните Добавить локальный принтер.
  4. Выберите Использовать существующий порт и нажмите кнопку Далее.
  5. В списке Изготовитель выберите Microsoft.
  6. Выберите Средство записи XPS-документов Microsoft и нажмите кнопку Далее.
  7. Выберите пункт Использовать уже установленный драйвер (рекомендуется) и нажмите кнопку Далее.
  8. Установите флажок Использовать в качестве принтера по умолчанию и нажмите кнопку Далее.
  9. Выберите Готово.

Шаг 2. Убедитесь, что изменение драйверов принтера привело к разрешению проблемы

  1. Запустите Word.
  2. Выберите меню «Файл» на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Если странное поведение не было устранено, перейдите к шагу 3.

Шаг 3. Переустановите исходный драйвер принтера.

Windows 10 и Windows 7

  1. В своей операционной системе найдите «Принтеры».

  2. Щелкните правой кнопкой мыши значок принтера по умолчанию и выберите команду Удалить.

    Если система запросит пароль администратора или подтверждение, введите пароль или нажмите кнопку Продолжить.

  3. Если будет предложено удалить все файлы, связанные с принтером, нажмите кнопку Да.

  4. Щелкните Добавить принтер или сканер и следуйте инструкциям Мастера установки принтера для переустановки драйвера принтера.

Шаг 4. Убедитесь, что изменение драйверов принтера привело к разрешению проблемы

  1. Запустите Word.
  2. Выберите меню «Файл» на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Если неисправность сохраняется, перейдите к способу 5.

Способ 5. Попытка принудительного восстановления файла в Word.

Шаг 1. Восстановление документа

В Word откройте меню «Файл» на ленте и выберите пункт Открыть.

  1. В диалоговом окне Открыть выберите нужный документ Word.
  2. Щелкните стрелку рядом с кнопкой Открыть и выберите команду Открыть и восстановить.

Шаг 2. Убедитесь, что восстановление документа привело к разрешению проблемы

Убедитесь, что странное поведение больше не возникает. Если неисправность сохраняется, перезагрузите Windows и перейдите к способу 6.

Способ 6. Изменение формата документа с последующим преобразованием документа обратно в формат Word.

Шаг 1. Откройте документ

  1. Запустите Word.
  2. Выберите меню «Файл» на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Шаг 2. Сохраните документ в другом формате

  1. Откройте меню «Файл» на ленте и выберите пункт Сохранить как.
  2. Выберите Другие форматы.
  3. В списке Сохранение файла выберите Rich Text Format (*.rtf).
  4. Выберите Сохранить.
  5. Откройте меню «Файл» на ленте и выберите пункт Закрыть.

Шаг 3. Откройте документ, затем сконвертируйте его обратно в формат Word

  1. В Word выберите Файл, затем Открыть.
  2. Щелкните конвертированный документ, затем выберите Открыть.
  3. Выберите Файл, затем команду Сохранить как.
  4. Выберите Документ Word в поле Сохранить как.
  5. Переименуйте файл и нажмите Сохранить.

Шаг 4. Убедитесь, что конвертация формата файла решила проблему

Убедитесь, что странное поведение больше не возникает. Если проблема не устранена, попробуйте сохранить файл в другом формате. Повторите шаги 1 – 4, затем попробуйте сохранить файл в других форматах в следующем порядке:

  • Веб-страница (.htm; .html)
  • в любом другом формате обработки текста;
  • в формате обычного текста (TXT).

Примечание

При сохранении файлов в формате Обычный текст (.txt) вы можете устранить повреждение документа. Однако все форматирование документа, все макросы и рисунки при этом теряются. При сохранении файлов в формате обычного текста (.txt) необходимо повторно форматировать документ. Поэтому формат Обычный текст (.txt) необходимо использовать только в том случае, если другие форматы не разрешают проблему.

Если неисправность сохраняется, перейдите к способу 7.

Способ 7. Скопируйте неповрежденные части поврежденного документа в новый документ.

Шаг 1. Создайте новый документ

  1. В Word выберите Файл и щелкните пункт Создать.
  2. Выберите Новый документ, затем Создать.

Шаг 2. Откройте поврежденный документ

  1. Выберите Файл, затем Открыть.
  2. Щелкните поврежденный документ, затем выберите Открыть.

Шаг 3. Скопируйте неповрежденные части поврежденного документа, а затем вставьте их в новый документ

Примечание

Если документ содержит разрывы разделов, копируйте только текст между разрывами. Разрывы разделов не следует копировать, так как они могут повредить новый документ. При копировании и вставке между документами необходимо изменить вид документа на черновой режим, чтобы избежать переноса разрывов разделов. Для перехода в черновой режим на вкладке Вид в группе Представления документа щелкните Черновик.

  1. В поврежденном документе найдите и выделите неповрежденню часть содержания документа.
  2. На вкладке Главная в группе Буфер обмена щелкните Копировать.
  3. На вкладке Вид в группе Окно щелкните Переключение окон.
  4. Щелкните новый документ, созданный в шаге 1.
  5. На вкладке Главная в группе Буфер обмена щелкните Вставить.
  6. Повторите шаги 3a – 3e для всех неповрежденных частей документа. Необходимо воссоздать поврежденные части документа.

Способ 8. Переключите представление документа и удалите поврежденное содержимое

В обрезанных документах, в которых отображаются не все страницы, можно переключить представление и удалить поврежденное содержимое.

  1. Определите номер страницы с поврежденным содержимым, из-за которого документ обрезается.

    1. В Word выберите Файл, затем Открыть.
    2. Щелкните поврежденный документ, затем выберите Открыть.
    3. Прокрутите документ до той страницы, после которой он обрезается. Запомните содержимое этой страницы.
  2. Переключите представление документа и удалите поврежденное содержимое.

    1. На вкладке Вид в группе Представления документа выберите элемент Веб-документ или Черновик.
    2. Прокрутите документ и найдите содержимое, после которого он обрезается.
    3. Выделите и удалите следующий абзац, таблицу или объект.
    4. На вкладке Вид в группе Представления документа выберите элемент Режим разметки. Переключайте представления и удаляйте содержимое до тех пор, пока документ не отобразится в полном виде в представлении Режим разметки.
    5. Сохраните документ.

Способ 9: Откройте документ с помощью блокнота

Если документ поврежден и ни один из предыдущих способов не работает, попробуйте восстановить его содержимое, открыв документ с помощью блокнота.

Примечание

Используя этот метод, вы потеряете все форматирование. Целью является восстановление содержимого.

  1. Найдите поврежденный документ с помощью проводника Windows.
  2. Щелкните документ правой кнопкой мыши и выберите Открыть с помощью.
  3. Выберите Блокнот:

Открытие документа Word в блокноте. 4. Документ откроется в Блокноте с дополнительным кодом и текстом вокруг содержимого.

Примечание

Возможно, вам придется изменить тип файла с Текстовые документы (.txt) на Все файлы (.*). 5. Очистите текст, удаляя все или большинство дополнительных знаков. 6. Выберите Файл, затем Сохранить как.... Переименуйте документ, чтобы гарантировать, что вы не перезаписали поврежденный.

Вернитесь к Word и откройте новый документ. Как только документ открыт в Word, вы можете очистить его и попытаться повторно применить утерянный формат.