Подключение Excel к базе данных в базе данных SQL Azure или Управляемый экземпляр SQL Azure и создание отчетаConnect Excel to a database in Azure SQL Database or Azure SQL Managed Instance, and create a report

ОБЛАСТЬ ПРИМЕНЕНИЯ: База данных SQL Azure Управляемый экземпляр SQL Azure

Можно подключить Excel к базе данных, а затем импортировать данные и создать таблицы и диаграммы на основе значений в базе данных.You can connect Excel to a database and then import data and create tables and charts based on values in the database. Работая с этим руководством, вы установите подключение между Excel и таблицей базы данных, сохраните файл, в котором хранятся данные и сведения о соединении для Excel, а затем создадите сводную диаграмму на основе значений базы данных.In this tutorial you will set up the connection between Excel and a database table, save the file that stores data and the connection information for Excel, and then create a pivot chart from the database values.

Прежде чем приступить к работе, необходимо создать базу данных.You'll need to create a database before you get started. Если у вас ее нет, см. статью Создание базы данных в базе данных SQL Azure и Создание брандмауэра IP на уровне сервера для получения базы данных с демонстрационными данными в течение нескольких минут.If you don't have one, see Create a database in Azure SQL Database and Create server-level IP firewall to get a database with sample data up and running in a few minutes.

Следуя инструкциям в этой статье, вы импортируете демонстрационные данные в Excel, но те же действия можно выполнять и с собственными данными.In this article, you'll import sample data into Excel from that article, but you can follow similar steps with your own data.

Вам также понадобится копия Excel.You'll also need a copy of Excel. В этой статье используется Microsoft Excel 2016.This article uses Microsoft Excel 2016.

Подключение к Excel и загрузка данныхConnect Excel and load data

  1. Чтобы подключить Excel к базе данных в базе данных SQL, откройте Excel и создайте новую книгу или откройте существующую книгу Excel.To connect Excel to a database in SQL Database, open Excel and then create a new workbook or open an existing Excel workbook.

  2. В строке меню в верхней части страницы выберите вкладку Данные, нажмите кнопку Получить данные, выберите пункт "Из Azure", а затем — пункт Из базы данных SQL Azure.In the menu bar at the top of the page, select the Data tab, select Get Data, select From Azure, and then select From Azure SQL Database.

    Выбор источника данных: Подключение Excel к базе данных SQL.

  3. В диалоговом окне SQL Server базу данных введите имя сервера , к которому нужно подключиться, в формате <ServerName > . Database.Windows.NET.In the SQL Server database dialog box, type the Server name you want to connect to in the form <servername>.database.windows.net. Пример: msftestserver.database.windows.net.For example, msftestserver.database.windows.net. При необходимости введите имя базы данных.Optionally, enter in the name of your database. Нажмите кнопку ОК, чтобы открыть окно учетных данных.Select OK to open the credentials window.

    Диалоговое окно «Подключение к серверу базы данных»

  4. В диалоговом окне SQL Server базу данных выберите в левой части элемент база данных , а затем введите имя пользователя и пароль для сервера, к которому вы хотите подключиться.In the SQL Server database dialog box, select Database on the left side, and then enter in your User Name and Password for the server you want to connect to. Нажмите кнопку Подключиться, чтобы открыть навигатор.Select Connect to open the Navigator.

    Ввод имени сервера и учетных данных для входа

    Совет

    В зависимости от сетевой среды подключение может оказаться невозможным, или если сервер не разрешает трафик с IP-адреса клиента.Depending on your network environment, you may not be able to connect or you may lose the connection if the server doesn't allow traffic from your client IP address. Перейдите на портал Azure, щелкните "Серверы SQL Server", выберите свой сервер, в разделе "Параметры" щелкните "Брандмауэр" и добавьте IP-адрес клиента.Go to the Azure portal, click SQL servers, click your server, click firewall under settings and add your client IP address. Дополнительные сведения см. в статье Настройка правила брандмауэра уровня сервера базы данных SQL Azure с помощью портала Azure.See How to configure firewall settings for details.

  5. В навигаторе выберите в списке нужную базу данных, выберите нужные таблицы или представления (мы выбрали vGetAllCategories), а затем нажмите кнопку Загрузить, чтобы перенести данные из базы данных в электронную таблицу Excel.In the Navigator, select the database you want to work with from the list, select the tables or views you want to work with (we chose vGetAllCategories), and then select Load to move the data from your database to your Excel spreadsheet.

    Выберите базу данных и таблицу.

Импорт данных в Excel и создание сводной диаграммыImport the data into Excel and create a pivot chart

Теперь, когда вы установили подключение, вы можете загрузить данные несколькими способами.Now that you've established the connection, you have several different options with how to load the data. Например, следующие шаги создают сводную диаграмму на основе данных, найденных в базе данных в базе данных SQL.For example, the following steps create a pivot chart based on the data found in your database in SQL Database.

  1. Выполните действия из предыдущего раздела, но на этот раз не нажимайте кнопку Загрузить, а выберите пункт Загрузить в из раскрывающегося списка Загрузить.Follow the steps in the previous section, but this time, instead of selecting Load, select Load to from the Load drop-down.

  2. Затем выберите способ представления данных в книге.Next, select how you want to view this data in your workbook. Мы выбрали режим Сводная диаграмма.We chose PivotChart. Кроме того, можно создать новый лист или добавить эти сведения в модель данных.You can also choose to create a New worksheet or to Add this data to a Data Model. Дополнительные сведения о моделях данных см. в статье Создание модели данных в Excel.For more information on Data Models, see Create a data model in Excel.

    Выбор формата данных в Excel

    Лист теперь содержит пустую сводную таблицу и диаграмму.The worksheet now has an empty pivot table and chart.

  3. В разделе Поля сводной таблицыустановите все флажки для полей, которые требуется просмотреть.Under PivotTable Fields, select all the check-boxes for the fields you want to view.

    Настройте отчет базы данных.

Совет

Если нужно подключить другие книги и листы Excel к базе данных, на вкладке Данные нажмите кнопку Последние источники, чтобы открыть диалоговое окно Последние источники.If you want to connect other Excel workbooks and worksheets to the database, select the Data tab, and select Recent Sources to launch the Recent Sources dialog box. Выберите в списке ранее созданное подключение и нажмите кнопку Открыть.From there, choose the connection you created from the list, and then click Open. Диалоговое окно «последние источники»Recent Sources dialog box

Создание постоянного подключения с помощью файла ODCCreate a permanent connection using .odc file

Чтобы сохранить сведения о подключении, можно создать файл ODC. После этого подключение можно будет выбирать в диалоговом окне Существующие подключения.To save the connection details permanently, you can create an .odc file and make this connection a selectable option within the Existing Connections dialog box.

  1. В строке меню в верхней части страницы выберите вкладку Данные и нажмите кнопку Существующие подключения, чтобы открыть диалоговое окно Существующие подключения.In the menu bar at the top of the page, select the Data tab, and then select Existing Connections to launch the Existing Connections dialog box.

    1. Нажмите кнопку Найти другие, чтобы открыть диалоговое окно Выбор источника данных.Select Browse for more to open the Select Data Source dialog box.

    2. Выберите файл +Новое подключение к SQL-серверу.odc и нажмите кнопку Открыть, чтобы запустить мастер подключения к данным.Select the +NewSqlServerConnection.odc file and then select Open to open the Data Connection Wizard.

      Диалоговое окно «Создание соединения»

  2. В мастере подключения к данным введите имя сервера и учетные данные для базы данных SQL.In the Data Connection Wizard, type in your server name and your SQL Database credentials. Выберите Далее.Select Next.

    1. В раскрывающемся списке выберите нужную базу данных.Select the database that contains your data from the drop-down.

    2. Выберите нужную таблицу или представление.Select the table or view you're interested in. Мы выбрали vGetAllCategories.We chose vGetAllCategories.

    3. Выберите Далее.Select Next.

      Мастер подключения к данным

  3. На следующем экране мастера подключения к данным выберите расположение файла, имя файла и понятное имя.Select the location of your file, the File Name, and the Friendly Name in the next screen of the Data Connection Wizard. Вы также можете сохранить пароль в файле, но это может сделать данные уязвимыми для несанкционированного доступа.You can also choose to save the password in the file, though this can potentially expose your data to unwanted access. По завершении нажмите кнопку Готово.Select Finish when ready.

    Сохранение подключения к данным

  4. Выберите способ импорта данных.Select how you want to import your data. Мы выбрали создание сводной таблицы.We chose to do a PivotTable. Кроме того, можно изменить свойства подключения, нажав кнопку Свойства.You can also modify the properties of the connection by select Properties. По окончании нажмите кнопку ОК.Select OK when ready. Если вы не сохранили пароль в файле, вам будет предложено ввести учетные данные.If you did not choose to save the password with the file, then you will be prompted to enter your credentials.

    Импорт данных

  5. Проверьте, сохранилось ли новое подключение. Для этого на вкладке Данные нажмите кнопку Существующие подключения.Verify that your new connection has been saved by expanding the Data tab, and selecting Existing Connections.

    Существующее подключение

Дальнейшие шагиNext steps