Устранение неполадок с выставлением счетов CSP с помощью сводных таблиц файлов использования

Эта статья поможет вам устранить неполадки с выставлением счетов для Поставщика облачных речений (CSP) с помощью сводных таблиц в файлах сверки (использования) Центра партнеров. Файлы использования Azure содержат все сведения об использовании и потреблении Azure. Сведения в файле помогут вам понять следующее:

  • Как использовать и применять резервирования Azure.
  • Согласование сведений в службе "Управление затратами" с выставленным счетом
  • Как устранить неполадки со скачком затрат.
  • Как вычислить суммы возмещения для соглашения об уровне обслуживания.

Используя сведения из файлов использования, можно получить более полное представление о проблемах использования и диагностировать их. Файлы использования создаются в формате (CSV) с разделителями-запятыми. Так как файлы использования могут быть большими CSV-файлами, их легче обрабатывать и просматривать как сводные таблицы в приложениях электронных таблиц, таких как Excel. В примерах, приведенных в этой статье, используется Excel, но можно использовать любое приложение для работы с электронными таблицами.

Только администраторы выставления счетов и глобальные администраторы имеют необходимые права доступа для скачивания файлов сверки. Дополнительные сведения см. в разделе Правила чтения позиций строк в файлах сверки Центра партнеров.

Получение данных и их форматирование

Так как файлы использования Azure имеют формат CSV, необходимо подготовить данные для использования в Excel. Чтобы представить эти данные в виде таблицы, выполните следующие действия.

  1. Скачайте файл использования, следуя инструкциям, приведенным в разделе Поиск счета.
  2. Откройте файл в Excel.
  3. Неформатированные данные соответствуют приведенным в следующем примере.
    Пример неформатированных данных в формате Excel
  4. Выберите в таблице первое поле PartnerID.
  5. Нажмите клавиши CTRL + SHIFT + СТРЕЛКА ВНИЗ, а затем CTRL + SHIFT + СТРЕЛКА ВПРАВО, чтобы выбрать все данные в таблице.
  6. В верхнем меню выберите Вставка > Таблица. В поле "Создать таблицу" выберите Таблица с заголовками, а затем нажмите ОК.
    Пример диалогового окна создания таблицы
  7. В верхнем меню выберите Вставка > Сводная таблица, а затем щелкните ОК. Действие создает лист в файле и переходит к области сводной таблицы в правой части листа.
    Пример области полей сводной таблицы

Область полей сводной таблицы — это область перетаскивания. Перейдите к следующему разделу для создания сводной таблицы.

Создание сводной таблицы для просмотра затрат Azure по ресурсам

В рамках этого раздела вы создадите сводную таблицу, в которой можно устранить неполадки общего использования Azure. С помощью примера таблицы можно узнать, какая служба потребляет больше всего ресурсов. Кроме того, можно просмотреть ресурсы с наибольшей стоимостью и узнать, как взимается плата за услугу.

  1. В области полей сводной таблицы перетащите Service Name и Resource в область Строки. Поместите Resource под Service Name.
    Пример, в котором показаны поля Service Name и Resource в области "Строки"
  2. Затем поместите Post-Tax Total в область Значения. Вы также можете использовать столбец Consumed Quantity, чтобы получить сведения о единицах потребления и транзакциях. Например, гигабайты и часы. Или транзакции вместо затрат в разных валютах, таких как USD, EUR и INR.
    Пример столбцов, добавленных в поля сводной таблицы
  3. Теперь у вас есть панель мониторинга для обобщенного исследования потребления. Для конкретной службы можно выполнить фильтрацию с помощью параметров фильтрации в сводной таблице.
    Пример параметра фильтрации сводной таблицы для метки строки Чтобы отфильтровать второй уровень в сводной таблице, например ресурс, выберите элемент второго уровня в таблице. Пример параметров фильтрации для поля выбора
  4. Чтобы использовать дополнительные фильтры, можно добавить столбцы SubscriptionID и Customer Company Name в область Фильтры и выбрать нужную область.

Создание сводной таблицы для просмотра сведений об использовании Azure по датам

В этом разделе описано, как создать сводную таблицу, которая позволит устранить неполадки, связанные с общим использованием Azure, просматривая данные по использованному количеству и дате. Очень полезно выявлять пики в использовании по дате и службе. Кроме того, можно просмотреть ресурсы с наибольшей стоимостью и узнать, как взимается плата за услугу.

Файл сверки содержит две таблицы. Одна расположена сверху (основная таблица), а другая — в нижней части документа. Эта вторая таблица содержит преимущественно ту же информацию, но в ней нет сведений о ценах и затратах. При этом в ней указана дата использования и потребленное количество.

Пример файлов сверки с двумя таблицами данных

  1. Выполните действия, описанные в разделе Получение данных и их форматирование, чтобы создать таблицу Excel с данными в нижней части файла сверки.
  2. Когда таблица будет готова и у вас будет лист сводной таблицы, выполните действия из раздела "Создание сводной таблицы для просмотра затрат Azure по ресурсам", чтобы подготовить панель мониторинга. Вместо того чтобы использовать сумму после уплаты налогов (Post-Tax Total), поместите Consumed quantity в область Значения.
  3. Добавьте Usage Date в раздел столбцов. Сводная таблица должна выглядеть примерно так, как показано в следующем примере.
    Пример итоговых полей сводной таблицы
  4. Теперь у вас есть панель мониторинга, на которой показано использование для каждой даты. Вы можете развернуть каждый месяц, выбрав символ + .

На панели мониторинга отображается потребленное количество единиц, например ГБ, часов и операций передачи.

Чтобы просмотреть цену за день, можно добавить Resource GUID в область Строки. В верхней таблице добавьте цену за единицу (ListPrice) для ресурса. Умножьте ListPrice на Consumed quantity, чтобы вычислить расходы до уплаты налогов. Суммы должны совпадать.

Для некоторых ресурсов (служб) цены могут меняться в зависимости от потребленного количества. Например, для некоторых ресурсов цена за первые потребленные 100 ГБ выше, чем за последующие гигабайты. При расчете затрат вручную учитывайте такое изменение цены в зависимости от потребления.

Создание сводной таблицы для просмотра затрат по определенному ресурсу

По одному ресурсу может взиматься плата за различные службы. Например, виртуальная машина может повлечь за собой оплату службы вычислений, лицензирования ОС, пропускной способности (передачи данных), использования RI и хранения моментальных снимков. При необходимости просмотра общего использования конкретных ресурсов ниже приведены инструкции по созданию панели мониторинга для просмотра общего использования с помощью файлов использования.

Файлы сверки не содержат сведений, касающихся ресурсов. Поэтому применяется агрегированный файл использования. Обратитесь в службу поддержки выставления счетов Azure с просьбой предоставить вам агрегированный файл использования для вашей подписки. Агрегированные файлы создаются на уровне подписки. Неформатированные данные соответствуют приведенным в следующем примере.

Пример неформатированного агрегированного файла использования

Файл содержит следующие столбцы.

  • UsageStart и UsageEnd. Дата для каждой позиции строки (каждой единицы использования). Например, каждый день.
  • MeteredResourceID. В Azure этот параметр соответствует идентификатору единицы измерения.
  • Properties. Содержит идентификатор экземпляра (имя ресурса) вместе с другими сведениями, например расположением.
  • Quantity. Потребленное количество в файле сверки.
  1. Выберите в таблице первое поле PartnerID.
  2. Нажмите клавиши CTRL + SHIFT + СТРЕЛКА ВНИЗ, а затем CTRL + SHIFT + СТРЕЛКА ВПРАВО, чтобы выбрать все данные в таблице.
  3. В верхнем меню выберите Вставка > Таблица. В поле "Создать таблицу" выберите Таблица с заголовками, а затем нажмите ОК.
    Пример диалогового окна создания таблицы
  4. В верхнем меню выберите Вставка > Сводная таблица, а затем щелкните ОК. Действие создает лист в файле и переходит к области сводной таблицы в правой части листа.
    Пример области полей сводной таблицы для файла сверки
  5. Затем добавьте MeteredResourceID в область Строки, а Quantity — в область Значения. Результаты содержат общую информацию об использовании. Для получения дополнительных сведений поместите UsageEndDateTime в область Столбцы.
    Пример общих сведений об использовании
  6. Чтобы просмотреть общий отчет, добавьте Properties в область Строки под MeteredResourceID. Тогда вы сможете просмотреть полную панель мониторинга по использованию.
  7. Чтобы выполнить фильтрацию по определенному ресурсу, добавьте Properties в область Фильтры и выберите нужное использование. Для поиска имени ресурса можно использовать функцию поиска. Чтобы просмотреть затраты на ресурс, найдите общее потребленное количество и умножьте его на цену по прайс-листу. Цена по прайс-листу зависит от идентификатора GUID ресурса (MeteredResourceID). Если ресурс использует несколько идентификаторов MeteredResourceID, необходимо записать общее значение для каждого из них.

Преобразование данных перед применением больших файлов использования

Иногда файл использования или сверки слишком велик для открытия. Или может потребоваться лишь часть информации для устранения проблемы. Например, может потребоваться информация только о конкретном ресурсе или потреблении нескольких служб или групп ресурсов. Перед созданием сводных таблиц можно преобразовать данные для их обобщения.

  1. Откройте пустую книгу в Excel.
  2. В верхнем меню щелкните Данные > Из текстового или CSV-файла, выберите файл использования, а затем нажмите Импорт.
  3. В нижней части окна нажмите кнопку Преобразовать данные. В новом окне отображается сводка по данным.
    Пример отображения сводных данных
  4. Если у вас есть Клиентское соглашение Майкрософт, пропустите этот шаг и переходите к следующему, так как файлы использования MCA обычно содержат заголовки столбцов в первых строках. Подготовьте данные, создав таблицу. Удалите верхние строки, оставляя только заголовки. Выберите Удалить строки > Удалить верхние строки.
    Пример отображения сводных данных
  5. В окне удаления верхних строк введите количество строк, которые нужно удалить в верхней части. Для EA обычно 2, для CSP — 1. Щелкните ОК.
  6. Выберите Использовать первую строку в качестве заголовков.
    Пример отображения сводных данных (категория измерения), Идентификатор экземпляра, Группа ресурсов. Кроме того, в одном документе можно использовать несколько фильтров. Рекомендуется применить все возможные фильтры, чтобы уменьшить размер документа, что поможет в дальнейшей работе.
  7. После применения фильтров выберите Закрыть и загрузить.
    Пример отображения сводных данных

После загрузки файла отображается таблица с отфильтрованными данными об использовании. Теперь можно создать новую сводную таблицу для устранения проблем с использованием.

Дальнейшие действия