Установка модуля PowerShell для AIPService

Область применения: Azure Information Protection, Office 365

К чему относится: клиент унифицированных меток и классический клиент AIP

Примечание

Для унификации и улучшения работы пользователей поддержка классического клиента Azure Information Protection и клиента управления метками на портале Azure прекращается с 31 марта 2021 г. Хотя классический клиент продолжит работать, дальнейшая поддержка предоставляться не будет и версии для обслуживания классического клиента больше не будут выпускаться.

Рекомендуется перейти на унифицированные метки и выполнить обновление до клиента унифицированных меток. Дополнительные сведения см. в недавней записи блога о прекращении использования.

Используйте следующие сведения, чтобы установить модуль Windows PowerShell для службы защиты из Azure Information Protection. Имя этого модуля — Аипсервице, и оно заменяет предыдущую версию с именем AADRM.

Этот модуль PowerShell можно использовать для администрирования службы защиты (Azure Rights Management) из командной строки с помощью любого компьютера Windows, который имеет подключение к Интернету и соответствует предварительным требованиям, перечисленным в следующем разделе. Windows PowerShell для Azure Information Protection поддерживает сценарии для автоматизации или может потребоваться для расширенных сценариев настройки. Дополнительные сведения о задачах администрирования и конфигурациях, поддерживаемых модулем, см. в статье Администрирование защиты из Azure Information Protection с помощью PowerShell.

Предварительные требования

В этой таблице перечислены предварительные требования для установки и использования модуля Аипсервице PowerShell для службы защиты из Azure Information Protection.

Требование Дополнительные сведения
Минимальная версия Windows PowerShell: 3.0 Вы можете проверить свою версию Windows PowerShell, набрав $PSVersionTable в сеансе PowerShell.

Если вам нужно установить более позднюю версию Windows PowerShell, см. раздел Обновление существующей версии Windows PowerShell.
Минимальная версия Microsoft .NET Framework: 4.5

Примечание. Эта версия платформы Microsoft .NET Framework входит в состав более поздних версий операционных систем, поэтому устанавливать ее вручную требуется, только если версия операционной системы клиента ниже, чем Windows 8.0, или если версия операционной системы сервера ниже, чем Windows Server 2012.
Если минимальная версия Microsoft .NET Framework еще не установлена, можно загрузить Microsoft .NET Framework 4,5.

Эта минимальная версия Microsoft .NET Framework необходима для некоторых классов, используемых модулем Аипсервице.

Если установлен модуль AADRM

Модуль Аипсервице заменяет старый модуль AADRM. Если установлен более старый модуль, удалите его, а затем установите модуль Аипсервице.

Новый модуль имеет псевдонимы для имен командлетов в старом модуле, чтобы все существующие сценарии продолжали работать. Однако Запланируйте обновление этих ссылок, прежде чем старый модуль станет неподдерживаемым. Поддержка модуля AADRM будет завершена 15 июля 2020.

Если модуль AADRM был установлен из коллекция PowerShell, то для его удаления запустите сеанс PowerShell с параметром Запуск от имени администратора и введите:

Uninstall-Module -Name AADRM

Если вы установили модуль AADRM с помощью средства администрирования Rights Management Azure, используйте программы и компоненты для удаления Rights Management администрирования Windows Azure AD.

Установка модуля Аипсервице

Модуль Аипсервице находится на коллекция PowerShell и недоступен в центре загрузки Майкрософт.

Если вы впервые используете коллекцию PowerShell, см. раздел Начало работы с коллекцией PowerShell. Следуйте инструкциям по требованиям к коллекции, включающим установку модуля PowerShellGet и поставщика NuGet.

Чтобы просмотреть сведения о модуле Аипсервице на коллекция PowerShell, перейдите на страницу аипсервице.

Чтобы установить модуль Аипсервице, запустите сеанс PowerShell с параметром Запуск от имени администратора и введите:

Install-Module -Name AIPService

Если вас предупредили об установке из ненадежного репозитория, можно нажать клавишу "Y" для подтверждения. Или нажмите клавишу N и настройте коллекция PowerShell как доверенный репозиторий с помощью команды, Set-PSRepository -Name PSGallery -InstallationPolicy Trusted а затем повторно выполните команду, чтобы установить модуль аипсервице.

Если у вас есть предыдущая версия модуля Аипсервице, установленного из коллекции, обновите ее до последней версии, введя:

Update-Module -Name AIPService

Дальнейшие действия

В сеансе Windows PowerShell проверьте версию установленного модуля. Эта проверка особенно важна при обновлении более старой версии:

(Get-Module AIPService –ListAvailable).Version

Примечание

Если эта команда завершается неудачно, сначала выполните команду Import-Module аипсервице.

Чтобы просмотреть список доступных командлетов, введите следующую команду:

Get-Command -Module AIPService

Чтобы получить справку по конкретному командлету, используйте команду Get-Help <cmdlet_name>. Параметр -online позволяет просмотреть актуальную справку на сайте документации Майкрософт. Пример:

Get-Help Connect-AipService -online

Дополнительные сведения

Перед выполнением команд, которые настраивают службу защиты, необходимо подключиться к службе с помощью командлета Connect-аипсервице .

Завершив выполнение команд конфигурации, рекомендуется отключиться от службы с помощью командлета Disconnect-аипсервице . В противном случае после периода бездействия соединение прервется автоматически. Из-за автоматического отключения, возможно, вам потребуется повторно подключиться в сеансе PowerShell.

Примечание

Если служба защиты еще не активирована, это можно сделать после подключения к службе с помощью командлета Enable-аипсервице .