Проекты Visual Studio — C++Visual Studio projects - C++

Проект Visual Studio основан на системе сборки MSBuild.A Visual Studio project is a project based on the MSBuild build system. MSBuild — это собственная система сборки для Visual Studio и, как правило, лучшая система сборки, используемая для специальных программ Windows.MSBuild is the native build system for Visual Studio and is generally the best build system to use for Windows-specific programs. MSBuild тесно интегрирована с Visual Studio, но ее можно использовать и из командной строки.MSBuild is tightly integrated with Visual Studio, but you can also use it from the command line. Для межплатформенных проектов или проектов, использующих библиотеки с открытым исходным кодом, рекомендуется использовать проекты CMake в Visual Studio в Visual Studio 2017 и более поздних версиях.For cross-platform projects, or projects that use open-source libraries, we recommend using CMake projects in Visual Studio in Visual Studio 2017 and later. Сведения об обновлении проектов MSBuild, созданных в более старых версиях Visual Studio, см. в руководстве по переносу и обновлению Microsoft C++.For information about upgrading MSBuild projects from older versions of Visual Studio, see the Microsoft C++ Porting and Upgrading Guide.

Создание проектаCreate a project

Чтобы создать проект C++, выберите Файл > Создать > Проект и настройте Язык C++.You can create C++ projects by choosing File > New > Project, then setting the Language to C++. В списке результатов появится список шаблонов проектов, которые можно фильтровать по платформе или типу проекта или введя ключевые слова в поле поиска.In the results list you see a list of project templates which you can filter by setting the Platform or Project Type and by typing keywords into the search box.

Шаблоны проектов Visual Studio 2019Visual Studio 2019 Project Templates

Чтобы создать проект C++, выберите Файл > Создать > Проект и выберите Visual C++ на панели слева.You can create C++ projects by choosing File > New > Project, then choosing Visual C++ in the left pane. В центральной области появится список шаблонов проекта:In the center pane you see a list of project templates:

Шаблоны проектовProject Templates

Дополнительные сведения о шаблонах проектов по умолчанию, которые входят в состав Visual Studio, см. в статье Шаблоны проектов C++ в Visual Studio.For more information about all the default project templates that are included in Visual Studio, see C++ project templates in Visual Studio. Вы можете создавать собственные шаблоны проектов.You can create your own project templates. Дополнительные сведения см. в разделе Практическое руководство. Создание шаблонов проектов.For more information, see How to: Create project templates.

После создания проект отображается в окне обозревателя решений:After you create a project, it appears in the Solution Explorer window:

обозреватель решений

При создании нового проекта также создается файл решения (SLN).When you create a new project, a solution file (.sln) is also created. Вы можете добавить дополнительные проекты в решение, щелкнув его правой кнопкой мыши в обозревателе решений.You can add additional projects to the solution by right-clicking on it in Solution Explorer. Файл решения используется для координации зависимостей сборки, если у вас несколько связанных проектов, но не выполняет других функций.The solution file is used to coordinate build dependencies when you have multiple related projects but doesn't do much more than that. Все параметры компилятора задаются на уровне проекта.All the compiler options are set at the project level.

Добавление элементовAdd items

Добавьте файлы исходного кода, значки или любые другие элементы в проект, щелкнув правой кнопкой мыши проект в обозревателе решений и выбрав Добавить > Новый или Добавить > Существующий.Add source code files, icons, or any other items to your project by right-clicking on the project in Solution Explorer and choosing Add > New or Add > Existing.

Добавление сторонних библиотекAdd third party libraries

Чтобы добавить сторонние библиотеки, используйте диспетчер пакетов vcpkg.To add third-party libraries, use the vcpkg package manager. Выполните шаг интеграции Visual Studio для настройки путей к библиотеке, когда вы ссылаетесь на нее из любого проекта Visual Studio.Run the Visual Studio integration step to set up the paths to that library when you reference it from any Visual Studio project.

Установка параметров компилятора и других свойств сборкиSet compiler options and other build properties

Чтобы настроить параметры сборки для проекта, в обозревателе решений щелкните проект правой кнопкой мыши и выберите пункт Свойства.To configure build settings for a project, right-click on the project in Solution Explorer and choose Properties. Подробнее см. в статье Настройка компилятора C++ и свойств сборки в Visual Studio.For more information, see Set C++ compiler and build properties in Visual Studio.

Компиляция и запускCompile and run

Чтобы скомпилировать и запустить новый проект, нажмите клавишу F5 или откройте раскрывающийся список отладки с зеленой стрелкой на главной панели инструментов.To compile and run the new project, press F5 or click the debug dropdown with the green arrow on the main toolbar. В раскрывающемся списке конфигурации можно выбрать, следует ли выполнять сборку Отладка или Выпуск (или другую пользовательскую конфигурацию).The configuration dropdown is where you choose whether to perform a Debug or Release build (or some other custom configuration).

Новый проект компилируется без ошибок.A new project compiles without errors. При добавлении собственного кода иногда возникают ошибки или предупреждения.When adding your own code, you may occasionally introduce an error or trigger a warning. Ошибка мешает завершению сборки, а предупреждение — нет.An error prevents the build from completing; a warning does not. Все ошибки и предупреждения будут отображаться в окне вывода и в списке ошибок при сборке проекта.All errors and warnings will appear both in the Output Window and in the Error List when you build the project.

Окно вывода и список ошибок

В списке ошибок можно нажать клавишу F1 на выделенной ошибке, чтобы перейти в раздел документации о ней.In the Error List, you can press F1 on a highlighted error to go to its documentation topic.

В этом разделеIn This Section

Настройка компилятора C++ и свойства сборки в Visual StudioSet C++ compiler and build properties in Visual Studio
Как использовать страницы свойств и листы свойств для указания параметров проекта.How to use Property Pages and Property Sheets to specify your project settings.

Использование эталонных библиотек и компонентов во время сборкиReference libraries and components at build time
Как включить в проект компоненты библиотек DLL, COM и .NET.How to include libs, DLLs, COM and .NET components in a project.

Упорядочение выходных файлов проектаOrganize Project Output Files
Как настроить расположение исполняемых файлов, созданных в процессе сборки.How to customize the location of the executable files created in the build process.

Настраиваемые этапы сборки и события сборкиCustom Build Steps and Build Events
Как добавить любую произвольную команду к процессу сборки с указанными точками.How to add any arbitrary command to the build process at specified points.

Создание проекта на основе имеющегося кодаCreate a project from existing code
Как создать новый проект Visual Studio из свободной коллекции исходных файлов.How to create a new Visual Studio project from a loose collection of source files.

См. такжеSee also

Проекты и системы сборкиProjects and build systems
Руководство по переносу и обновлению Microsoft C++Microsoft C++ Porting and Upgrading Guide