Пошаговое руководство. Развертывание программы (C++)Walkthrough: Deploying Your Program (C++)

Теперь, когда вы создали свое приложение, выполнив описанные ранее пошаговые руководства, необходимо выполнить последний шаг — создать установщик, чтобы другие пользователи могли установить программу на своих компьютерах.Now that you've created your application by completing the earlier related walkthroughs, the last step is to create an installer so that other users can install the program on their computers. Для создания установщика следует добавить новый проект в имеющееся решение.For the installer, you'll add a new project to your existing solution. Выходным файлом этого проекта будет являться файл setup.exe, который служит для установки приложения на другом компьютере.The output of this new project is a setup.exe file that will install your app on another computer.

В этом пошаговом руководстве показано, как развернуть приложение с помощью установщика Windows.The walkthrough shows how to use Windows Installer to deploy your application. Кроме того, для развертывания приложения может использоваться ClickOnce.You can also use ClickOnce to deploy an application. Дополнительные сведения см. в разделе ClickOnce Deployment for Visual C++ Applications.For more information, see ClickOnce Deployment for Visual C++ Applications. Дополнительные общие сведения о развертывании см. в разделе Развертывание приложений, служб и компонентов.For more information about deployment in general, see Deploying Applications, Services, and Components.

Предварительные требованияPrerequisites

Установка шаблона проекта установки и развертывания Visual StudioInstall the Visual Studio setup and deployment project template

Инструкции в этом разделе отличаются в зависимости от установленной версии Visual Studio.The steps in this section vary depending on which version of Visual Studio you have installed. Чтобы ознакомиться с документацией по предпочтительной версии Visual Studio, используйте селектор Версия.To see the documentation for your preferred version of Visual Studio, use the Version selector control. Он находится в верхней части оглавления на этой странице.It's found at the top of the table of contents on this page.

Установка шаблона проекта установки и развертывания для Visual Studio 2019To install the setup and deployment project template for Visual Studio 2019

  1. Если вы еще не скачали расширение проектов Microsoft Visual Studio Installer, сделайте это сейчас.If you haven't already done so, download the Microsoft Visual Studio Installer Projects extension. Это расширение предоставляется использующим Visual Studio разработчикам бесплатно. Оно добавляет в Visual Studio функции шаблонов для проектов установки и развертывания.The extension is free for Visual Studio developers and adds the functionality of the setup and deployment project templates to Visual Studio. Если вы подключены к Интернету, выберите в Visual Studio Расширения > Управление расширениями.When you're connected to the Internet, in Visual Studio, choose Extensions > Manage Extensions. В диалоговом окне Расширения и обновления выберите вкладку В сети и введите в поле поиска строку проекты установщика Microsoft Visual Studio.Under the Extensions and Updates dialog, select the Online tab and type Microsoft Visual Studio Installer Projects in the search box. Нажмите клавишу ВВОД, выберите Проекты Microsoft Visual Studio <version> Installer и щелкните Скачать.Hit Enter, select Microsoft Visual Studio <version> Installer Projects, and click Download. Выберите запуск и установку расширения, а затем перезапустите Visual Studio.Choose to run and install the extension, then restart Visual Studio.

  2. В строке меню Visual Studio последовательно выберите Файл > Последние проекты и решения, а затем действие открытия проекта.On the Visual Studio menu bar, choose File > Recent Projects and Solutions, and then choose to reopen your project.

  3. В строке меню выберите Файл > Создать > Проект, чтобы открыть диалоговое окно Создание проекта.On the menu bar, choose File > New > Project to open the Create a New Project dialog box. В поле поиска введите "Установка" и выберите в списке результатов пункт Проект установки.In the search box, type "Setup" and from the results list choose Setup Project.

  4. В поле Имя введите имя проекта установки.Enter a name for the setup project in the Name box. В раскрывающемся списке Решение выберите пункт Добавить в решение.In the Solution drop-down list, select Add to solution. Нажмите кнопку ОК, чтобы создать проект установки.Choose the OK button to create the setup project. В окне редактора откроется вкладка File Assistant (ProjectName) (Помощник по файлам (имя проекта)).A File Assistant (ProjectName) tab opens in the editor window.

  5. Щелкните правой кнопкой мыши узел Папка приложения и последовательно выберите Добавить > Выходной элемент проекта, чтобы открыть диалоговое окно Добавление выходной группы проекта.Right-click the Application Folder node and select Add > Project Output to open the Add Project Output Group dialog box.

  6. В этом диалоговом окне выберите Основные выходные файлы и щелкните OK.In the dialog box, select Primary Output and click OK. Появится новый элемент с именем Primary Output from Game (Active) (Основные выходные файлы игры (активно)).A new item named Primary Output from Game (Active) appears.

  7. Выберите этот элемент Primary Output from Game (Active) (Основные выходные файлы игры (активно)), щелкните его правой кнопкой мыши и выберите пункт Create Shortcut to Primary Output from Game (Active) (Создать ярлык на основные выходные файлы игры (активно)).Select the item Primary Output from Game (Active), right-click and choose Create Shortcut to Primary Output from Game (Active). Появится новый элемент с именем Shortcut to Primary Output from Game (Active) (Ярлык на основные выходные файлы игры (активно)).A new item named Shortcut to Primary Output from Game (Active) appears.

  8. Присвойте этому ярлыку имя Игра, затем перетащите его в узел User's Programs Menu (Пользовательское меню "Программы") в левой части окна.Rename the shortcut item to Game, then drag and drop the item into the User's Programs Menu node on the left side of the window.

  9. В обозревателе решений выберите проект Установщик игры, а затем Представление > Окно "Свойства" или нажмите клавишу F4, чтобы открыть окно Свойства.In Solution Explorer, select the Game Installer project and choose View > Properties Window or hit F4 to open the Properties window.

  10. Укажите дополнительные сведения, которые вы хотите отображать в установщике.Specify additional details as you want them to appear in the installer. Например, укажите Contoso в поле Производитель, Установщик игры в поле Название продукта и https://www.contoso.com в поле SupportUrl (URL-адрес поддержки).For example, use Contoso for Manufacturer, Game Installer for Product Name, and https://www.contoso.com for SupportUrl.

  11. В строке меню последовательно выберите пункты Сборка > Диспетчер конфигураций.On the menu bar, choose Build > Configuration Manager. В таблице Проект установите флажок в столбце Сборка для элемента Установщик игры.In the Project table, under the Build column, check the box for Game Installer. Щелкните Закрыть.Click Close.

  12. В строке меню выберите Сборка > Собрать решение, чтобы выполнить сборку проекта "Игра" и проекта "Установщик игры".On the menu bar, choose Build > Build Solution to build the Game project and the Game Installer project.

  13. В папке решения найдите программу setup.exe, собранную из проекта "Установщик игры", и запустите ее, чтобы установить приложение "Игра" на компьютере.In the solution folder, locate the setup.exe program that was built from the Game Installer project, and then run it to install the Game application on your computer. Можно скопировать этот файл (вместе с GameInstaller.msi), чтобы установить приложение и все необходимые файлы библиотеки на другом компьютере.You can copy this file (and GameInstaller.msi) to install the application and its required library files on another computer.

Установка шаблона проекта установки и развертывания для Visual Studio 2017 и более ранних версийTo install the setup and deployment project template for Visual Studio 2017 and earlier

  1. Если вы подключены к Интернету, выберите в Visual Studio Сервис > Расширения и обновления.When you're connected to the Internet, in Visual Studio, choose Tools > Extensions and Updates.

  2. В разделе Расширения и обновления выберите вкладку В Интернете и введите в поле поиска строку проекты установщика Microsoft Visual Studio.Under Extensions and Updates, select the Online tab and type Microsoft Visual Studio Installer Projects in the search box. Нажмите клавишу ВВОД, выберите Проекты Microsoft Visual Studio <version> Installer и щелкните Скачать.Hit Enter, select Microsoft Visual Studio <version> Installer Projects, and click Download.

  3. Выберите установку расширения, а затем перезапустите Visual Studio.Choose to install the extension, then restart Visual Studio.

  4. В строке меню последовательно выберите Файл > Последние проекты и решения и щелкните решение Игра, чтобы снова открыть его.On the menu bar, choose File > Recent Projects and Solutions, and then choose the Game solution to reopen it.

Создание проекта установки и установка программыTo create a setup project and install your program

  1. Измените активную конфигурацию решения, указав значение Выпуск.Change the active solution configuration to Release. В строке меню последовательно выберите пункты Сборка > Диспетчер конфигураций.On the menu bar, choose Build > Configuration Manager. В диалоговом окне Диспетчер конфигураций выберите в раскрывающемся списке Активная конфигурация решения пункт Выпуск.In the Configuration Manager dialog box, on the Active solution configuration drop-down list, select Release. Нажмите кнопку Закрыть, чтобы сохранить конфигурацию.Choose the Close button to save the configuration.

  2. В строке меню последовательно выберите пункты Файл > Создать > Проект, чтобы открыть диалоговое окно Новый проект.On the menu bar, choose File > New > Project to open the New Project dialog box.

  3. В левой области диалогового окна разверните узлы Установленные > Другие типы проектов, а затем выберите пункт Visual Studio Installer.In the left pane of the dialog box, expand the Installed > Other Project Types nodes, and then select Visual Studio Installer. В центральной области выберите Настройка проекта.In the center pane, select Setup Project.

  4. В поле Имя введите имя проекта установки.Enter a name for the setup project in the Name box. Для этого примера введите Установщик игры.For this example, enter Game Installer. В раскрывающемся списке Решение выберите пункт Добавить в решение.In the Solution drop-down list, select Add to solution. Нажмите кнопку ОК, чтобы создать проект установки.Choose the OK button to create the setup project. В окне редактора откроется вкладка File Assistant (Game Installer) (Помощник по файлам (установщик игры)).A File Assistant (Game Installer) tab opens in the editor window.

  5. Щелкните правой кнопкой мыши узел Папка приложения и последовательно выберите Добавить > Выходной элемент проекта, чтобы открыть диалоговое окно Добавление выходной группы проекта.Right-click the Application Folder node and select Add > Project Output to open the Add Project Output Group dialog box.

  6. В этом диалоговом окне выберите Основные выходные файлы и щелкните OK.In the dialog box, select Primary Output and click OK. Появится новый элемент с именем Primary Output from Game (Active) (Основные выходные файлы игры (активно)).A new item named Primary Output from Game (Active) appears.

  7. Выберите этот элемент Primary Output from Game (Active) (Основные выходные файлы игры (активно)), щелкните его правой кнопкой мыши и выберите пункт Create Shortcut to Primary Output from Game (Active) (Создать ярлык на основные выходные файлы игры (активно)).Select the item Primary Output from Game (Active), right-click and choose Create Shortcut to Primary Output from Game (Active). Появится новый элемент с именем Shortcut to Primary Output from Game (Active) (Ярлык на основные выходные файлы игры (активно)).A new item named Shortcut to Primary Output from Game (Active) appears.

  8. Присвойте этому ярлыку имя Игра, затем перетащите его в узел User's Programs Menu (Пользовательское меню "Программы") в левой части окна.Rename the shortcut item to Game, then drag and drop the item into the User's Programs Menu node on the left side of the window.

  9. В обозревателе решений выберите проект Установщик игры, а затем Представление > Окно "Свойства" или нажмите клавишу F4, чтобы открыть окно Свойства.In Solution Explorer, select the Game Installer project and choose View > Properties Window or hit F4 to open the Properties window.

  10. Укажите дополнительные сведения, которые вы хотите отображать в установщике.Specify additional details as you want them to appear in the installer. Например, укажите Contoso в поле Производитель, Установщик игры в поле Название продукта и https://www.contoso.com в поле SupportUrl (URL-адрес поддержки).For example, use Contoso for Manufacturer, Game Installer for Product Name, and https://www.contoso.com for SupportUrl.

  11. В строке меню последовательно выберите пункты Сборка > Диспетчер конфигураций.On the menu bar, choose Build > Configuration Manager. В таблице Проект установите флажок в столбце Сборка для элемента Установщик игры.In the Project table, under the Build column, check the box for Game Installer. Щелкните Закрыть.Click Close.

  12. В строке меню выберите Сборка > Собрать решение, чтобы выполнить сборку проекта "Игра" и проекта "Установщик игры".On the menu bar, choose Build > Build Solution to build the Game project and the Game Installer project.

  13. В папке решения найдите программу setup.exe, собранную из проекта "Установщик игры", и запустите ее, чтобы установить приложение "Игра" на компьютере.In the solution folder, locate the setup.exe program that was built from the Game Installer project, and then run it to install the Game application on your computer. Можно скопировать этот файл (вместе с GameInstaller.msi), чтобы установить приложение и все необходимые файлы библиотеки на другом компьютере.You can copy this file (and GameInstaller.msi) to install the application and its required library files on another computer.

Next StepsNext Steps

Предыдущий: Пошаговое руководство. Отладка проекта (C++)Previous: Walkthrough: Debugging a Project (C++)

См. такжеSee also

Справочник по языку C++C++ Language Reference
Проекты и системы сборкиProjects and build systems
Развертывание классических приложенийDeploying Desktop Applications