Редакторы ресурсов (C++)Resource Editors (C++)

Редактор ресурсов — это специализированная среда для создания или изменения ресурсов, включенных в проект Visual Studio.A resource editor is a specialized environment for creating or modifying resources that are included in a Visual Studio project. Редакторы ресурсов Visual Studio используют общий набор способов и интерфейсов, упрощая и ускоряя создание и изменение ресурсов приложения.The Visual Studio resource editors share techniques and interfaces to help you create and modify application resources quickly and easily. Редакторы ресурсов позволяют просматривать и изменять ресурсы в соответствующем редакторе, а также предварительно просматривать ресурсы.Resource editors enable you to view and edit resources in the appropriate editor and preview resources.

Соответствующий редактор открывается автоматически при создании или открытии ресурса.The appropriate editor opens automatically when you create or open a resource.

Примечание

Так как управляемые проекты не используют файлы скриптов ресурсов, необходимо открыть ресурсы из Обозреватель решений.Because managed projects do not use resource script files, you must open your resources from Solution Explorer. Для работы с файлами ресурсов в управляемых проектах можно использовать Редактор изображений и двоичный редактор .You can use the Image Editor and the Binary Editor to work with resource files in managed projects. Все управляемые ресурсы, которые нужно редактировать, должны быть связанными ресурсами.Any managed resources you want to edit must be linked resources. Редакторы ресурсов Visual Studio не поддерживают редактирование внедренных ресурсов.The Visual Studio resource editors do not support editing embedded resources.

РедакторUse the... Редактируемый элементTo edit...
Редактор сочетаний клавишAccelerator Editor Таблицы сочетаний клавиш в проектах Visual Studio C++.Accelerator tables in Visual Studio C++ projects.
Двоичный редакторBinary Editor Двоичные данные и настраиваемые ресурсы в проектах Visual C++, Visual Basic или Visual C#Binary data information and custom resources in Visual C++, Visual Basic, or Visual C# projects.
Редактор диалоговых оконDialog Editor Диалоговые окна в проектах Visual Studio C++.Dialog boxes in Visual Studio C++ projects.
Image EditorImage Editor Точечные рисунки, значки, курсоры и другие файлы изображений в проектах Visual C++, Visual Basic или Visual C#Bitmaps, icons, cursors, and other image files in Visual C++, Visual Basic, or Visual C# projects.
Редактор менюMenu Editor Ресурсы меню в проектах Visual Studio C++.Menu resources in Visual Studio C++ projects.
Редактор ленты (Ribbon)Ribbon Editor Ресурсы ленты в проектах MFCRibbon resources in MFC projects.
Редактор строкString Editor Таблицы строк в проектах Visual Studio C++.String tables in Visual Studio C++ projects.
Редактор панелей инструментовToolbar Editor Ресурсы панели инструментов в проектах Visual Studio C++.Toolbar resources in Visual Studio C++ projects. Редактор панелей инструментов является частью редактора изображений.The Toolbar Editor is part of the Image Editor.
Редактор сведений о версииVersion Information Editor Сведения о версии в проектах Visual Studio C++.Version information in Visual Studio C++ projects.

Примечание

Если в проекте еще нет RC-файла, см. раздел как создать ресурсы.If your project doesn't already contain an .rc file, see How to: Create Resources.

Просмотр и изменение ресурсовView and Edit Resources

Каждый тип ресурса имеет редактор ресурсов, относящийся к этому типу ресурса.Each resource type has a resource editor specific to that resource type. Вы можете изменить расположение, размер, добавить элементы управления и компоненты или иным образом изменять аспекты ресурса с помощью соответствующего редактора.You can rearrange, resize, add controls and features, or otherwise modify aspects of a resource using the associated editor. Можно также изменить ресурс в текстовом формате и в двоичном формате.You can also edit a resource in text format and binary format. Дополнительные сведения см. в разделе инструкции. Создание ресурсов.For more information, see How to: Create Resources.

Некоторые типы ресурсов — это отдельные файлы, которые можно импортировать и использовать различными способами. к ним относятся точечные рисунки, значки, курсоры, панели инструментов и HTML-файлы.Some resource types are individual files that can be imported and used in various ways; these include bitmaps, icons, cursors, toolbars, and html files. Такие ресурсы имеют имена файлов и идентификаторы ресурсов.Such resources have file names and resource identifiers. Другие, такие как диалоговые окна, меню и таблицы строк в проектах Win32, существуют только как часть файла скрипта ресурсов (RC) или файла шаблона ресурса (. RCT).Others, such as dialogs, menus, and string tables in Win32 projects, exist only as part of a resource script (.rc) file or resource template (.rct) file.

Ресурсы также можно редактировать вне проекта, не открывая проект.Resources can also be edited outside of the project without having the project open. Дополнительные сведения см. в разделе инструкции. Создание ресурсов.For more information, see How to: Create Resources.

Примечание

Свойства ресурса можно изменить с помощью окна Свойства .Properties of a resource can be modified using the Properties window.

  • Чтобы изменить свойства ресурса, в представление ресурсовщелкните правой кнопкой мыши ресурс, который нужно изменить, и выберите пункт свойства.To edit the properties of a resource, in Resource View, right-click the resource you want to edit and choose Properties. Затем в окно свойствизмените свойства ресурса.Then, in the Properties window, change the properties of your resource.

  • Чтобы отменить изменения, внесенные в свойства ресурса, убедитесь, что ресурс имеет фокус в представление ресурсов и выберите команду отменить в меню Правка .To undo a change made to the properties of a resource, make sure your resource has focus in Resource View and choose Undo from the Edit menu.

Ресурсы Win32Win32 Resources

Доступ к ресурсам Win32 можно получить в области представление ресурсов .You can access Win32 resources in the Resource View pane.

Просмотр ресурса Win32 в редакторе ресурсовTo view a Win32 resource in a resource editor

  1. Последовательно выберите пункты меню Просмотреть > другие > представление ресурсов Windows.Go to menu View > Other Windows > Resource View.

  2. Если окно представление ресурсов не является самым верхним, выберите вкладку представление ресурсов , чтобы отобразить ее вверху.If the Resource View window isn't the top-most window, select the Resource View tab to bring it to the top.

  3. В представление ресурсов разверните папку для проекта, содержащего ресурсы, которые требуется просмотреть.From Resource View, expand the folder for the project that contains resources you want to view. Например, если требуется просмотреть ресурс диалогового окна, разверните папку «диалог ».For example, if you want to view a dialog resource, expand the Dialog folder.

  4. Дважды щелкните ресурс, например IDD_ABOUTBOX.Double-click the resource, for example, IDD_ABOUTBOX.

    Ресурс открывается в соответствующем редакторе.The resource opens in the appropriate editor. Например, для диалоговых ресурсов ресурс открывается в редакторе диалоговых окон.For example, for dialog resources, the resource opens inside the Dialog Editor.

Удаление существующего ресурса Win32To delete an existing Win32 resource

  1. В представление ресурсов разверните узел типа ресурса.In Resource View, expand the node for a resource type.

  2. Щелкните правой кнопкой мыши ресурс, который необходимо удалить, и выберите пункт Удалить.Right-click on the resource you want to delete and choose Delete.

Совет

Этот метод также можно использовать при открытии RC-файла в окне документа за пределами проекта.You can also use this method when you have the .rc file open in a document window outside a project.

Ресурсы управляемого проектаManaged Project Resources

Так как управляемые проекты не используют файлы скриптов ресурсов, необходимо открыть ресурсы из Обозреватель решений.Because managed projects don't use resource script files, you must open your resources from Solution Explorer. Используйте Редактор изображений и двоичный редактор для работы с файлами ресурсов в управляемых проектах.Use the Image Editor and the Binary Editor to work with resource files in managed projects. Все управляемые ресурсы, которые требуется изменить, должны быть связанными ресурсами, а редакторы ресурсов Visual Studio не поддерживают изменение внедренных ресурсов.Any managed resources you want to edit must be linked resources and Visual Studio resource editors don't support editing embedded resources.

  • Чтобы просмотреть управляемый ресурс в редакторе ресурсов, в Обозреватель решений дважды щелкните ресурс, например Bitmap1.bmp, и ресурс откроется в соответствующем редакторе.To view a managed resource in a resource editor, in Solution Explorer, double-click the resource, for example, Bitmap1.bmp, and the resource opens in the appropriate editor.

  • Чтобы удалить существующий управляемый ресурс, в Обозреватель решений щелкните правой кнопкой мыши ресурс, который нужно удалить, и выберите пункт Удалить.To delete an existing managed resource, in Solution Explorer, right-click the resource you want to delete and choose Delete.

Предварительный просмотр ресурсовPreview Resources

Предварительный просмотр ресурсов позволяет просматривать графические ресурсы, не открывая их.Preview your resources to allow you to view graphical resource without opening them. Предварительный просмотр также полезен для исполняемых файлов после их компиляции, так как идентификаторы ресурсов изменяются числами.Previewing is also useful for executables after you've compiled them, because the resource identifiers change to numbers. Поскольку эти числовые идентификаторы часто не содержат достаточно информации, предварительный просмотр ресурсов поможет быстро их найти.Since these numeric identifiers often don't provide enough information, previewing the resources helps you quickly identify them.

Следующие типы ресурсов предоставляют предварительный просмотр визуального макета: точечный рисунок, диалоговое окно, значок, меню, курсор, панель инструментовThe following resource types provide a visual layout preview: Bitmap, Dialog, Icon, Menu, Cursor, Toolbar

Следующие ресурсы не предоставляют визуальную предварительную версию: ускоритель, манифест, таблицу строк, сведения о версииThe following resources don't provide a visual preview: Accelerator, Manifest, String Table, Version Information

Примечание

Для предварительного просмотра ресурсов требуется Win32.To preview resources requires Win32.

Предварительный просмотр ресурсовTo preview resources

  1. В представление ресурсов или окне документа выберите ресурс, например IDD_ABOUTBOX.In Resource View or a document window, select your resource, for example, IDD_ABOUTBOX.

  2. В окно свойствнажмите кнопку страницы свойств .In the Properties window, select the Property Pages button.

    Совет

    Используйте ярлык, перейдите в меню Просмотр > страниц свойств.Use a shortcut, go to menu View > Property Pages.

    Откроется страница свойств ресурса, в которой отображается Предварительная версия этого ресурса.The Property page for the resource opens displaying a preview of that resource. Можно использовать клавиши со стрелками вверх и вниз для навигации по элементу управления "дерево" в представление ресурсов или в окне документа.You can use the Up and Down arrow keys to navigate the tree control in Resource View or the document window. Страница свойств останется открытой и отобразит все ресурсы, которые находятся в фокусе и доступны для предварительного просмотра.The Property page will stay open and show any resource that has focus and can be previewed.

ТребованияRequirements

НетNone

См. также разделSee also

Работа с файлами ресурсовWorking with Resource Files
Файлы ресурсовResource Files
Идентификаторы ресурсов (символы)Resource Identifiers (Symbols)