Установка .NET Framework для разработчиков

Платформа .NET является неотъемлемой частью многих приложений, выполняющихся в операционной системе Windows, и предоставляет общие функциональные возможности для выполнения этих приложений. С точки зрения разработчиков платформа .NET предоставляет полную и согласованную модель программирования для разработки приложений с великолепным пользовательским интерфейсом и простым и безопасным обменом данными.

Примечание

Эта статья предназначена для разработчиков, которые хотят установить .NET Framework в собственной системе, или для тех, кто хочет установить платформу вместе со своими приложениями. Сведения об установке .NET Framework приводятся в специальных статьях об установке .NET Framework в определенных операционных системах, например в разделе Установка платформы .NET Framework в Windows 10 и Windows Server 2016.

В этой статье содержатся ссылки для установки всех версий платформы .NET Framework с .NET Framework 4.5 до .NET Framework 4.8 на компьютере. Разработчики могут использовать эти ссылки для загрузки и распространения .NET Framework вместе со своими приложениями. Подробные сведения о развертывании версии .NET Framework в приложении см. в статье Руководство по развертыванию .NET Framework для разработчиков.

Важно!

Содержимое платформы .NET Framework, подписанное ранее с помощью сертификатов, использующих алгоритм SHA1, перестанет использоваться, чтобы поддержать развитие отраслевых стандартов.

Следующие версии платформы .NET Framework достигнут окончания поддержки 26 апреля 2022 г. : 4.5.2, 4.6 и 4.6.1. После этой даты исправления безопасности, обновления и техническая поддержка для этих версий предоставляться не будут.

Если вы используете платформу .NET Framework 4.5.2, 4.6 или 4.6.1, обновите развернутую среду выполнения до более новой версии, например .NET Framework 4.6.2 до 26 апреля 2022 г. , чтобы продолжить получать обновления и техническую поддержку.

Для версий .NET Framework 3.5 SP1 и 4.6.2–4.8 будут доступны обновленные установщики, подписанные с использованием SHA2. Дополнительные сведения см. в плане прекращения использования SHA1, записи блога, посвященной обновлению жизненного цикла .NET 4.5.2, 4.6 и 4.6.1 и часто задаваемых вопросах.

Важно!

В системе может быть только одна версия 4.х, так как все версии .NET Framework, начиная с версии .NET Framework 4, — это локальные обновления. Кроме того, некоторые версии платформы .NET Framework предустанавливаются в некоторые версии операционной системы Windows. Это означает следующее:

  • Если на компьютере установлена более поздняя версия 4.x, вы не сможете установить предыдущую версию 4.x.
  • Если в операционной системе предустановлена определенная версия .NET Framework, вы не сможете установить предыдущую версию 4.x на том же компьютере.
  • При установке более поздней версии не нужно удалять предыдущую версию.

Дополнительные сведения о версиях .NET Framework и определении установленной версии на компьютере см. в разделах Версии и зависимости и Практическое руководство. Определение установленных версий платформы .NET Framework.

Примечание

Сведения о .NET Framework 3.5 см. в разделе Установка платформы .NET Framework 3.5 в Windows 11, Windows 10, Windows 8.1 и Windows 8.

В следующей таблице вы найдете полезные ссылки, а далее в документе — другую нужную информацию. Чтобы просмотреть требования к системе для .NET Framework перед установкой, ознакомьтесь с разделом Требования к системе. Справочные сведения по устранению неполадок см. в разделе Устранение неполадок.

Версия платформы .NET Framework Установщик (пакет разработчика и среда выполнения) Поддержка платформ
4.8 .NET Framework 4.8 Входит в состав:

Windows 11
Обновление Windows 10 за май 2019 г. (и более поздние версии)
Visual Studio 2019 с обновлением 16.3

Можно установить в:

Обновление Windows 10 за октябрь 2018 г.
Обновление Windows 10 за апрель 2018 г.
Windows 10 Fall Creators Update
Обновление Windows 10 Creators Update
Юбилейное обновление Windows 10 Anniversary Update
Windows 8.1 и более ранней версии
Windows Server 2022
Windows Server 2019
Windows Server, версия 1809
Windows Server, версия 1803

(полный список см. в разделе Требования к системе)
4.7.2 .NET Framework 4.7.2 Входит в состав:

Обновление Windows 10 за октябрь 2018 г.
Обновление Windows 10 за апрель 2018 г.
Windows Server 2019
Windows Server, версия 1809
Windows Server, версия 1803
Visual Studio 2017 с обновлением 15.8

Можно установить в:

Windows 10 Fall Creators Update
Обновление Windows 10 Creators Update
Юбилейное обновление Windows 10 Anniversary Update
Windows 8.1 и более ранней версии
Windows Server, версия 1709 и более ранние

(полный список см. в разделе Требования к системе)
4.7.1 .NET Framework 4.7.1 Входит в состав:

Windows 10 Fall Creators Update
Windows Server, версия 1709
Visual Studio 2017 с обновлением 15.5

Можно установить в:

Обновление Windows 10 Creators Update
Юбилейное обновление Windows 10 Anniversary Update
Windows 8.1 и более ранней версии
Windows Server 2016 и более ранние версии
(полный список см. в разделе Требования к системе)
4.7 .NET Framework 4.7 Входит в состав:

Обновление Windows 10 Creators Update
Visual Studio 2017 с обновлением 15.3

Можно установить в:

Юбилейное обновление Windows 10 Anniversary Update
Windows 8.1 и более ранней версии
Windows Server 2016 и более ранние версии
(полный список см. в разделе Требования к системе)
4.6.2 .NET Framework 4.6.2 Входит в состав:

Юбилейное обновление Windows 10 Anniversary Update

Можно установить в:

Ноябрьское обновление Windows 10
Windows 10
Windows 8.1 и более ранней версии
Windows Server 2012 R2 и более ранней версии
(полный список см. в разделе Требования к системе)
4.6.1 .NET Framework 4.6.1 Входит в состав:

Visual Studio 2015 с обновлением 2

Можно установить в:

Windows 10
Windows 8.1 и более ранней версии
Windows Server 2012 R2 и более ранней версии
(полный список см. в разделе Требования к системе)
4.6 .NET Framework 4.6 Входит в состав:

Windows 10
Visual Studio 2015

Можно установить в:

Windows 8.1 и более ранней версии
Windows Server 2012 R2 и более ранней версии
(полный список см. в разделе Требования к системе)
4.5.2 .NET Framework 4.5.2 Можно установить в:

Windows 8.1 и более ранней версии
Windows Server 2012 R2 и более ранней версии
(полный список см. в разделе Требования к системе)
4.5.1 .NET Framework 4.5.1 Входит в состав:

Windows 8.1
Windows Server 2012 R2
Visual Studio 2013

Можно установить в:

Windows 8 и более ранние версии
Windows Server 2012 и более ранние версии
(полный список см. в разделе Требования к системе)
4.5 .NET Framework 4.5 Входит в состав:

Windows 8
Windows Server 2012
Visual Studio 2012

Можно установить в:

Windows 7 и более ранние версии
Windows Server 2008 SP2 и более ранние версии
(полный список см. в разделе Требования к системе)

Важно!

Начиная с версии 2022, Visual Studio больше не включает компоненты для .NET Framework 4.0–4.5.1, так как эти версии больше не поддерживаются. Visual Studio 2022 и более поздние версии не могут выполнять сборку приложений, предназначенных для платформ .NET Framework 4.0–4.5.1. Чтобы сохранить возможность сборки таких приложений, используйте Visual Studio 2019 и более ранние версии.

Можно установить Developer Pack (если он доступен) для конкретной версии платформы .NET Framework на всех поддерживаемых платформах.

пакеты разработчика предназначены только для определенной версии платформа .NET Framework и не включают предыдущие версии. например, пакет для разработчиков платформа .NET Framework 4,8 не включает платформа .NET Framework 4,7.

Веб- или автономный установщик можно установить в следующих ОС:

  • Windows 8.1 и более ранней версии

  • Windows Server 2012 R2 и более ранней версии

Полный список см. в разделе Требования к системе.

Общие сведения о платформе .NET Framework для пользователей и разработчиков см. в статье Начало работы. Сведения о развертывании .NET Framework с приложением см. в руководстве по развертыванию. Информацию об архитектуре и основных функциях .NET Framework см. в обзоре.

Варианты установки

Установите пакет разработчика для нескольких платформ, который позволяет осуществлять разработку в последней версии .NET Framework в Visual Studio или других средах разработки, или загрузите распространяемый пакет .NET Framework для распространения с приложением или элементом управления.

Установка .NET Framework Developer Pack или Microsoft .NET Framework Targeting Pack

Пакет выбора целевой платформы Targeting Pack позволяет нацелить приложение на конкретную версию платформы .NET Framework при разработке в Visual Studio и некоторых других средах. Пакет разработчика Developer Pack включает в себя определенную версию .NET Framework и подходящий пакет SDK вместе с соответствующим пакетом Targeting Pack.

Пакет разработчика для NET Framework 4.5.1 или 4.5.2, пакет выбора целевой платформы для .NET Framework 4.6 и пакет разработчика для .NET Framework 4.6.1, 4.6.2, 4.7, 4.7.1, 4.7.2 или 4.8 включают в себя базовые сборки, языковые пакеты и файлы IntelliSense для определенной версии .NET Framework, которые можно использовать в интегрированной среде разработки, такой как Visual Studio. Если вы используете Visual Studio, пакет разработчика или пакет выбора целевой платформы также добавляет установленную версию .NET Framework в набор доступных для выбора платформ при создании проекта. Выберите один из следующих вариантов.

На странице загрузки пакета разработчика нажмите кнопку Загрузка. Затем щелкните Выполнить или Сохранить и выполните предложенные инструкции. Вы также можете установить пакет разработчика или пакет выбора целевой платформы для конкретной версии .NET Framework, выбрав его из списка дополнительных компонентов в рабочей нагрузке Разработка классических приложений .NET в Visual Studio Installer, как показано на рисунке ниже.

Visual Studio installer with .NET Framework options selected.

При нацеливании на конкретную версию платформы .NET Framework ваше приложение создается с помощью базовых сборок, включенных в данную версию пакета разработчика. Во время выполнения сборки разрешаются из глобального кэша сборок, а базовые сборки не используются.

при создании приложения из Visual Studio или с помощью MSBuild из командной строки MSBuild может отобразить ошибку MSB3644, "не найдены ссылочные сборки для платформы"framework-version". чтобы устранить эту ошибку, скачайте пакет разработчика или целевой пакет для этой версии платформа .NET Framework.

Установка и загрузка распространяемого пакета .NET Framework

Установщики скачивают компоненты платформы .NET Framework для приложения или элемента управления, ориентированного на эти версии .NET Framework. Эти компоненты необходимо установить на все компьютеры, где выполняется это приложение или элемент управления. Оба установщика являются распространяемыми, поэтому их можно включить в программу установки для приложения.

Страница загрузки представлена на нескольких языках, но большинство загрузок предоставляются только на английском языке. Для поддержки дополнительных языков необходимо установить языковой пакет.

Предусмотрено два типа распространяемых установщиков:

  • Веб-установщик (начальный веб-загрузчик) загружает из Интернета все необходимые компоненты и языковой пакет, соответствующий операционной системе компьютера. Этот пакет намного меньше, чем автономный установщик, однако для установки требуется постоянное подключение к Интернету. Для поддержки дополнительных языков можно скачать и установить автономные языковые пакеты.

  • Автономный установщик (автономный распространяемый пакет) содержит все необходимые компоненты для установки платформы .NET Framework, но не содержит языковые пакеты. Этот загружаемый файл больше файла веб-установщика. Автономный установщик не требует подключения к Интернету. После запуска автономного установщика можно скачать и установить автономные языковые пакеты. При отсутствии постоянного подключения к Интернету воспользуйтесь автономным установщиком.

Автономный установщик и веб-установщик предназначены для компьютеров x86 и x64 (см. раздел Требования к системе), но не поддерживают компьютеры на основе Itanium.

  1. Откройте страницу загрузки требуемой версии платформы .NET Framework:

  2. Выберите язык страницы загрузки. Этот параметр не загружает локализованные ресурсы платформы .NET Framework; он влияет только на текст, отображаемый на странице загрузки.

  3. Выберите Загрузить.

  4. При появлении соответствующего запроса выберите загрузку, соответствующую архитектуре системы, затем нажмите Далее.

  5. При появлении запроса на скачивание выполните одно из следующих действий.

    • Если требуется установить платформу .NET Framework на компьютер, выберите Выполнить и следуйте инструкциям на экране.

    • Если требуется загрузить платформу .NET Framework для распространения, выберите Сохранить и следуйте инструкциям на экране.

  6. Если требуется загрузить ресурсы для дополнительных языков, следуйте инструкциям по установке языковых пакетов в следующем разделе.

Примечание

При возникновении неполадок во время установки см. раздел Устранение неполадок.

Примечания по установке

  • .NET Framework 4.5 и более поздние версии заменяют .NET Framework 4.0 При установке этих версий в системе, где установлена версия .NET Framework 4, сборки заменяются.

  • При удалении .NET Framework 4.5 или более поздней версии автоматически удаляются все существовавшие ранее файлы .NET Framework 4. Если вам нужно вернуться к .NET Framework 4, ее придется полностью переустановить со всеми обновлениями. Ознакомьтесь со статьей Installing the .NET Framework (Установка платформы .NET Framework).

  • Для установки .NET Framework 4.5 и более поздних версий требуются права администратора.

  • Распространяемый пакет платформы .NET Framework 4.5 был обновлен 9 октября 2012 г., чтобы устранить проблему, связанную с неправильной отметкой времени в цифровом сертификате, которая вызывала преждевременное истечение срока действия цифровой подписи в файлах, создаваемых и подписываемых Microsoft. Если вы ранее установили распространяемый пакет платформы .NET Framework 4.5 от 16 августа 2012 г., рекомендуем обновить установленную копию до последнего распространяемого пакета, который доступен на странице скачивания .NET Framework. Дополнительные сведения об этой проблеме см. в статье Советы по безопасности (Microsoft) (2749655).

Установка языковых пакетов

Языковые пакеты — это исполняемые файлы, содержащие локализованные ресурсы (например, переведенные тексты сообщений об ошибках и пользовательского интерфейса) для поддерживаемых языков. Если языковой пакет не установлен, сообщения об ошибках платформы .NET Framework и другой текст отображаются на английском. Обратите внимание, что веб-установщик автоматически устанавливает языковой пакет, который соответствует операционной системе, но можно загрузить на компьютер дополнительные языковые пакеты. Автономные установщики не содержат языковых пакетов.

Важно!

Языковые пакеты не содержат компоненты платформы .NET Framework, необходимые для запуска приложения, поэтому перед установкой языкового пакета необходимо запустить веб-установщик или автономный установщик. Если вы уже установили языковой пакет, удалите его, установите .NET Framework и переустановите языковой пакет.

  1. Откройте страницу загрузки языковых пакетов для установленной версии платформы .NET Framework:

  2. Выберите требуемый язык в списке и подождите несколько секунд, чтобы страница перезагрузилась на этом языке.

  3. Выберите Загрузить.

В приведенной ниже таблице перечислены поддерживаемые языки.

Язык culture
Арабский ar
Чешский cs
Датский da
Голландский nl
Финский fi
Английский (США) en-US
Французский fr
Немецкий de
Греческий el
Иврит he
Венгерский hu
Итальянский it
Японский ja
Корейский ko
Норвежский нет
Польский pl
Португальский (Бразилия) pt-BR
Португальский (Португалия) pt-PT
Русский ru
Китайский, упрощенное письмо zh-CHS
Испанский es
Шведский sv
Китайский (традиционный) zh-CHT
Турецкий tr

Следующие шаги

См. также