OWA или ECP перестают работать после установки обновления безопасности
Симптомы
После установки обновления для системы безопасности на сервере под управлением Microsoft Exchange Server Outlook в Интернете (OWA) или Exchange панель управления (ECP) или оба приложения перестают работать на сервере.
OWA отображает следующее сообщение об ошибке:
Что-то пошло не так
Ваш запрос не удалось выполнить. Код состояния HTTP: 500
ECP отображает следующее сообщение об ошибке:
Ошибка сервера в приложении /ecp.
Не удалось загрузить файл или сборку "Microsoft.Exchange.Common, Version=15.0.0.0 ... Culture=neutral, PublicKeyToken=31bf3856ad364e54' или одна из его зависимостей. Не удается найти указанный файл.
Причина
Эти ошибки возникают в том случае, если обновление безопасности было установлено вручную на сервере с включенным контролем учетных записей пользователей, но без использования повышенных разрешений.
Решение
Используйте повышенные разрешения, чтобы переустановить обновление безопасности на сервере.
- Нажмите кнопку Пуск, затем введите cmd.
- Щелкните в результатах поиска Командную строку правой кнопкой мыши и выберите Запуск от имени администратора.
- Если открывается окно Контроль учетных записей, выберите вариант открытия окна командной строки с повышенными привилегиями и нажмите кнопку Продолжить. Если окно контроля учетных записей (UAC) не появляется, перейдите к следующему шагу.
- Введите полный путь к файлу .msp для этого обновления безопасности, а затем нажмите клавишу Ввод.
- После установки обновления перезапустите сервер.
Проверьте, можно ли теперь получить доступ к OWA и ECP на сервере без отображения сообщения об ошибке.
Если сообщение об ошибке продолжает отображаться в ECP, выполните следующие действия:
Запустите диспетчер IIS на сервере.
Перейдите в раздел Серверный сайт Exchange>Виртуальный каталог ECP.
Выберите Параметры приложения>BinsearchFolder.
Проверьте пути к указанным каталогам Exchange. При этом отображаются пути каталогов, которые выглядят приблизительно следующим образом:
%ExchangeInstallDir%bin;
%ExchangeInstallDir%bin\CmdletExtensionAgents;
%ExchangeInstallDir%ClientAccess\Owa\binЗамените указанные пути на следующие:
C:\Program Files\Microsoft\Exchange Server\V15\bin;
C:\Program Files\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents;
C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\binПримечание Пути должны указывать расположение, где установлен Exchange Server. В следующих примерах предполагается, что программа установлена на диске C и используется версия Microsoft Exchange Server 2013. Если он установлен на другом диске на сервере или используется другая версия, например Microsoft Exchange Server 2010, используйте путь и сведения о версии, подходящие для установки.
Перейдите к папке, в которой хранятся сценарии Exchange Server. По умолчанию сценарии находятся в следующем пути для Exchange Server 2013:
C:\Program Files\Microsoft\Exchange Server\v15\Bin
Примечание Для Exchange Server 2010 сценарии будут располагаться в папке V14.
Запустите командную консоль Exchange от имени администратора и выполните следующие сценарии:
.\UpdateCas.ps1
и.\UpdateConfigFiles.ps1
.Выйдите из командной консоли Exchange и откройте окно командной строки от имени администратора.
Запустите
iisreset
.Перезапустите сервер и убедитесь, что сообщение об ошибке больше не отображается при доступе к ECP.
Обратная связь
https://aka.ms/ContentUserFeedback.
Ожидается в ближайшее время: в течение 2024 года мы постепенно откажемся от GitHub Issues как механизма обратной связи для контента и заменим его новой системой обратной связи. Дополнительные сведения см. в разделеОтправить и просмотреть отзыв по