OWA или ECP перестают работать после установки обновления безопасности

Симптомы

После установки обновления для системы безопасности на сервере под управлением Microsoft Exchange Server Outlook в Интернете (OWA) или Exchange панель управления (ECP) или оба приложения перестают работать на сервере.

OWA отображает следующее сообщение об ошибке:

Что-то пошло не так
Ваш запрос не удалось выполнить. Код состояния HTTP: 500

Снимок экрана с сообщением об ошибке в OWA.

ECP отображает следующее сообщение об ошибке:

Ошибка сервера в приложении /ecp.
Не удалось загрузить файл или сборку "Microsoft.Exchange.Common, Version=15.0.0.0 ... Culture=neutral, PublicKeyToken=31bf3856ad364e54' или одна из его зависимостей. Не удается найти указанный файл.

Снимок экрана с сообщением об ошибке в ECP.

Причина

Эти ошибки возникают в том случае, если обновление безопасности было установлено вручную на сервере с включенным контролем учетных записей пользователей, но без использования повышенных разрешений.

Решение

Используйте повышенные разрешения, чтобы переустановить обновление безопасности на сервере.

  1. Нажмите кнопку Пуск, затем введите cmd.
  2. Щелкните в результатах поиска Командную строку правой кнопкой мыши и выберите Запуск от имени администратора.
  3. Если открывается окно Контроль учетных записей, выберите вариант открытия окна командной строки с повышенными привилегиями и нажмите кнопку Продолжить. Если окно контроля учетных записей (UAC) не появляется, перейдите к следующему шагу.
  4. Введите полный путь к файлу .msp для этого обновления безопасности, а затем нажмите клавишу Ввод.
  5. После установки обновления перезапустите сервер.

Проверьте, можно ли теперь получить доступ к OWA и ECP на сервере без отображения сообщения об ошибке.

Если сообщение об ошибке продолжает отображаться в ECP, выполните следующие действия:

  1. Запустите диспетчер IIS на сервере.

  2. Перейдите в раздел Серверный сайт Exchange>Виртуальный каталог ECP.

  3. Выберите Параметры приложения>BinsearchFolder.

  4. Проверьте пути к указанным каталогам Exchange. При этом отображаются пути каталогов, которые выглядят приблизительно следующим образом:

    %ExchangeInstallDir%bin;
    %ExchangeInstallDir%bin\CmdletExtensionAgents;
    %ExchangeInstallDir%ClientAccess\Owa\bin

  5. Замените указанные пути на следующие:

    C:\Program Files\Microsoft\Exchange Server\V15\bin;
    C:\Program Files\Microsoft\Exchange Server\V15\bin\CmdletExtensionAgents;
    C:\Program Files\Microsoft\Exchange Server\V15\ClientAccess\Owa\bin

    Примечание Пути должны указывать расположение, где установлен Exchange Server. В следующих примерах предполагается, что программа установлена на диске C и используется версия Microsoft Exchange Server 2013. Если он установлен на другом диске на сервере или используется другая версия, например Microsoft Exchange Server 2010, используйте путь и сведения о версии, подходящие для установки.

  6. Перейдите к папке, в которой хранятся сценарии Exchange Server. По умолчанию сценарии находятся в следующем пути для Exchange Server 2013:

    C:\Program Files\Microsoft\Exchange Server\v15\Bin

    Примечание Для Exchange Server 2010 сценарии будут располагаться в папке V14.

  7. Запустите командную консоль Exchange от имени администратора и выполните следующие сценарии: .\UpdateCas.ps1 и .\UpdateConfigFiles.ps1.

  8. Выйдите из командной консоли Exchange и откройте окно командной строки от имени администратора.

  9. Запустите iisreset.

  10. Перезапустите сервер и убедитесь, что сообщение об ошибке больше не отображается при доступе к ECP.