Excel.RangeView interface

Объект rangeView представляет набор видимых ячеек в родительском диапазоне.

Свойства

cellAddresses

Представляет адреса ячеек RangeView.

columnCount

Число видимых столбцов.

formulas

Представляет формулу в формате A1.

formulasLocal

Представляет формулу в формате A1 на языке пользователя и в соответствии с его языковым стандартом. Например, английская формула "=SUM(A1, 1.5)" превратится в "=СУММ(A1;1,5)" на русском языке.

formulasR1C1

Представляет формулу в формате R1C1.

index

Возвращает значение, представляющее индекс RangeView.

numberFormat

Представляет код в числовом формате Excel для данной ячейки.

rowCount

Количество видимых строк.

rows

Представляет коллекцию видимых ячеек в диапазоне, сопоставленных с указанным диапазоном.

text

Текстовые значения указанного диапазона. Текстовое значение не зависит от ширины ячейки. #Подстановка знаков, которая происходит в пользовательском интерфейсе Excel, не влияет на текстовое значение, возвращенное API.

values

Представляет необработанные значения указанного объекта rangeView. Могут возвращаться строковые и числовые данные, а также логические значения. Ячейки, содержащие ошибку, вернут строку ошибки.

valueTypes

Представляет тип данных каждой ячейки.

Методы

getRange()

Получает родительский диапазон, сопоставленный с текущим объектом RangeView.

load(propertyNames)

Добавляет в очередь команду для загрузки указанных свойств объекта. context.sync()Перед чтением свойств необходимо вызвать метод.

Сведения о свойстве

cellAddresses

Представляет адреса ячеек RangeView.

readonly cellAddresses: any[][];

Значение свойства

any[][]

columnCount

Число видимых столбцов.

readonly columnCount: number;

Значение свойства

number

formulas

Представляет формулу в формате A1.

formulas: any[][];

Значение свойства

any[][]

formulasLocal

Представляет формулу в формате A1 на языке пользователя и в соответствии с его языковым стандартом. Например, английская формула "=SUM(A1, 1.5)" превратится в "=СУММ(A1;1,5)" на русском языке.

formulasLocal: any[][];

Значение свойства

any[][]

formulasR1C1

Представляет формулу в формате R1C1.

formulasR1C1: any[][];

Значение свойства

any[][]

index

Возвращает значение, представляющее индекс RangeView.

readonly index: number;

Значение свойства

number

numberFormat

Представляет код в числовом формате Excel для данной ячейки.

numberFormat: any[][];

Значение свойства

any[][]

rowCount

Количество видимых строк.

readonly rowCount: number;

Значение свойства

number

rows

Представляет коллекцию видимых ячеек в диапазоне, сопоставленных с указанным диапазоном.

readonly rows: RangeViewCollection;

Значение свойства

text

Текстовые значения указанного диапазона. Текстовое значение не зависит от ширины ячейки. #Подстановка знаков, которая происходит в пользовательском интерфейсе Excel, не влияет на текстовое значение, возвращенное API.

readonly text: string[][];

Значение свойства

string[][]

values

Представляет необработанные значения указанного объекта rangeView. Могут возвращаться строковые и числовые данные, а также логические значения. Ячейки, содержащие ошибку, вернут строку ошибки.

values: any[][];

Значение свойства

any[][]

valueTypes

Представляет тип данных каждой ячейки.

readonly valueTypes: RangeValueType[][];

Значение свойства

Сведения о методе

getRange()

Получает родительский диапазон, сопоставленный с текущим объектом RangeView.

getRange(): Range;

Возвращаемое значение

load(propertyNames)

Добавляет в очередь команду для загрузки указанных свойств объекта. context.sync()Перед чтением свойств необходимо вызвать метод.

load(propertyNames?: string | string[]): void;

Параметры

propertyNames
string | string[]

Строка, разделенная запятыми, или массив строк, указывающий свойства для загрузки.

Возвращаемое значение

void