Элемент Set

Указывает набор требований из Office API JavaScript, который требуется Office надстройки для активации.

Тип надстройки: контентные и почтовые надстройки, надстройки области задач

Синтаксис

<Set Name="string" MinVersion="n .n">

Содержится в

Sets

Атрибуты

Атрибут Тип Обязательный Описание
Имя string Обязательный Имя набора требований.
MinVersion string необязательный Указывает минимальную версию набора API, необходимую надстройке. Переопределяет значение DefaultMinVersion, если оно указано в элементе родительских наборов.

Примечания

Дополнительные сведения о наборах обязательных элементов см. в статье Версии Office и наборы обязательных элементов.

Дополнительные сведения о атрибуте MinVersion элемента Set и атрибуте DefaultMinVersion элемента Sets см. в элементе Set the Requirements in the manifest.

Важно!

Для почтовых надстроек доступен только один набор обязательных элементов "Mailbox". Он содержит все подмножество API, поддерживаемое почтовыми надстройками Outlook, а в манифесте почтовой надстройки необходимо указать набор обязательных элементов "Mailbox" (это обязательно для почтовых надстроек, в отличие от надстроек области задачи и контентных надстроек). Кроме того, в почтовых надстройках невозможно объявить поддержку определенных методов.