Загрузка неопубликованных надстроек Office для тестированияSideload Office Add-ins for testing

Вы можете установить надстройку Office для тестирования в клиенте Office, запущенном в Windows, используя каталог общих папок для публикации манифеста в сетевом файловом ресурсе.You can install an Office Add-in for testing in an Office client running on Windows by publishing the manifest to a network file share (instructions below).

Примечание

Если проект надстройки создан с помощью достаточно новой версии генератора Yeoman для надстроек Office, неопубликованная надстройка автоматически загружается в классический клиент Office, когда вы запускаете команду npm start.If your add-in project was created with a sufficiently recent version of the Yeoman generator for Office Add-ins, the add-in will automatically sideload in the Office desktop client when you run npm start.

Эта статья относится только к тестированию надстроек Word, Excel, PowerPoint и Project в Windows.This article applies only to testing Word, Excel, PowerPoint, and Project add-ins on Windows. Для выполнения тестирования на другой платформе или тестирования надстроек Outlook см. одну из указанных ниже тем о загрузке неопубликованных надстроек.If you want to test on another platform or want to test an Outlook add-in, see one of the following topics to sideload your add-in:

В приведенном ниже видео показано, как загрузить неопубликованную надстройку в классическое приложение Office или Office в Интернете с помощью каталога общих папок.The following video walks you through the process of sideloading your add-in on Office desktop or Office Online using a shared folder catalog.

Общий доступ к папкеShare a folder

  1. На том компьютере с Windows, где должна размещаться надстройка, перейдите к родительской папке или диску с папкой, которую требуется использовать в качестве каталога общих папок.In File Explorer on the Windows computer where you want to host your add-in, go to the parent folder, or drive letter, of the folder you want to use as your shared folder catalog.

  2. Откройте контекстное меню для папки, которую нужно использовать в качестве каталога общих папок (щелкните папку правой кнопкой мыши), и выберите пункт Свойства.Open the context menu for the folder you want to use as your shared folder catalog (right-click the folder) and choose Properties.

  3. В диалоговом окне Свойства откройте вкладку Доступ и нажмите кнопку Общий доступ.Within the Properties dialog window, open the Sharing tab and then choose the Share button.

    диалоговое окно "Свойства" папки с выделенной вкладкой "Доступ" и кнопкой "Общий доступ"

  4. В диалоговом окне Доступ к сети добавьте себя и любых других пользователей и/или группы пользователей, которым следует предоставить доступ к вашей надстройке.Within the Network access dialog window, add yourself and any other users and/or groups with whom you want to share your add-in. Вам потребуются разрешения на чтение и запись папки.You will need at least Read/Write permission to the folder. Завершив выбор пользователей, которым предоставляется совместный доступ, нажмите кнопку Поделиться.After you have finished choosing people to share with, choose the Share button.

  5. Когда появится подтверждение, что папка открыта для общего доступа, запишите полный сетевой путь, отображаемый сразу после имени папки.When you see confirmation that Your folder is shared, make note of the full network path that's displayed immediately following the folder name. (Это значение нужно вводить как URL-адрес каталога при указании общей папки в качестве доверенного каталога, как описано в следующем разделе этой статьи). Нажмите кнопку Готово, чтобы закрыть диалоговое окно Доступ к сети.(You will need to enter this value as the Catalog Url when you specify the shared folder as a trusted catalog, as described in the next section of this article.) Choose the Done button to close the Network access dialog window.

    Диалоговое окно "Доступ к сети" с выделенным путем для общего доступа

  6. Нажмите кнопку Закрыть, чтобы закрыть диалоговое окно Свойства.Choose the Close button to close the Properties dialog window.

Указание общей папки в качестве доверенного каталогаSpecify the shared folder as a trusted catalog

  1. Откройте новый документ в Excel, Word, PowerPoint или Project.Open a new document in Excel, Word, PowerPoint, or Project.

  2. Перейдите на вкладку Файл, а затем выберите Параметры.Choose the File tab, and then choose Options.

  3. Выберите Центр управления безопасностью, а затем нажмите кнопку Параметры центра управления безопасностью.Choose Trust Center, and then choose the Trust Center Settings button.

  4. Выберите пункт Доверенные каталоги надстроек.Choose Trusted Add-in Catalogs.

  5. В поле URL-адрес каталога введите полный сетевой путь к папке, к которой вы ранее предоставили общий доступ.In the Catalog Url box, enter the full network path to the folder that you shared previously. Если вы не записали полный сетевой путь к папке при предоставлении к ней общего доступа, его можно получить в диалоговом окне Свойства папки, как показано на снимке экрана ниже.If you failed to note the folder's full network path when you shared the folder, you can get it from the folder's Properties dialog window, as shown in the following screenshot.

    диалоговое окно "Свойства" папки с выделенной вкладкой "Доступ" и сетевым путем

  6. После ввода полного сетевого пути доступа к папке в поле URL-адрес каталога, нажмите кнопку Добавить каталог.After you've entered the full network path of the folder into the Catalog Url box, choose the Add catalog button.

  7. Установите флажок Показывать в меню для только что добавленного элемента и нажмите кнопку ОК, чтобы закрыть диалоговое окно Центр управления безопасностью.Select the Show in Menu check box for the newly-added item, and then choose the OK button to close the Trust Center dialog window.

    Диалоговое окно "Центр управления безопасностью" с выбранным каталогом

  8. Нажмите кнопку ОК, чтобы закрыть диалоговое окно Параметры Word.Choose the OK button to close the Word Options dialog window.

  9. Закройте и снова откройте приложение Office, чтобы изменения вступили в силу.Close and reopen the Office application so your changes will take effect.

Загрузка неопубликованной надстройкиSideload your add-in

  1. XML-файл манифеста тестируемой надстройки необходимо поместить в каталог общих папок.Put the manifest XML file of any add-in that you are testing in the shared folder catalog. Обратите внимание, что вы развертываете веб-приложение непосредственно на веб-сервере.Note that you deploy the web application itself to a web server. Не забудьте указать URL-адрес в элементе SourceLocation файла манифеста.Be sure to specify the URL in the SourceLocation element of the manifest file.

    Важно!

    Использовать конечную точку HTTPS для надстройки не обязательно, но настоятельно рекомендуется. Надстройки без SSL-защиты (HTTPS) выдают предупреждения о небезопасном контенте и ошибки во время использования. Для запуска в Office Online и публикации в AppSource надстройка должна быть защищена с помощью SSL. Если надстройка получает данные из внешнего источника, она должна использовать SSL-соединение для защиты данных при передаче. Самозаверяющие сертификаты можно использовать для разработки и тестирования, если они добавлены в список доверенных сертификатов на локальном компьютере.While not strictly required in all add-in scenarios, using an HTTPS endpoint for your add-in is strongly recommended. Add-ins that are not SSL-secured (HTTPS) generate unsecure content warnings and errors during use. If you plan to run your add-in in Office Online or publish your add-in to AppSource, it must be SSL-secured. If your add-in accesses external data and services, it should be SSL-secured to protect data in transit. Self-signed certificates can be used for development and testing, so long as the certificate is trusted on the local machine.

  2. В Excel, Word или PowerPoint откройте на ленте вкладку Вставка и выберите Мои надстройки.In Excel, Word, or PowerPoint, select My Add-ins on the Insert tab of the ribbon. В Project выберите Мои надстройки на вкладке Project ленты.In Project, select My Add-ins on the Project tab of the ribbon.

  3. Нажмите ОБЩАЯ ПАПКА в верхней части диалогового окна Надстройки Office.Choose SHARED FOLDER at the top of the Office Add-ins dialog box.

  4. Выберите имя надстройки и нажмите кнопку Добавить, чтобы вставить надстройку.Select the name of the add-in and choose OK to insert the add-in.

См. такжеSee also