Использование функций "Поиск решения" из VBAUsing the Solver VBA Functions

Прежде чем использовать функции средства "Поиск решения" из VBA, необходимо включить надстройку "Поиск решения" в диалоговом окне Параметры Excel.Before you can use the Solver VBA functions from VBA, you must enable the Solver add-in in the Excel Options dialog box.

  1. На вкладке Файл выберите пункт Параметры под вкладкой Excel.Click the File tab, and then click Options below the Excel tab.

  2. В диалоговом окне Параметры Excel выберите пункт Надстройки.In the Excel Options dialog box, click Add-Ins.

  3. В раскрывающемся списке Управление выберите пункт Надстройки Excel и нажмите кнопку Перейти.In the Manage drop-down box, select Excel Add-ins, and then click Go.

  4. В диалоговом окне Надстройки выберите пункт Надстройка "Поиск решения" и нажмите кнопку "ОК".In the Add-Ins dialog box, select Solver Add-in, and then click OK.

После включения надстройки "Поиск решения" приложение Excel автоматически установит надстройку, если она еще не установлена, а команда Поиск решения будет добавлена в группу Анализ на вкладке Данные на ленте.After you have enabled the Solver add-in, Excel will auto-install the Add-in if it is not already installed, and the Solver command will be added to the Analysis group on the Data tab in the ribbon.

Прежде чем использовать функции поиска решения VBA в редакторе Visual Basic, необходимо создать ссылку на надстройку "Поиск решения".Before you can use the Solver VBA functions in the Visual Basic Editor, you must establish a reference to the Solver add-in. В редакторе Visual Basic с активным модулем щелкните Ссылки в меню Сервис, а затем выберите пункт Поиск решения в разделе Доступные ссылки. In the Visual Basic Editor, with a module active, click References on the Tools menu, and then select Solver under Available References. Если пункт поиск решения не отображается в разделе Доступные ссылки, нажмите кнопку Обзор и откройте элемент Solver.xlam во вложенной папке \Program Files\Microsoft Office\Office14\Library\SOLVER.If Solver does not appear under Available References, click Browse, and then open Solver.xlam in the \Program Files\Microsoft Office\Office14\Library\SOLVER subfolder. Для управления надстройкой "Поиск решения" из VBA можно использовать следующие функции.The following functions can be used to control the Solver add-in from VBA. Каждая функция соответствует действию, которое можно выполнить в интерактивном режиме с помощью диалоговых окон Параметры поиска решения, Варианты поиска решения и Результаты поиска решения надстройки "Поиск решения".Each function corresponds to an action that you can perform interactively, through the Solver Parameters, Solver Options, and Solver Results dialog boxes of the Solver add-in.

Поддержка и обратная связьSupport and feedback

Есть вопросы или отзывы, касающиеся Office VBA или этой статьи?Have questions or feedback about Office VBA or this documentation? Руководство по другим способам получения поддержки и отправки отзывов см. в статье Поддержка Office VBA и обратная связь.Please see Office VBA support and feedback for guidance about the ways you can receive support and provide feedback.