Начало работы с Power BI DesktopGetting started with Power BI Desktop

Добро пожаловать в руководство по началу работы с Power BI Desktop.Welcome to the Power BI Desktop Getting Started Guide. Этот краткий обзор Power BI Desktop знакомит вас с принципами работы инструмента и его функциями и позволяет развить навыки создания надежных моделей данных (и потрясающих отчетов) и повысить эффективность своей работы в области бизнес-аналитики.This short tour of Power BI Desktop gets you acquainted with how it works, demonstrates what it can do, and accelerates your ability to build robust data models — along with amazing reports — that amplify your business intelligence efforts.

Предпочитаете смотреть, а не читать?Prefer to watch instead of read? Прежде всего ознакомьтесь с нашим вводным видео.Feel free to take a look at our getting started video. Если вы хотите изучить видео с соответствующими демонстрационными данными, можно загрузить этот пример книги Excel.And if you want to follow along with the video with matching sample data, you can download this sample Excel workbook.

Power BI Desktop позволяет создать коллекцию запросов, подключений к данным и отчетов, к которым легко предоставить общий доступ другим пользователям.Power BI Desktop lets you create a collection of queries, data connections, and reports that can easily be shared with others. В Power BI Desktop интегрированы проверенные технологии Майкрософт: эффективная подсистема обработки запросов, система моделирования данных и визуализации. Инструмент полностью совместим с интернет-службой Power BI.Power BI Desktop integrates proven Microsoft technologies – the powerful Query engine, data modeling, and visualizations – and works seamlessly with the online Power BI service.

Благодаря сочетанию интерфейса Power BI Desktop (где аналитики и другие пользователи могут создавать многофункциональные подключения данных, модели и отчеты) и службы Power BI (предоставляющей общий доступ к отчетам Power BI Desktop, чтобы пользователи могли просматривать их и взаимодействовать с ними) становится гораздо проще моделировать, строить, совместно использовать и расширять новые идеи из мира данных.With the combination of Power BI Desktop (where analysts and others can create powerful data connections, models and reports) and the Power BI service (where Power BI Desktop reports can be shared so users can view and interact with them), new insights from the world of data are easier to model, build, share, and extend.

Аналитики данных найдут в Power BI Desktop мощный, гибкий и отличающийся высокой доступностью инструмент для подключения к большим объемам данных, формирования больших объемов данных, построения надежных моделей и создания хорошо структурированных отчетов.Data analysts will find Power BI Desktop a powerful, flexible, and a highly accessible tool to connect with and shape the world of data, build robust models, and craft well-structured reports.

Как использовать это руководствоHow to use this guide

Это руководство можно быстро просмотреть, чтобы получить краткий обзор, или внимательно прочесть каждый раздел, чтобы хорошо понять, как работает Power BI Desktop.You can use this guide in a couple of ways – scan it for a quick overview, or read through each section for a strong understanding of how Power BI Desktop works.

Если вы спешите, можно всего за несколько минут просмотреть это руководство, вынеся из него представление о том, как функционирует Power BI Desktop и как его использовать.If you’re in a hurry you can do a visual sweep of this guide in just a couple minutes, and come away with a good sense of how Power BI Desktop operates, and how to use it. Большая часть данного руководства состоит из экранов с визуализациями работы Power BI Desktop.Most of this guide consists of screens that visually show how Power BI Desktop works.

Для более глубокого понимания прочтите каждый раздел, выполните приведенные в нем действия и получите свой собственный файл Power BI Desktop, готовый к отправке в службу Power BI и совместному использованию с другими пользователями.For a more thorough understanding you can read through each section, perform the steps, and walk away with your own Power BI Desktop file that’s ready to post onto the Power BI service, and share with others.

Примечание

Существует также отдельная и специализированная версия Power BI, которая называется Сервер отчетов Microsoft Power BI. Она предназначена для клиентов, которые хотят, чтобы их данные и отчеты оставались в локальной среде.There is also a separate and specialized version of Power BI called Power BI Report Server, which is for customers who need their data and reporting to remain on-premises. Для использования с этой версией существует также отдельная и специализированная версия Power BI Desktop, которая называется Power BI Desktop для Сервера отчетов Microsoft Power BI. Она работает только с версией "Сервер отчетов Microsoft Power BI".For use with that specialized version, there's also a separate and specialized version of Power BI Desktop called Power BI Desktop for Power BI Report Server, which works only with the Report Server version of Power BI. В этой статьей описывается стандартная версия Power BI Desktop.This article describes the standard Power BI Desktop.

Принципы работы Power BI DesktopHow Power BI Desktop works

В Power BI Desktop вы подключаетесь к данным (обычно к нескольким источникам данных), формируете эти данные (с помощью запросов, создающих информативные, наглядные модели данных) и используете эту модель для создания отчетов (которые пользователи могут использовать в своей работе, в том числе совместной).With Power BI Desktop, you connect to data (usually multiple data sources), shape that data (with queries that build insightful, compelling data models), and use that model to create reports (which others can leverage, build upon, and share).

После выполнения этих действий (подключения к данным, формирования данных и подготовки отчетов) требуемым образом можно сохранить свою работу в формате файла Power BI Desktop, который имеет расширение PBIX.When the steps are completed to your satisfaction – connect, shape, and report – you can save that work in Power BI Desktop file format, which is the .pbix extension. Файлы Power BI Desktop могут совместно использоваться, как любые другие файлы, но наиболее эффективный способ предоставления общего доступа к этим файлам заключается в их отправке в службу Power BI.Power BI Desktop files can be shared like any other file, but the most compelling way to share Power BI Desktop files is to upload them (share them) on the Power BI service.

Power BI Desktop централизует, упрощает и ускоряет то, что в противном случае могло бы представлять собой разрозненный, неупорядоченный и достаточно сложный процесс проектирования и создания репозиториев и отчетов бизнес-аналитики.Power BI Desktop centralizes, simplifies, and streamlines what can otherwise be a scattered, disconnected, and arduous process of designing and creating business intelligence repositories and reports.

Готовы попробовать?Ready to give it a try? Давайте начнем.Let’s get started.

Установка и запуск Power BI DesktopInstall and run Power BI Desktop

Power BI Desktop можно загрузить в службе Power BI , щелкнув значок шестеренки и выбрав Power BI Desktop.You can download Power BI Desktop from the Power BI service, by selecting the gear icon, then select Power BI Desktop.

Power BI Desktop устанавливается как приложение и выполняется на рабочем столе.Power BI Desktop is installed as an application, and runs on your desktop.

При запуске Power BI Desktop отображается экран приветствия .When you run Power BI Desktop, a Welcome screen is displayed.

Здесь можно Получить данные, просмотреть Последние источникиили Открыть другие отчеты непосредственно с экрана приветствия (по ссылкам в области слева).You can Get Data, see Recent Sources, or Open Other Reports directly from the Welcome screen (from the links in the left pane). Если закрыть этот экран (нажать x в правом верхнем углу), появляется представление Отчет Power BI Desktop.If you close the screen (select the x in the top right corner), the Report view of Power BI Desktop is displayed.

В Power BI Desktop три представления: Отчет , Данные и Связи .There are three views in Power BI Desktop: Report view, Data view, and Relationships view. Power BI Desktop также включает Редактор запросов, который открывается в отдельном окне.Power BI Desktop also includes Query Editor, which opens in a separate window. В представлении Редактор запросовможно создавать запросы и преобразовывать данные, а затем загружать уточненные модели данных в Power BI Desktop и создавать отчеты.In Query Editor, you can build queries and transform data, then load that refined data model into Power BI Desktop, and create reports.

На следующем экране показаны значки трех представлений в левой части Power BI Desktop: Отчет, Данныеи Связи(сверху вниз).The following screen shows the three view icons along the left of Power BI Desktop: Report, Data, and Relationships, from top to bottom. Отображаемое в настоящее время представление обозначено желтой полосой слева.The currently displayed view is indicated by the yellow bar along the left. В данном случае сейчас отображается представление Отчет .In this case, Report view is currently displayed. Для смены представления нужно выбрать любой из трех значков.You can change views by selecting any of those three icons.

После установки Power BI Desktop можно подключаться к данным, формировать данные и создавать отчеты (обычно в таком порядке).With Power BI Desktop installed you’re ready to connect to data, shape data, and build reports (usually in that order). В следующих разделах мы поочередно ознакомим вас с этими действиями.In the next few sections, we take a tour through each in turn.

Подключение к даннымConnect to data

После установки Power BI Desktop вы готовы подключаться к непрерывно расширяющейся среде данных.With Power BI Desktop installed, you’re ready to connect to the ever expanding world of data. В окне запросов доступны все виды источников данных.There are all sorts of data sources available in the Query window. На следующем рисунке показано, как подключиться к данным, щелкнув на ленте вкладку Главная и выбрав Получить данные > Еще.The following image shows how to connect to data, by selecting the Home ribbon, then Get Data > More.

В этом кратком обзоре мы будем подключаться к нескольким разным источникам данных в Интернете .For this quick tour, we'll connect to a couple different Web data sources.

Представьте, что вы уходите на пенсию и хотите жить там, где много солнечного света, мягкие налоги и хорошее здравоохранение; — или, возможно, вы аналитик данных и хотите получить эти сведения, чтобы помочь клиентам.Imagine you’re retiring – you want to live where there’s lots of sunshine, preferable taxes, and good health care – or perhaps you’re a data analyst, and you want that information to help your customers. Например, возможно, вы хотите помочь своему продавцу солнцезащитных очков организовать адресную реализацию там, где солнце больше светит.For example, perhaps you want to help your sunglasses retailer target sales where the sun shines most frequently.

В любом случае интересующие вас данные в этих и многих других областях имеются на следующем веб-ресурсе:Either way, the following Web resource has interesting data about those topics, and more:

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspxhttp://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Выберите Получить данные > Интернет и вставьте адрес.Select Get Data > Web and paste the address.

Когда вы нажмете кнопку ОК, начнет работу функциональность Запрос Power BI Desktop.When you select OK, the Query functionality of Power BI Desktop goes to work. Запрос обращается к веб-ресурсу, и в окне Навигатор отображается найденное на веб-странице.Query contacts the Web resource, and the Navigator window returns what it found on that Web page. В данном случае найдена таблица (Таблица 0) и общий интернет-документ.In this case, it found a table (Table 0) and the overall Web Document. Нас интересует эта таблица, поэтому мы выбираем ее из списка.We’re interested in the table, so we select it from the list. В окне Навигатор доступен предварительный просмотр содержимого.The Navigator window displays a preview.

На этом этапе можно изменить запрос перед загрузкой таблицы, нажав кнопку Изменить внизу окна, или загрузить эту таблицу.At this point we can edit the query before loading the table, by selecting Edit from the bottom of the window, or we can load the table.

Если нажать кнопку Изменить, загружается редактор запросов и отображается представление таблицы.When we select Edit, Query Editor launches and a representative view of the table is presented. Появляется область Параметры запроса (если эта область не отображается, щелкните на ленте вкладку Вид, а затем последовательно выберите Показать > Параметры запроса, чтобы вывести на экран область Параметры запроса).The Query Settings pane is displayed (if it’s not, you can select View from the ribbon, then Show > Query Settings to display the Query Settings pane). Вот как это выглядит.Here’s what that looks like.

Дополнительные сведения о подключении к данным см. в статье Подключение к данным в Power BI Desktop.For more information about connecting to data, see Connect to Data in Power BI Desktop.

В следующем разделе мы настроим данные так, чтобы они соответствовали нашим потребностям.In the next section, we adjust the data so it meets our needs. Процесс настройки подключенных данных называется формированием данных.The process of adjusting connected data is called shaping data.

Формирование и объединение данных.Shape and combine data

Теперь, когда мы подключились к источнику данных, необходимо настроить данные для наших потребностей.Now that we’ve connected to a data source, we need to adjust the data to meet our needs. Иногда настройка означает преобразование данных, например переименование столбцов или таблиц, изменение текста на числа, удаление строк, установку первой строки в качестве заголовков и т. д.Sometimes adjusting means transforming the data – such as renaming columns or tables, changing text to numbers, removing rows, setting the first row as headers, and so on.

В редакторе запросов в Power BI Desktop можно в полной мере использовать контекстные меню в дополнение к задачам, доступным на ленте.The Query editor in Power BI Desktop makes ample use of right-click menus, in addition to having tasks available on the ribbon. Почти все действия, которые можно выбрать на ленте Преобразование , также доступны, если щелкнуть правой кнопкой мыши элемент (например, столбец) и выбрать соответствующий пункт в появившемся меню.Most of what you can select in the Transform ribbon is also available by right-clicking an item (such as a column) and choosing from the menu that appears.

Формирование данныхShape data

При формировании данных в редакторе запросоввы создаете пошаговые инструкции (которые автоматически выполняются в этом редакторе запросов ) для настройки данных по мере их загрузки и отображения в редакторе .When you shape data in the Query Editor, you’re providing step-by-step instructions (that Query Editor carries out for you) to adjust the data as Query Editor loads and presents it. Это не влияет на исходный источник данных; корректируется или формируется только это конкретное представление данных.The original data source is not affected; only this particular view of the data is adjusted, or shaped.

Указываемые действия (переименование таблицы, преобразование типа данных или удаление столбцов) записываются редактором запросов, и каждый раз, когда этот запрос подключается к источнику данных, эти действия выполняются, чтобы данные всегда были сформированы указанным образом.The steps you specify (such as rename a table, transform a data type, or delete columns) are recorded by Query Editor, and each time this query connects to the data source those steps are carried out so that the data is always shaped the way you specify. Это происходит всякий раз, когда вы используете этот запрос в Power BI Desktop или когда кто-либо другой использует ваш открытый для общего доступа запрос, например в службе Power BI .This process occurs whenever you use the query in Power BI Desktop, or for anyone who uses your shared query, such as in the Power BI service. Эти действия последовательно записываются в области Параметры запроса в разделе Примененные действия.Those steps are captured, sequentially, in the Query Settings pane under Applied Steps.

На следующем рисунке показана область Параметры запроса для сформированного запроса — мы разберем каждое из этих действий ниже.The following image shows the Query Settings pane for a query that has been shaped – we’ll go through each of those steps in the next few paragraphs.

Давайте вернемся к нашим данным, найденным путем подключения к источнику данных в Интернете, и сформируем эти данные в соответствии с нашими потребностями.Let’s get back to our retirement data, which we found by connecting to a Web data source, and shape that data to fit our needs.

Во-первых, большинство оценок были представлены в редакторе запросов как целые числа, но не все из них (один столбец содержал текст и числа, поэтому он не был преобразован автоматически).For starters, most ratings were brought into Query Editor as whole numbers, but not all of them (one column contained text and numbers, so it wasn't automatically converted). Мы хотим, чтобы данные были числами.We need the data to be numbers. Для этого достаточно щелкнуть правой кнопкой мыши заголовок столбца и выбрать Изменить тип > Целое число, чтобы изменить тип данных.No problem – just right-click the column header, and select Change Type > Whole Number to change the data type. Если нужно выбрать несколько столбцов, сначала выберите столбец, нажмите и удерживайте клавишу SHIFT, в то же время выбирая дополнительные смежные столбцы, а затем щелкните правой кнопкой мыши заголовок столбца, чтобы изменить все выбранные столбцы.If we needed to choose more than one column, we could first select a column then hold down SHIFT, select additional adjacent columns, and then right-click a column header to change all selected columns. Можно также использовать клавишу CTRL для выбора несмежных столбцов.You can also use CTRL to select non-adjacent columns.

Также можно изменить (или преобразовать эти столбцы из текста в заголовок), воспользовавшись лентой Преобразование .You can also change, or transform, those columns from text to header by using the Transform ribbon. На следующем рисунке показана лента Преобразование ; стрелка на рисунке указывает на кнопку Тип данных , которая позволяет преобразовать текущий тип данных в другой.Here’s the Transform ribbon, with an arrow pointing toward the Data Type button, which lets you transform the current data type to another.

Обратите внимание, что внесенные изменения отражаются в области Параметры запросав разделе Примененные действия .Note that in Query Settings, the Applied Steps reflect the changes that were made. Если требуется удалить какой-либо шаг из процесса формирования, можно просто выбрать этот шаг и щелкнуть значок X слева от него.If I want to remove any step from the shaping process, I simply select that step, and then select the X to the left of the step.

Мы должны сделать еще несколько дополнительных изменений, чтобы получить нужный нам запрос.We need to make a few more changes to get the query where we want it:

  • Удалить первый столбец — он нам не нужен, в нем просто содержатся лишние строки, в которых говорится "Проверьте, как ваш штат оценивается для выхода на пенсию", возникшие в результате получения этой таблицы из веб-данных.Remove the first column – we don’t need it, it just includes redundant rows that say “Check out how your state ranks for retirement” which is an artifact of this being a Web based table
  • Устранить несколько ошибок — на веб-странице один столбец содержит текст в сочетании с числами (некоторые штаты включены в одну категорию).Fix a few Errors – on the Web page, one column had text mixed in with the numbers (some states tied in one category). Это хорошо работает на веб-сайте, но не годится для анализа данных.That works well in the website, but not for our data analysis. В данном случае это можно легко исправить и продемонстрировать некоторые полезные функции и возможности редактора запросов и его раздела Примененные действияIt's easy (in this case) to fix, and shows some cool features and capabilities of Query Editor and its Applied Steps
  • Изменить имя таблицы : имя Таблица 0 не несет полезных сведений, но его легко изменить.Change the Table Name – that Table 0 is not a useful descriptor, but changing it simple

Каждое из этих действий продемонстрировано в разделе Формирование и объединение данных в Power BI Desktop.Each of these steps is demonstrated in Shape and Combine Data in Power BI Desktop. Вы можете извлечь эту страницу или продолжить работать с этим документом, чтобы увидеть, что следует делать далее.Feel free to check out that page, or keep going in this document to see what you would do next. Следующий раздел продолжается после применения приведенных выше изменений.The next section picks up after the changes above are applied.

Объединение данныхCombine data

Эти данные о различных штатах представляют интерес и будут использоваться для создания дополнительных аналитических исследований и запросов.That data about various states is interesting, and will be useful for building additional analysis efforts and queries. Однако есть одна проблема: в большей части данных здесь используется не полное название штата, а его двухбуквенный код.But there’s one problem: most data out there uses a two-letter abbreviation for state codes, not the full name of the state. Нам нужно каким-либо способом связать названия штатов с их кодами.We need some way to associate state names with their abbreviations.

Нам повезло: имеется другой общедоступный источник данных, который делает именно это, но требуется его изрядное формирование, прежде чем можно будет подключить его к нашей таблице.We’re in luck: there’s another public data source that does just that, but it needs a fair amount of shaping before we can connect it to our retirement table. Вот этот веб-ресурс для кодов штатов:Here’s the Web resource for state abbreviations:

http://en.wikipedia.org/wiki/List_of_U.S._state_abbreviationshttp://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations

Из ленты Главная в представлении Редактор запросов выберите Получить данные > Интернет, введите адрес, нажмите кнопку ОК. В окне Навигатор отобразится содержимое этой веб-странице.From the Home ribbon in Query Editor, we select Get Data > Web and type the address, select OK, and the Navigator window shows what it found on that Web page.

Мы устанавливаем флажок (Таблица[изменить]) , поскольку в этой таблице содержатся нужные нам данные, но их нужно немного очистить.We select Table[edit] because it includes the data we want, but it’s going to take quite a bit of shaping to pare that table’s data down. Каждое из этих действий также демонстрируется в разделе Формирование и объединение данных в Power BI Desktop.Each of these steps is also demonstrated in Shape and Combine Data in Power BI Desktop. Итак, вот что мы делаем.To summarize those steps, here's what we do:

Мы выбираем Изменить, а затем вносим следующие изменения.We select Edit, then:

  • Удалим первые две строки : они появились в результате создания таблицы на веб-странице определенным способом, они не нужны.Remove the top two rows – they’re a result of the way that Web page’s table was created, and we don’t need them.
  • Удалим последние 26 строк : это все территории, которые включать не нужно.Remove the bottom 26 rows – they’re all the territories, which we don’t need to include.
  • Отфильтруем значение Washington DC (Вашингтон, Округ Колумбия) — таблица RetirementStats не содержит значение DC, поэтому мы исключим ее из списка.Filter out Washington DC – the retirement stats table doesn't include DC, so we'll exclude it from our list.
  • Удалим несколько ненужных столбцов : нам требуется только сопоставление штата с его официальным двухбуквенным кодом, поэтому мы можем удалить другие столбцы.Remove a few unneeded columns – we only need the mapping of state to its official two-letter abbreviation, so we can remove the other columns.
  • Используем первую строку в качестве заголовков : поскольку мы удалили три верхние строки, текущая верхняя строка является нужным нам заголовком.Use the first row as headers – since we removed the top three rows, the current top row is the header we want.

    Примечание

    Это подходящий момент, чтобы показать, как важна последовательность примененных шагов в редакторе запросов, так как она может влиять на способ формирования данных.This is a good time to point out that the sequence of applied steps in Query Editor is important, and can affect how the data is shaped. Также важно рассмотреть, как один шаг может повлиять на последующий шаг; если удалить шаг из раздела Примененные действия, то последующие шаги могут работать не так, как предполагалось, из-за влияния последовательности шагов запроса.It’s also important to consider how one step may impact another subsequent step; if you remove a step from the Applied Steps, subsequent steps may not behave as originally intended, because of the impact of the query’s sequence of steps.

  • Переименовываем столбцы и саму таблицу : как правило, существует несколько способов изменения имени столбца и можно выбрать любой из них.Rename the columns, and the table itself – as usual, there are a couple ways to rename a column, you can choose whichever you prefer.

После того как таблица StateCodes сформирована, можно объединить эти две таблицы (или два запроса) в одну; поскольку таблицы, которые у нас получились, представляют собой результат запросов к данным, они часто называются запросами.With the StateCodes table shaped, we can combine these two tables, or queries, into one; since the tables we now have are a result of the queries we applied to the data, they’re often referred to as queries.

Существует два основных способа объединения запросов: слияние и дополнение.There are two primary ways of combining queries – merging and appending.

Если имеется один или несколько столбцов, которые требуется добавить в другой запрос, нужно выполнить слияние запросов.When you have one or more columns that you’d like to add to another query, you merge the queries. При наличии дополнительных строк данных, которые нужно добавить в существующий запрос, выполняется дополнение запроса.When you have additional rows of data that you’d like to add to an existing query, you append the query.

В данном случае мы хотим слить запросы.In this case we want to merge queries. Для начала мы выберем запрос, с которым хотим выполнить слияние другого запроса, а затем выберем команду Объединить запросы на вкладке ленты Главная .To get started, we select the query into which we want the other query to merge, then select Merge Queries from the Home tab on the ribbon.

Появится окно Слияние , предлагающее выбрать таблицу для слияния с выбранной и соответствующие столбцы для слияния.The Merge window appears, prompting us to select which table we’d like merged into the selected table, and then, the matching columns to use for the merge. Выберите столбец Штат из таблицы (запроса) RetirementStats , затем выберите запрос StateCodes (в данном случае это просто, так как существует только один другой запрос, а при подключении к нескольким источникам данных приходится выбирать из нескольких запросов).Select State from the RetirementStats table (query), then select the StateCodes query (easy in this case, since there’s only one other query – when you connect to many data sources, there are many queries to choose from). Выбрав нужные сопоставляемые столбцы ( Штат из таблицы RetirementStats и Название штата из таблицы StateCodes , мы увидим окно Слияние , которое выглядит следующим образом, и активную кнопку ОК .When we select the correct matching columns – State from RetirementStats, and State Name from StateCodes – the Merge window looks like the following, and the OK button is enabled.

В конце запроса создается столбец NewColumn , содержащий данные из таблицы (запроса), которая была объединена с существующим запросом.A NewColumn is created at the end of the query, which is the contents of the table (query) that was merged with the existing query. Все столбцы из объединенного запроса включены в столбец NewColumn, но можно Развернуть таблицу и включить нужные столбцы.All columns from the merged query are condensed into the NewColumn, but you can select to Expand the table, and include whichever columns you want. Чтобы развернуть объединенную таблицу и выбрать столбцы для включения, щелкните значок развертывания ().To expand the merged table, and select which columns to include, select the expand icon (). Появится окно Развернуть .The Expand window appears.

В данном случае нам нужен только столбец Код штата , поэтому мы выберем только этот столбец, а затем нажмем кнопку ОК.In this case, we only want the State Code column, so we select only that column and then select OK. Мы снимаем флажок Использовать имя исходного столбца как префикс , поскольку нам это не нужно; если оставить этот флажок, то объединенный столбец будет называться NewColumn.State Code (имя исходного столбца NewColumn, затем точка, а затем имя столбца, отображаемого в запросе).We clear the checkbox from Use original column name as prefix because we don’t need or want that; if we leave that selected, the merged column would be named NewColumn.State Code (the original column name, or NewColumn, then a dot, then the name of the column being brought into the query).

Примечание

Хотите опробовать разные способы выведения таблицы NewColumn на экран?Want to play around with how to bring in that NewColumn table? Вы можете немного поэкспериментировать, и если вас не устроит результат, просто удалите этот шаг из списка примененных действий в области параметров запроса ; ваш запрос вернется в состояние до применения шага Развернуть .You can experiment a bit, and if you don’t like the results, just delete that step from the Applied Steps list in the Query Settings pane; your query returns to the state prior to applying that Expand step. Это как бесплатная попытка, которую вы можете повторять сколько угодно, пока процесс развертывания не будет происходить так, как нужно.It’s like a free do-over, which you can do as many times as you like until the expand process looks the way you want it.

Теперь у нас есть один запрос (таблица), объединяющий два источника данных, каждый из которых сформирован так, как нам нужно.We now have a single query (table) that combined two data sources, each of which has been shaped to meet our needs. Этот запрос может служить основой для большого количества дополнительных подключений к представляющим интерес данным, таким как стоимость содержания, демографические данные или вакансии в любом штате.This query can serve as a basis for lots of additional, interesting data connections – such as housing cost statistics, demographics, or job opportunities in any state.

Подробное описание каждого действия по формированию и объединению данных см. в статье Формирование и объединение данных в Power BI Desktop.For a more complete description of each of these shape and combine data steps, see Shape and Combine Data in Power BI Desktop.

Теперь у нас есть достаточно данных для создания нескольких интересных отчетов в Power BI Desktop.For now, we have enough data to create a few interesting reports, all within Power BI Desktop. Поскольку это важный этап процесса, давайте сохраним этот файл Power BI Desktop и назовем его Начало работы с Power BI Desktop.Since this is a milestone let’s save this Power BI Desktop file – we’ll call it Getting Started with Power BI Desktop. Чтобы применить изменения в редакторе запросов и загрузить их в Power BI Desktop, выберите Закрыть и применить на ленте Главная.To apply the changes in Query Editor and load them into Power BI Desktop, select Close & Apply from the Home ribbon.

Создание отчетовBuild reports

После загрузки таблицы можно внести дополнительные изменения. Кроме того, можно повторно загружать модель, чтобы применить внесенные изменения.Additional changes can be made after the table is loaded, and you can reload a model to apply any changes you make. Однако сейчас этого достаточно.But for now this will do. В представлении Отчет в Power BI Desktop можно приступить к созданию отчетов.In Power BI Desktop Report view, you can begin to build reports.

Представление Отчет имеет пять основных областей:The Report view has five main areas:

  1. лента, на которой отображаются стандартные задачи, связанные с отчетами и визуализациями;The ribbon, which displays common tasks associated with reports and visualizations
  2. представление Отчет , где создаются и оформляются визуализации;The Report view, or canvas, where visualizations are created and arranged
  3. область вкладок Страницы внизу, где можно выбрать и добавить страницу отчета;The Pages tab area along the bottom, which lets you select or add a report page
  4. область Визуализации , где можно изменить визуализации, настроить цвета и оси, применить фильтры, перетащить поля и многое другое;The Visualizations pane, where you can change visualizations, customize colors or axes, apply filters, drag fields, and more
  5. область Поля , где элементы запросов и фильтры можно перетащить в представление Отчет или область Фильтры зоны Визуализации .The Fields pane, where query elements and filters can be dragged onto the Report view, or dragged to the Filters area of the Visualizations pane

Области Визуализации и Поля можно свернуть, щелкнув маленькую стрелку сбоку, чтобы освободить больше места в представлении Отчет для построения впечатляющих визуализаций.The Visualizations and Fields pane can be collapsed by selecting the small arrow along the edge, providing more space in the Report view to build cool visualizations. При изменении представлений вы также увидите эти указывающие вверх или вниз стрелки, означающее, что можно развернуть или свернуть этот раздел соответственно.When modifying visualizations, you'll also see these arrows pointing up or down, which means you can expand or collapse that section, accordingly.

Для создания визуализации просто перетащите поле из списка Поля в представление Отчет .To create a visualization, just drag a field from the Fields list onto the Report view. В данном случае давайте перетащим поле Штат из области RetirementStats и посмотрим, что произойдет.In this case, let’s drag the State field from RetirementStats, and see what happens.

Посмотрите... Power BI Desktop автоматически создает визуализацию на основе карты, так как распознает, что поле Штат содержит данные о географическом положении.Look at that... Power BI Desktop automatically created a map-based visualization, because it recognized that the State field contained geolocation data.

Обратите внимание, что в области Визуализации можно выбрать различные типы визуализаций, а в области под этими значками можно перетащить поля в разные области, чтобы применить условные обозначения, или изменить визуализацию любым другим способом.Notice that in the Visualizations pane, I can select different types of visualizations, and in the area below those icons, I can drag fields to different areas to apply a Legend, or otherwise modify the visualization.

Давайте немного перенесемся вперед и посмотрим, как выглядит представление отчетов после добавления небольшого количества визуализаций и нескольких новых страниц отчета.Let’s fast-forward a bit, and see what the Report view looks like after a handful of visualizations have been added, as well as a few new Report pages. Дополнительные сведения об отчетах см. в статье Представление отчетов в Power BI Desktop.For more information about reports, see Report View in Power BI Desktop.

На первой странице отчета представлена перспектива данных на основе общего рейтинга.The first Report page provides a perspective of the data based on Overall rank. Когда мы выбираем одну из визуализаций, в области Поля и фильтры отображаются выбранные поля и структура визуализации (поля которой применяются к разделам Общая ось, Значения столбцови Значения строк).When we select one of the visualizations, the Fields and Filters pane shows which fields are selected, and the structure of the visualization (which fields are applied to the Shared Axis, Column Values, and Line Values).

Этот отчет состоит из шести страниц , каждая из которых визуализирует определенные элементы данных.There are six Pages in this Report, each visualizing certain elements of our data.

  1. На первой странице выше отображаются все штаты на основе общего рейтинга.The first page, shown above, shows all states based on Overall rank.
  2. На второй странице отображаются сведения о десяти лучших штатах исходя из общего рейтинга.The second page focuses on the top ten states based on Overall rank.
  3. На третьей странице отображаются 10 лучших штатов по стоимости жизни (и соответствующие данные).For the third page, the best 10 states for cost of living (and associated data) are visualized.
  4. На четвертой странице отображаются сведения о погоде для 15 самых солнечных штатов.Weather is the focus of the fourth page, filtered to the 15 sunniest states.
  5. На пятой странице приводятся графики и визуализации данных по общему благосостоянию для 15 лучших штатов.On the fifth page, Community well-being is charted and visualized for the top 15 states.
  6. Наконец, на шестой странице визуализируется статистика преступности для десяти лучших (и худших) штатов.Lastly, crime statistics are visualized, showing the best (and well, the last) ten states.

Вот как выглядит страница отчета, посвященная стоимости жизни.Here’s what the cost of living-focused Report page looks like.

Присутствуют все виды интересных отчетов и визуализаций, которые вы можете создать.There are all sorts of interesting reports and visualizations you can create.

Совместное использование работыShare your work

Теперь, когда у нас есть достаточно полный отчет Power BI Desktop, им можно поделиться с другими в службе Power BI .Now that we have a Power BI Desktop report that’s reasonably complete, we can share it with others on the Power BI service. Существует несколько способов предоставления общего доступа к своей работе в Power BI Desktop.There are a few ways to share your work in Power BI Desktop. Работу можно опубликовать в службе Power BI , можно загрузить файл PBIX непосредственно из службы Power BI или сохранить этот файл и отправить его как любой другой файл.You can publish to the Power BI service, you can upload the .pbix file directly from the Power BI service, or you can save the .pbix file and send it like any other file.

Во-первых, рассмотрим публикацию в службе Power BI непосредственно из Power BI Desktop.First, let's look at publishing to the Power BI service directly from Power BI Desktop. На ленте Главная выберите Опубликовать.On the Home ribbon, select Publish.

Вам может быть предложено выполнить вход в Power BI.You may be prompted to sign in to Power BI.

Если вы выполнили вход и завершили процесс публикации, отобразится следующее диалоговое окно.When you've signed in and the publish process is complete, you see the following dialog.

При входе Power BI вы увидите только что загруженный файл Power BI Desktop в разделах службы Панели мониторинга, Отчетыи Наборы данных .When you sign in to Power BI, you'll see Power BI Desktop file you just loaded in the Dashboards, Reports, and Datasets sections of the service.

Кроме того, для предоставления общего доступа к своей работе можно загрузить ее из службы Power BI .Another way to share your work is to load it from within the Power BI service. C помощью следующей ссылки можно открыть службу Power BI в браузере:The following link brings up the Power BI service in a browser:

https://app.powerbi.com

Нажмите Получить данные , чтобы запустить процесс загрузки своего отчета Power BI Desktop.Select Get Data to start the process of loading your Power BI Desktop report.

Появится страница получения данных , на которой можно выбрать источник получения своих данных.The Get Data page appears, from which you can select where to get your data from. В этом случае мы выберем Получить из поля Файлы .In this case, we select Get from the Files box.

Появляется представление Файлы .The Files view appears. Нам нужно выбрать Локальный файл.In this case, we select Local File.

При выборе файла Power BI загружает файл.When you select the file, Power BI uploads the file.

После передачи файла можно выбрать его в поле Отчеты в левой области службы Power BI.Once the file is uploaded, you can select the file from the Reports in the left pane of the Power BI service.

В службе Power BI отображается первая страница отчета.The Power BI service displays the first page of the report. Вы можете выбрать любую вкладку в нижней части страницы, чтобы отобразить соответствующую страницу отчета.Along the bottom of the page, you can select any tab to display that page of the report.

Можно внести изменения в отчет в службе Power BI , выбрав Редактировать отчет в верхней части холста отчета.You can make changes to a report in the Power BI service by selecting Edit Report from the top of the report canvas.

Чтобы сохранить отчет, выберите Файл > Сохранить как в службе.To save your report, select File > Save As from the service. Там присутствуют все виды интересных визуальных элементов, которые можно создать в службе Power BI из отчета и закрепить на панели мониторинга.There are all sorts of interesting visuals you can create in the Power BI service from your report, which you can pin to a dashboard. Дополнительные сведения о панелях мониторинга в службе Power BI см. в рекомендациях по проектированию идеальной панели мониторинга.To learn about dashboards in the Power BI service, see Tips for designing a great dashboard.

После сохранения щелкните значок Поделиться на главной странице.Once saved, select the Share icon on the main page.

Отсюда можно отправить по электронной почте сообщение коллегам, с которыми вы хотите совместно использовать панель мониторинга.From here, you can send an email to colleagues with whom you’d like to share the dashboard.

Дополнительные сведения о создании, изменении панелей мониторинга и предоставлении общего доступа к ним см. в разделе Совместное использование панели мониторинга.For more information about creating, sharing, and modifying dashboards, see Share a dashboard.

С помощью Power BI Desktop и службы Power BI можно создавать все виды впечатляющих гибридных веб-приложений и визуализаций на основе данных.There are all sorts of compelling data-related mash-ups and visualizations you can do with Power BI Desktop, and with the Power BI service. Дополнительные сведения см. в следующем разделе.Check out the next section for more information.

Дальнейшие действияNext steps

Power BI Desktop предоставляет широкие возможности.There are all sorts of things you can do with Power BI Desktop. Дополнительные сведения об этих возможностях см. в следующих ресурсах.For more information on its capabilities, check out the following resources: