Общие сведения о запросах в Power BI DesktopQuery overview in Power BI Desktop

С помощью Power BI Desktop вы можете подключаться к миру данных, создавать привлекательные и фундаментальные отчеты и совместно использовать свою работу с другими пользователями, которые затем могут использовать ее для расширения своих возможностей по бизнес-аналитике.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop имеет три представления:Power BI Desktop has three views:

  • Представление отчетов — здесь можно использовать запросы для создания впечатляющих визуализаций, их упорядочивания и добавления на них нескольких страниц, которые можно использовать совместно с другими пользователями.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Представление данных — здесь можно просматривать данные отчета в формате модели данных, добавлять меры, создавать новые столбцы и управлять связями.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Представление связей — здесь можно получить графическое представление связей, установленных в вашей модели данных, а также при необходимости изменять их или управлять ими.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Доступ к этим представлениям осуществляется путем выбора одного из трех значков, расположенных вдоль левой стороны Power BI Desktop.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. На следующем рисунке выбрано представление отчетов, на что указывает желтая полоска рядом со значком.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop также имеет редактор запросов, где можно подключиться к одному или нескольким источникам данных, преобразовывать данные в соответствии с потребностями, а также загружать модель в Power BI Desktop.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Этот документ содержит общие сведения о работе с данными в редакторе запросов.This document provides an overview of the work with data in the Query Editor. В конце документа вы найдете ссылки на дополнительные сведения и рекомендации по поддерживаемым типам данных, подключению к данным, формированию данных, созданию связей и началу работы.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Но сначала давайте ознакомимся с редактором запросов.But first, let’s see get acquainted with Query Editor.

Редактор запросовThe Query Editor

Чтобы открыть редактор запросов, в Power BI Desktop на вкладке Главная нажмите кнопку Изменить запросы.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Без подключения к данным в редакторе запросов отображается пустая область.With no data connections, Query Editor appears as a blank pane, ready for data.

После загрузки запроса представление редактора запросов становится гораздо более интересным.Once a query is loaded, Query Editor view becomes more interesting. Если мы подключимся к указанному ниже веб-источнику данных, редактор запросов загрузит сведения о данных и мы сможем начинать их формировать.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspxhttp://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Вот так выглядит редактор запросов после подключения к данным:Here’s how Query Editor appears once a data connection is established:

  1. На ленте многие кнопки теперь можно использовать для взаимодействия с данными в запросе.In the ribbon, many buttons are now active to interact with the data in the query
  2. В левой области перечислены запросы, которые можно выбирать, просматривать и формировать.In the left pane, queries are listed and available for selection, viewing, and shaping
  3. В центральной области отображаются данные из выбранного запроса, и их можно формировать.In the center pane, data from the selected query is displayed and available for shaping
  4. Появляется окно параметров запроса, в котором перечислены свойства запроса и примененные действия.The Query Settings window appears, listing the query’s properties and applied steps

Мы рассмотрим каждую из этих четырех областей — ленту, область запросов, представление данных и область параметров запроса — в следующих разделах.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Лента запросаThe query ribbon

Лента в редакторе запросов состоит из четырех вкладок: Главная, Преобразовать, Добавить столбец и Вид.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

На вкладке Главная содержатся общие задачи запроса, включая первый шаг в любом запросе — получение данных.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. На следующем рисунке показана вкладка Главная ленты.The following image shows the Home ribbon.

Чтобы подключиться к данным и начать процесс построения запросов, нажмите кнопку Получить данные .To connect to data and begin the query building process, select the Get Data button. Появится меню с наиболее распространенными источниками данных.A menu appears, providing the most common data sources.

Дополнительные сведения о доступных источниках данных см. в разделе Источники данных.For more information about available data sources, see Data Sources. Сведения о подключении к данным, включая примеры и инструкции, см. в разделе Подключение к данным.For information about connecting to data, including examples and steps, see Connect to Data.

На вкладке Преобразовать предоставляется доступ к распространенным задачам преобразования данных, таким как добавление или удаление столбцов, изменение типов данных, разбиение столбцов и другие задачи управления данными.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. На следующем рисунке показана вкладка Преобразовать ленты.The following image shows the Transform tab.

Дополнительные сведения о преобразовании данных, включая примеры, см. в разделе Объединение и формирование данных.For more information about transforming data, including examples, see Combine and Shape Data.

На вкладке Добавить столбец предоставляются дополнительные задачи, связанные с добавлением столбца, форматированием данных столбца и добавлением настраиваемых столбцов.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. На следующем рисунке показана вкладка Добавить столбец ленты.The following image shows the Add Column tab.

Вкладка Вид на ленте используется для переключения между разными областями или окнами.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Она также используется для отображения расширенного редактора.It’s also used to display the Advanced Editor. На следующем рисунке показана вкладка Вид ленты.The following image shows the View tab.

Полезно знать, что многие задачи, доступные на ленте, также доступны по щелчку правой кнопкой мыши столбца или других данных в центральной области.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Левая областьThe left pane

В левой области отображается число активных запросов, а также имя запроса.The left pane displays the number of active queries, as well as the name of the query. При выборе запроса в левой области его данные отображаются в центральной области, где их можно формировать и преобразовывать в соответствии со своими потребностями.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. На следующем рисунке показана левая область с несколькими запросами.The following image shows the left pane with multiple queries.

Центральная область (область данных)The center (data) pane

В центральной области, или области данных, отображаются данные из выбранного запроса.In the center pane, or Data pane, date from the selected query is displayed. Здесь выполняется большая часть работы с представлением запросов.This is where much of the work of the Query view is accomplished.

На следующем рисунке показано установленное ранее подключение к интернет-данным, столбец Overall score (Общий рейтинг) выбран, и выполняется щелчок его заголовка правой кнопкой мыши, чтобы отобразить доступные пункты меню.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Обратите внимание, что многие из этих пунктов контекстного меню совпадают с кнопками на вкладках ленты.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

При выборе пункта контекстного меню (или нажатии кнопки на ленте) запрос применяет это действие к данным и сохраняет его как часть самого запроса.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Действия записываются в области Параметры запроса в последовательном порядке, как описано в следующем разделе.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Область параметров запросаThe query settings pane

В области Параметры запроса отображаются все действия, связанные с запросом.The Query Settings pane is where all steps associated with a query are displayed. Например, на следующем рисунке в разделе Примененные действия области Параметры запроса отражен тот факт, что мы только что изменили тип столбца Overall score (Общий рейтинг).For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

По мере применения к запросу дополнительных действий по формированию они регистрируются в разделе Примененные действия .As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

Важно знать, что базовый источник данных не изменяется; редактор запросов настраивает и формирует представление его данных, и все взаимодействие с базовыми данными происходит на основе сформированного и измененного редактором запросов представления этих данных.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

В области Параметры запроса можно переименовывать действия, удалять действия или упорядочивать их по своему усмотрению.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Для этого щелкните правой кнопкой мыши действие в разделе Примененные действия и в появившемся меню выберите соответствующую команду.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Все действия запроса выполняются в порядке их отображения в области Примененные действия.All query steps are carried out in the order they appear in the Applied Steps pane.

Расширенный редакторThe Advanced Editor

Если вы хотите просмотреть код, который создает запрос в каждом действии, или нужно создать собственный формирующий код, можно использовать расширенный редактор.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Чтобы запустить расширенный редактор, выберите на ленте вкладку Вид , а затем нажмите Расширенный редактор.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Появится окно с существующим кодом запроса.A window appears, showing the existing query code.

Можно непосредственно редактировать код в окне Расширенный редактор .You can directly edit the code in the Advanced Editor window. Чтобы закрыть окно, нажмите кнопку Готово или Отмена .To close the window, select the Done or Cancel button.

Сохранение работыSaving your work

Когда запрос готов, можно использовать редактор запросов для применения изменений к модели данных в Power BI Desktop, после чего закрыть редактор запросов.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. Для этого выберите пункт Закрыть и применить в меню Файл редактора запросов.To do that, select Close & Apply from Query Editor's File menu.

По мере хода выполнения Power BI Desktop выводит диалоговое окно для отображения состояния.As progress is made, Power BI Desktop provides a dialog to display its status.

После создания запроса или для сохранения результатов работы Power BI Desktop может сохранить вашу работу в виде PBIX-файла.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Чтобы сохранить результаты работы, выберите Файл > Сохранить (или Файл > Сохранить как), как показано на следующем рисунке.To save your work, select File > Save (or File > Save As), as shown in the following image.

Дальнейшие действияNext steps

Power BI Desktop предоставляет широкие возможности.There are all sorts of things you can do with Power BI Desktop. Дополнительные сведения об этих возможностях см. в следующих ресурсах.For more information on its capabilities, check out the following resources: