Использование внешней среды R IDE с Power BIUse an external R IDE with Power BI

В Power BI Desktop можно использовать внешнюю среду R IDE (интегрированная среда разработки) для создания и редактирования R-скриптов, которые затем будут использоваться в Power BI.With Power BI Desktop, you can use your external R IDE (Integrated Development Environment) to create and refine R scripts, then use those scripts in Power BI.

Включение внешней среды R IDEEnable an external R IDE

Ранее для создания и выполнения R-скриптов вам нужно было использовать редактор R-скриптов в Power BI Desktop.Previously, you had to use the R script editor in Power BI Desktop to create and run R scripts. Сейчас вы можете запускать внешнюю среду R IDE из Power BI Desktop с автоматическим импортом и отображением данных в R IDE.With this release, you can launch your external R IDE from Power BI Desktop and have your data automatically imported and displayed in the R IDE. Вы можете изменять скрипты во внешней среде R IDE, а затем снова добавлять их в Power BI Desktop для создания визуальных элементов и отчетов Power BI.From there, you can modify the script in that external R IDE, then paste it back into Power BI Desktop to create Power BI visuals and reports.

Начиная с версии Power BI Desktop, выпущенной в сентябре 2016 года, (версия 2.39.4526.362) можно указать, какую среду R IDE вы хотите использовать, и запустить ее автоматически из Power BI Desktop.Beginning with the September 2016 release of Power BI Desktop (version 2.39.4526.362), you can specify which R IDE you would like to use, and have it launch automatically from within Power BI Desktop.

ТребованияRequirements

Чтобы использовать эту функцию, необходимо установить R IDE на локальном компьютере.To use this feature, you need to install an R IDE on your local computer. Так как в Power BI Desktop не предусмотрена возможность включения, развертывания или установки модуля R, вам нужно отдельно установить R на локальном компьютере.Power BI Desktop does not include, deploy or install the R engine, so you must separately install R on your local computer. Используя следующие варианты, вы можете выбрать среду R IDE для использования.You can choose which R IDE to use, with the following options:

  • Вы можете установить свою любимую среду R IDE из доступных бесплатно, таких как Revolution Open и CRAN Repository.You can install your favorite R IDE, many of which are available for free, such as the Revolution Open download page, and the CRAN Repository.
  • Power BI Desktop также поддерживает R Studio и Visual Studio 2015 со средствами редактирования R для Visual Studio.Power BI Desktop also supports R Studio and Visual Studio 2015 with R Tools for Visual Studio editors.
  • Вы можете запустить другую среду R IDE, чтобы с помощью следующих действий запустить эту R IDE, используя Power BI Desktop.You can also install a different R IDE and have Power BI Desktop launch that R IDE by doing one of the following:

    • Вы можете связать файлы .R с внешней средой IDE, которая будет запущена с помощью Power BI Desktop.You can associate .R files with the external IDE you want Power BI Desktop to launch.
    • Вы можете указать исполняемый файл, который должно запустить приложение Power BI Desktop. Для этого в диалоговом окне Options (Параметры) в разделе R Script Options (Параметры R-скрипта) выберите Other (Другие).You can specify the .exe that Power BI Desktop should launch by selecting Other from the R Script Options section of the Options dialog. Чтобы открыть диалоговое окно Options (Параметры), последовательно выбрав элементы File > Options and settings > Options (Файл > Параметры и настройки > Параметры).You can bring up the Options dialog by going to File > Options and settings > Options.

Если вы установили нескольких сред R IDE, вы можете указать, какую из них следует запустить. Для этого выберите ее в раскрывающемся списке Detected R IDEs (Обнаруженные среды R IDE) в диалоговом окне Options (Параметры).If you have multiple R IDEs installed, you can specify which will be launched by selecting it from the Detected R IDEs drop-down in the Options dialog.

По умолчанию приложение Power BI Desktop запустит R Studio в качестве внешней R IDE, если она установлена на локальном компьютере. Если среда R Studio не установлена, но установлена Visual Studio 2015 со средствами R для Visual Studio, будет запущена эта среда.By default, Power BI Desktop will launch R Studio as the external R IDE if it's installed on your local computer; if R Studio is not installed and you have Visual Studio 2015 with R Tools for Visual Studio, that will be launched instead. Если не установлена ни одна из сред R IDE, запустится приложение, ассоциированное с файлами .R.If neither of those R IDEs is installed, the application associated with .R files is launched.

Если нет сопоставления с файлом .R, вы можете указать путь к пользовательской интегрированной среде разработки в разделе Browse to your preferred R IDE (Переход к предпочтительной R IDE) диалогового окна Options (Параметры).And if no .R file association exists, it's possible to specify a path to a custom IDE in the Browse to your preferred R IDE section of the Options dialog. Вы также можете запустить другую среду R IDE, щелкнув значок Settings (Настройки) рядом со стрелкой Launch R IDE (Запуск R IDE) в приложении Power BI Desktop.You can also launch a different R IDE by selecting the Settings gear icon beside the Launch R IDE arrow icon, in Power BI Desktop.

Запуск R IDE из Power BI DesktopLaunch an R IDE from Power BI Desktop

Чтобы запустить R IDE из Power BI Desktop, сделайте следующее.To launch an R IDE from Power BI Desktop, take the following steps.

  1. Загрузите данные в Power BI Desktop.Load data into Power BI Desktop.
  2. В области Поля выберите поля, с которыми вы собираетесь работать.Select some fields from the Fields pane that you want to work with. Если вы еще не включили визуальные элементы скрипта, вам будет предложено сделать это.If you haven't enabled script visuals yet, you'll be prompted to do so.

  3. Если визуальные элементы скрипта включены, вы можете выбрать визуальный элемент R в области Визуализации. Будет создан пустой визуальный элемент R, готовый для отображения результатов скрипта.When script visuals are enabled, you can select an R visual from the Visualizations pane, which creates a blank R visual that's ready to display the results of your script. Также отобразится область Редактор R-скриптов.The R script editor pane also appears.

  4. Теперь вы можете выбрать поля, которые будут использоваться в R-скрипте.Now you can select the fields you want to use in your R script. Когда вы выберете поля, Редактор R-скриптов автоматически создаст код скрипта с учетом этого выбора.When you select a field, the R script editor field automatically creates script code based on the field or fields you select. Вы можете создать (или вставить) R-скрипт непосредственно в область Редактор R-скриптов либо же оставить этот элемент пустым.You can either create (or paste) your R script directly in the R script editor pane, your you can leave it empty.

    Примечание

    По умолчанию для визуальных элементов R используется тип агрегирования Не подводить итоги.The default aggregation type for R visuals is do not summarize.

  5. Теперь можно запускать среду R IDE непосредственно из Power BI Desktop.You can now launch your R IDE directly from Power BI Desktop. Нажмите кнопку запуска R-IDE (справа от заголовка Редактор R-скриптов, как показано ниже).Select the Launch R IDE button, found on the right side of the R script editor title bar, as shown below.

  6. Выбранная среда R IDE будет запущена службой Power BI Desktop, как показано на следующем рисунке (здесь в качестве среды R IDE по умолчанию используется RStudio).Your specified R IDE is launched by Power BI Desktop, as shown in the following image (in this image, RStudio is the default R IDE).

    Примечание

    Power BI Desktop добавляет первые три строки скрипта, обеспечивая возможность импорта данных из Power BI Desktop после запуска скрипта.Power BI Desktop adds the first three lines of the script so it can import your data from Power BI Desktop once you run the script.

  7. Любой скрипт, созданный в области редактора R-скриптов в Power BI Desktop отобразится, начиная со строки 4 среды R IDE.Any script you created in the R script editor pane of Power BI Desktop appears starting in line 4 in your R IDE. Теперь вы можете создавать свой R-скрипт в среде R IDE.At this point you can create your R script in the R IDE. Когда R-скрипт будет выполнен в среде R IDE, его нужно скопировать и вставить обратно в область Редактор R-скриптов в Power BI Desktop, за исключением первых трех строк скрипта, автоматически созданных службой Power BI Desktop.Once your R script is complete in your R IDE, you need to copy and paste it back into the R script editor pane in Power BI Desktop, excluding the first three lines of the script that Power BI Desktop automatically generated. Не следует копировать первые три строки скрипта в Power BI Desktop, так как эти строки предназначены только для импорта данных в R IDE из Power BI Desktop.Do not copy the first three lines of script back into Power BI Desktop, those lines were only used to import your data to your R IDE from Power BI Desktop.

Известные ограниченияKnown limitations

При запуске среды R IDE непосредственно из Power BI Desktop действуют следующие ограничения.Launching an R IDE directly from Power BI Desktop has a few limitations:

  • Автоматический экспорт скрипта из R IDE в Power BI Desktop не поддерживается.Automatically exporting your script from your R IDE into Power BI Desktop is not supported.
  • Редактор R Client (RGui.exe) не поддерживается, так как сам редактор не поддерживает открытие файлов.R Client editor (RGui.exe) is not supported, because the editor itself does not support opening files.

Дальнейшие действияNext steps

Ознакомьтесь с дополнительными материалами по R в Power BI.Take a look at the following additional information about R in Power BI.