Использование языка R в редакторе запросовUsing R in Query Editor

В редакторе запросов Power BI Desktop можно использовать язык программирования R, который широко применяют специалисты по статистике, аналитики и специалисты по обработке данных.You can use R, a programming language widely used by statisticians, data scientists, and data analysts, in the Power BI Desktop Query Editor. Интеграция языка R в редактор запросов позволяет выполнять очистку данных с помощью R, а также формирование и анализ данных в наборах данных, в частности заполнение отсутствующих данных, прогнозирование и кластеризацию.This integration of R into Query Editor lets you perform data cleansing using R, and perform advanced data shaping and analytics in datasets, including completion of missing data, predictions, and clustering, just to name a few. R — эффективный язык, который можно использовать в редакторе запросов для подготовки модели данных и создания отчетов.R is a powerful language, and can be used in Query Editor to prepare your data model and create reports.

Установка RInstalling R

Чтобы использовать R в редакторе запросов Power BI Desktop, необходимо установить R на локальном компьютере.To use R in Power BI Desktop's Query Editor, you need to install R on your local machine. Вы можете скачать и установить R бесплатно из различных расположений, включая страницу скачивания Revolution Open и репозиторий CRAN.You can download and install R for free from many locations, including the Revolution Open download page, and the CRAN Repository.

Использование языка R в редакторе запросовUsing R in Query Editor

Чтобы продемонстрировать использование R в редакторе запросов, воспользуемся примером из набора данных фондовой биржи в CSV-файле, который вы можете скачать здесь.To show how to use R in Query Editor, we'll use an example from a stock market dataset, based on a .CSV file that you can download from here and follow along. Ниже перечислены шаги для этого примера.The steps for this example are the following:

  1. Сначала загрузите данные в Power BI Desktop.First, load your data into Power BI Desktop. В этом примере мы загрузим файл EuStockMarkets_NA.csv.In this example we'll load the EuStockMarkets_NA.csv file. В Power BI Desktop на вкладке ленты Главная последовательно выберите элементы Получение данных > CSV.Select Get Data > CSV from the Home ribbon in Power BI Desktop.

  2. Выберите файл и нажмите кнопку Открыть. CSV-файл отобразится в диалоговом окне CSV-файл.Select the file and select Open, and the CSV is displayed in the CSV file dialog.

  3. После того как данные загрузятся, вы увидите их в Power BI Desktop в области Поля.Once the data is loaded, you'll see it in the Fields pane in Power BI Desktop.

  4. Откройте редактор запросов. Для этого в Power BI Desktop на вкладке Главная нажмите кнопку Изменить запросы.Open Query Editor by selecting Edit Queries from the Home tab in Power BI Desktop.

  5. На вкладке Преобразование нажмите кнопку Запустить сценарий R. Откроется редактор Запустить сценарий R, который показан на следующем шаге.In the Transform tab, select Run R Script and the Run R Script editor appears (shown in the next step). Обратите внимание, что в строках 15 и 20 отсутствуют данные, как и в других строках, которых не видно на приведенном ниже рисунке.Notice that rows 15 and 20 suffer from missing data, as do other rows you can't see in the following image. В инструкциях ниже показано, как язык R может заполнить эти строки (и заполнит их).The steps below show how R can (and will) complete those rows for you.

  6. Например, введем следующий код сценария:For this example, we'll enter the following script code:

    library(mice)
    tempData <- mice(dataset,m=1,maxit=50,meth='pmm',seed=100)
    completedData <- complete(tempData,1)
    output <- dataset
    output$completedValues <- completedData$"SMI missing values"
    

    Примечание

    Чтобы этот код сценария работал правильно, в вашей среде R должна быть установлена библиотека mice.You'll need to have the mice library installed in your R environment for the previous script code to work properly. Чтобы установить библиотеку Mice, выполните в своем экземпляре R такую команду: | > install.packages('mice')To install mice, run the following in your R installation: | > install.packages('mice')

    Код в диалоговом окне Запустить сценарий R будет выглядеть так:When put into the Run R Script dialog, the code looks like the following:

  7. Если нажать кнопку ОК, в редакторе запросов появится предупреждение о конфиденциальности данных.When we select OK, Query Editor displays a warning about data privacy.

  8. Чтобы сценарии R правильно работали в службе Power BI, уровень конфиденциальности всех источников данных должен иметь значение Общедоступный.For the R scripts to work properly in the Power BI service, all data sources need to be set to public. Дополнительные сведения о параметрах конфиденциальности и результатах их использования см. в статье об уровнях конфиденциальности.For more information about privacy settings and their implications, see Privacy Levels.

    Выбрав общедоступный уровень конфиденциальности, вы увидите новый столбец в области Поля, который называется completedValues.Once we do so, we see a new column in the Fields well called completedValues. Обратите внимание на несколько отсутствующих элементов данных, например в строках 15 и 18.Notice there are a few missing data elements, such as on row 15 and 18. В следующем разделе вы узнаете, как язык R обрабатывает эти строки.We'll see how R handles that in the next section.

Используя только пять строк сценария R, редактор запросов заполнит отсутствующие значения с помощью прогнозной модели.With just five lines of R script, Query Editor filled in the missing values with a predictive model.

Создание визуальных элементов с помощью данных сценария RCreating visuals from R script data

Создадим визуальный элемент, чтобы увидеть, как код сценария R заполнил отсутствующие значения с помощью библиотеки Mice (см. рисунок ниже).Now we can create a visual to see how the R script code using the mice library completed the missing values, as shown in the following image.

Когда будет создан визуальный элемент (а также другие визуальные элементы, которые можно создать с помощью Power BI Desktop), мы сможем сохранить файл Power BI Desktop в формате PBIX, а затем использовать в службе Power BI модель данных и сценарий R, которые включены в эту модель.Once that visual is complete, and any other visuals we might want to create using Power BI Desktop, we can save the Power BI Desktop file (which saves as a .pbix file) and then use the data model, including the R scripts that are part of it, in the Power BI service.

Примечание

Хотите просмотреть заполненный PBIX-файл с результатами выполнения этих действий?Want to see a completed .pbix file with these steps completed? Вам повезло: вы можете загрузить заполненный файл Power BI Desktop, используемый в этих примерах, прямо здесь.You're in luck - you can download the completed Power BI Desktop file used in these examples right here.

После отправки PBIX-файла в службу Power BI необходимо выполнить еще несколько дополнительных действий, чтобы обновить данные (в службе) и включить обновление визуальных элементов в службе (для обновления визуальных элементов данным требуется доступ к R).Once you've uploaded the .pbix file to the Power BI service, a couple more steps are necessary to enable data refresh (in the service) and to enable visuals to be updated in the service (the data needs access to R for visuals to be updated). Вот эти действия:The additional steps are the following:

  • Включите запланированное обновление для набора данных. Чтобы включить запланированное обновление для книги, содержащей набор данных со сценариями R, см. инструкции в статье Настройка запланированного обновления, которая также включает информацию о шлюзе Personal Gateway.Enable scheduled refresh for the dataset - to enable scheduled refresh for the workbook that contains your dataset with R scripts, see Configuring scheduled refresh, which also includes information about Personal Gateway.
  • Установите шлюз Personal Gateway. Установите Personal Gateway на компьютере, на котором сохранен файл и установлен язык R. Службе Power BI необходимо получить доступ к этой книге и повторно преобразовать для просмотра все обновленные визуальные элементы.Install the Personal Gateway - you need a Personal Gateway installed on the machine where the file is located, and where R is installed; the Power BI service must access that workbook and re-render any updated visuals. См. дополнительную информацию в инструкциях по установке и настройке шлюза Personal Gateway.You can get more information on how to install and configure Personal Gateway.

ОграниченияLimitations

Существуют ограничения на запросы, включающие сценарии R, которые созданы в редакторе запросов.There are some limitations to queries that include R scripts created in Query Editor:

  • Всем параметрам источника данных R должно быть присвоено значение Общедоступный. Все остальные действия в запросе, созданном в редакторе запросов, также должны быть общедоступными.All R data source settings must be set to Public, and all other steps in a query created in Query Editor must also be public. Чтобы получить параметры источника данных, в Power BI Desktop выберите элементы Файл > Параметры и настройки > Параметры источника данных.To get to data source settings, in Power BI Desktop select File > Options and settings > Data source settings.

    В диалоговом окне Параметры источника данных выберите источники данных, а затем щелкните Править разрешения и убедитесь, что для параметра Уровень конфиденциальности указано значение Общедоступный.From the Data Source Settings dialog, select the the data source(s) and then select Edit Permissions... and ensure that the Privacy Level is set to Public.

  • Чтобы включить запланированное обновление визуальных объектов R или набора данных, включите запланированное обновление и установите шлюз Personal Gateway на компьютере, на котором сохранена книга и установлен экземпляр R.To enable scheduled refresh of your R visuals or dataset, you need to enable Scheduled refresh and have a Personal Gateway installed on the computer that houses the workbook and the R installation. Дополнительные сведения о запланированном обновлении и шлюзе Personal Gateway см. в статьях по ссылкам, приведенным в предыдущем разделе.For more information on both, see the previous section in this article, which provides links to learn more about each.

С помощью R и пользовательских запросов можно выполнять разные операции. Просматривайте и формируйте свои данные, придавая им нужный вид.There are all sorts of things you can do with R and custom queries, so explore and shape your data just the way you want it to appear.