Общие сведения о запросах в Power BI DesktopQuery overview in Power BI Desktop

С помощью Power BI Desktop вы можете подключаться к миру данных, создавать привлекательные и фундаментальные отчеты и совместно использовать свою работу с другими пользователями, которые затем могут использовать ее для расширения своих возможностей по бизнес-аналитике.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop имеет три представления:Power BI Desktop has three views:

  • Представление отчетов — здесь можно использовать запросы для создания впечатляющих визуализаций, их упорядочивания и добавления на них нескольких страниц, которые можно использовать совместно с другими пользователями.Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Представление данных — здесь можно просматривать данные отчета в формате модели данных, добавлять меры, создавать новые столбцы и управлять связями.Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • Представление связей — здесь можно получить графическое представление связей, установленных в вашей модели данных, а также при необходимости изменять их или управлять ими.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Доступ к этим представлениям осуществляется путем выбора одного из трех значков, расположенных вдоль левой стороны Power BI Desktop.Access these views by selecting one of the three icons along the left side of Power BI Desktop. На следующем рисунке выбрано представление Отчеты, на что указывает желтая полоска рядом со значком.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Снимок экрана: Power BI Desktop с выбранным представлением отчета

Power BI Desktop также поставляется с редактором Power Query.Power BI Desktop also comes with Power Query Editor. Используйте редактор Power Query, чтобы подключаться к одному или нескольким источникам данных, преобразовывать данные в соответствии с потребностями, а также загружать модель в Power BI Desktop.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Этот документ содержит общие сведения о работе с данными в редакторе Power Query, но это еще не все.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. В конце этого документа вы найдете ссылки на подробные указания по поддерживаемым типам данных.At the end of this document, you'll find links to detailed guidance about supported data types. Вы также найдете руководство по подключению к данным, формированию данных, созданию связей и началу работы.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Но сначала давайте ознакомимся с Редактором Power Query.But first, let's see get acquainted with Power Query Editor.

Редактор Power QueryPower Query Editor

Чтобы открыть Редактор Power Query, в Power BI Desktop на вкладке Главная выберите Преобразование данных.To get to Power Query Editor, select Transform data from the Home tab of Power BI Desktop.

Снимок экрана: Power BI Desktop, где отображается вкладка "Главная" для открытия Редактора Power Query

Без подключения к данным в Power Query отображается пустая область.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Снимок экрана: Power BI Desktop, где Редактор Power Query без подключений к данным

После загрузки запроса представление редактора Power Query становится гораздо более интересным.Once a query is loaded, Power Query Editor view becomes more interesting. Если мы подключимся к указанному ниже веб-источнику данных, редактор Power Query загрузит сведения о данных и мы сможем начинать их формировать.If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Вот так выглядит Редактор Power Query после подключения к данным.Here's how Power Query Editor appears once a data connection is established:

  1. На ленте многие кнопки теперь можно использовать для взаимодействия с данными в запросе.In the ribbon, many buttons are now active to interact with the data in the query.

  2. В левой области перечислены запросы, которые можно выбирать, просматривать и формировать.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. В центральной области отображаются данные из выбранного запроса, и их можно формировать.In the center pane, data from the selected query is displayed and available for shaping.

  4. Появляется область Параметры запроса, в которой перечислены свойства запроса и примененные действия.The Query Settings pane appears, listing the query's properties and applied steps.

    Снимок экрана: Power BI Desktop, где отображается панель "Параметры запроса" в Редакторе Power Query

Мы рассмотрим каждую из этих четырех областей — ленту, область запросов, представление данных и область параметров запроса.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Лента запросаThe query ribbon

Лента в редакторе Power Query состоит из четырех вкладок: Главная, Преобразовать, Добавить столбец и Представление.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

На вкладке Главная содержатся общие задачи запросов.The Home tab contains the common query tasks.

Снимок экрана: Power BI Desktop, где отображается лента запроса Редактора Power Query

Чтобы подключиться к данным и начать процесс построения запросов, выберите Создать источник.To connect to data and begin the query building process, select New Source. Появится меню с наиболее распространенными источниками данных.A menu appears, providing the most common data sources.

Снимок экрана: Power BI Desktop с кнопкой "Создать источник"

Дополнительные сведения о доступных источниках данных см. в разделе Источники данных.For more information about available data sources, see Data Sources. Сведения о подключении к данным, включая примеры и инструкции, см. в разделе Подключение к данным.For information about connecting to data, including examples and steps, see Connect to Data.

Вкладка Преобразовать предоставляет доступ к общим задачам преобразования данных, например:The Transform tab provides access to common data transformation tasks, such as:

  • добавление или удаление столбцов;Adding or removing columns
  • изменение типов данных;Changing data types
  • разделение столбцов;Splitting columns
  • другие задачи с данными.Other data-driven tasks

Снимок экрана: Power BI Desktop с вкладкой "Главная"

Дополнительные сведения о преобразовании данных, включая примеры, см. в разделе Учебник. Формирование и объединение данных в Power BI Desktop.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

На вкладке Добавить столбец предоставляются дополнительные задачи, связанные с добавлением столбца, форматированием данных столбца и добавлением настраиваемых столбцов.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. На следующем рисунке показана вкладка Добавить столбец ленты.The following image shows the Add Column tab.

Снимок экрана: Power BI Desktop с вкладкой "Добавление столбца"

Вкладка Вид на ленте используется для переключения между разными областями или окнами.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Она также используется для отображения Расширенного редактора.It's also used to display the Advanced Editor. На следующем рисунке показана вкладка Вид ленты.The following image shows the View tab.

Снимок экрана: Power BI Desktop с вкладкой "Вид"

Полезно знать, что многие задачи, доступные на ленте, также доступны по щелчку правой кнопкой мыши столбца или других данных в центральной области.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Левая область (запросы)The left (Queries) pane

В левой области (Запросы) отображается число активных запросов, а также имя запроса.The left pane, or Queries pane, displays the number of active queries and the name of the query. При выборе запроса в левой области его данные отображаются в центральной области, где их можно формировать и преобразовывать в соответствии со своими потребностями.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. На следующем рисунке показана левая область с запросом.The following image shows the left pane with a query.

Снимок экрана: Power BI Desktop с элементом "Запросы" на левой панели

Центральная область (область данных)The center (Data) pane

В центральной области, или области Данные, отображаются данные из выбранного запроса.In the center pane, or Data pane, data from the selected query is displayed. Здесь выполняется большая часть работы с представлением Запросы.This pane is where much of the work of the Query view is accomplished.

На следующем рисунке показано подключение к веб-данным, установленное ранее.In the following image shows the Web data connection established earlier. Выбран столбец Продукт, его заголовок показывает доступные пункты меню по правому щелчку мыши.The Product column is selected, and its header is right-clicked to show the available menu items. Обратите внимание, что многие из этих пунктов контекстного меню совпадают с кнопками на вкладках ленты.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Снимок экрана: Power BI Desktop с элементом "Данные" на центральной панели

При выборе пункта контекстного меню (или нажатии кнопки на ленте) запрос применяет это действие к данным.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Он также сохраняет шаг как часть самого запроса.It also saves step as part of the query itself. Действия записываются в области Параметры запроса в последовательном порядке, как описано в следующем разделе.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Правая область (параметры запроса)The right (Query Settings) pane

В области Параметры запроса справа отображаются все действия, связанные с запросом.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Например, на следующем рисунке в разделе Примененные действия области Параметры запроса отражен тот факт, что мы только что изменили тип столбца Overall score (Общий рейтинг).For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Снимок экрана: Power BI Desktop с элементом "Параметры запроса" на правой панели

По мере применения к запросу дополнительных действий по формированию они регистрируются в разделе Примененные действия.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Важно помнить, что базовые данные не меняются.It's important to know that the underlying data isn't changed. Вместо этого редактор Power Query настраивает и формирует представление данных.Rather, Power Query Editor adjusts and shapes its view of the data. Он также формирует и корректирует представление любого взаимодействия с базовыми данными, которое происходит на основе сформированного и измененного представления данных в Редакторе Power Query.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

В области Параметры запроса можно переименовывать действия, удалять действия или упорядочивать их по своему усмотрению.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Для этого щелкните правой кнопкой мыши действие в разделе Примененные действия и в появившемся меню выберите соответствующую команду.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Все действия запроса выполняются в порядке их отображения в области Примененные действия.All query steps are carried out in the order they appear in the Applied Steps pane.

Снимок экрана: Power BI Desktop со свойствами параметров запроса и фильтрами "Примененные шаги"

Расширенный редакторAdvanced Editor

Расширенный редактор позволяет увидеть код, создаваемый редактором Power Query на каждом шаге.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Он также позволяет создать собственный код формирования.It also lets you create your own shaping code. Чтобы запустить расширенный редактор, выберите на ленте вкладку Вид , а затем нажмите Расширенный редактор.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Появится окно с существующим кодом запроса.A window appears, showing the existing query code.
Снимок экрана: Power BI Desktop с диалоговым окном "Расширенный редактор"Screenshot of Power B I Desktop showing Advanced Editor dialog box.

Можно непосредственно редактировать код в окне Расширенный редактор .You can directly edit the code in the Advanced Editor window. Чтобы закрыть окно, нажмите кнопку Готово или Отмена .To close the window, select the Done or Cancel button.

Сохранение работыSaving your work

Если запрос находится в нужном месте, выберите Закрыть и применить в меню Файл в редакторе Power Query.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Это действие применяет изменения и закрывает редактор.This action applies the changes and closes the editor.
Снимок экрана: Power BI Desktop с параметром "Закрыть и применить" на вкладке "Файл"Screenshot of Power B I Desktop showing Close and Apply option under File tab.

По мере хода выполнения Power BI Desktop выводит диалоговое окно для отображения состояния.As progress is made, Power BI Desktop provides a dialog to display its status.
Снимок экрана: Power BI Desktop с диалоговым окном подтверждения "Применить изменения запросов"

Когда будете готовы, Power BI Desktop можете сохранить вашу работу в виде файла PBIX.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Чтобы сохранить результаты работы, выберите Файл > Сохранить (или Файл > Сохранить как), как показано на следующем рисунке.To save your work, select File > Save (or File > Save As), as shown in the following image.
Снимок экрана: Power BI Desktop, где отображается вкладка "Файл" Редактора Power QueryScreenshot of Power B I Desktop showing Power Query Editor File tab.

Дальнейшие действияNext steps

Power BI Desktop предоставляет широкие возможности.There are all sorts of things you can do with Power BI Desktop. Дополнительные сведения об этих возможностях см. в следующих ресурсах.For more information on its capabilities, check out the following resources: