Настройки Visual Web Developer

Настройки Visual Web Developer предназначены для оптимизации опыта пользователей и увеличения производительности веб-разработчиков. Настройки Visual Web Developer являются частью настроек Visual Studio, функции, позволяющей настроить и сохранить параметры интегрированной разработки среды (IDE) Visual Studio.

Параметры интегрированной среды разработки также можно переносить или перезагружать на других компьютерах. Дополнительные сведения см. в разделе Практическое руководство. Совместное использование параметров на разных компьютерах или в разных версиях Visual Studio.

Описанные ниже команды меню и диалоговые окна являются параметрами по умолчанию для Visual Web Developer. Чтобы изменить параметры, щелкните Импорт и экспорт настроек в меню Сервис. Для получения дополнительных сведений о настройке параметров см. Работа с параметрами.

Окна и представления

Функция

Отображается по умолчанию?

Примечания

Стек вызовов

Да, при запуске отладки.

Представление классов

Нет

Окно "Команда"

Нет

Обозреватель серверов/обозреватель баз данных

Да

В продуктах экспресс-выпуска Visual Studio имя этого окна — Обозреватель баз данных. Во всех других продуктах Visual Studio это окно называется Обозреватель серверов.

Представление конструирования

Нет

Режим исходного кода является представлением по умолчанию для IDE при редактировании веб-страницы. Можно настроить интегрированную среду разработки так, чтобы Представление конструирования являлся представлением по умолчанию. Дополнительные сведения см. в разделе Страница "Общие", папка "Среда", диалоговое окно "Параметры".

Окно "Структура документа"

Нет

Динамическая справка

Да

Сведения о настройке динамической справки см. в разделе How to: Customize Dynamic Help.

Окно "Список ошибок"

Да

Окно "Список ошибок" изначально скрыто.

Окно интерпретации

Да, при запуске отладки.

обозреватель объектов

Нет

Окно выходных данных

Да, при запуске отладки.

окно свойств

Да

В открытом веб-проекте окно свойств отображает сведения о выделенном в данный момент элементе.

Solution Explorer

Да

В открытом веб-проекте Solution Explorer отображает элементы в проекте. Включать связанные файлы установлен по умолчанию.

Режим исходного кода

Да

В открытом проекте веб-страницы открываются в Режим исходного кода по умолчанию. Можно настроить параметры для использования Представление конструирования в качестве представления по умолчанию. Дополнительные сведения см. в разделе Страница "Общие", папка "Среда", диалоговое окно "Параметры".

Начальная страница

Да

Начальная страница является страницей по умолчанию, когда ни один веб-проект не загружен в интегрированной среде разработки. домашняя страница отображает статьи из RSS-канала для MSDN: Visual Web Developer 2005 Edition. RSS-каналу может быть присвоен указанный канал. Дополнительные сведения о настройке поведения домашней страницы см. в разделе Настройка начальной страницы.

Список задач (Visual Studio)

Нет

панель элементов

Да

При открытии Visual Web Developer с пустой интегрированной средой разработки панель элементов пуст. В открытом веб-проекте панель элементов отображает компоненты в алфавитном порядке.

Веб-обозреватель интегрированной среды разработки

Нет

Окно интерпретации

Да, при запуске отладки.

Отображаются окна Локальные и Наблюдение.

Кроме того, следующим элементам разрешены определенные действия при использовании параметров Visual Web Developer по умолчанию.

Клавиатура

Функция

Поведение

Предварительно определенные сочетания клавиш

General Development Settings Default Shortcut Keys действуют.

Прочие элементы интерфейса IDE

Функция

Поведение

Параметры конструктора

Видом по умолчанию является Режим исходного кода, а не Представление конструирования.

Главные меню, контекстные меню, панели инструментов, команды

Меню Файл оптимизировано для создания и открытия веб-узелов. Команды Новый веб-узел и Открыть веб-узел доступны непосредственно из меню Файл.

Команда Структура документа доступна прямо в меню Вид, а не через подменю Другие окна. В Visual Studio 2005 доступно несколько вариантов окна, отсутствующих в Visual Web Developer.

Управление окнами и макеты

Вид окон по умолчанию:

Вид окон отладчика по умолчанию:

См. также

Задачи

Практическое руководство. Изменение параметров выделения

Практическое руководство. Определение параметров для команды

Ссылки

Страница "Параметры импорта и экспорта", папка "Среда", диалоговое окно "Параметры"