Статьи базы знаний, посвященные службам машинного перевода в SharePoint Server

ОБЛАСТЬ ПРИМЕНЕНИЯ:yes-img-132013 yes-img-162016 yes-img-192019 yes-img-seSubscription Edition no-img-sopSharePoint в Microsoft 365

Узнайте, как устранять оповещения о службе машинного перевода в пакете управления SharePoint Server 2019, 2016 и 2013 для System Center Operations Manager (SCOM).

В этом разделе представлены статьи базы знаний о службе машинного перевода в SharePoint Server. Как правило, они отображаются при переходе по ссылке в оповещении консоли Operations Manager. Эти статьи служат для поиска и устранения проблем со службой машинного перевода.

Скачайте и установите:

Для устранения оповещений о службе машинного перевода используйте следующее:

Служба машинного перевода: база данных очереди недоступна

**Имя оповещения:**Служба машинного перевода: база данных очереди недоступна

Сводка. Критическое состояние этого монитора показывает, что служба машинного перевода не может получить доступ к контенту, который она должна перевести.

Симптомы

  • Новые задания не отправляются.

  • Элементы существующих заданий не завершаются или "зависают" и не продвигаются в очереди заданий.

Причина

Возможные причины:

  • база данных очереди не отвечает из-за загрузки сети или физического сервера SQL;

  • разрешения на доступ к пользовательской базе данных недействительны;

  • база данных очереди недоступна.

Решение

Решение 1. Проверьте состояние базы данных службы машинного перевода SQL Server.

  1. На веб-сайте центра администрирования SharePoint в разделе Параметры системы в области чтения щелкните Управление серверами в этой ферме.

  2. В разделе Сведения о ферме запомните сервер базы данных службы машинного перевода, а также имя и версию базы данных конфигурации.

  3. Запустите SQL Server Management Studio и подключитесь к серверу базы данных конфигурации.

  4. Если база данных конфигурации не существует, запустите мастер настройки продуктов и технологий SharePoint.

Решение 2. Проверьте сетевое подключение к SQL Server.

  1. На веб-сайте центра администрирования в разделе "Параметры системы" в области чтения щелкните Управление серверами в этой ферме.

  2. В разделе Сведения о ферме запомните сервер базы данных службы машинного перевода, а также имя и версию базы данных конфигурации.

  3. Откройте окно командной строки и введите команду ping чтобы проверить подключение к серверу.

  4. Если связи с сервером нет, то проблема связана с сетевым подключением или вызвана другой причиной, не позволяющей получить ответ от сервера.

  5. Зайдите на сервер и устраните эту проблему.

Служба машинного перевода: сбой машинного перевода — No 1

**Имя оповещения:**Служба машинного перевода: сбой машинного перевода

Сводка. Критическое состояние этого монитора показывает, что машинный перевод через интернет-службу перевода не работает.

Симптомы

Поскольку подключение к интернет-службе перевода не установлено, служба будет работать правильно, но будет возвращать ошибку при обработке каждого элемента перевода.

Причина

Возможные причины:

  • служба машинного перевода не подключена к Интернету;

  • интернет-служба перевода отключена;

  • в интернет-службе перевода произошло некоторое количество перемежающихся сбоев (превышающее установленное пороговое значение).

Решение

Убедитесь, что приложение службы машинного перевода имеет доступ к Интернету.

  1. Убедитесь, что учетная запись пользователя, с помощью которой выполняется данная процедура, является участником группы администраторов фермы.

  2. В разделе Управление приложениями веб-сайта центра администрирования щелкните Управление приложениями-службами.

  3. На странице Управление приложениями-службами в списке приложений-служб выберите службу машинного перевода.

  4. В разделе Подключение к интернет-службе перевода в окне сервера веб-прокси выполните одно из следующих действий:

  • щелкните Использовать интернет-настройки по умолчанию;

  • щелкните Использовать указанный прокси и введите сервер веб-прокси и номер порта.

Проверьте параметры MachineTranslationAddress, MachineTranslationClientId и MachineTranslationCategory для приложения службы машинного перевода.

  1. Убедитесь, что учетная запись пользователя, с помощью которой выполняется данная процедура, является участником группы администраторов фермы.

  2. В командной строке PowerShell введите следующую команду:

    Get-SPServiceApplication -Name "name" | ft MachineTranslationAddress, MachineTranslationClientId, MachineTranslationCategory

    где "name" — имя приложения службы машинного перевода.

  3. Для проверки возвращенных значений сравните их с документацией или сделайте тестовый вызов.

  4. Исправьте значения на основании проверки. Если значение невозможно проверить, используйте значение по умолчанию.

Служба машинного перевода: сбой машинного перевода — No 2

**Имя оповещения:**Служба машинного перевода: сбой машинного перевода

**Сводка:**Критическое состояние этого монитора указывает на сбой задания таймера службы машинного перевода.

Симптомы

  • Новые задания успешно вступят в базу данных. Однако элементы перевода для этого задания никогда не запускатся.

  • Существующие задания могут не завершиться. Все элементы перевода, которые уже назначены серверам приложений, по-прежнему могут завершиться успешно, но элементы перевода, которые не назначены серверам приложений, не будут запущены. Это оставляет задание бессрочно неполным.

Причина

Задание таймера очереди службы машинного перевода не выполняется.

Решение

Решение 1. Перезапустите службу машинного перевода.

  1. На веб-сайте центра администрирования в разделе Параметры системы в области чтения щелкните Управление серверами в этой ферме.

  2. В столбце Сервер щелкните имя сбойного сервера приложений. Откроется страница Службы на сервере.

  3. В столбце Служба найдите Службу машинного перевода. Нажмите кнопку Остановить, затем — Пуск.

Решение 2. Создайте новое приложение службы машинного перевода.

  1. На веб-сайте центра администрирования в разделе Управление приложениями в области чтения щелкните Управление приложениями-службами.

  2. В столбце Тип щелкните имя приложения Службы машинного перевода с экземпляром службы, в котором произошел сбой.

  3. На ленте нажмите кнопку Удалить.

  4. В диалоговом окне Удаление приложения службы нажмите кнопку ОК.

  5. Создайте новое приложение службы машинного перевода.

Служба машинного перевода недоступна

**Имя оповещения:**Служба машинного перевода недоступна

Сводка. Критическое состояние этого монитора показывает, что служба машинного перевода недоступна.

Симптомы. Если вызовы служб не работают в службе машинного перевода, задания не могут быть отправлены на сервер приложений для немедленной обработки или отправки в очередь заданий. То есть служба недоступна и не работает.

Причина

Возможные причины:

  • указанный сервер приложений SharePoint Server недоступен;

  • Низкая скорость отклика указанного сервера приложений в связи с общей перегрузкой сети или загрузкой конкретного сервера.

Решение

Решение 1. Проверка журналов ошибок:

  • Откройте средство просмотра событий Windows.

  • Найдите событие с идентификатором 8049 в Windows. Журнал событий приложения.

  • В описании события найдите и выпишите отказавший сервер приложений.

Решение 2. Проверьте подключение к серверу приложений.

  • Откройте веб-сайт центра администрирования SharePoint на сервере приложений, испытывающем затруднения.

  • Если с неисправного сервера не удается получить доступ к центру администрирования, убедитесь в правильной настройке параметров сети и наличии у сервера необходимых разрешений на присоединение к ферме SharePoint.

Решение 3. Убедитесь, что на сбойном сервере выполняется служба машинного перевода.

  1. На веб-сайте центра администрирования в области чтения в разделе Параметры системы щелкните Управление серверами в этой ферме.

  2. Убедитесь, что служба машинного перевода выполняется на сбойном сервере приложений.

  3. Если для неисправного приложения-службы имеется прокси приложения-службы, создайте новое приложение-службу.

Решение 4. Перезапустите службу машинного перевода.

  1. На веб-сайте центра администрирования в области чтения в разделе Параметры системы щелкните Управление серверами в этой ферме.

  2. В столбце Сервер щелкните имя сбойного сервера приложений. Откроется страница Службы на сервере.

  3. В столбце Служба найдите службу машинного перевода, щелкните Остановить, а затем Запустить.

Решение 5. Создайте новое приложение службы машинного перевода.

  1. На веб-сайте центра администрирования в области чтения в разделе Управление приложениями щелкните Управление приложениями-службами.

  2. В столбце Тип щелкните имя приложения Службы машинного перевода с экземпляром службы, в котором произошел сбой.

  3. На ленте нажмите кнопку Удалить.

  4. В диалоговом окне Удаление приложения службы нажмите кнопку ОК.

  5. Создайте новое приложение службы машинного перевода.

Служба машинного перевода: контент недоступен

**Имя оповещения:**Служба машинного перевода: содержимое недоступно

Сводка. Критическое состояние этого монитора показывает, что CSOM-запросы из внутреннего сервера на внешний сервер не работают.

Симптомы: файлы не могут быть извлечены для обработки, и элементы, которые уже обрабатываются, не будут записаны. То есть файлы недоступны, и элементы будут постоянно завершатся сбоем.

Причина

Возможные причины:

  • проверка подлинности сервер-сервер настроена неправильно;

  • база данных контента не отвечает из-за загрузки сети или физического сервера SQL;

  • разрешения на доступ к базе данных контента недействительны;

  • база данных контента недоступна.

Решение

Решение 1. Проверьте состояние базы данных контента SQL Server.

  1. На веб-сайте центра администрирования SharePoint в разделе Параметры системы в области чтения щелкните Управление серверами в этой ферме.

  2. В разделе Сведения о ферме запомните сервер базы данных контента, а также имя и версию базы данных конфигурации.

  3. Запустите SQL Server Management Studio и подключитесь к серверу базы данных контента.

  4. Если база данных контента не существует, запустите мастер настройки продуктов и технологий SharePoint.

Решение 2. Проверьте сетевое подключение к SQL Server.

  1. На веб-сайте центра администрирования в разделе Параметры системы в области чтения щелкните Управление серверами в этой ферме.

  2. В разделе Сведения о ферме запомните сервер базы данных контента, а также имя и версию базы данных контента.

  3. Откройте окно командной строки и введите команду ping чтобы проверить подключение к серверу.

    Если связи с сервером нет, то проблема связана с сетевым подключением или вызвана другой причиной, не позволяющей получить ответ от сервера.

  4. Зайдите на сервер и устраните эту проблему.

Решение 3. Убедитесь, что проверка подлинности сервер-сервер настроена правильно.

См. раздел Configure server-to-server authentication in SharePoint Server.

Служба машинного перевода: сбой рабочего процесса

**Имя оповещения:**Служба машинного перевода: сбой рабочей роли

Сводка. Критическое состояние этого монитора показывает, что рабочие процессы службы машинного перевода не работают.

Симптомы. Эти ошибки необходимо отслеживать, чтобы конечные пользователи через некоторое время не обнаружили сбой всех элементов.

Причина

Возможные причины:

  • поврежден входной файл;

  • сбой рабочего процесса службы перевода;

  • ошибка при сохранении файла в локальном хранилище.

Решение

Решение 1. Проверка журналов ошибок:

  1. Откройте средство просмотра событий Windows.

  2. В журнале событий приложений Windows найдите событие с кодом 8049.

  3. В описании события найдите и выпишите отказавший сервер приложений.

Решение 2. Проверьте подключение к серверу приложений.

  1. Откройте веб-сайт центра администрирования SharePoint на сервере приложений, испытывающем затруднения.

  2. Если с неисправного сервера не удается получить доступ к центру администрирования, убедитесь в правильной настройке параметров сети и наличии у сервера необходимых разрешений на присоединение к ферме SharePoint.

Решение 3. Убедитесь, что на сбойном сервере выполняется служба машинного перевода.

  1. На веб-сайте центра администрирования в области чтения в разделе Параметры системы щелкните Управление серверами в этой ферме.

  2. Убедитесь, что служба машинного перевода выполняется на сбойном сервере приложений.

  3. Если для неисправного приложения-службы имеется прокси приложения-службы, создайте новое приложение-службу.

Решение 4. Перезапустите службу машинного перевода.

  1. На веб-сайте центра администрирования в области чтения в разделе Параметры системы щелкните Управление серверами в этой ферме.

  2. В столбце Сервер щелкните имя сбойного сервера приложений. Откроется страница Службы на сервере.

  3. В столбце Служба найдите службу машинного перевода, щелкните Остановить, а затем Запустить.

Решение 5. Создайте новое приложение службы машинного перевода.

  1. На веб-сайте центра администрирования в области чтения в разделе "Управление приложениями" щелкните "Управление приложениями-службами".

  2. В столбце Тип щелкните имя приложения Службы машинного перевода с экземпляром службы, в котором произошел сбой.

  3. На ленте нажмите кнопку Удалить.

  4. В диалоговом окне Удаление приложения службы нажмите кнопку ОК.

  5. Создайте новое приложение службы машинного перевода.

См. также

Понятия

Планирование мониторинга в SharePoint Server

Другие ресурсы

Пакет мониторинга System Center для SharePoint Foundation

Пакет мониторинга System Center для SharePoint Server 2013

Пакет мониторинга System Center для SharePoint Server 2016