Сохранение графов взаимоблокировок (приложение SQL Server Profiler)

Применимо к: даSQL Server (все поддерживаемые версии)

В этом подразделе описывается, как сохранять графы взаимоблокировок с помощью приложения Приложение SQL Server Profiler. Графы взаимоблокировок сохраняются в виде XML-файлов.

Сохранение событий графа взаимоблокировок по отдельности

  1. В меню Файл выберите пункт Создать трассировку, а затем подключитесь к экземпляру SQL Server.

    отображается диалоговое окно Свойства трассировки .

    Примечание

    Если выбран параметр Начать трассировку немедленно после установления соединения, диалоговое окно Свойства трассировки не появляется, а вместо этого начинается трассировка. Чтобы отключить этот параметр, в меню Сервис выберите пункт Параметры и снимите флажок Начать трассировку немедленно после установления соединения.

  2. В диалоговом окне Свойства трассировки введите имя трассировки в поле Имя трассировки .

  3. В списке Использовать шаблон выберите шаблон, на котором будет основана трассировка. Чтобы не использовать шаблон, выберите Пустой.

  4. Выполните одно из следующих действий.

    • Для записи данных трассировки в файле установите флажок Сохранить в файл. Укажите значение Установить максимальный размер файла.

      При необходимости установите флажки Включить переключение файлов и Обработка данных трассировки сервером .

    • Для записи данных трассировки в таблицу базы данных установите флажок Сохранить в таблицу.

      При необходимости установите флажок Максимальное число строк и укажите значение.

  5. При необходимости установите флажок Включить время остановки трассировки и укажите дату и время остановки.

  6. Перейдите на вкладку Выбор событий.

  7. В столбце данных События разверните категорию событий Locks и установите флажок Deadlock graph (Граф взаимоблокировок). Если категория событий Locks недоступна, установите флажок Показать все события, чтобы отобразить ее.

    Вкладка Настройки извлечения событий добавлена в диалоговое окно Свойства трассировки.

  8. На вкладке Настройки извлечения событий установите флажок Сохранить события XML взаимоблокировок отдельно.

  9. В диалоговом окне Сохранить как введите имя файла, в котором будут сохраняться события графа взаимоблокировок.

  10. Чтобы все события графа взаимоблокировок сохранялись в одном XML-файле, установите флажок Все пакеты XML взаимоблокировок в один файл. Чтобы для каждого графа взаимоблокировок создавался отдельный XML-файл, установите флажок Каждый пакет XML взаимоблокировок в отдельный файл.

После сохранения файла взаимоблокировок его можно открыть в среде SQL Server Management Studio. Дополнительные сведения см. в разделе Открытие, просмотр и печать файла взаимоблокировок (среда SQL Server Management Studio).

См. также раздел

Анализ взаимоблокировок в приложении SQL Server Profiler